ShapeUp API: ShapeUp API

  • Main Page
  • Classes
  • Files
  • Related Pages
  • Examples

ShapeUp API

1.00

This is the API for ShapeUp General Plug-Ins, a.k.a. GPI's. The support for GPI's was introduced in ShapeUp v1.2.00. The main difference between the new GPI model and the older plug-in types is that it now is the plug-in that defines and controls what actions to be taken. A GPI can handle all the things the old plug-ins could do, and a lot more. E.g. hook into ShapeUp menues, create and manage its own toolbars, draw objects in the map window, utilise the ShapeUp status bar, and a lot more.

This manual is divided in the following sections:

  • Introduction
  • GPI Message Routing
  • GPI Serialization
  • GPI Threading
Generated on Thu Apr 15 10:55:32 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Introduction

  • Related Pages
  • Examples
ShapeUp API

Introduction

A GPI is a win32 DLL with the extension '.gpi'. Unlike the previous plug-in types (except for statistical plug-ins) a GPI is loaded on start-up, and remains loaded until ShapeUp terminates.

The GPI needs to export three function in order to be considered valid by ShapeUp:

  • fnInit(), for initialisation
  • fnVersion(), to tell ShapeUp what version of the API the GPI was built with.
  • fnGUID(), to identify this plug-in.
and optionally:
  • fnTerminate(), for any clean-up process.
These functions can be exported by declaring them in a .def file for the project.

Now you can proceed to the GPI Message Routing.

Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: GPI Message Routing

ShapeUp API

GPI Message Routing

When a GPI is initialised, it may hook into one or more notification functions supplied by ShapeUp. These can be mouse action in the map window, adding menu items and toolbars and get notified when the user selects an item, etc.

A callback function is supplied to ShapeUp in fnInit() to set the function which should be notified on the subscribed events. This is the pfnHook member of the SUImport supplied in the SUExport argument to the function.

SURESULT __cdecl fnInit(SUExport *pExport)
{
    ...
    pExport->import.pfnHook = MyHookFunc;
    ...
}

For the purpose of adding notification hooks, the ShapeUp API exposes several functions on the form ShapeUp_AddXxxHook(), see example_hooks.cpp.

As an example, study the following:

SURESULT __cdecl fnInit(SUExport *pExport)
{
    ...
    ShapeUp_AddPostDrawHook(0);
    ...
}
This will tell ShapeUp to notify the GPI when the map has been refreshed to allow the plug-in to overlay its own graphics.

A sample of the hook function might look like:

SURESULT __cdecl MyHookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args)
{
    switch (hookType)
    {
    case HOOKTYPE_POSTDRAW:
        DrawSomething();
        break;
    default:
        break;
    }
    return SURESULT_OK;
}
Here, the value found in args->userData, is the same value used when adding the hook. Some of the handlers have more information in the args data. Check each HOOKTYPE for what the args really points to. It is however always safe to treat the args as a pointer to a SUHookData struct.

Make sure you have first read the introduction.

Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: GPI Serialization

ShapeUp API

GPI Serialization

A GPI can store data in the ShapeUp workspace file (*.sup) when the user chooses to save the workspace. Data can be saved on workspace basis, and/or on theme basis. When such a workspace is later loaded, the stored data is sent to the plug-in to be parsed and used.

E.g. if a plug-in draws extra data on top of the map, the settings for how this is drawn can be stored in the workspace file and reused when that workspace is reopened.

Note:
A plug-in can set the data to be serialized at almost any time. The only time it's not permitted is during the loading process.
A sample of how to store data:
{
    struct MyData
    {
        int version;
        double precision;
    } data;

    const char *string_data = "Some data";

    // Store data on workspace level
    SUWorkspace workspace(hWorkspace);
    workspace.SetSerialData(sizeof(MyData), &data);

    // Store data on theme level
    SUTheme theme(hTheme);
    theme.SetSerialData(strlen(string_data) + 1, string_data);
}

In order to reserialize data stored, a hook funktion needs to be used, ShapeUp_AddDeserializeHook(), which enables a call to the GPI hook function when a loading operation occurrs.

A sample of the deserialize hook functionality might look like:

SURESULT __cdecl fnInit(SUExport *pExport)
{
    ...
    // Set hook function
    pExport->import.pfnHook = MyHookFunc;

    // Set-up our loading hook
    ShapeUp_AddDeserializeHook(0);
    ...
}

SURESULT __cdecl MyHookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args)
{
    switch (hookType)
    {
    case HOOKTYPE_DESERIALIZE:
        {
            // args is really a pointer to a SUDeserializeHookData struct
            SUDeserializeHookData *data = (SUDeserializeHookData*) args;

            // If data->hTheme == NULL we are loading a workspace, otherwise
            // we are loading the theme pointed to by data->hTheme

            if (data->hTheme == NULL)
                LoadWorkspaceData(hWorkspace, data);
            else
                LoadThemeData(hWorkspace, data);
        }
        break;
    default:
        break;
    }
    return SURESULT_OK;
}
Warning:
Do not assume that the workspace hWorkspace in the hook function will point to the workspace containing the currently loading theme. I.e. if the user is loading themes from a workspace using the Insert | Add Themes from Workspace command, the hWorkspace will point to the active workspace rather than the workspace that contains the themes to be extracted. In this case, any serialized workspace based data in the loading workspace file will remain unread. This means you cannot store data for a theme that is depending on data stored for its workspace.
See also:
ShapeUp_AddDeserializeHook(), FNTYPE_WORKSPACE_SETSERIALDATA, FNTYPE_THEME_SETSERIALDATA, HOOKTYPE_DESERIALIZE
Make sure you have first read the introduction.
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: GPI Threading

ShapeUp API

GPI Threading

A GPI runs in the ShapeUp main thread, but there is support for having 'collector threads' which asks for a synchronised call from ShapeUp when actions need to be taken. E.g. a collector thread could run and query an external data source, like GPS equipment, for updates. When an update occurrs, the GPI asks ShapeUp to get a synchronised call where it will take action on the event.

A sample thread function:

#define DATAUPDATE1 0
#define DATAUPDATE2 1
void MyThreadFunc()
{
    while (continueToRun)
    {
        if (DataAvailable())
            ShapeUp_WantUpdate(DATAUPDATE1);
        ...
    }
}

You can use different values as user data for the call to ShapeUp_WantUpdate() to distinguish different tasks.

A sample of the hook function might look like:

SURESULT __cdecl MyHookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args)
{
    // Here we are synchronized with the ShapeUp main thread, and we can call
    // any ShapeUp function.
    switch (hookType)
    {
    case HOOKTYPE_WANTUPDATE:
        switch (args->userData)
        {
        case DATAUPDATE1:
            ReadData1AndDoSomething();
            break;
        case DATAUPDATE2:
            ReadData2AndDoSomething();
            break;
        default:
            break;
        }
        break;
    default:
        break;
    }
    return SURESULT_OK;
}
See also:
ShapeUp_WantUpdate(), FNTYPE_SHAPEUP_WANTUPDATE, HOOKTYPE_WANTUPDATE
Make sure you have first read the introduction.
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class List

  • Class List
  • Class Hierarchy
  • Class Members

ShapeUp API Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
SUDataPage | Handles custom data pages in ShapeUp
SUException | A wrapper class for error return values
SUJavaScript | Handles JavaScripts in ShapeUp
SUMap | Represents the ShapeUp map window
SUMenuItem | Handles a single ShapeUp menu item
SUObject | Base class for ShapeUp object classes
SUPoint | Representation of a integer based position or vector
SUPointf | Representation of a floating point double precision based position or vector
SURecordset | Multi-purpose recordset class
SURectf | Representation of a floating point double precision based axis-aligned rectangle
SUShape | Handles a shape object in ShapeUp
SUSize | Representation of a integer based size in two dimensions
SUSizef | Representation of a floating point double precision based size in two dimensions
SUStatusBar | Represents the ShapeUp status bar
SUTheme | Represents a ShapeUp theme or layer
SUToolBar | Handles a plug-in defined toolbar
SUWorkspace | Wrapper for a ShapeUp workspace
tagSUAddFileFormatHandlerHookData |
tagSUAddJavaScriptInvokeHookData |
tagSUAddMenuItemHookData |
tagSUARGAddAttribute |
tagSUARGAddDataPage |
tagSUARGAddHook |
tagSUARGAddShape |
tagSUARGAllocate |
tagSUARGAllocateStatusBarPane |
tagSUARGBatchAddShape |
tagSUARGBeginProgress |
tagSUARGBrowseTheme |
tagSUARGCreateNewTheme |
tagSUARGCreateNewThemeFromSelection |
tagSUARGCreateToolBar |
tagSUARGDeleteAttribute |
tagSUARGDeleteShape |
tagSUARGDPtoGP |
tagSUARGDraw |
tagSUARGGetAttribute |
tagSUARGGetAttributeIndex |
tagSUARGGetAttributeType |
tagSUARGGetBOOL |
tagSUARGGetBounds |
tagSUARGGetClosestPoint |
tagSUARGGetColor |
tagSUARGGetCoordinate |
tagSUARGGetDWORD |
tagSUARGGetErrorDescription |
tagSUARGGetFont |
tagSUARGGetHandle |
tagSUARGGetHandleByIndex |
tagSUARGGetHWND |
tagSUARGGetInfoTip |
tagSUARGGetInteractionState |
tagSUARGGetIntersectingShapes |
tagSUARGGetShapeBytes |
tagSUARGGetShapesByQuery |
tagSUARGGetShapesInRect |
tagSUARGGetShapeType |
tagSUARGGetSize |
tagSUARGGetText |
tagSUARGGetTextByIndex |
tagSUARGGetUnsigned |
tagSUARGGetUnsignedByIndex |
tagSUARGGetWorkspace |
tagSUARGGPtoDP |
tagSUARGIsShapeSelected |
tagSUARGJSCallFunction |
tagSUARGLoadJavaScript |
tagSUARGLog |
tagSUARGRemoveHook |
tagSUARGRemoveTheme |
tagSUARGRepaint |
tagSUARGReplaceShapeData |
tagSUARGSelectShape |
tagSUARGSetAttribute |
tagSUARGSetAttributes |
tagSUARGSetBOOL |
tagSUARGSetButtonBOOL |
tagSUARGSetColor |
tagSUARGSetDouble |
tagSUARGSetDWORD |
tagSUARGSetFloat |
tagSUARGSetInteractionState |
tagSUARGSetPoint |
tagSUARGSetRasterImage |
tagSUARGSetSerialData |
tagSUARGSetStatusBarPaneInfo |
tagSUARGSetText |
tagSUARGSetTextByIndex |
tagSUARGSetUnsigned |
tagSUARGWantUpdate |
tagSUARGZoomToExtent |
tagSUARGZoomToSelection |
tagSUDeserializeHookData |
tagSUExport |
tagSUFileFormatHandlerHookData |
tagSUHookData |
tagSUImport |
tagSUJavaScriptArgument |
tagSUJavaScriptInvokeHookData |
tagSUMenuItemHookData |
tagSUMouseHookData |
tagSUPreRemoveShapeHookData |
tagSUPreRemoveThemeHookData |
tagSUShapeSelChangeHookData |
tagSUToolBarButtonHookData |
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUDataPage Class Reference

  • Class Hierarchy
  • Class Members

SUDataPage Class Reference

Handles custom data pages in ShapeUp. More...

#include <ShapeUpAPI.h>

Inheritance diagram for SUDataPage:

SUObject List of all members.

Public Member Functions

SUDataPage ()
SUDataPage (SUHANDLE hDataPage)
void | Remove ()
HWND | GetHWND ()

Detailed Description

One or more custom data pages can be added to any workspace. A data page can contain any windows child control. E.g list controls, tree controls or any combination of controls placed on a parent control.

A Custom Data Page

Examples:

example_sudatapage.cpp.

Constructor & Destructor Documentation

SUDataPage::SUDataPage ( ) [inline]

Default constructor.

SUDataPage::SUDataPage ( SUHANDLE hDataPage ) [inline]

Constructor.

Parameters:
hDataPage = handle to a ShapeUp data page object.
See also:
SUWorkspace::AddDataPage()

Member Function Documentation

void SUDataPage::Remove ( ) [inline]

Removes this data page from the workspace it's attached to. If the child window is still attached to this data page, it will be destroyed.

See also:
DataPage_Remove(), Workspace_AddDataPage()
Examples:
example_sudatapage.cpp.

HWND SUDataPage::GetHWND ( ) [inline]

Gets access to the ShapeUp data page window.

Returns:
Returns the windows handle to the data page window.
See also:
DataPage_GetHWND()
Examples:
example_sudatapage.cpp.

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUException Class Reference

SUException Class Reference

A wrapper class for error return values. More...

#include <ShapeUpAPI.h>

List of all members.

Public Member Functions

SUException (SURESULT res)
SURESULT | GetErrorCode () const
std::string | GetErrorDesc () const

Protected Attributes

SURESULT _res

Detailed Description

An SUException is thrown from the SU classes when an error code is returned from ShapeUp.
Examples:

example_sudatapage.cpp, and example_sutoolbar.cpp.

Constructor & Destructor Documentation

SUException::SUException ( SURESULT res ) [inline]

Constructor.

Parameters:
res is a SURESULT value from a ShapeUp call.

Member Function Documentation

SURESULT SUException::GetErrorCode ( ) const [inline]

Getter for the error code.

Returns:
The actual SURESULT.

std::string SUException::GetErrorDesc ( ) const [inline]

Translates the underlying SURESULT into a human readable string.

Returns:
The error description.
Examples:
example_sudatapage.cpp, and example_sutoolbar.cpp.

Member Data Documentation

SURESULT SUException::_res [protected]

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUJavaScript Class Reference

SUJavaScript Class Reference

Handles JavaScripts in ShapeUp. More...

#include <ShapeUpAPI.h>

Inheritance diagram for SUJavaScript:

SUObject List of all members.

Public Member Functions

SUJavaScript ()
SUJavaScript (SUHANDLE hJavaScript)
void | Run ()
void | CallFunction (const char *func_name)
void | Close ()

Detailed Description

An SUJavaScript object can be loaded using SUWorkspace::LoadJavaScript(). This script can then be executed via Run(), or a single function in the script may be called.
Note: When creating a JavaScript, ShapeUp will have to run it once to instanciate the function objects. This will have the side effect that any code at file level will be executed the first time the CallFunction() method is called, after which the desired function is called. You can either avoid this by not having any code at file level, or make use of it as an initialisation method. See the following example:
var myState1 = 0;
var myLayer = null;

function doSomething()
{
    myState++;
}

function init()
{
    myLayer = workspace.addNewLayer('Point');
    workspace.refresh();
}

// call to init() on file level, see SUJavaScript
init();

Constructor & Destructor Documentation

SUJavaScript::SUJavaScript ( ) [inline]

Default constructor.

SUJavaScript::SUJavaScript ( SUHANDLE hJavaScript ) [inline]

Constructor.

Parameters:
hJavaScript = handle to a ShapeUp JavaScript.
See also:
SUWorkspace::LoadJavaScript(), Workspace_LoadJavaScript()

Member Function Documentation

void SUJavaScript::Run ( ) [inline]

Executes a loaded JavaScript.

See also:
JavaScript_Run(), SUWorkspace::LoadJavaScript(), Workspace_LoadJavaScript()

void SUJavaScript::CallFunction ( const char * func_name ) [inline]

Executes a named function in a loaded JavaScript.

Todo:
There is currently no support for passing arguments to the function back and forth.
Parameters:
func_name = name of the function to execute.
See also:
JavaScript_CallFunction(), SUWorkspace::LoadJavaScript(), Workspace_LoadJavaScript()

void SUJavaScript::Close ( ) [inline]

Closes a loaded JavaScript.

See also:
JavaScript_Close(), SUWorkspace::LoadJavaScript(), Workspace_LoadJavaScript()

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUMap Class Reference

SUMap Class Reference

Represents the ShapeUp map window. More...

#include <ShapeUpAPI.h>

Inheritance diagram for SUMap:

SUObject List of all members.

Public Member Functions

SUMap (SUHANDLE hMap)
void | GetBounds (SURectf &r)
void | GetViewSize (SUSize &s)
void | GPtoDP (const SUPointf &p, SUPoint &pt)
void | DPtoGP (const SUPoint &p, SUPointf &pt)
HWND | GetHWND ()
void | Repaint (bool bFullRedraw)
void | Draw (HDC hdc, const SUSize &imagesize, const SUPointf &center, double geoWidth=0., double geoHeight=0.)
void | CenterMap (const SUPointf &pt)
void | CenterMap (double x, double y)
void | Zoom (double factor)
void | ZoomToSelection (SUHANDLE hTheme)
void | ZoomToExtent (SUHANDLE hTheme)
unsigned long | GetInteractionState ()
void | SetInteractionState (unsigned long state)

Detailed Description

Each ShapeUp workspace contains a ShapeUp map window. This window may be used to overlay graphics, or change the view of the graphics within it.

The ShapeUp map also maintaines an interaction state, MAPSTATE, which controls the behaviour of the map presented to the user.

Constructor & Destructor Documentation

SUMap::SUMap ( SUHANDLE hMap ) [inline]

Constructor.

Parameters:
hMap = handle to a ShapeUp map window.
See also:
SUWorkspace::GetMapWindow(), Workspace_GetMapWindow()

Member Function Documentation

void SUMap::GetBounds ( SURectf & r ) [inline]

Retrieves the geographical bounds of the map window.

Parameters:
r = a SURectf that will receive the bounds.
See also:
Map_GetBounds()

void SUMap::GetViewSize ( SUSize & s ) [inline]

Retrieves the view size in device units of the map window.

Parameters:
s = a SUSize that will receive the size.
See also:
Map_GetViewSize()

void SUMap::GPtoDP | ( | const SUPointf & | p,
 |  | SUPoint & | pt |
 | ) |  |  | [inline]

Converts geographical points, GP, to device points, DP.

Parameters:
p | = a SUPointf containing the geographical points.
pt | = a SUPoint that will receive the device points.
See also:
Map_GetViewSize()

void SUMap::DPtoGP | ( | const SUPoint & | p,
 |  | SUPointf & | pt |
 | ) |  |  | [inline]

Converts device points, DP, to geographical points, GP.

Parameters:
p | = a SUPoint containing the device points.
pt | = a SUPointf that will receive the geographical points.
See also:
Map_GetViewSize()

HWND SUMap::GetHWND ( ) [inline]

Gets access to the ShapeUp map window.

Returns:
Returns the windows handle to the map window.
See also:
Map_GetHWND()

void SUMap::Repaint ( bool bFullRedraw ) [inline]

Forces the map window to repaint itself. The map is rendered in two steps. First all map objects are drawn to a background buffer. Then that buffer is painted on the map, and on top of that, temporary objects are drawn. Temporary objects are rubber rectangles, bookmark icons, shapes being drawn, etc.

Parameters:
bFullRedraw if true, all map objects are redrawn, and if false, the background buffer is used to paint the map objects and only the top items are redrawn.
See also:
Map_Repaint()

void SUMap::Draw | ( | HDC | hdc,
 |  | const SUSize & | imagesize,
 |  | const SUPointf & | center,
 |  | double | geoWidth = 0.,
 |  | double | geoHeight = 0. |
 | ) |  |  | [inline]

Paints the current map to a dc.

See also:
Map_Draw()

void SUMap::CenterMap ( const SUPointf & pt ) [inline]

Centers the map.

Parameters:
pt is the new center point.
See also:
Map_GetViewSize()

void SUMap::CenterMap | ( | double | x,
 |  | double | y |
 | ) |  |  | [inline]

Centers the map.

Parameters:
x | is the new center point east-west component.
y | is the new center point north-south component.
See also:
Map_GetViewSize()

void SUMap::Zoom ( double factor ) [inline]

Zooms the map.

Parameters:
factor is the factor used to zoom the map. 0.0 < factor < 1.0 zooms in, and 1.0 < factor zooms out.
See also:
Map_Zoom()

void SUMap::ZoomToSelection ( SUHANDLE hTheme ) [inline]

Zooms the map to the extent of selected shapes in a layer.

Parameters:
hTheme is a handle to a ShapeUp theme, or a SUTheme object, in which to find selected ojects.
See also:
Map_Zoom()

void SUMap::ZoomToExtent ( SUHANDLE hTheme ) [inline]

Zooms the map to the extent of a layer.

Parameters:
hTheme is a handle to a ShapeUp theme, or a SUTheme object.
See also:
Map_ZoomToExtent()

unsigned long SUMap::GetInteractionState ( ) [inline]

Returns the current map interaction state. The interaction state is a value indicating what the user is about to do, or is doing, in the map. This is in short the state of the mutual exclusive toolbar buttons like select, rectangle select, circle select, etc. This can be used to add new states to the map.

Returns:
A ShapeUp map interaction state.
See also:
SetInteractionState(), Map_GetInteractionState(), MAPSTATE

void SUMap::SetInteractionState ( unsigned long state ) [inline]

Sets a new map interaction state. The interaction state is a value indicating what the user is about to do, or is doing, in the map. This is in short the state of the mutual exclusive toolbar buttons like select, rectangle select, circle select, etc. This can be used to add new states to the map.

Parameters:
state is the new state. It must be one of the defined map interaction states. Note: Not all map states defined can be set. Check MAPSTATE for more info.
See also:
GetInteractionState(), Map_SetInteractionState(), MAPSTATE

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUMenuItem Class Reference

SUMenuItem Class Reference

Handles a single ShapeUp menu item. More...

#include <ShapeUpAPI.h>

Inheritance diagram for SUMenuItem:

SUObject List of all members.

Public Member Functions

SUMenuItem ()
SUMenuItem (SUHANDLE hMenuItem)
void SetEnabled (bool bEnable)

Detailed Description

An SUMenuItem object can be retreived from various sources, e.g. ShapeUp_AddNewLayerHook() returns a handle to a menu item.
See also:
ShapeUp_AddNewLayerHook()

Constructor & Destructor Documentation

SUMenuItem::SUMenuItem ( ) [inline]

Default constructor.

SUMenuItem::SUMenuItem ( SUHANDLE hMenuItem ) [inline]

Constructor.

Parameters:
hMenuItem is a handle to a menu item.

Member Function Documentation

void SUMenuItem::SetEnabled ( bool bEnable ) [inline]

Changes the availability of the menu item.

Parameters:
bEnable = true enables the item, false disables.

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUObject Class Reference

SUObject Class Reference

Base class for ShapeUp object classes. More...

#include <ShapeUpAPI.h>

Inheritance diagram for SUObject:

SUDataPage SUJavaScript SUMap SUMenuItem SURecordset SUShape SUTheme SUToolBar SUWorkspace List of all members.

Public Member Functions

SUObject ()
SUObject (SUHANDLE h)
virtual | ~SUObject ()
operator SUHANDLE ()
virtual bool | IsValid () const

Protected Attributes

SUHANDLE _h

Detailed Description

SUObject manages the internal handle to the ShapeUp object.

Constructor & Destructor Documentation

SUObject::SUObject ( ) [inline]

Default constructor.

SUObject::SUObject ( SUHANDLE h ) [inline]

Constructor.

Parameters:
h is a handle to a ShapeUp object.

virtual SUObject::~SUObject ( ) [inline, virtual]

Virtual destructor.

Member Function Documentation

SUObject::operator SUHANDLE ( ) [inline]

Used for conversion to an SUHANDLE.

virtual bool SUObject::IsValid ( ) const [inline, virtual]

Checks if this object has a valid SUHANDLE.

Returns:
true if valid, and false otherwise.

Member Data Documentation

SUHANDLE SUObject::_h [protected]

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUPoint Class Reference

SUPoint Class Reference

Representation of a integer based position or vector.

#include <ShapeUpAPI.h>

List of all members.

Public Member Functions

SUPoint ()
SUPoint (int _x, int _y)
const SUPoint & | operator+= (const SUPoint &p)
const SUPoint & | operator-= (const SUPoint &p)
bool | operator== (const SUPoint &rhs) const
bool | operator!= (const SUPoint &rhs) const

Public Attributes

int | x
int | y

Constructor & Destructor Documentation

SUPoint::SUPoint ( ) [inline]

Default constructor.

SUPoint::SUPoint | ( | int | _x,
 |  | int | _y |
 | ) |  |  | [inline]

Member Function Documentation

const SUPoint& SUPoint::operator+= ( const SUPoint & p ) [inline]

const SUPoint& SUPoint::operator-= ( const SUPoint & p ) [inline]

bool SUPoint::operator== ( const SUPoint & rhs ) const [inline]

bool SUPoint::operator!= ( const SUPoint & rhs ) const [inline]

Member Data Documentation

int SUPoint::x

int SUPoint::y

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUPointf Class Reference

SUPointf Class Reference

Representation of a floating point double precision based position or vector.

#include <ShapeUpAPI.h>

List of all members.

Public Member Functions

SUPointf ()
SUPointf (double _x, double _y)
const SUPointf & | operator+= (const SUPointf &p)
const SUPointf & | operator-= (const SUPointf &p)
bool | operator== (const SUPointf &rhs) const
bool | operator!= (const SUPointf &rhs) const

Public Attributes

double | x
double | y

Constructor & Destructor Documentation

SUPointf::SUPointf ( ) [inline]

Default constructor.

SUPointf::SUPointf | ( | double | _x,
 |  | double | _y |
 | ) |  |  | [inline]

Member Function Documentation

const SUPointf& SUPointf::operator+= ( const SUPointf & p ) [inline]

const SUPointf& SUPointf::operator-= ( const SUPointf & p ) [inline]

bool SUPointf::operator== ( const SUPointf & rhs ) const [inline]

bool SUPointf::operator!= ( const SUPointf & rhs ) const [inline]

Member Data Documentation

double SUPointf::x

double SUPointf::y

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SURecordset Class Reference

SURecordset Class Reference

Multi-purpose recordset class. More...

#include <ShapeUpAPI.h>

Inheritance diagram for SURecordset:

SUObject List of all members.

Public Member Functions

SURecordset ()
SURecordset (SUHANDLE hRecordset)
void | Next ()
void | Prev ()
void | First ()
void | Last ()
SUHANDLE Get ()
bool | Eof ()
bool | Bof ()
void | Close ()
size_t | GetCount ()

Detailed Description

An SURecordset object can be retreived from various sources, e.g. SUWorkspace::GetSelectedThemes() and SUTheme::GetShapesInRect(). Depending on the source, the recordset contains handles to different objects. However, one recordset always manages handles to the same object type.

Once a recordset is opened, it must be closed with a call to Close().

Constructor & Destructor Documentation

SURecordset::SURecordset ( ) [inline]

Default constructor.

SURecordset::SURecordset ( SUHANDLE hRecordset ) [inline]

Constructor.

Parameters:
hRecordset is a handle to a ShapeUp recordset.

Member Function Documentation

void SURecordset::Next ( ) [inline]

Advances the recordset cursor to the next record.

void SURecordset::Prev ( ) [inline]

Backs the recordset cursor to the previous record.

void SURecordset::First ( ) [inline]

Sets the recordset cursor to the first record.

void SURecordset::Last ( ) [inline]

Sets the recordset cursor to the last record.

SUHANDLE SURecordset::Get ( ) [inline]

Retreives the element at the recordset cursor. The object return type depends on the source of the recordset. It is safe to store a handle to an object for later use while traversing the recordset.

Returns:
A handle to the ShapeUp object.

bool SURecordset::Eof ( ) [inline]

Checks if the recordset cursor is advanced beyond the last record.

Returns:
true if the recordset cursor is advanced beyond the last record, otherwise false.

bool SURecordset::Bof ( ) [inline]

Checks if the recordset cursor is pointing before the first record.

Returns:
true if the recordset cursor is pointing before the last record, otherwise false.

void SURecordset::Close ( ) [inline]

Closes the recordset, and frees internal resources.

IMPORTANT: All recordsets must be closed to avoid memory leaks.

size_t SURecordset::GetCount ( ) [inline]

Gets the number of records in the recordset.

Returns:
The number of records in the recordset.

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SURectf Class Reference

SURectf Class Reference

Representation of a floating point double precision based axis-aligned rectangle.

#include <ShapeUpAPI.h>

List of all members.

Public Member Functions

SURectf ()
SURectf (double _x1, double _y1, double _x2, double _y2)
void | Normalize ()
double | Width () const
double | Height () const
void | Inflate (const SUSizef &s)
bool | Contains (const SUPointf &p)
bool | Contains (double x, double y) const
bool | Intersects (const SURectf &r) const

Public Attributes

double | x1
double | y1
double | x2
double | y2

Constructor & Destructor Documentation

SURectf::SURectf ( ) [inline]

Default constructor.

SURectf::SURectf | ( | double | _x1,
 |  | double | _y1,
 |  | double | _x2,
 |  | double | _y2 |
 | ) |  |  | [inline]

Member Function Documentation

void SURectf::Normalize ( ) [inline]

Arranges the rectangle to ensure x1 <= x2 and y1 <= y2.

double SURectf::Width ( ) const [inline]

Returns the width of this rectangle.

Returns:
The width of this rectangle which might be negative if not normalized.

double SURectf::Height ( ) const [inline]

Returns the height of this rectangle.

Returns:
The height of this rectangle which might be negative if not normalized.

void SURectf::Inflate ( const SUSizef & s ) [inline]

Increases the size of the rectangle with two times s (each side once).

Postcondition:
The rectangle is normalized.

bool SURectf::Contains ( const SUPointf & p ) [inline]

Returns true if the point p is contained within the rectangle, otherwise false.

bool SURectf::Contains | ( | double | x,
 |  | double | y |
 | ) |  |  | const [inline]

Returns true if the point at coordinate (x, y) is contained within the rectangle, otherwise false.

bool SURectf::Intersects ( const SURectf & r ) const [inline]

Returns true if the rectangle intersects the rectangle r, otherwise false.

Member Data Documentation

double SURectf::x1

double SURectf::y1

double SURectf::x2

double SURectf::y2

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUShape Class Reference

SUShape Class Reference

Handles a shape object in ShapeUp. More...

#include <ShapeUpAPI.h>

Inheritance diagram for SUShape:

SUObject List of all members.

Public Member Functions

SUShape ()
SUShape (SUHANDLE hShape)
bool | IsSelected (SUHANDLE hTheme) const
void | Select (SUHANDLE hTheme, bool bSelect)
ShapeType | GetShapeType () const
void | GetBounds (SURectf &r) const
size_t | GetPartCount () const
size_t | GetCoordinateCount (size_t part) const
void | GetCoordinate (size_t part, size_t coordIndex, SUPointf &coord) const
void | GetClosestPoint (const SUPointf &ref, SUPointf &closest) const
std::string | GetAttribute (SUHANDLE hTheme, size_t index) const
void | SetAttribute (SUHANDLE hTheme, size_t index, const char *data)
void | SetAttributes (SUHANDLE hTheme, size_t count, const char *data[])
size_t | GetShapeSizeBytes () const
void | GetShapeBytes (unsigned char *buffer, size_t bufferSize) const

Detailed Description

The SUShape class represents a shape object in ShapeUp. A shape can be a point, polyline or a polygon.
Examples:

example_loadergpi.cpp.

Constructor & Destructor Documentation

SUShape::SUShape ( ) [inline]

Default constructor.

SUShape::SUShape ( SUHANDLE hShape ) [inline]

Constructor.

Parameters:
hShape = handle to a ShapeUp shape.
See also:
SUTheme::GetShape(), Theme_GetShape()

Member Function Documentation

bool SUShape::IsSelected ( SUHANDLE hTheme ) const [inline]

Checks whether a shape is selected or not.

Parameters:
hTheme = handle to a ShapeUp theme, or a SUTheme object, in which to find this object. Note: A shape can be contained in more than one theme under certain circumstances.
Returns:
true if the shape is selected in the theme hTheme, and false otherwise.
See also:
SUTheme, Shape_IsSelected()

void SUShape::Select | ( | SUHANDLE | hTheme,
 |  | bool | bSelect |
 | ) |  |  | [inline]

Selects or deselects the shape object.

Parameters:
hTheme | = handle to a ShapeUp theme, or a SUTheme object, in which to find this object. Note: A shape can be contained in more than one theme under certain circumstances.
bSelect | = if true, the shape will be selected, else deselected.
See also:
SUTheme, Shape_Select()

ShapeType SUShape::GetShapeType ( ) const [inline]

Gets the shape type of this shape.

Returns:
the ShapeType value of this shape.
See also:
Shape_GetShapeType()

void SUShape::GetBounds ( SURectf & r ) const [inline]

Gets the shapes bounding box.

Parameters:
r [out] = a rectangle that will receive the shape bounds.
See also:
Shape_GetBounds()

size_t SUShape::GetPartCount ( ) const [inline]

Gets the count of all parts in this shape.

Returns:
the number of parts in this shape.
See also:
Shape_GetPartCount()

size_t SUShape::GetCoordinateCount ( size_t part ) const [inline]

Gets the count of all coordinates in a part for this shape.

Parameters:
part [in] = zero based index of the part to query.
Returns:
the number of coordinates for the given part.
See also:
Shape_GetCoordinateCount()

void SUShape::GetCoordinate | ( | size_t | part,
 |  | size_t | coordIndex,
 |  | SUPointf & | coord |
 | ) |  |  | const [inline]

Gets a coordinate from this shape.

Parameters:
part | [in] = zero based index of the part to query.
coordIndex | [in] = zero based index of the coordinate of the part to query.
coord | [out] = the coordinate at the specified index.
See also:
Shape_GetCoordinate()

void SUShape::GetClosestPoint | ( | const SUPointf & | ref,
 |  | SUPointf & | closest |
 | ) |  |  | const [inline]

Gets the coordinate of this shape closest to a reference point.

Parameters:
ref | [in] = reference point.
closest | [out] = the coordinate on this shape closest to ref.
See also:
Shape_GetClosestPoint()

std::string SUShape::GetAttribute | ( | SUHANDLE | hTheme,
 |  | size_t | index |
 | ) |  |  | const [inline]

Queries this shape for one of its attributes.

Parameters:
hTheme | = handle to a ShapeUp theme, or a SUTheme object, in which to find this object. Note: A shape can be contained in more than one theme under certain circumstances.
index | = zero-based index of the attribute column to query.
Returns:
an attribute value of this shape.
See also:
SUTheme, Shape_GetAttribute()

void SUShape::SetAttribute | ( | SUHANDLE | hTheme,
 |  | size_t | index,
 |  | const char * | data |
 | ) |  |  | [inline]

Sets an attribute for this shape.

Parameters:
hTheme | = handle to a ShapeUp theme, or a SUTheme object, in which to find this object. Note: A shape can be contained in more than one theme under certain circumstances.
index | = zero-based index of the attribute column to set.
data | = null-terminated string containing the attribute data.
See also:
SUTheme, Shape_SetAttribute()
Examples:
example_loadergpi.cpp.

void SUShape::SetAttributes | ( | SUHANDLE | hTheme,
 |  | size_t | count,
 |  | const char * | data[] |
 | ) |  |  | [inline]

Sets multiple attribute values of a shape within a theme.

Parameters:
hTheme | is an SUHANDLE to the theme containing the shape.
count | is the number of attribute values in data.
data | is an array of null-terminated strings that contains the new values. The data array may contain fewer attributes than the theme can handle. To avoid affecting an attribute value, set the appropriate field to NULL. To clear an attribute, set the field to an empty string, "".
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
Shape_SetAttributes(), SetAttribute()

size_t SUShape::GetShapeSizeBytes ( ) const [inline]

Queries this shape for how many bytes are required to store the underlying binary shape object.

Returns:
The number of bytes required to store the binary shape object.
See also:
Shape_GetShapeBytes()

void SUShape::GetShapeBytes | ( | unsigned char * | buffer,
 |  | size_t | bufferSize |
 | ) |  |  | const [inline]

Retrieves the underlying binary shape object.

Parameters:
buffer | = a byte buffer larege enough to store the binary shape object. To get the size needed, first query the shape using the GetShapeSizeBytes() method.
bufferSize | = the size in bytes of buffer.
See also:
GetShapeSizeBytes(), Shape_GetShapeBytes()

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUSize Class Reference

SUSize Class Reference

Representation of a integer based size in two dimensions.

#include <ShapeUpAPI.h>

List of all members.

Public Member Functions

SUSize ()
SUSize (size_t w, size_t h)

Public Attributes

size_t | width
size_t | height

Constructor & Destructor Documentation

SUSize::SUSize ( ) [inline]

SUSize::SUSize | ( | size_t | w,
 |  | size_t | h |
 | ) |  |  | [inline]

Member Data Documentation

size_t SUSize::width

size_t SUSize::height

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUSizef Class Reference

SUSizef Class Reference

Representation of a floating point double precision based size in two dimensions.

#include <ShapeUpAPI.h>

List of all members.

Public Member Functions

SUSizef ()
SUSizef (double w, double h)

Public Attributes

double | width
double | height

Constructor & Destructor Documentation

SUSizef::SUSizef ( ) [inline]

SUSizef::SUSizef | ( | double | w,
 |  | double | h |
 | ) |  |  | [inline]

Member Data Documentation

double SUSizef::width

double SUSizef::height

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUStatusBar Class Reference

SUStatusBar Class Reference

Represents the ShapeUp status bar. More...

#include <ShapeUpAPI.h>

List of all members.

Public Member Functions

SUStatusBar ()
void | SetText (const char *text)
void | BeginProgress (const char *title=NULL, float progress=0.f)
void | SetProgress (float progress)
void | EndProgress ()
size_t | AllocatePane (size_t width)
void | ReleasePane (size_t paneIndex)
size_t | GetPaneCount ()
void | SetPaneInfo (size_t paneIndex, const char *text, HICON hIcon)

Protected Attributes

std::vector< SUHANDLE > | _paneHandles
SUHANDLE _hProgress

Detailed Description

The ShapeUp statusbar can be accessed from a GPI, allowing it to allocate a dedicated statusbar pane for displaying status information, or to use the progress bar that is used by ShapeUp internal functions.

Constructor & Destructor Documentation

SUStatusBar::SUStatusBar ( ) [inline]

Default constructor.

Member Function Documentation

void SUStatusBar::SetText ( const char * text ) [inline]

Sets the information in a pane previously allocated by a call to AllocatePane(). A pane can have a text, an icon or both.

Parameters:
text is the new text string. NULL clears the field, and displays the 'Ready' message.
See also:
ShapeUp_SetStatusBarText()

void SUStatusBar::BeginProgress | ( | const char * | title = NULL,
 |  | float | progress = 0.f |
 | ) |  |  | [inline]

This function will prepare the progress bar in ShapeUp's statusbar. Any call to BeginProgress() must have a matching call to EndProgress().

Parameters:
title | = Optional progress bar title which, if supplied, will be dispayed to the left och the progress bar. A null value means no title, which is default.
progress | = Optional initial progress where 0.0f <= progress <= 1.0f. Default is 0.
See also:
ShapeUp_BeginProgress()

void SUStatusBar::SetProgress ( float progress ) [inline]

This function will prepare the progress bar in ShapeUp's statusbar. Any call to BeginProgress() must have a matching call to EndProgress().

Parameters:
progress = initial progress where 0.0f <= progress <= 1.0f.
See also:
ShapeUp_SetProgress()

void SUStatusBar::EndProgress ( ) [inline]

This function will close the progress bar in ShapeUp's statusbar. Any call to BeginProgress() must have a matching call to EndProgress().

See also:
ShapeUp_EndProgress()

size_t SUStatusBar::AllocatePane ( size_t width ) [inline]

This function will allocate a pane in ShapeUp's statusbar. The GPI will have exclusive access to this pane. A status bar pane can contain text, an icon or both. Since there is only a limited space make sure it's used for something valuable, or that it's lifetime is short. A GPI may allocate more than one pane.

Parameters:
width = desired width of the pane in pixels.
Returns:
The pane index if successful.
See also:
ReleasePane(), ShapeUp_AllocateStatusBarPane()

void SUStatusBar::ReleasePane ( size_t paneIndex ) [inline]

This function will release a pane previously allocated by a call to AllocatePane().

Parameters:
paneIndex = the index of the pane to release.
See also:
ReleasePane(), ShapeUp_ReleaseStatusBarPane()

size_t SUStatusBar::GetPaneCount ( ) [inline]

Retrieves the number of panes this SUStatusBar has allocated.

Returns:
The number of panes.

void SUStatusBar::SetPaneInfo | ( | size_t | paneIndex,
 |  | const char * | text,
 |  | HICON | hIcon |
 | ) |  |  | [inline]

Sets the information in a pane previously allocated by a call to AllocatePane(). A pane can have a text, an icon or both.

Parameters:
paneIndex | = the index of the pane to release.
text | = text to be displayed in the pane. Null clears the text.
hIcon | = handle to an icon to be displayed in the pane. Null clears the icon.
See also:
AllocatePane(), ShapeUp_SetStatusBarPaneInfo()

Member Data Documentation

std::vector<SUHANDLE> SUStatusBar::_paneHandles [protected]

SUHANDLE SUStatusBar::_hProgress [protected]

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUTheme Class Reference

SUTheme Class Reference

Represents a ShapeUp theme or layer. More...

#include <ShapeUpAPI.h>

Inheritance diagram for SUTheme:

SUObject List of all members.

Public Member Functions

SUTheme ()
SUTheme (SUHANDLE hTheme)
SUShape | AddShape (const CShapeRecord *shapeData)
void | BatchAddShapeBegin ()
void | BatchAddShapeEnd ()
void | ReplaceShapeData (SUHANDLE hShape, const CShapeRecord *shapeData)
void | DeleteShape (SUHANDLE hShape)
bool | IsSelected ()
bool | IsReadOnly ()
bool | IsVisible ()
std::string | GetName ()
void | SetName (const char *name)
size_t | GetAttributeCount ()
std::string | GetAttributeName (size_t column)
unsigned long | GetAttributeType (size_t column)
size_t | GetAttributeIndex (const char *name)
size_t | GetShapeCount ()
SUShape | GetShape (size_t index)
SUShape | GetShapeFromIndex (size_t index)
ShapeType | GetShapeType ()
void | GetBounds (SURectf &r)
void | RecalcBounds ()
SURecordset | GetIntersectingShapes (SUShape shape)
SURecordset | GetShapesInRect (const SURectf &r, bool bPartiallyInRectOk)
size_t | GetSelectionCount ()
SURecordset GetSelectedShapes ()
SURecordset | GetSelectedShapesInRect (const SURectf &r, bool bPartiallyInRectOk)
std::string | GetInfoTip (SUShape shape)
void | GetFont (LOGFONT *font, COLORREF *clr)
SURecordset | GetShapesByQuery (const char *where)
SUHANDLE LookupWorkspace ()
size_t | AddAttribute (unsigned long type, const char *name, const char *defaultval=NULL)
void | DeleteAttribute (size_t index)
void | SetAttributeComment (size_t index, const char *comment)
std::string | GetComment ()
void | SetComment (const char *comment)
COLORREF | GetPenColor ()
void | SetPenColor (COLORREF clr)
COLORREF | GetFillColor ()
void | SetFillColor (COLORREF clr)
size_t | GetPenWidth ()
void | SetPenWidth (size_t width)
size_t | GetPenStyle ()
void | SetPenStyle (size_t style)
void | SetRasterImage (HBITMAP hbm, double west, double south, double east, double north, const char *sourceHint)
void | SetSerialData (size_t byteCount, const void *bytes)
void | ClearSelection ()
void | Select (bool select)
void | InvertSelection ()

Detailed Description

A ShapeUp theme manages raster images or vector objects and their attributes. Data can be added, manipulated or removed.

Even though ShapeUp supports different types of vector data, such as points, lines and polygons, a single theme may currently not contain more than one type.

An SUTheme is normally retrieved from an SUWorkspace object.

Examples:

example_loadergpi.cpp.

Constructor & Destructor Documentation

SUTheme::SUTheme ( ) [inline]

Default constructor.

SUTheme::SUTheme ( SUHANDLE hTheme ) [inline]

Constructor.

Parameters:
hTheme is a handle to a ShapeUp theme.
See also:
SUWorkspace::GetTheme(), Workspace_GetTheme()

Member Function Documentation

SUShape SUTheme::AddShape ( const CShapeRecord * shapeData ) [inline]

Adds a new shape to this theme. Adding a shape updates the themes bounding box automatically.

Parameters:
shapeData is the shape to be added. ShapeUp makes a copy of this shape.
Returns:
Returns a handle to the created shape.
See also:
Theme_AddShape(), BatchAddShapeBegin(), BatchAddShapeEnd()
Examples:
example_loadergpi.cpp.

void SUTheme::BatchAddShapeBegin ( ) [inline]

Turns off indexing and other time consuming tasks when calling AddShape(). Use this if many shapes should be added at once. After the shapes have been added, call BatchAddShapeEnd() to turn the features back on again.

See also:
AddShape(), BatchAddShapeEnd(), Theme_BatchAddShapeBegin()

void SUTheme::BatchAddShapeEnd ( ) [inline]

Turns on indexing and other tasks after calling AddShape().

See also:
AddShape(), BatchAddShapeBegin(), Theme_BatchAddShapeEnd()

void SUTheme::ReplaceShapeData | ( | SUHANDLE | hShape,
 |  | const CShapeRecord * | shapeData |
 | ) |  |  | [inline]

Replaces a shape in this theme. After this operation, the handle hShape is still valid, but points to the new shape instead. Also, after a call to this function, the themes bounding box must be updated via a call to SUTheme::RecalcBounds()

Parameters:
hShape | is a handle to the shape to replace.
shapeData | is the shape to be inserted. ShapeUp makes a copy of this shape.
See also:
Theme_ReplaceShapeData(), SUTheme::RecalcBounds()

void SUTheme::DeleteShape ( SUHANDLE hShape ) [inline]

Deletes a shape in this theme. After this operation, the handle hShape is invalid. Also, after a call to this function, the themes bounding box must be updated via a call to SUTheme::RecalcBounds()

Parameters:
hShape is a handle to the shape to delete.
See also:
Theme_DeleteShape()

bool SUTheme::IsSelected ( ) [inline]

Queries ShapeUp if this theme is selected or not.

Returns:
True if this theme is selected, and false otherwise.
See also:
Theme_IsSelected()

bool SUTheme::IsReadOnly ( ) [inline]

Queries ShapeUp if this theme is read-only or not.

Returns:
True if this theme is read-only, and false otherwise.
See also:
Theme_IsReadOnly()

bool SUTheme::IsVisible ( ) [inline]

Queries ShapeUp if this theme is visible or not.

Returns:
True if this theme is visible, and false otherwise.
See also:
Theme_IsReadOnly()

std::string SUTheme::GetName ( ) [inline]

Queries ShapeUp for the name of this theme.

Returns:
The name of this theme.
See also:
Theme_GetName()

void SUTheme::SetName ( const char * name ) [inline]

Sets a new name for this theme.

Parameters:
name is a null-terminated string containing the new name for this theme.
See also:
Theme_SetName()

size_t SUTheme::GetAttributeCount ( ) [inline]

Queries ShapeUp for the number of attributes this theme has.

Returns:
The number of attributes.
See also:
Theme_GetAttributeCount()

std::string SUTheme::GetAttributeName ( size_t column ) [inline]

Queries ShapeUp for the name of this themes attributes.

Parameters:
column is the zero-based index of the attribute.
Returns:
The name of attribute at index column.
See also:
Theme_GetAttributeName()

unsigned long SUTheme::GetAttributeType ( size_t column ) [inline]

Queries ShapeUp for the type of this themes attributes.

Parameters:
column is the zero-based index of the attribute.
Returns:
The attribute type of attribute at index column.
See also:
ATTRIBUTETYPE, Theme_GetAttributeType()

size_t SUTheme::GetAttributeIndex ( const char * name ) [inline]

Queries ShapeUp for the index of a named attribute in this theme.

Parameters:
name is the name of the attribute to look up.
Returns:
The index of the named attribute. Throws an exception if the look-up failed.
See also:
ATTRIBUTETYPE, Theme_GetAttributeIndex()

size_t SUTheme::GetShapeCount ( ) [inline]

Queries ShapeUp for the number of shapes this theme has.

Returns:
The number of shapes in this theme.
See also:
Theme_GetShapeCount()

SUShape SUTheme::GetShape ( size_t index ) [inline]

Queries ShapeUp for a shape of this theme.

Parameters:
index is the zero-based index of the shape in this theme.
Returns:
The SUShape object at the given index.
See also:
Theme_GetShape()

SUShape SUTheme::GetShapeFromIndex ( size_t index ) [inline]

Queries ShapeUp for a shape of this theme.

Parameters:
index is the shape index of the shape in this theme.
Returns:
The SUShape object with the given index.
See also:
Theme_GetShape()

ShapeType SUTheme::GetShapeType ( ) [inline]

Queries ShapeUp for the shape type of this theme.

Returns:
The ShapeType of this theme.
See also:
Theme_GetShapeType()

void SUTheme::GetBounds ( SURectf & r ) [inline]

Gets the layers bounding box.

Parameters:
r [out] is a rectangle that will receive the shape bounds.
See also:
Theme_GetBounds()

void SUTheme::RecalcBounds ( ) [inline]

Call this function to recalculate the layers bounding box after its data has been manipulated.

See also:
SUTheme::ReplaceShapeData()

SURecordset SUTheme::GetIntersectingShapes ( SUShape shape ) [inline]

Queries ShapeUp for the shapes in this theme that intersects the shape argument. If the shape argument is taken from this theme, it is excluded from the resulting recordset. It's important to close the resulting recordset using SURecordset::Close() to avoid resource leaks.

Parameters:
shape is a shape to compare this theme's shapes to to find intersections.
Returns:
A recordset containing shapes.
See also:
SURecordset, Theme_GetIntersectingShapes()

SURecordset SUTheme::GetShapesInRect | ( | const SURectf & | r,
 |  | bool | bPartiallyInRectOk |
 | ) |  |  | [inline]

Queries ShapeUp for the shapes in a given rectangle in this theme. It's important to close the resulting recordset using SURecordset::Close() to avoid resource leaks.

Parameters:
r | is a rectangle to compare this theme's shapes to to find intersections.
bPartiallyInRectOk | if true, this function returns shapes intersecting the rectangle r. If false, only shapes fully contained in the rectangle r is returned.
Returns:
A recordset containing shapes.
See also:
SURecordset, Theme_GetShapesInRect()

size_t SUTheme::GetSelectionCount ( ) [inline]

Returns the number of selected objects in this theme.

Returns:
The number of selected objects.
See also:
Theme_GetSelectionCount()

SURecordset SUTheme::GetSelectedShapes ( ) [inline]

Queries ShapeUp for the selected shapes in this theme. It's important to close the resulting recordset using SURecordset::Close() to avoid resource leaks.

Returns:
A recordset containing shapes.
See also:
SURecordset, Theme_GetSelectedShapes()

SURecordset SUTheme::GetSelectedShapesInRect | ( | const SURectf & | r,
 |  | bool | bPartiallyInRectOk |
 | ) |  |  | [inline]

Queries ShapeUp for the selected shapes in a given rectangle in this theme. It's important to close the resulting recordset using SURecordset::Close() to avoid resource leaks.

Parameters:
r | is a rectangle to compare this theme's shapes to to find intersections.
bPartiallyInRectOk | if true, this function returns selected shapes intersecting the rectangle r. If false, only selected shapes fully contained in the rectangle r is returned.
Returns:
A recordset containing shapes.
See also:
SURecordset, Theme_GetSelectedShapesInRect()

std::string SUTheme::GetInfoTip ( SUShape shape ) [inline]

Gets the InfoTip of a shape in the theme. The InfoTip is translated from the themes InfoTip Template using attributes of the shape.

Parameters:
shape is the shape for which the InfoTip should be retrieved.
Returns:
The translated InfoTip for the SUShape shape.
See also:
SUShape, Theme_GetInfoTip()

void SUTheme::GetFont | ( | LOGFONT * | font,
 |  | COLORREF * | clr |
 | ) |  |  | [inline]

Gets font information for this theme.

Parameters:
font | is a pointer to a LOGFONT struct that will receive the font information. May be NULL if not required.
clr | is a pointer to a COLORREF value that will receive the text color information. May be NULL if not required.
See also:
GetFont()

SURecordset SUTheme::GetShapesByQuery ( const char * where ) [inline]

Queries ShapeUp for the shapes matching a query string in this theme. It's important to close the resulting recordset using SURecordset::Close() to avoid resource leaks.

Parameters:
where is an SQL where-statement as found in the ShapeUp Query dialog.
Returns:
A recordset containing shapes.
See also:
SURecordset, Theme_GetShapesByQuery()

SUHANDLE SUTheme::LookupWorkspace ( ) [inline]

Queries this theme for its parent workspace.

Returns:
A handle to a ShapeUp workspace.
See also:
Theme_LookupWorkspace()

size_t SUTheme::AddAttribute | ( | unsigned long | type,
 |  | const char * | name,
 |  | const char * | defaultval = NULL |
 | ) |  |  | [inline]

Adds an attribute to this theme.

Parameters:
type | is an ATTRIBUTETYPE value indicating the type of the attribute.
name | is a null-terminated string containing the name of the new attribute. This value may not be NULL nor an empty string.
defaultval | is a null-terminated string containing an optional default value to be added to all shapes. This parameter may be NULL.
Returns:
The index of the created attribute.
See also:
ATTRIBUTETYPE, DeleteAttribute(), Theme_AddAttribute()
Examples:
example_loadergpi.cpp.

void SUTheme::DeleteAttribute ( size_t index ) [inline]

Deletes an attribute from this theme.

Parameters:
index is the zero-based index of the attribute.
See also:
AddAttribute(), Theme_DeleteAttribute()

void SUTheme::SetAttributeComment | ( | size_t | index,
 |  | const char * | comment |
 | ) |  |  | [inline]

Sets the comment for an attribute.

Parameters:
index | is the zero-based index of the attribute.
comment | is the new attribute comment. Use NULL to clear the comment.
See also:
Theme_SetAttributeComment()

std::string SUTheme::GetComment ( ) [inline]

Gets the theme comment.

Returns:
The theme comment.
See also:
Theme_GetComment()

void SUTheme::SetComment ( const char * comment ) [inline]

Sets the theme comment.

Parameters:
comment is the new theme comment.
See also:
Theme_SetComment()

COLORREF SUTheme::GetPenColor ( ) [inline]

Gets the theme's pen color.

Returns:
The theme's pen color.
See also:
Theme_GetPenColor()

void SUTheme::SetPenColor ( COLORREF clr ) [inline]

Sets the theme's pen color.

Parameters:
clr is the theme's new pen color.
See also:
Theme_SetPenColor()

COLORREF SUTheme::GetFillColor ( ) [inline]

Gets the theme's fill color.

Returns:
The theme's pen color.
See also:
Theme_GetFillColor()

void SUTheme::SetFillColor ( COLORREF clr ) [inline]

Sets the theme's fill color.

Parameters:
clr is the theme's new pen color.
See also:
Theme_SetFillColor()

size_t SUTheme::GetPenWidth ( ) [inline]

Gets the theme's pen width.

Returns:
The theme's pen width.
See also:
Theme_GetPenWidth()

void SUTheme::SetPenWidth ( size_t width ) [inline]

Sets the theme's pen width.

Parameters:
width is the theme's new pen width.
See also:
Theme_SetPenWidth()

size_t SUTheme::GetPenStyle ( ) [inline]

Gets the theme's pen style.

Returns:
The theme's pen style. For a list of possible style values see PENSTYLE.
See also:
Theme_GetPenStyle(), PENSTYLE

void SUTheme::SetPenStyle ( size_t style ) [inline]

Sets the theme's pen style.

Parameters:
style is the theme's new pen style. For a list of possible style values see PENSTYLE.
See also:
Theme_SetPenStyle(), PENSTYLE

void SUTheme::SetRasterImage | ( | HBITMAP | hbm,
 |  | double | west,
 |  | double | south,
 |  | double | east,
 |  | double | north,
 |  | const char * | sourceHint |
 | ) |  |  | [inline]

Sets the theme's pen width.

Parameters:
hbm | is a handle to a Windows bitmap. ShapeUp will take ownership of the bitmap and destroy it when its no longer needed.
west | is the western boudary of the raster.
south | is the southern boudary of the raster.
east | is the eastern boudary of the raster.
north | is the northern boudary of the raster.
sourceHint | is a description of where the data came from. E.g. if loaded from a file, this could be the file name. This parameter is informational only, and may be NULL. If supplied, it is displayed in the ShapeUp statistical view.
See also:
Theme_SetRasterImage()

void SUTheme::SetSerialData | ( | size_t | byteCount,
 |  | const void * | bytes |
 | ) |  |  | [inline]

Sets data to be serialized with a theme. This function can be called at any time setting new data. However, when this function is called, any old data is discarded and fully replaced with the new.
This data can later be restored from a ShapeUp workspace file when it is loaded, if the plug-in has set up a deserialize hook using the ShapeUp_AddDeserializeHook call.

Parameters:
byteCount | is the size of the bytes array.
bytes | is a pointer to a byte sequence containing the data to be serialized.
See also:
Theme_SetSerialData()

void SUTheme::ClearSelection ( ) [inline]

Clears the current shape selection in a theme.

See also:
Theme_ClearSelection()

void SUTheme::Select ( bool select ) [inline]

Clears the current shape selection in a theme.

Parameters:
select is true if selecting and false if deselecting.
See also:
Theme_Select()

void SUTheme::InvertSelection ( ) [inline]

Inverts the current shape selection in this theme.

See also:
Theme_InvertSelection()

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUToolBar Class Reference

SUToolBar Class Reference

Handles a plug-in defined toolbar. More...

#include <ShapeUpAPI.h>

Inheritance diagram for SUToolBar:

SUObject List of all members.

Public Member Functions

SUToolBar ()
void | Create (HINSTANCE hInstance, LPCTSTR lpszResourceName, const char *name)
void | Create (HINSTANCE hInstance, UINT nID, const char *name)
bool | IsVisible ()
size_t | GetButtonCount ()
void | SetButtonEnabled (UINT nID, bool bEnable)
void | SetButtonChecked (UINT nID, bool bChecked)

Detailed Description

An SUToolBar object should be created by the plug-in if it wants to supply an extra toolbar. A plug-in can have more than one toolbar if necessary. ShapeUp does not currently expose its own toolbars.

To get toolbar button notifications, the ShapeUp_AddToolBarButtonHook() must have been called, and the plug-in hook function, set in fnInit(), must handle HOOKTYPE_TOOLBARBUTTON notifications.

Examples:

example_sutoolbar.cpp.

Constructor & Destructor Documentation

SUToolBar::SUToolBar ( ) [inline]

Default constructor.

Member Function Documentation

void SUToolBar::Create | ( | HINSTANCE | hInstance,
 |  | LPCTSTR | lpszResourceName,
 |  | const char * | name |
 | ) |  |  | [inline]

Creates a new ShapeUp toolbar.

Parameters:
hInstance | = handle to the module containing the toolbar resource.
lpszResourceName | = name of the toolbar resource.
name | = name of the toolbar used in ShapeUp. (Displayed to users)
Examples:
example_sutoolbar.cpp.

void SUToolBar::Create | ( | HINSTANCE | hInstance,
 |  | UINT | nID,
 |  | const char * | name |
 | ) |  |  | [inline]

Creates a new ShapeUp toolbar.

Parameters:
hInstance | = handle to the module containing the toolbar resource.
nID | = id of the toolbar resource.
name | = name of the toolbar used in ShapeUp. (Displayed to users)

bool SUToolBar::IsVisible ( ) [inline]

Checks if this toolbar is visible or not.

Returns:
true if the toolbar is visible, and false otherwise.
See also:
ToolBar_IsVisible()

size_t SUToolBar::GetButtonCount ( ) [inline]

Retrieves the number of buttons in this toolbar.

Returns:
The button count.
See also:
ToolBar_GetButtonCount()

void SUToolBar::SetButtonEnabled | ( | UINT | nID,
 |  | bool | bEnable |
 | ) |  |  | [inline]

Enables or disables a button in this toolbar.

Parameters:
nID | = id of the toolbar button defined in the toolbar resource.
bEnable | = true enables and false disables the button.
See also:
ToolBar_SetButtonEnabled()
Examples:
example_sutoolbar.cpp.

void SUToolBar::SetButtonChecked | ( | UINT | nID,
 |  | bool | bChecked |
 | ) |  |  | [inline]

Checks or unchecks a button in this toolbar.

Parameters:
nID | = id of the toolbar button defined in the toolbar resource.
bChecked | = true checks and false unchecks the button.
See also:
ToolBar_SetButtonChecked()
Examples:
example_sutoolbar.cpp.

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: SUWorkspace Class Reference

SUWorkspace Class Reference

Wrapper for a ShapeUp workspace. More...

#include <ShapeUpAPI.h>

Inheritance diagram for SUWorkspace:

SUObject List of all members.

Public Member Functions

SUWorkspace ()
SUWorkspace (SUHANDLE hWorkspace)
SUMap GetMapWindow ()
size_t | GetThemeCount () const
SUTheme | GetTheme (size_t index)
SUTheme GetSelectedTheme ()
SURecordset GetSelectedThemes ()
size_t | GetSelectionCount ()
SUTheme | CreateNewTheme (ShapeType type, const char *name)
SUTheme | CreateNewThemeFromSelection (SUTheme source, const char *name)
bool | BrowseTheme (const char *title, SUTheme &theme)
void | GetBounds (SURectf &r)
void | Log (const char *line)
bool | IsActive ()
void | Refresh ()
SUJavaScript | LoadJavaScript (const char *file)
std::string | GetComment ()
void | SetComment (const char *comment)
bool | RemoveTheme (SUTheme theme)
void | SetSerialData (size_t byteCount, const void *bytes)
SUHANDLE | AddDataPage (const char *name)
void | ClearSelection ()

Detailed Description

A ShapeUp workspace manages a number of themes. These themes can contain point, line or polygon vector data, or raster images. Although the most common scenario is to have one workspace opened at a time, ShapeUp supports having multiple workspaces opened. Also keep in mind, there might not be a workspace at all.

Most hook functions supply a handle to the active workspace, or the workspace where the action takes place. These workspaces are not necessarily the same!

You may always query ShapeUp for workspaces using the ShapeUp_GetWorkspaceCount(), ShapeUp_GetWorkspace() and ShapeUp_GetActiveWorkspace() API functions.

Examples:

example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

Constructor & Destructor Documentation

SUWorkspace::SUWorkspace ( ) [inline]

Default constructor.

SUWorkspace::SUWorkspace ( SUHANDLE hWorkspace ) [inline]

Constructor.

Parameters:
hWorkspace is a handle to a ShapeUp workspace.
See also:
ShapeUp_GetWorkspace(), ShapeUp_GetWorkspaceCount(), ShapeUp_GetActiveWorkspace()

Member Function Documentation

SUMap SUWorkspace::GetMapWindow ( ) [inline]

Queries the workspace for its map window.

Returns:
A handle to a ShapeUp map window.
See also:
SUMap, Workspace_GetMapWindow()

size_t SUWorkspace::GetThemeCount ( ) const [inline]

Retrieves the number of themes currently in this workspace.

Returns:
The theme count.
See also:
SUTheme, Workspace_GetThemeCount()

SUTheme SUWorkspace::GetTheme ( size_t index ) [inline]

Retrieves a theme in this workspace.

Parameters:
index is the zero-based index of the theme to retrieve, where 0 is the topmost layer.
Returns:
A handle to a ShapeUp theme.
See also:
SUTheme, Workspace_GetTheme()

SUTheme SUWorkspace::GetSelectedTheme ( ) [inline]

Queries ShapeUp for a single selected theme in this workspace.

Returns:
A selected theme, or a null-theme if no themes were selected or if more than one theme was selected.
See also:
Workspace_GetSelectedTheme()

SURecordset SUWorkspace::GetSelectedThemes ( ) [inline]

Queries ShapeUp for the selected themes in this workspace.

Returns:
A recordset containing themes.
See also:
SURecordset, Workspace_GetSelectedThemes()

size_t SUWorkspace::GetSelectionCount ( ) [inline]

Returns the number of selected themes in this workspace.

Returns:
The number of selected themes.
See also:
Workspace_GetSelectionCount()

SUTheme SUWorkspace::CreateNewTheme | ( | ShapeType | type,
 |  | const char * | name |
 | ) |  |  | [inline]

Creates a new theme of specified sort in this workspace.

Parameters:
type | is the type of objects this theme should contain.
name | is a null-terminated string used as the themes initial name. This parameter might be NULL to get default naming.
Returns:
An SUTheme object representing the newly created theme.
See also:
SUTheme, Workspace_CreateNewTheme()

SUTheme SUWorkspace::CreateNewThemeFromSelection | ( | SUTheme | source,
 |  | const char * | name |
 | ) |  |  | [inline]

Creates a new theme based on the selection in a source theme in this workspace.

Parameters:
source | is the theme containing selected shapes to be copied.
name | is a null-terminated string used as the themes initial name. This parameter might be NULL to get default naming.
Returns:
An SUTheme object representing the newly created theme.
See also:
SUTheme, Workspace_CreateNewThemeFromSelection()

bool SUWorkspace::BrowseTheme | ( | const char * | title,
 |  | SUTheme & | theme |
 | ) |  |  | [inline]

Opens the Browse Theme dialog, and lets the user select a theme.

Parameters:
title | is the title of this dialog. If NULL, the title will default to "Select Theme"
theme | [out] is an SUTheme that will receive the selected theme.
Returns:
True if a theme was selected, and false if the user pressed the cancel button.
See also:
SUTheme, Workspace_BrowseTheme()

void SUWorkspace::GetBounds ( SURectf & r ) [inline]

Gets the workspace's bounding box.

Parameters:
r [out] is a rectangle that will receive the aggregated bounds of all themes.
See also:
SUTheme::GetBounds(), Workspace_GetBounds()

void SUWorkspace::Log ( const char * line ) [inline]

Writes a line of text to the console window of this workspace.

Parameters:
line is the text to be written.
See also:
Workspace_Log()

bool SUWorkspace::IsActive ( ) [inline]

Retrieves the active state of this workspace.

Returns:
True if this workspace is active, adn false otherrwise.
See also:
Workspace_IsActive()

void SUWorkspace::Refresh ( ) [inline]

Forces the workspace to repaint all components.

See also:
Workspace_Refresh()

SUJavaScript SUWorkspace::LoadJavaScript ( const char * file ) [inline]

Loads a JavaScript from file.

Parameters:
file is the name of the JavaScript file to load. If no absolute path is given, the script will be searched for relative the ShapeUp Scripts sub-directory.
Returns:
A handle to a loaded SUJavaScript.
See also:
SUJavaScript, ShapeUp_HasJavaScriptSupport(), Workspace_LoadJavaScript()

std::string SUWorkspace::GetComment ( ) [inline]

Gets the workspace comment found in the workspace properties dialog.

Returns:
The workspace comment.
See also:
Workspace_GetComment()

void SUWorkspace::SetComment ( const char * comment ) [inline]

Sets the workspace comment found in the workspace properties dialog.

Parameters:
comment is the new workspace comment.
See also:
Workspace_SetComment()

bool SUWorkspace::RemoveTheme ( SUTheme theme ) [inline]

Removes a theme from a workspace.

Parameters:
theme is the SUHANDLE to the theme to remove.
Returns:
true if the theme could be removed, adn false otherwise.
See also:
Workspace_RemoveTheme()

void SUWorkspace::SetSerialData | ( | size_t | byteCount,
 |  | const void * | bytes |
 | ) |  |  | [inline]

Sets data to be serialized with a workspace. This function can be called at any time setting new data. However, when this function is called, any old data is discarded and fully replaced with the new.
This data can later be restored from a ShapeUp workspace file when it is loaded, if the plug-in has set up a deserialize hook using the ShapeUp_AddDeserializeHook call.

Parameters:
byteCount | is the size of the bytes array.
bytes | is a pointer to a byte sequence containing the data to be serialized.
See also:
Workspace_SetSerialData()

SUHANDLE SUWorkspace::AddDataPage ( const char * name ) [inline]

Adds a new custom data page to the workspace.

Parameters:
name is the name for the new data page.
Returns:
This function returns the SUHANDLE to the created data page on success.
See also:
Workspace_AddDataPage()

void SUWorkspace::ClearSelection ( ) [inline]

Deselects all themes in the workspace.

Returns:
true if the theme could be removed, adn false otherwise.
See also:
Workspace_RemoveTheme()

The documentation for this class was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUAddFileFormatHandlerHookData Struct Reference

tagSUAddFileFormatHandlerHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

const char * | filterdescription
const char * | pattern

Member Data Documentation

const char* tagSUAddFileFormatHandlerHookData::filterdescription

const char* tagSUAddFileFormatHandlerHookData::pattern

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUAddJavaScriptInvokeHookData Struct Reference

tagSUAddJavaScriptInvokeHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHookData hd
const char ** | properties
const char ** | methods

Member Data Documentation

SUHookData tagSUAddJavaScriptInvokeHookData::hd

SUHookData header.

const char** tagSUAddJavaScriptInvokeHookData::properties

Array of supported properties. Array must end with a NULL pointer.

const char** tagSUAddJavaScriptInvokeHookData::methods

Array of supported methods. Array must end with a NULL pointer.

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUAddMenuItemHookData Struct Reference

tagSUAddMenuItemHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

unsigned long | menuItemType
const char * | menuString
const char * | menuDescr
HICON | hReserved
SUHANDLE * hMenuItem

Member Data Documentation

unsigned long tagSUAddMenuItemHookData::menuItemType

const char* tagSUAddMenuItemHookData::menuString

const char* tagSUAddMenuItemHookData::menuDescr

HICON tagSUAddMenuItemHookData::hReserved

SUHANDLE* tagSUAddMenuItemHookData::hMenuItem

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGAddAttribute Struct Reference

tagSUARGAddAttribute Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
unsigned long | type
const char * | name
const char * | defaultval
size_t * | index

Member Data Documentation

SUHANDLE tagSUARGAddAttribute::hTheme

unsigned long tagSUARGAddAttribute::type

const char* tagSUARGAddAttribute::name

const char* tagSUARGAddAttribute::defaultval

size_t* tagSUARGAddAttribute::index

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGAddDataPage Struct Reference

tagSUARGAddDataPage Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hWorkspace
const char * | name
HWND * | page
SUHANDLE * hDataPage

Member Data Documentation

SUHANDLE tagSUARGAddDataPage::hWorkspace

const char* tagSUARGAddDataPage::name

HWND* tagSUARGAddDataPage::page

SUHANDLE* tagSUARGAddDataPage::hDataPage

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGAddHook Struct Reference

tagSUARGAddHook Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShapeUp
int | hookType
unsigned long | userData
void * | args

Member Data Documentation

SUHANDLE tagSUARGAddHook::hShapeUp

int tagSUARGAddHook::hookType

unsigned long tagSUARGAddHook::userData

void* tagSUARGAddHook::args

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGAddShape Struct Reference

tagSUARGAddShape Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
const CShapeRecord * shapeData
SUHANDLE * hShape

Member Data Documentation

SUHANDLE tagSUARGAddShape::hTheme

const CShapeRecord* tagSUARGAddShape::shapeData

SUHANDLE* tagSUARGAddShape::hShape

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGAllocate Struct Reference

tagSUARGAllocate Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

size_t | count
void ** | bytes

Member Data Documentation

size_t tagSUARGAllocate::count

void** tagSUARGAllocate::bytes

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGAllocateStatusBarPane Struct Reference

tagSUARGAllocateStatusBarPane Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

size_t width
SUHANDLE * hStatusPane

Member Data Documentation

size_t tagSUARGAllocateStatusBarPane::width

SUHANDLE* tagSUARGAllocateStatusBarPane::hStatusPane

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGBatchAddShape Struct Reference

tagSUARGBatchAddShape Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShapeUp
SUHANDLE hTheme
BOOL index_on

Member Data Documentation

SUHANDLE tagSUARGBatchAddShape::hShapeUp

SUHANDLE tagSUARGBatchAddShape::hTheme

BOOL tagSUARGBatchAddShape::index_on

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGBeginProgress Struct Reference

tagSUARGBeginProgress Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

const char * | title
float | progress
SUHANDLE * hProgress

Member Data Documentation

const char* tagSUARGBeginProgress::title

float tagSUARGBeginProgress::progress

SUHANDLE* tagSUARGBeginProgress::hProgress

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGBrowseTheme Struct Reference

tagSUARGBrowseTheme Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hWorkspace
const char * pszTitle
SUHANDLE * hTheme

Member Data Documentation

SUHANDLE tagSUARGBrowseTheme::hWorkspace

const char* tagSUARGBrowseTheme::pszTitle

SUHANDLE* tagSUARGBrowseTheme::hTheme

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGCreateNewTheme Struct Reference

tagSUARGCreateNewTheme Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hWorkspace
ShapeType | type
const char * | pszName
SUHANDLE * hTheme

Member Data Documentation

SUHANDLE tagSUARGCreateNewTheme::hWorkspace

ShapeType tagSUARGCreateNewTheme::type

const char* tagSUARGCreateNewTheme::pszName

SUHANDLE* tagSUARGCreateNewTheme::hTheme

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGCreateNewThemeFromSelection Struct Reference

tagSUARGCreateNewThemeFromSelection Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hWorkspace
SUHANDLE hSourceTheme
const char * pszName
SUHANDLE * hResultTheme

Member Data Documentation

SUHANDLE tagSUARGCreateNewThemeFromSelection::hWorkspace

SUHANDLE tagSUARGCreateNewThemeFromSelection::hSourceTheme

const char* tagSUARGCreateNewThemeFromSelection::pszName

SUHANDLE* tagSUARGCreateNewThemeFromSelection::hResultTheme

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGCreateToolBar Struct Reference

tagSUARGCreateToolBar Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShapeUp
HINSTANCE | hInstResource
LPCTSTR | lpszResourceName
const char * | name
SUHANDLE * hToolBar

Member Data Documentation

SUHANDLE tagSUARGCreateToolBar::hShapeUp

HINSTANCE tagSUARGCreateToolBar::hInstResource

LPCTSTR tagSUARGCreateToolBar::lpszResourceName

const char* tagSUARGCreateToolBar::name

SUHANDLE* tagSUARGCreateToolBar::hToolBar

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGDeleteAttribute Struct Reference

tagSUARGDeleteAttribute Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
size_t index

Member Data Documentation

SUHANDLE tagSUARGDeleteAttribute::hTheme

size_t tagSUARGDeleteAttribute::index

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGDeleteShape Struct Reference

tagSUARGDeleteShape Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
SUHANDLE hShape

Member Data Documentation

SUHANDLE tagSUARGDeleteShape::hTheme

SUHANDLE tagSUARGDeleteShape::hShape

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGDPtoGP Struct Reference

tagSUARGDPtoGP Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hMap
int | dpx
int | dpy
double * | gpx
double * | gpy

Member Data Documentation

SUHANDLE tagSUARGDPtoGP::hMap

int tagSUARGDPtoGP::dpx

int tagSUARGDPtoGP::dpy

double* tagSUARGDPtoGP::gpx

double* tagSUARGDPtoGP::gpy

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGDraw Struct Reference

tagSUARGDraw Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hMap
HDC | hdc
size_t | imageWidth
size_t | imageHeight
double | xCenter
double | yCenter
double | geoWidth
double | geoHeight

Member Data Documentation

SUHANDLE tagSUARGDraw::hMap

HDC tagSUARGDraw::hdc

size_t tagSUARGDraw::imageWidth

size_t tagSUARGDraw::imageHeight

double tagSUARGDraw::xCenter

double tagSUARGDraw::yCenter

double tagSUARGDraw::geoWidth

double tagSUARGDraw::geoHeight

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetAttribute Struct Reference

tagSUARGGetAttribute Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShape
SUHANDLE hTheme
size_t | nCol
char * | buffer
size_t * | bufferSize

Member Data Documentation

SUHANDLE tagSUARGGetAttribute::hShape

SUHANDLE tagSUARGGetAttribute::hTheme

size_t tagSUARGGetAttribute::nCol

char* tagSUARGGetAttribute::buffer

size_t* tagSUARGGetAttribute::bufferSize

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetAttributeIndex Struct Reference

tagSUARGGetAttributeIndex Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
const char * | name
size_t * | index

Member Data Documentation

SUHANDLE tagSUARGGetAttributeIndex::hTheme

const char* tagSUARGGetAttributeIndex::name

size_t* tagSUARGGetAttributeIndex::index

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetAttributeType Struct Reference

tagSUARGGetAttributeType Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
size_t | index
unsigned long * | type

Member Data Documentation

SUHANDLE tagSUARGGetAttributeType::hTheme

size_t tagSUARGGetAttributeType::index

unsigned long* tagSUARGGetAttributeType::type

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetBOOL Struct Reference

tagSUARGGetBOOL Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
BOOL * boolval

Member Data Documentation

SUHANDLE tagSUARGGetBOOL::hObject

BOOL* tagSUARGGetBOOL::boolval

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetBounds Struct Reference

tagSUARGGetBounds Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
double * | xmin
double * | ymin
double * | xmax
double * | ymax

Member Data Documentation

SUHANDLE tagSUARGGetBounds::hObject

double* tagSUARGGetBounds::xmin

double* tagSUARGGetBounds::ymin

double* tagSUARGGetBounds::xmax

double* tagSUARGGetBounds::ymax

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetClosestPoint Struct Reference

tagSUARGGetClosestPoint Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShape
double | refx
double | refy
double * | closestx
double * | closesty

Member Data Documentation

SUHANDLE tagSUARGGetClosestPoint::hShape

double tagSUARGGetClosestPoint::refx

double tagSUARGGetClosestPoint::refy

double* tagSUARGGetClosestPoint::closestx

double* tagSUARGGetClosestPoint::closesty

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetColor Struct Reference

tagSUARGGetColor Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
COLORREF * clr

Member Data Documentation

SUHANDLE tagSUARGGetColor::hObject

COLORREF* tagSUARGGetColor::clr

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetCoordinate Struct Reference

tagSUARGGetCoordinate Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShape
size_t | nPart
size_t | nIndex
double * | x
double * | y
double * | z

Member Data Documentation

SUHANDLE tagSUARGGetCoordinate::hShape

size_t tagSUARGGetCoordinate::nPart

size_t tagSUARGGetCoordinate::nIndex

double* tagSUARGGetCoordinate::x

double* tagSUARGGetCoordinate::y

double* tagSUARGGetCoordinate::z

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetDWORD Struct Reference

tagSUARGGetDWORD Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
unsigned long * dwordval

Member Data Documentation

SUHANDLE tagSUARGGetDWORD::hObject

unsigned long* tagSUARGGetDWORD::dwordval

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetErrorDescription Struct Reference

tagSUARGGetErrorDescription Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SURESULT errCode
char * | buffer
size_t * | bufferSize

Member Data Documentation

SURESULT tagSUARGGetErrorDescription::errCode

char* tagSUARGGetErrorDescription::buffer

size_t* tagSUARGGetErrorDescription::bufferSize

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetFont Struct Reference

tagSUARGGetFont Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
LOGFONT * | font
COLORREF * | clr

Member Data Documentation

SUHANDLE tagSUARGGetFont::hObject

LOGFONT* tagSUARGGetFont::font

COLORREF* tagSUARGGetFont::clr

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetHandle Struct Reference

tagSUARGGetHandle Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
SUHANDLE * hResult

Member Data Documentation

SUHANDLE tagSUARGGetHandle::hObject

SUHANDLE* tagSUARGGetHandle::hResult

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetHandleByIndex Struct Reference

tagSUARGGetHandleByIndex Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
size_t nIndex
SUHANDLE * hResult

Member Data Documentation

SUHANDLE tagSUARGGetHandleByIndex::hObject

size_t tagSUARGGetHandleByIndex::nIndex

SUHANDLE* tagSUARGGetHandleByIndex::hResult

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetHWND Struct Reference

tagSUARGGetHWND Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
HWND * hWnd

Member Data Documentation

SUHANDLE tagSUARGGetHWND::hObject

HWND* tagSUARGGetHWND::hWnd

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetInfoTip Struct Reference

tagSUARGGetInfoTip Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
SUHANDLE hShape
char * | buffer
size_t * | bufferSize

Member Data Documentation

SUHANDLE tagSUARGGetInfoTip::hTheme

SUHANDLE tagSUARGGetInfoTip::hShape

char* tagSUARGGetInfoTip::buffer

size_t* tagSUARGGetInfoTip::bufferSize

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetInteractionState Struct Reference

tagSUARGGetInteractionState Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hMap
SUHANDLE hShapeUp
unsigned long * state

Member Data Documentation

SUHANDLE tagSUARGGetInteractionState::hMap

SUHANDLE tagSUARGGetInteractionState::hShapeUp

unsigned long* tagSUARGGetInteractionState::state

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetIntersectingShapes Struct Reference

tagSUARGGetIntersectingShapes Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
SUHANDLE hShape
SUHANDLE * hRecordset

Member Data Documentation

SUHANDLE tagSUARGGetIntersectingShapes::hTheme

SUHANDLE tagSUARGGetIntersectingShapes::hShape

SUHANDLE* tagSUARGGetIntersectingShapes::hRecordset

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetShapeBytes Struct Reference

tagSUARGGetShapeBytes Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShape
unsigned char * | buffer
size_t * | bufferSize

Member Data Documentation

SUHANDLE tagSUARGGetShapeBytes::hShape

unsigned char* tagSUARGGetShapeBytes::buffer

size_t* tagSUARGGetShapeBytes::bufferSize

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetShapesByQuery Struct Reference

tagSUARGGetShapesByQuery Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
const char * where
SUHANDLE * hRecordset

Member Data Documentation

SUHANDLE tagSUARGGetShapesByQuery::hTheme

const char* tagSUARGGetShapesByQuery::where

SUHANDLE* tagSUARGGetShapesByQuery::hRecordset

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetShapesInRect Struct Reference

tagSUARGGetShapesInRect Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
double | xmin
double | ymin
double | xmax
double | ymax
BOOL | bPartInRectOk
SUHANDLE * hRecordset

Member Data Documentation

SUHANDLE tagSUARGGetShapesInRect::hTheme

double tagSUARGGetShapesInRect::xmin

double tagSUARGGetShapesInRect::ymin

double tagSUARGGetShapesInRect::xmax

double tagSUARGGetShapesInRect::ymax

BOOL tagSUARGGetShapesInRect::bPartInRectOk

SUHANDLE* tagSUARGGetShapesInRect::hRecordset

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetShapeType Struct Reference

tagSUARGGetShapeType Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
ShapeType * type

Member Data Documentation

SUHANDLE tagSUARGGetShapeType::hObject

ShapeType* tagSUARGGetShapeType::type

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetSize Struct Reference

tagSUARGGetSize Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
size_t * | width
size_t * | height

Member Data Documentation

SUHANDLE tagSUARGGetSize::hObject

size_t* tagSUARGGetSize::width

size_t* tagSUARGGetSize::height

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetText Struct Reference

tagSUARGGetText Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
char * | buffer
size_t * | bufferSize

Member Data Documentation

SUHANDLE tagSUARGGetText::hObject

char* tagSUARGGetText::buffer

size_t* tagSUARGGetText::bufferSize

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetTextByIndex Struct Reference

tagSUARGGetTextByIndex Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
size_t | index
char * | buffer
size_t * | bufferSize

Member Data Documentation

SUHANDLE tagSUARGGetTextByIndex::hObject

size_t tagSUARGGetTextByIndex::index

char* tagSUARGGetTextByIndex::buffer

size_t* tagSUARGGetTextByIndex::bufferSize

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetUnsigned Struct Reference

tagSUARGGetUnsigned Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
size_t * unsignedval

Member Data Documentation

SUHANDLE tagSUARGGetUnsigned::hObject

size_t* tagSUARGGetUnsigned::unsignedval

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetUnsignedByIndex Struct Reference

tagSUARGGetUnsignedByIndex Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
size_t | nIndex
size_t * | unsignedval

Member Data Documentation

SUHANDLE tagSUARGGetUnsignedByIndex::hObject

size_t tagSUARGGetUnsignedByIndex::nIndex

size_t* tagSUARGGetUnsignedByIndex::unsignedval

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGetWorkspace Struct Reference

tagSUARGGetWorkspace Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

size_t nIndex
SUHANDLE * hWorkspace

Member Data Documentation

size_t tagSUARGGetWorkspace::nIndex

SUHANDLE* tagSUARGGetWorkspace::hWorkspace

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGGPtoDP Struct Reference

tagSUARGGPtoDP Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hMap
double | gpx
double | gpy
int * | dpx
int * | dpy

Member Data Documentation

SUHANDLE tagSUARGGPtoDP::hMap

double tagSUARGGPtoDP::gpx

double tagSUARGGPtoDP::gpy

int* tagSUARGGPtoDP::dpx

int* tagSUARGGPtoDP::dpy

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGIsShapeSelected Struct Reference

tagSUARGIsShapeSelected Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShape
SUHANDLE hTheme
BOOL * selected

Member Data Documentation

SUHANDLE tagSUARGIsShapeSelected::hShape

SUHANDLE tagSUARGIsShapeSelected::hTheme

BOOL* tagSUARGIsShapeSelected::selected

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGJSCallFunction Struct Reference

tagSUARGJSCallFunction Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hJavaScript
const char * name

Member Data Documentation

SUHANDLE tagSUARGJSCallFunction::hJavaScript

const char* tagSUARGJSCallFunction::name

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGLoadJavaScript Struct Reference

tagSUARGLoadJavaScript Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hWorkspace
const char * file
SUHANDLE * hJavaScript

Member Data Documentation

SUHANDLE tagSUARGLoadJavaScript::hWorkspace

const char* tagSUARGLoadJavaScript::file

SUHANDLE* tagSUARGLoadJavaScript::hJavaScript

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGLog Struct Reference

tagSUARGLog Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hWorkspace
const char * line

Member Data Documentation

SUHANDLE tagSUARGLog::hWorkspace

const char* tagSUARGLog::line

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGRemoveHook Struct Reference

tagSUARGRemoveHook Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShapeUp
int hookType

Member Data Documentation

SUHANDLE tagSUARGRemoveHook::hShapeUp

int tagSUARGRemoveHook::hookType

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGRemoveTheme Struct Reference

tagSUARGRemoveTheme Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hWorkspace
SUHANDLE hTheme
BOOL * ok

Member Data Documentation

SUHANDLE tagSUARGRemoveTheme::hWorkspace

SUHANDLE tagSUARGRemoveTheme::hTheme

BOOL* tagSUARGRemoveTheme::ok

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGRepaint Struct Reference

tagSUARGRepaint Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hMap
BOOL bFullRedraw

Member Data Documentation

SUHANDLE tagSUARGRepaint::hMap

BOOL tagSUARGRepaint::bFullRedraw

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGReplaceShapeData Struct Reference

tagSUARGReplaceShapeData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
SUHANDLE hShape
const CShapeRecord * shapeData

Member Data Documentation

SUHANDLE tagSUARGReplaceShapeData::hTheme

SUHANDLE tagSUARGReplaceShapeData::hShape

const CShapeRecord* tagSUARGReplaceShapeData::shapeData

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSelectShape Struct Reference

tagSUARGSelectShape Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShape
SUHANDLE hTheme
BOOL select

Member Data Documentation

SUHANDLE tagSUARGSelectShape::hShape

SUHANDLE tagSUARGSelectShape::hTheme

BOOL tagSUARGSelectShape::select

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetAttribute Struct Reference

tagSUARGSetAttribute Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShape
SUHANDLE hTheme
size_t | nCol
const char * | data

Member Data Documentation

SUHANDLE tagSUARGSetAttribute::hShape

SUHANDLE tagSUARGSetAttribute::hTheme

size_t tagSUARGSetAttribute::nCol

const char* tagSUARGSetAttribute::data

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetAttributes Struct Reference

tagSUARGSetAttributes Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShape
SUHANDLE hTheme
size_t | count
const char ** | data

Member Data Documentation

SUHANDLE tagSUARGSetAttributes::hShape

SUHANDLE tagSUARGSetAttributes::hTheme

size_t tagSUARGSetAttributes::count

const char** tagSUARGSetAttributes::data

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetBOOL Struct Reference

tagSUARGSetBOOL Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
BOOL boolval

Member Data Documentation

SUHANDLE tagSUARGSetBOOL::hObject

BOOL tagSUARGSetBOOL::boolval

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetButtonBOOL Struct Reference

tagSUARGSetButtonBOOL Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hToolBar
SUHANDLE hShapeUp
UINT | nID
BOOL | boolval

Member Data Documentation

SUHANDLE tagSUARGSetButtonBOOL::hToolBar

SUHANDLE tagSUARGSetButtonBOOL::hShapeUp

UINT tagSUARGSetButtonBOOL::nID

BOOL tagSUARGSetButtonBOOL::boolval

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetColor Struct Reference

tagSUARGSetColor Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
COLORREF clr

Member Data Documentation

SUHANDLE tagSUARGSetColor::hObject

COLORREF tagSUARGSetColor::clr

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetDouble Struct Reference

tagSUARGSetDouble Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
double doubleval

Member Data Documentation

SUHANDLE tagSUARGSetDouble::hObject

double tagSUARGSetDouble::doubleval

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetDWORD Struct Reference

tagSUARGSetDWORD Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
unsigned long dwordval

Member Data Documentation

SUHANDLE tagSUARGSetDWORD::hObject

unsigned long tagSUARGSetDWORD::dwordval

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetFloat Struct Reference

tagSUARGSetFloat Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
float floatval

Member Data Documentation

SUHANDLE tagSUARGSetFloat::hObject

float tagSUARGSetFloat::floatval

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetInteractionState Struct Reference

tagSUARGSetInteractionState Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hMap
SUHANDLE hShapeUp
unsigned long state

Member Data Documentation

SUHANDLE tagSUARGSetInteractionState::hMap

SUHANDLE tagSUARGSetInteractionState::hShapeUp

unsigned long tagSUARGSetInteractionState::state

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetPoint Struct Reference

tagSUARGSetPoint Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
double | x
double | y

Member Data Documentation

SUHANDLE tagSUARGSetPoint::hObject

double tagSUARGSetPoint::x

double tagSUARGSetPoint::y

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetRasterImage Struct Reference

tagSUARGSetRasterImage Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hTheme
HBITMAP | hbm
double | west
double | south
double | east
double | north
const char * | sourceHint

Member Data Documentation

SUHANDLE tagSUARGSetRasterImage::hTheme

HBITMAP tagSUARGSetRasterImage::hbm

double tagSUARGSetRasterImage::west

double tagSUARGSetRasterImage::south

double tagSUARGSetRasterImage::east

double tagSUARGSetRasterImage::north

const char* tagSUARGSetRasterImage::sourceHint

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetSerialData Struct Reference

tagSUARGSetSerialData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShapeUp
SUHANDLE hObject
size_t | byteCount
const void * | bytes

Member Data Documentation

SUHANDLE tagSUARGSetSerialData::hShapeUp

SUHANDLE tagSUARGSetSerialData::hObject

size_t tagSUARGSetSerialData::byteCount

const void* tagSUARGSetSerialData::bytes

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetStatusBarPaneInfo Struct Reference

tagSUARGSetStatusBarPaneInfo Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hStatusPane
const char * | text
HICON | hIcon
void * | pReserved

Member Data Documentation

SUHANDLE tagSUARGSetStatusBarPaneInfo::hStatusPane

const char* tagSUARGSetStatusBarPaneInfo::text

HICON tagSUARGSetStatusBarPaneInfo::hIcon

void* tagSUARGSetStatusBarPaneInfo::pReserved

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetText Struct Reference

tagSUARGSetText Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
const char * buffer

Member Data Documentation

SUHANDLE tagSUARGSetText::hObject

const char* tagSUARGSetText::buffer

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetTextByIndex Struct Reference

tagSUARGSetTextByIndex Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
size_t | index
const char * | buffer

Member Data Documentation

SUHANDLE tagSUARGSetTextByIndex::hObject

size_t tagSUARGSetTextByIndex::index

const char* tagSUARGSetTextByIndex::buffer

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGSetUnsigned Struct Reference

tagSUARGSetUnsigned Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hObject
size_t unsignedval

Member Data Documentation

SUHANDLE tagSUARGSetUnsigned::hObject

size_t tagSUARGSetUnsigned::unsignedval

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGWantUpdate Struct Reference

tagSUARGWantUpdate Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShapeUp
unsigned long ulUserData

Member Data Documentation

SUHANDLE tagSUARGWantUpdate::hShapeUp

unsigned long tagSUARGWantUpdate::ulUserData

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGZoomToExtent Struct Reference

tagSUARGZoomToExtent Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hMap
SUHANDLE hTheme

Member Data Documentation

SUHANDLE tagSUARGZoomToExtent::hMap

SUHANDLE tagSUARGZoomToExtent::hTheme

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUARGZoomToSelection Struct Reference

tagSUARGZoomToSelection Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hMap
SUHANDLE hTheme

Member Data Documentation

SUHANDLE tagSUARGZoomToSelection::hMap

SUHANDLE tagSUARGZoomToSelection::hTheme

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUDeserializeHookData Struct Reference

tagSUDeserializeHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHookData hd
SUHANDLE hTheme
size_t | byteCount
const void * | bytes

Member Data Documentation

SUHookData tagSUDeserializeHookData::hd

SUHookData header.

SUHANDLE tagSUDeserializeHookData::hTheme

Contains a handle to the currently loading theme. If NULL, workspace data is being loaded.

size_t tagSUDeserializeHookData::byteCount

Size in bytes of the bytes buffer.

const void* tagSUDeserializeHookData::bytes

Byte buffer containing the data to be loaded.

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUExport Struct Reference

tagSUExport Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHANDLE hShapeUp
SUCall ShapeUp_Call
SUImport import

Detailed Description

Examples:

example_hooks.cpp, example_javascriptable.cpp, example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

Member Data Documentation

SUHANDLE tagSUExport::hShapeUp

This is the handle to ShapeUp itself. It's needed in some function calls.

SUCall tagSUExport::ShapeUp_Call

The function to use when to query and control ShapeUp from a GPI.

SUImport tagSUExport::import

This should be filled in by the plug-in.

Examples:
example_hooks.cpp, example_javascriptable.cpp, example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUFileFormatHandlerHookData Struct Reference

tagSUFileFormatHandlerHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHookData hd
const char * filename

Member Data Documentation

SUHookData tagSUFileFormatHandlerHookData::hd

const char* tagSUFileFormatHandlerHookData::filename

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUHookData Struct Reference

tagSUHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

unsigned long userData

Detailed Description

Examples:

example_hooks.cpp, example_javascriptable.cpp, example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

Member Data Documentation

unsigned long tagSUHookData::userData

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUImport Struct Reference

tagSUImport Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

const char * | pszName
const char * | pszDescription
const char * | pszInfo
const char * | pszPluginVersion
SUHOOKFUNC pfnHook
PFNSETTINGS pfnSettings
void * | pReserved

Member Data Documentation

const char* tagSUImport::pszName

A short distinct name of this GPI

Examples:
example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

const char* tagSUImport::pszDescription

A short one-line description of this plug-in.

Examples:
example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

const char* tagSUImport::pszInfo

A description of this plug-in, possibly multiple lines. License and copyright info should go here.

Examples:
example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

const char* tagSUImport::pszPluginVersion

Version string for this plug-in.

Examples:
example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

SUHOOKFUNC tagSUImport::pfnHook

Called upon ShapeUp action.

Examples:
example_hooks.cpp, and example_javascriptable.cpp.

PFNSETTINGS tagSUImport::pfnSettings

Pointer to a function that will display settings for this plug-in. If the plug-in has no settings, set this to NULL.

void* tagSUImport::pReserved

Reserved for future use.

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUJavaScriptArgument Struct Reference

tagSUJavaScriptArgument Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

DataType type
union {
SUHANDLE handleVal
int intVal
char * stringVal
double doubleVal
BOOL boolVal
COLORREF colorVal
};

Detailed Description

Examples:

example_javascriptable.cpp.

Member Data Documentation

DataType tagSUJavaScriptArgument::type

Examples:
example_javascriptable.cpp.

SUHANDLE tagSUJavaScriptArgument::handleVal

int tagSUJavaScriptArgument::intVal

char* tagSUJavaScriptArgument::stringVal

Examples:
example_javascriptable.cpp.

double tagSUJavaScriptArgument::doubleVal

BOOL tagSUJavaScriptArgument::boolVal

COLORREF tagSUJavaScriptArgument::colorVal

Examples:
example_javascriptable.cpp.

union { ... }

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUJavaScriptInvokeHookData Struct Reference

tagSUJavaScriptInvokeHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHookData hd
const char * | name
DWORD | flags
size_t | argc
const SUJavaScriptArgument * | args
size_t | retc
SUJavaScriptArgument * rets

Detailed Description

This is an example of how to construct the return values.
    // Let's return 2 values, a shape and a string, to the calling JavaScript
    // (Error handling omitted for simplicity)

    SUJavaScriptInvokeHookData *args; // From the hook function
    SUHANDLE hWorkspace;              // From the hook function

    args->retc = 2;
    ShapeUp_Allocate(sizeof(SUJavaScriptArgument) * args->retc, (void**)&args->rets);

    args->rets[0].type = DT_SUHANDLE;
    args->rets[0].handleVal = SUWorkspace(hWorkspace).GetTheme(0).GetShape(0);

    args->rets[1].type = DT_STRING;
    args->rets[1].stringVal = ShapeUp_DuplicateString("A string");
The return value is by default treated as an Array of values, even if there is only one element. To avoid this if the intention is just to return one value, set the flags member of SUJavaScriptInvokeHookData to include JSIHDF_TREATRETURNASSINGLEVALUE.

The following return values are supported:

  • int
  • double
  • null terminated char*
  • boolean
  • COLORREF
  • SUHANDLE to a theme
  • SUHANDLE to a shape
Note:
It's important to use ShapeUp_Allocate() or one of its relatives to allocate memory for the return values since ShapeUp will deallocate the structure.
The hook function can return any of:
  • SURESULT_OK to indicate success.
  • SURESULT_E_NOTIMPLEMENTED to indicate the the call was not handled.
  • SURESULT_E_ILLEGALPARAM to indicate that the parameters were incorrect for this method.
See also:
ShapeUp_Allocate(), ShapeUp_DuplicateString()
Examples:

example_javascriptable.cpp.

Member Data Documentation

SUHookData tagSUJavaScriptInvokeHookData::hd

SUHookData header.

const char* tagSUJavaScriptInvokeHookData::name

Contains the name of the property or method being invoked.

Examples:
example_javascriptable.cpp.

DWORD tagSUJavaScriptInvokeHookData::flags

See JavaScriptInvokeHookDataFlags for appropriate values.

size_t tagSUJavaScriptInvokeHookData::argc

Count of the arguments pointed to by args.

Examples:
example_javascriptable.cpp.

const SUJavaScriptArgument* tagSUJavaScriptInvokeHookData::args

Argument array containing the data sent to the plug-in.

Examples:
example_javascriptable.cpp.

size_t tagSUJavaScriptInvokeHookData::retc

Count of the return values pointed to by rets. Filled in by the GPI.

Examples:
example_javascriptable.cpp.

SUJavaScriptArgument* tagSUJavaScriptInvokeHookData::rets

Return array containing the data sent back to the JavaScript. Filled in by the GPI.

Examples:
example_javascriptable.cpp.

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUMenuItemHookData Struct Reference

tagSUMenuItemHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHookData hd
SUHANDLE hMenuItem

Member Data Documentation

SUHookData tagSUMenuItemHookData::hd

SUHANDLE tagSUMenuItemHookData::hMenuItem

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUMouseHookData Struct Reference

tagSUMouseHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHookData hd
long | x
long | y
UINT | flags
unsigned long | ulReserved

Detailed Description

Examples:

example_hooks.cpp.

Member Data Documentation

SUHookData tagSUMouseHookData::hd

long tagSUMouseHookData::x

long tagSUMouseHookData::y

UINT tagSUMouseHookData::flags

unsigned long tagSUMouseHookData::ulReserved

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUPreRemoveShapeHookData Struct Reference

tagSUPreRemoveShapeHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHookData hd
SUHANDLE hTheme
SUHANDLE hShape

Member Data Documentation

SUHookData tagSUPreRemoveShapeHookData::hd

SUHANDLE tagSUPreRemoveShapeHookData::hTheme

SUHANDLE tagSUPreRemoveShapeHookData::hShape

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUPreRemoveThemeHookData Struct Reference

tagSUPreRemoveThemeHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHookData hd
SUHANDLE hTheme

Detailed Description

Examples:

example_hooks.cpp.

Member Data Documentation

SUHookData tagSUPreRemoveThemeHookData::hd

SUHANDLE tagSUPreRemoveThemeHookData::hTheme

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUShapeSelChangeHookData Struct Reference

tagSUShapeSelChangeHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHookData hd
SUHANDLE hTheme
BOOL bAllowNewGUI

Member Data Documentation

SUHookData tagSUShapeSelChangeHookData::hd

SUHANDLE tagSUShapeSelChangeHookData::hTheme

BOOL tagSUShapeSelChangeHookData::bAllowNewGUI

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: tagSUToolBarButtonHookData Struct Reference

tagSUToolBarButtonHookData Struct Reference

#include <ShapeUpAPI.h>

List of all members.

Public Attributes

SUHookData hd
UINT nCommandID

Detailed Description

Examples:

example_hooks.cpp, and example_sutoolbar.cpp.

Member Data Documentation

SUHookData tagSUToolBarButtonHookData::hd

UINT tagSUToolBarButtonHookData::nCommandID

Examples:
example_sutoolbar.cpp.

The documentation for this struct was generated from the following file:
  • ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Hierarchical Index

ShapeUp API Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • SUException
  • SUObject
    • SUDataPage
    • SUJavaScript
    • SUMap
    • SUMenuItem
    • SURecordset
    • SUShape
    • SUTheme
    • SUToolBar
    • SUWorkspace
  • SUPoint
  • SUPointf
  • SURectf
  • SUSize
  • SUSizef
  • SUStatusBar
  • tagSUAddFileFormatHandlerHookData
  • tagSUAddJavaScriptInvokeHookData
  • tagSUAddMenuItemHookData
  • tagSUARGAddAttribute
  • tagSUARGAddDataPage
  • tagSUARGAddHook
  • tagSUARGAddShape
  • tagSUARGAllocate
  • tagSUARGAllocateStatusBarPane
  • tagSUARGBatchAddShape
  • tagSUARGBeginProgress
  • tagSUARGBrowseTheme
  • tagSUARGCreateNewTheme
  • tagSUARGCreateNewThemeFromSelection
  • tagSUARGCreateToolBar
  • tagSUARGDeleteAttribute
  • tagSUARGDeleteShape
  • tagSUARGDPtoGP
  • tagSUARGDraw
  • tagSUARGGetAttribute
  • tagSUARGGetAttributeIndex
  • tagSUARGGetAttributeType
  • tagSUARGGetBOOL
  • tagSUARGGetBounds
  • tagSUARGGetClosestPoint
  • tagSUARGGetColor
  • tagSUARGGetCoordinate
  • tagSUARGGetDWORD
  • tagSUARGGetErrorDescription
  • tagSUARGGetFont
  • tagSUARGGetHandle
  • tagSUARGGetHandleByIndex
  • tagSUARGGetHWND
  • tagSUARGGetInfoTip
  • tagSUARGGetInteractionState
  • tagSUARGGetIntersectingShapes
  • tagSUARGGetShapeBytes
  • tagSUARGGetShapesByQuery
  • tagSUARGGetShapesInRect
  • tagSUARGGetShapeType
  • tagSUARGGetSize
  • tagSUARGGetText
  • tagSUARGGetTextByIndex
  • tagSUARGGetUnsigned
  • tagSUARGGetUnsignedByIndex
  • tagSUARGGetWorkspace
  • tagSUARGGPtoDP
  • tagSUARGIsShapeSelected
  • tagSUARGJSCallFunction
  • tagSUARGLoadJavaScript
  • tagSUARGLog
  • tagSUARGRemoveHook
  • tagSUARGRemoveTheme
  • tagSUARGRepaint
  • tagSUARGReplaceShapeData
  • tagSUARGSelectShape
  • tagSUARGSetAttribute
  • tagSUARGSetAttributes
  • tagSUARGSetBOOL
  • tagSUARGSetButtonBOOL
  • tagSUARGSetColor
  • tagSUARGSetDouble
  • tagSUARGSetDWORD
  • tagSUARGSetFloat
  • tagSUARGSetInteractionState
  • tagSUARGSetPoint
  • tagSUARGSetRasterImage
  • tagSUARGSetSerialData
  • tagSUARGSetStatusBarPaneInfo
  • tagSUARGSetText
  • tagSUARGSetTextByIndex
  • tagSUARGSetUnsigned
  • tagSUARGWantUpdate
  • tagSUARGZoomToExtent
  • tagSUARGZoomToSelection
  • tagSUDeserializeHookData
  • tagSUExport
  • tagSUFileFormatHandlerHookData
  • tagSUHookData
  • tagSUImport
  • tagSUJavaScriptArgument
  • tagSUJavaScriptInvokeHookData
  • tagSUMenuItemHookData
  • tagSUMouseHookData
  • tagSUPreRemoveShapeHookData
  • tagSUPreRemoveThemeHookData
  • tagSUShapeSelChangeHookData
  • tagSUToolBarButtonHookData
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- _ -

  • _h : SUObject
  • _hProgress : SUStatusBar
  • _paneHandles : SUStatusBar
  • _res : SUException
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: File Index

  • File List
  • File Members

ShapeUp API File List

Here is a list of all files with brief descriptions:
ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: ShapeUpAPI.h File Reference

  • File List
  • File Members

ShapeUpAPI.h File Reference

#include "shapefile.h"
#include <string>
#include <vector>

Classes

struct | tagSUHookData
struct | tagSUShapeSelChangeHookData
struct | tagSUPreRemoveThemeHookData
struct | tagSUPreRemoveShapeHookData
struct | tagSUMouseHookData
struct | tagSUToolBarButtonHookData
struct | tagSUMenuItemHookData
struct | tagSUAddMenuItemHookData
struct | tagSUFileFormatHandlerHookData
struct | tagSUAddFileFormatHandlerHookData
struct | tagSUDeserializeHookData
struct | tagSUAddJavaScriptInvokeHookData
struct | tagSUJavaScriptArgument
struct | tagSUJavaScriptInvokeHookData
struct | tagSUARGAddHook
struct | tagSUARGRemoveHook
struct | tagSUARGGetErrorDescription
struct | tagSUARGCreateToolBar
struct | tagSUARGGetWorkspace
struct | tagSUARGSetStatusBarPaneInfo
struct | tagSUARGAllocateStatusBarPane
struct | tagSUARGGetHandle
struct | tagSUARGCreateNewTheme
struct | tagSUARGCreateNewThemeFromSelection
struct | tagSUARGGetBounds
struct | tagSUARGLog
struct | tagSUARGBrowseTheme
struct | tagSUARGGetSize
struct | tagSUARGGPtoDP
struct | tagSUARGDPtoGP
struct | tagSUARGGetHWND
struct | tagSUARGRepaint
struct | tagSUARGDraw
struct | tagSUARGSetPoint
struct | tagSUARGSetDouble
struct | tagSUARGZoomToSelection
struct | tagSUARGZoomToExtent
struct | tagSUARGAddShape
struct | tagSUARGReplaceShapeData
struct | tagSUARGDeleteShape
struct | tagSUARGGetBOOL
struct | tagSUARGSetBOOL
struct | tagSUARGGetText
struct | tagSUARGSetText
struct | tagSUARGGetTextByIndex
struct | tagSUARGSetTextByIndex
struct | tagSUARGGetDWORD
struct | tagSUARGSetDWORD
struct | tagSUARGGetInteractionState
struct | tagSUARGSetInteractionState
struct | tagSUARGGetUnsigned
struct | tagSUARGGetUnsignedByIndex
struct | tagSUARGSetUnsigned
struct | tagSUARGGetHandleByIndex
struct | tagSUARGGetCoordinate
struct | tagSUARGGetClosestPoint
struct | tagSUARGGetShapeType
struct | tagSUARGGetIntersectingShapes
struct | tagSUARGGetInfoTip
struct | tagSUARGGetFont
struct | tagSUARGGetShapesByQuery
struct | tagSUARGGetShapesInRect
struct | tagSUARGIsShapeSelected
struct | tagSUARGSelectShape
struct | tagSUARGGetAttribute
struct | tagSUARGSetAttribute
struct | tagSUARGSetAttributes
struct | tagSUARGGetShapeBytes
struct | tagSUARGSetButtonBOOL
struct | tagSUARGBeginProgress
struct | tagSUARGSetFloat
struct | tagSUARGAddAttribute
struct | tagSUARGGetAttributeType
struct | tagSUARGDeleteAttribute
struct | tagSUARGJSCallFunction
struct | tagSUARGLoadJavaScript
struct | tagSUARGWantUpdate
struct | tagSUARGGetColor
struct | tagSUARGSetColor
struct | tagSUARGBatchAddShape
struct | tagSUARGRemoveTheme
struct | tagSUARGSetRasterImage
struct | tagSUARGSetSerialData
struct | tagSUARGAddDataPage
struct | tagSUARGAllocate
struct | tagSUARGGetAttributeIndex
struct | tagSUImport
struct | tagSUExport
class | SUPoint
Representation of a integer based position or vector. More...
class | SUPointf
Representation of a floating point double precision based position or vector. More...
class | SUSize
Representation of a integer based size in two dimensions. More...
class | SUSizef
Representation of a floating point double precision based size in two dimensions. More...
class | SURectf
Representation of a floating point double precision based axis-aligned rectangle. More...
class | SUObject
Base class for ShapeUp object classes. More...
class | SUException
A wrapper class for error return values. More...
class | SUMenuItem
Handles a single ShapeUp menu item. More...
class | SUToolBar
Handles a plug-in defined toolbar. More...
class | SUStatusBar
Represents the ShapeUp status bar. More...
class | SURecordset
Multi-purpose recordset class. More...
class | SUDataPage
Handles custom data pages in ShapeUp. More...
class | SUJavaScript
Handles JavaScripts in ShapeUp. More...
class | SUMap
Represents the ShapeUp map window. More...
class | SUShape
Handles a shape object in ShapeUp. More...
class | SUTheme
Represents a ShapeUp theme or layer. More...
class | SUWorkspace
Wrapper for a ShapeUp workspace. More...

Defines

VERSION
The version of this file.
See also:
fnVersion()

#define | SHAPEUP_API_VERSION 100
JavaScriptInvokeHookData flags
The JavaScriptInvokeHookData flags are used in the JavaScriptInvokeHookData struct.

#define | JSIHDF_DEFAULT 0x00000000
#define | JSIHDF_TREATRETURNASSINGLEVALUE 0x00000001
MENUITEMTYPE
The MENUITEMTYPES are indicators to where ShapeUp will add new menu items. The SUHOOKFUNC defined in the GPI will receive a notification with args being a pointer to a SUMenuItemHookData.

#define | __MENUITEMTYPE_NIL__ 0x0000
#define | MENUITEMTYPE_ADDNEWLAYER 0x0001
#define | MENUITEMTYPE_LOADLAYER 0x0002
#define | MENUITEMTYPE_ADVANCEDSELECTION 0x0003
#define | MENUITEMTYPE_ADVANCEDEDIT 0x0004
#define | MENUITEMTYPE_EXPORTLAYER 0x0005
#define | MENUITEMTYPE_TOOLS 0x0006
#define | MENUITEMTYPE_COPYSPECIAL 0x0007
#define | __MENUITEMTYPE_COUNT__ 0x0008
HOOKTYPE
The hook types are used in the GPI hook function, SUHOOKFUNC, set by the plug-in in SUImport on start-up.
See also:
fnInit, SUExport, SUImport, SUHOOKFUNC

#define | __HOOKTYPE_NIL__ 0x0000
#define | HOOKTYPE_POSTDRAW 0x0001
#define | HOOKTYPE_IDLE 0x0002
#define | HOOKTYPE_MOUSEMOVE 0x0003
#define | HOOKTYPE_SHAPESELCHANGE 0x0004
#define | HOOKTYPE_PRECLOSEWORKSPACE 0x0005
#define | HOOKTYPE_PREREMOVETHEME 0x0006
#define | HOOKTYPE_LBUTTONDOWN 0x0007
#define | HOOKTYPE_LBUTTONUP 0x0008
#define | HOOKTYPE_TOOLBARBUTTON 0x0009
#define | HOOKTYPE_MENUITEM 0x000A
#define | HOOKTYPE_PREREMOVESHAPE 0x000B
#define | HOOKTYPE_WANTUPDATE 0x000C
#define | HOOKTYPE_FILEFORMATHANDLER 0x000D
#define | HOOKTYPE_DESERIALIZE 0x000E
#define | HOOKTYPE_WORKSPACEREADY 0x000F
#define | HOOKTYPE_JAVASCRIPTINVOKE 0x0010
#define | HOOKTYPE_LAYERSELCHANGE 0x0011
#define | __HOOKTYPE_COUNT__ 0x0012
MAPSTATE
The various MAPSTATE defines are used with functions Map_GetInteractionState() and Map_SetInteractionState(). States supplied by a GPI must be in the range [MAPSTATE_PLUGINSTATEFIRST, MAPSTATE_PLUGINSTATELAST]

#define | __MAPSTATE_NIL__ 0x0000
#define | MAPSTATE_SINGLESELECT 0x0001
#define | MAPSTATE_RECTSELECT 0x0002
#define | MAPSTATE_RECTSELECTTRACKING 0x0003
#define | MAPSTATE_CIRCLESELECT 0x0004
#define | MAPSTATE_CIRCLESELECTTRACKING 0x0005
#define | MAPSTATE_PAN 0x0006
#define | MAPSTATE_PANNING 0x0007
#define | MAPSTATE_ZOOMIN 0x0008
#define | MAPSTATE_ZOOMINTRACKING 0x0009
#define | MAPSTATE_ZOOMOUT 0x000A
#define | MAPSTATE_MEASURING 0x000B
#define | MAPSTATE_DRAWING 0x000C
#define | MAPSTATE_ADJUSTVERTEX 0x000D
#define | MAPSTATE_ADJUSTINGVERTEX 0x000E
#define | MAPSTATE_ADDVERTEX 0x000F
#define | MAPSTATE_ADDINGVERTEX 0x0010
#define | MAPSTATE_POLYGONSELECT 0x0011
#define | MAPSTATE_POLYGONSELECTTRACKING 0x0012
#define | MAPSTATE_SPLITOBJECT 0x0013
#define | MAPSTATE_SPLITTINGOBJECT 0x0014
#define | __MAPSTATE_COUNT__ 0x0015
#define | MAPSTATE_CUSTOM 0x00FF
#define | MAPSTATE_PLUGINSTATEFIRST 0x0100
#define | MAPSTATE_PLUGINSTATELAST 0x01FF
ATTRIBUTETYPE
Attribute types are used to determine the types of the attributes in a ShapeUp layer. They are also used when adding new attributes to a layer.

Any of the types can be combined with the ATTRIBUTETYPE_PRIMARYKEY flag to indicate that the attribute is part of a primary key.

#define | ATTRIBUTETYPE_STRING 0
#define | ATTRIBUTETYPE_INT 1
#define | ATTRIBUTETYPE_DOUBLE 2
#define | ATTRIBUTETYPE_DATE 3
#define | ATTRIBUTETYPE_BOOL 4
#define | ATTRIBUTETYPE_PRIMARYKEY 0x80000000
PENSTYLE
Pen styles are used to create visual effects for rendered lines.

#define | PENSTYLE_SOLID 0
#define | PENSTYLE_DASH 1
#define | PENSTYLE_DOT 2
#define | PENSTYLE_DASHDOT 3
#define | PENSTYLE_DASHDOTDOT 4
#define | __PENSTYLE_COUNT__ 0x0005
FNTYPE
Function specifiers used in calls to SUExport::ShapeUp_Call().

#define | __FNTYPE_NIL__ 0x0000
#define | FNTYPE_SHAPEUP_ADDHOOK 0x0001
#define | FNTYPE_SHAPEUP_REMOVEHOOK 0x0002
#define | FNTYPE_SHAPEUP_REMOVEALLHOOKS 0x0003
#define | FNTYPE_SHAPEUP_GETERRORDESCRIPTION 0x0004
#define | FNTYPE_SHAPEUP_GETWORKSPACECOUNT 0x0005
#define | FNTYPE_SHAPEUP_GETWORKSPACE 0x0006
#define | FNTYPE_SHAPEUP_GETACTIVEWORKSPACE 0x0007
#define | FNTYPE_SHAPEUP_HASJAVASCRIPTSUPPORT 0x005A
#define | FNTYPE_SHAPEUP_WANTUPDATE 0x005B
#define | FNTYPE_SHAPEUP_ISVALIDHANDLE 0x005C
#define | FNTYPE_SHAPEUP_ALLOCATE 0x0074
#define | FNTYPE_SHAPEUP_DEALLOCATE 0x0075
#define | FNTYPE_SHAPEUP_GETVERSION 0x0076
#define | FNTYPE_SHAPEUP_SETSTATUSBARTEXT 0x0069
#define | FNTYPE_SHAPEUP_SETSTATUSBARPANEINFO 0x0008
#define | FNTYPE_SHAPEUP_ALLOCATESTATUSBARPANE 0x004A
#define | FNTYPE_SHAPEUP_RELEASESTATUSBARPANE 0x004B
#define | FNTYPE_SHAPEUP_BEGINPROGRESS 0x004F
#define | FNTYPE_SHAPEUP_SETPROGRESS 0x0050
#define | FNTYPE_SHAPEUP_ENDPROGRESS 0x0051
#define | FNTYPE_TOOLBAR_CREATE 0x0042
#define | FNTYPE_TOOLBAR_ISVISIBLE 0x0079
#define | FNTYPE_TOOLBAR_GETBUTTONCOUNT 0x0043
#define | FNTYPE_TOOLBAR_SETBUTTONENABLED 0x0044
#define | FNTYPE_TOOLBAR_SETBUTTONCHECKED 0x0045
#define | FNTYPE_MENUITEM_SETENABLED 0x004E
#define | FNTYPE_WORKSPACE_GETMAPWINDOW 0x0009
#define | FNTYPE_WORKSPACE_GETTHEMECOUNT 0x000A
#define | FNTYPE_WORKSPACE_GETTHEME 0x000B
#define | FNTYPE_WORKSPACE_GETSELECTEDTHEME 0x0055
#define | FNTYPE_WORKSPACE_GETSELECTEDTHEMES 0x004D
#define | FNTYPE_WORKSPACE_GETSELECTIONCOUNT 0x0078
#define | FNTYPE_WORKSPACE_CREATENEWTHEME 0x000C
#define | FNTYPE_WORKSPACE_CREATENEWTHEMEFROMSELECTION 0x007E
#define | FNTYPE_WORKSPACE_GETBOUNDS 0x000D
#define | FNTYPE_WORKSPACE_LOG 0x000E
#define | FNTYPE_WORKSPACE_ISACTIVE 0x000F
#define | FNTYPE_WORKSPACE_BROWSETHEME 0x0010
#define | FNTYPE_WORKSPACE_REFRESH 0x0048
#define | FNTYPE_WORKSPACE_LOADJAVASCRIPT 0x0056
#define | FNTYPE_WORKSPACE_GETCOMMENT 0x005D
#define | FNTYPE_WORKSPACE_SETCOMMENT 0x005E
#define | FNTYPE_WORKSPACE_REMOVETHEME 0x006A
#define | FNTYPE_WORKSPACE_SETSERIALDATA 0x006C
#define | FNTYPE_WORKSPACE_ADDDATAPAGE 0x006E
#define | FNTYPE_WORKSPACE_CLEARSELECTION 0x0073
#define | FNTYPE_DATAPAGE_REMOVE 0x006F
#define | FNTYPE_DATAPAGE_GETHWND 0x0070
#define | FNTYPE_JAVASCRIPT_RUN 0x0057
#define | FNTYPE_JAVASCRIPT_CALLFUNCTION 0x0058
#define | FNTYPE_JAVASCRIPT_CLOSE 0x0059
#define | FNTYPE_MAP_GETBOUNDS 0x0011
#define | FNTYPE_MAP_GETVIEWSIZE 0x0012
#define | FNTYPE_MAP_GPTODP 0x0013
#define | FNTYPE_MAP_DPTOGP 0x0014
#define | FNTYPE_MAP_GETHWND 0x0015
#define | FNTYPE_MAP_REPAINT 0x0016
#define | FNTYPE_MAP_DRAW 0x0017
#define | FNTYPE_MAP_CENTERMAP 0x003A
#define | FNTYPE_MAP_ZOOM 0x003B
#define | FNTYPE_MAP_ZOOMTOSELECTION 0x003C
#define | FNTYPE_MAP_ZOOMTOEXTENT 0x003D
#define | FNTYPE_MAP_GETINTERACTIONSTATE 0x003E
#define | FNTYPE_MAP_SETINTERACTIONSTATE 0x003F
#define | FNTYPE_THEME_ADDSHAPE 0x0018
#define | FNTYPE_THEME_BATCHADDSHAPE 0x0063
#define | FNTYPE_THEME_REPLACESHAPEDATA 0x0019
#define | FNTYPE_THEME_DELETESHAPE 0x001A
#define | FNTYPE_THEME_ISSELECTED 0x001B
#define | FNTYPE_THEME_ISREADONLY 0x001C
#define | FNTYPE_THEME_ISVISIBLE 0x004C
#define | FNTYPE_THEME_GETNAME 0x001D
#define | FNTYPE_THEME_SETNAME 0x001E
#define | FNTYPE_THEME_GETATTRIBUTECOUNT 0x001F
#define | FNTYPE_THEME_GETSHAPECOUNT 0x0020
#define | FNTYPE_THEME_GETSHAPE 0x0021
#define | FNTYPE_THEME_GETSHAPEFROMINDEX 0x0022
#define | FNTYPE_THEME_GETSHAPETYPE 0x0023
#define | FNTYPE_THEME_GETBOUNDS 0x0024
#define | FNTYPE_THEME_RECALCBOUNDS 0x0025
#define | FNTYPE_THEME_GETINTERSECTINGSHAPES 0x0026
#define | FNTYPE_THEME_GETSELECTIONCOUNT 0x0027
#define | FNTYPE_THEME_GETSELECTEDSHAPES 0x0028
#define | FNTYPE_THEME_GETINFOTIP 0x0029
#define | FNTYPE_THEME_GETFONT 0x002A
#define | FNTYPE_THEME_GETSHAPESBYQUERY 0x002B
#define | FNTYPE_THEME_GETSHAPESINRECT 0x0040
#define | FNTYPE_THEME_GETATTRIBUTENAME 0x0046
#define | FNTYPE_THEME_GETATTRIBUTEINDEX 0x007D
#define | FNTYPE_THEME_GETATTRIBUTETYPE 0x0077
#define | FNTYPE_THEME_LOOKUPWORKSPACE 0x0049
#define | FNTYPE_THEME_GETSELECTEDSHAPESINRECT 0x0052
#define | FNTYPE_THEME_ADDATTRIBUTE 0x0053
#define | FNTYPE_THEME_DELETEATTRIBUTE 0x0054
#define | FNTYPE_THEME_SETATTRIBUTECOMMENT 0x0083
#define | FNTYPE_THEME_GETCOMMENT 0x005F
#define | FNTYPE_THEME_SETCOMMENT 0x0060
#define | FNTYPE_THEME_GETPENCOLOR 0x0061
#define | FNTYPE_THEME_SETPENCOLOR 0x0062
#define | FNTYPE_THEME_GETFILLCOLOR 0x0065
#define | FNTYPE_THEME_SETFILLCOLOR 0x0066
#define | FNTYPE_THEME_GETPENWIDTH 0x0067
#define | FNTYPE_THEME_SETPENWIDTH 0x0068
#define | FNTYPE_THEME_GETPENSTYLE 0x0081
#define | FNTYPE_THEME_SETPENSTYLE 0x0082
#define | FNTYPE_THEME_SETRASTERIMAGE 0x006B
#define | FNTYPE_THEME_SETSERIALDATA 0x006D
#define | FNTYPE_THEME_CLEARSELECTION 0x0071
#define | FNTYPE_THEME_SELECT 0x0072
#define | FNTYPE_THEME_INVERTSELECTION 0x007F
#define | FNTYPE_SHAPE_ISSELECTED 0x002C
#define | FNTYPE_SHAPE_SELECT 0x002D
#define | FNTYPE_SHAPE_GETSHAPETYPE 0x002E
#define | FNTYPE_SHAPE_GETBOUNDS 0x002F
#define | FNTYPE_SHAPE_GETPARTCOUNT 0x007A
#define | FNTYPE_SHAPE_GETCOORDINATECOUNT 0x007B
#define | FNTYPE_SHAPE_GETCOORDINATE 0x007C
#define | FNTYPE_SHAPE_GETCLOSESTPOINT 0x0080
#define | FNTYPE_SHAPE_GETATTRIBUTE 0x0030
#define | FNTYPE_SHAPE_SETATTRIBUTE 0x0047
#define | FNTYPE_SHAPE_SETATTRIBUTES 0x0064
#define | FNTYPE_SHAPE_GETSHAPEBYTES 0x0031
#define | FNTYPE_RECORDSET_NEXT 0x0032
#define | FNTYPE_RECORDSET_PREV 0x0033
#define | FNTYPE_RECORDSET_FIRST 0x0034
#define | FNTYPE_RECORDSET_LAST 0x0035
#define | FNTYPE_RECORDSET_GET 0x0036
#define | FNTYPE_RECORDSET_EOF 0x0037
#define | FNTYPE_RECORDSET_BOF 0x0038
#define | FNTYPE_RECORDSET_CLOSE 0x0039
#define | FNTYPE_RECORDSET_GETCOUNT 0x0041
#define | __FNTYPE_COUNT__ 0x0084
SURESULT
#define | SURESULT_OK 0
#define | SURESULT_FALSE 1
#define | SURESULT_E_NOTIMPLEMENTED 2
#define | SURESULT_E_NOSUCHERROR 3
#define | SURESULT_E_INVALIDHANDLE 100
#define | SURESULT_E_ILLEGALPARAM 101
#define | SURESULT_E_UNSUPPORTEDSHAPETYPE 102
#define | SURESULT_E_UNEXPECTEDSHAPETYPE 103
#define | SURESULT_E_INDEXOUTOFBOUNDS 104
#define | SURESULT_E_PERMISSIONDENIED 105
#define | SURESULT_E_BUFFEROVERFLOW 106
#define | SURESULT_E_INVALIDQUERY 107
#define | SURESULT_E_UNKNOWNHOOKTYPE 108
#define | SURESULT_E_OUTOFRESOURCES 109
#define | SURESULT_E_SCRIPTERROR 110

Typedefs

typedef HANDLE | SUHANDLE
typedef HRESULT | SURESULT
typedef tagSUHookData | SUHookData
typedef tagSUShapeSelChangeHookData | SUShapeSelChangeHookData
typedef tagSUPreRemoveThemeHookData | SUPreRemoveThemeHookData
typedef tagSUPreRemoveShapeHookData | SUPreRemoveShapeHookData
typedef tagSUMouseHookData | SUMouseHookData
typedef tagSUToolBarButtonHookData | SUToolBarButtonHookData
typedef tagSUMenuItemHookData | SUMenuItemHookData
typedef tagSUAddMenuItemHookData | SUAddMenuItemHookData
typedef tagSUFileFormatHandlerHookData | SUFileFormatHandlerHookData
typedef tagSUAddFileFormatHandlerHookData | SUAddFileFormatHandlerHookData
typedef tagSUDeserializeHookData | SUDeserializeHookData
typedef tagSUAddJavaScriptInvokeHookData | SUAddJavaScriptInvokeHookData
typedef enum tagDataType | DataType
typedef tagSUJavaScriptArgument | SUJavaScriptArgument
typedef tagSUJavaScriptInvokeHookData | SUJavaScriptInvokeHookData
typedef SURESULT(__cdecl *) | SUHOOKFUNC (SUHANDLE hWorkspace, int hookType, SUHookData *args)
typedef void(__cdecl *) | PFNSETTINGS ()
typedef tagSUARGAddHook | SUARGAddHook
typedef tagSUARGRemoveHook | SUARGRemoveHook
typedef tagSUARGGetErrorDescription | SUARGGetErrorDescription
typedef tagSUARGCreateToolBar | SUARGCreateToolBar
typedef tagSUARGGetWorkspace | SUARGGetWorkspace
typedef tagSUARGSetStatusBarPaneInfo | SUARGSetStatusBarPaneInfo
typedef tagSUARGAllocateStatusBarPane | SUARGAllocateStatusBarPane
typedef tagSUARGGetHandle | SUARGGetHandle
typedef tagSUARGCreateNewTheme | SUARGCreateNewTheme
typedef tagSUARGCreateNewThemeFromSelection | SUARGCreateNewThemeFromSelection
typedef tagSUARGGetBounds | SUARGGetBounds
typedef tagSUARGLog | SUARGLog
typedef tagSUARGBrowseTheme | SUARGBrowseTheme
typedef tagSUARGGetSize | SUARGGetSize
typedef tagSUARGGPtoDP | SUARGGPtoDP
typedef tagSUARGDPtoGP | SUARGDPtoGP
typedef tagSUARGGetHWND | SUARGGetHWND
typedef tagSUARGRepaint | SUARGRepaint
typedef tagSUARGDraw | SUARGDraw
typedef tagSUARGSetPoint | SUARGSetPoint
typedef tagSUARGSetDouble | SUARGSetDouble
typedef tagSUARGZoomToSelection | SUARGZoomToSelection
typedef tagSUARGZoomToExtent | SUARGZoomToExtent
typedef tagSUARGAddShape | SUARGAddShape
typedef tagSUARGReplaceShapeData | SUARGReplaceShapeData
typedef tagSUARGDeleteShape | SUARGDeleteShape
typedef tagSUARGGetBOOL | SUARGGetBOOL
typedef tagSUARGSetBOOL | SUARGSetBOOL
typedef tagSUARGGetText | SUARGGetText
typedef tagSUARGSetText | SUARGSetText
typedef tagSUARGGetTextByIndex | SUARGGetTextByIndex
typedef tagSUARGSetTextByIndex | SUARGSetTextByIndex
typedef tagSUARGGetDWORD | SUARGGetDWORD
typedef tagSUARGSetDWORD | SUARGSetDWORD
typedef tagSUARGGetInteractionState | SUARGGetInteractionState
typedef tagSUARGSetInteractionState | SUARGSetInteractionState
typedef tagSUARGGetUnsigned | SUARGGetUnsigned
typedef tagSUARGGetUnsignedByIndex | SUARGGetUnsignedByIndex
typedef tagSUARGSetUnsigned | SUARGSetUnsigned
typedef tagSUARGGetHandleByIndex | SUARGGetHandleByIndex
typedef tagSUARGGetCoordinate | SUARGGetCoordinate
typedef tagSUARGGetClosestPoint | SUARGGetClosestPoint
typedef tagSUARGGetShapeType | SUARGGetShapeType
typedef tagSUARGGetIntersectingShapes | SUARGGetIntersectingShapes
typedef tagSUARGGetInfoTip | SUARGGetInfoTip
typedef tagSUARGGetFont | SUARGGetFont
typedef tagSUARGGetShapesByQuery | SUARGGetShapesByQuery
typedef tagSUARGGetShapesInRect | SUARGGetShapesInRect
typedef tagSUARGIsShapeSelected | SUARGIsShapeSelected
typedef tagSUARGSelectShape | SUARGSelectShape
typedef tagSUARGGetAttribute | SUARGGetAttribute
typedef tagSUARGSetAttribute | SUARGSetAttribute
typedef tagSUARGSetAttributes | SUARGSetAttributes
typedef tagSUARGGetShapeBytes | SUARGGetShapeBytes
typedef tagSUARGSetButtonBOOL | SUARGSetButtonBOOL
typedef tagSUARGBeginProgress | SUARGBeginProgress
typedef tagSUARGSetFloat | SUARGSetFloat
typedef tagSUARGAddAttribute | SUARGAddAttribute
typedef tagSUARGGetAttributeType | SUARGGetAttributeType
typedef tagSUARGDeleteAttribute | SUARGDeleteAttribute
typedef tagSUARGJSCallFunction | SUARGJSCallFunction
typedef tagSUARGLoadJavaScript | SUARGLoadJavaScript
typedef tagSUARGWantUpdate | SUARGWantUpdate
typedef tagSUARGGetColor | SUARGGetColor
typedef tagSUARGSetColor | SUARGSetColor
typedef tagSUARGBatchAddShape | SUARGBatchAddShape
typedef tagSUARGRemoveTheme | SUARGRemoveTheme
typedef tagSUARGSetRasterImage | SUARGSetRasterImage
typedef tagSUARGSetSerialData | SUARGSetSerialData
typedef tagSUARGAddDataPage | SUARGAddDataPage
typedef tagSUARGAllocate | SUARGAllocate
typedef tagSUARGGetAttributeIndex | SUARGGetAttributeIndex
typedef tagSUImport | SUImport
typedef SURESULT(__cdecl *) | SUCall (int function, void *arg)
typedef tagSUExport | SUExport

Enumerations

enum tagDataType {
DT_SUHANDLE = 0, DT_INT = 1, DT_STRING = 2, DT_DOUBLE = 3,
DT_BOOL = 4, DT_COLOR = 5
}

Functions

SURESULT __cdecl | fnInit (const SUExport *export)
size_t __cdecl | fnVersion ()
const GUID *__cdecl | fnGUID ()
void __cdecl | fnTerminate ()
SURESULT | ShapeUp_AddPostDrawHook (unsigned long userData)
SURESULT | ShapeUp_AddIdleHook (unsigned long userData)
SURESULT | ShapeUp_AddMouseMoveHook (unsigned long userData)
SURESULT | ShapeUp_AddLButtonDownHook (unsigned long userData)
SURESULT | ShapeUp_AddLButtonUpHook (unsigned long userData)
SURESULT | ShapeUp_AddToolBarButtonHook (unsigned long userData)
SURESULT | ShapeUp_AddNewLayerHook (unsigned long userData, const char *menuString, const char *menuDescr, void *pReserved, SUHANDLE *hMenuItem)
SURESULT | ShapeUp_AddLoadLayerHook (unsigned long userData, const char *menuString, const char *menuDescr, void *pReserved, SUHANDLE *hMenuItem)
SURESULT | ShapeUp_AddCopySpecialHook (unsigned long userData, const char *menuString, const char *menuDescr, void *pReserved, SUHANDLE *hMenuItem)
SURESULT | ShapeUp_AddAdvancedSelectionHook (unsigned long userData, const char *menuString, const char *menuDescr, void *pReserved, SUHANDLE *hMenuItem)
SURESULT | ShapeUp_AddAdvancedEditHook (unsigned long userData, const char *menuString, const char *menuDescr, void *pReserved, SUHANDLE *hMenuItem)
SURESULT | ShapeUp_AddExportLayerHook (unsigned long userData, const char *menuString, const char *menuDescr, void *pReserved, SUHANDLE *hMenuItem)
SURESULT | ShapeUp_AddRemoveLayerHook (unsigned long userData)
SURESULT | ShapeUp_AddRemoveShapeHook (unsigned long userData)
SURESULT | ShapeUp_AddFileFormatHandlerHook (unsigned long userData, const char *filterdescription, const char *pattern)
SURESULT | ShapeUp_AddToolsHook (unsigned long userData, const char *menuString, const char *menuDescr, void *pReserved, SUHANDLE *hMenuItem)
SURESULT | ShapeUp_AddDeserializeHook (unsigned long userData)
SURESULT | ShapeUp_AddWorkspaceReadyHook (unsigned long userData)
SURESULT | ShapeUp_AddJavaScriptInvokeHook (unsigned long userData, const char *properties[], const char *methods[])
SURESULT | ShapeUp_AddShapeSelectionChangedHook (unsigned long userData)
SURESULT | ShapeUp_AddLayerSelectionChangedHook (unsigned long userData)
SURESULT ShapeUp_RemoveMouseMoveHook ()
SURESULT ShapeUp_RemoveShapeSelectionChangedHook ()
SURESULT ShapeUp_RemoveLayerSelectionChangedHook ()
SURESULT ShapeUp_RemoveAllHooks ()
SURESULT | ShapeUp_WantUpdate (unsigned long userData)
SURESULT | ShapeUp_IsValidHandle (SUHANDLE handle, BOOL *valid)
SURESULT | ShapeUp_Allocate (size_t count, void **bytes)
SURESULT | ShapeUp_Deallocate (void *bytes)
char * | ShapeUp_DuplicateString (const char *str)
SURESULT | ShapeUp_GetVersion (char *buffer, size_t *bufferSize)
SURESULT | ShapeUp_GetWorkspaceCount (size_t *count)
SURESULT | ShapeUp_GetWorkspace (size_t index, SUHANDLE *hWorkspace)
SURESULT | ShapeUp_GetActiveWorkspace (SUHANDLE *hWorkspace)
SURESULT | ShapeUp_HasJavaScriptSupport (BOOL *support)
SURESULT | ShapeUp_GetErrorDescription (SURESULT errCode, char *buffer, size_t *bufferSize)
SURESULT | ShapeUp_SetStatusBarText (const char *text)
SURESULT | ShapeUp_SetStatusBarPaneInfo (SUHANDLE hStatusPane, const char *text, HICON hIcon, void *pReserved)
SURESULT | ShapeUp_AllocateStatusBarPane (size_t width, SUHANDLE *hStatusPane)
SURESULT | ShapeUp_ReleaseStatusBarPane (SUHANDLE hStatusPane)
SURESULT | ShapeUp_BeginProgress (const char *title, float progress, SUHANDLE *hProgress)
SURESULT | ShapeUp_SetProgress (SUHANDLE hProgress, float progress)
SURESULT | ShapeUp_EndProgress (SUHANDLE hProgress)
SURESULT | MenuItem_SetEnabled (SUHANDLE hMenuItem, BOOL bEnabled)
SURESULT | ToolBar_Create (HINSTANCE hInstResource, LPCTSTR lpszResourceName, const char *name, SUHANDLE *hToolbar)
SURESULT | ToolBar_IsVisible (SUHANDLE hToolbar, BOOL *visible)
SURESULT | ToolBar_GetButtonCount (SUHANDLE hToolbar, size_t *count)
SURESULT | ToolBar_SetButtonEnabled (SUHANDLE hToolbar, UINT nID, BOOL bEnabled)
SURESULT | ToolBar_SetButtonChecked (SUHANDLE hToolbar, UINT nID, BOOL bChecked)
SURESULT | JavaScript_Run (SUHANDLE hJavaScript)
SURESULT | JavaScript_CallFunction (SUHANDLE hJavaScript, const char *name)
SURESULT | JavaScript_Close (SUHANDLE hJavaScript)
SURESULT | Workspace_GetMapWindow (SUHANDLE hWorkspace, SUHANDLE *hMap)
SURESULT | Workspace_GetThemeCount (SUHANDLE hWorkspace, size_t *count)
SURESULT | Workspace_GetTheme (SUHANDLE hWorkspace, size_t nIndex, SUHANDLE *hTheme)
SURESULT | Workspace_GetSelectedTheme (SUHANDLE hWorkspace, SUHANDLE *hTheme)
SURESULT | Workspace_GetSelectedThemes (SUHANDLE hWorkspace, SUHANDLE *hRecordset)
SURESULT | Workspace_GetSelectionCount (SUHANDLE hWorkspace, size_t *count)
SURESULT | Workspace_CreateNewTheme (SUHANDLE hWorkspace, ShapeType type, const char *name, SUHANDLE *hTheme)
SURESULT | Workspace_CreateNewThemeFromSelection (SUHANDLE hWorkspace, SUHANDLE hSourceTheme, const char *name, SUHANDLE *hTheme)
SURESULT | Workspace_GetBounds (SUHANDLE hWorkspace, double *xmin, double *ymin, double *xmax, double *ymax)
SURESULT | Workspace_Log (SUHANDLE hWorkspace, const char *line)
SURESULT | Workspace_IsActive (SUHANDLE hWorkspace, BOOL *active)
SURESULT | Workspace_BrowseTheme (SUHANDLE hWorkspace, const char *title, SUHANDLE *hTheme)
SURESULT | Workspace_Refresh (SUHANDLE hWorkspace)
SURESULT | Workspace_LoadJavaScript (SUHANDLE hWorkspace, const char *file, SUHANDLE *hJavaScript)
SURESULT | Workspace_GetComment (SUHANDLE hWorkspace, char *buffer, size_t *bufferSize)
SURESULT | Workspace_SetComment (SUHANDLE hWorkspace, const char *buffer)
SURESULT | Workspace_RemoveTheme (SUHANDLE hWorkspace, SUHANDLE hTheme, BOOL *ok)
SURESULT | Workspace_SetSerialData (SUHANDLE hWorkspace, size_t byteCount, const void *bytes)
SURESULT | Workspace_AddDataPage (SUHANDLE hWorkspace, const char *name, HWND *page, SUHANDLE *hDataPage)
SURESULT | Workspace_ClearSelection (SUHANDLE hWorkspace)
SURESULT | Map_GetBounds (SUHANDLE hMap, double *xmin, double *ymin, double *xmax, double *ymax)
SURESULT | Map_GetViewSize (SUHANDLE hMap, size_t *width, size_t *height)
SURESULT | Map_GPtoDP (SUHANDLE hMap, double gpx, double gpy, int *dpx, int *dpy)
SURESULT | Map_DPtoGP (SUHANDLE hMap, int dpx, int dpy, double *gpx, double *gpy)
SURESULT | Map_GetHWND (SUHANDLE hMap, HWND *hWnd)
SURESULT | Map_Repaint (SUHANDLE hMap, BOOL bFullRedraw)
SURESULT | Map_Draw (SUHANDLE hMap, HDC hdc, size_t iw, size_t ih, double x, double y, double gw, double gh)
SURESULT | Map_CenterMap (SUHANDLE hMap, double x, double y)
SURESULT | Map_Zoom (SUHANDLE hMap, double factor)
SURESULT | Map_ZoomToSelection (SUHANDLE hMap, SUHANDLE hTheme)
SURESULT | Map_ZoomToExtent (SUHANDLE hMap, SUHANDLE hTheme)
SURESULT | Map_GetInteractionState (SUHANDLE hMap, unsigned long *state)
SURESULT | Map_SetInteractionState (SUHANDLE hMap, unsigned long state)
SURESULT | Theme_AddShape (SUHANDLE hTheme, const CShapeRecord *shapeData, SUHANDLE *hShape)
SURESULT | Theme_BatchAddShapeBegin (SUHANDLE hTheme)
SURESULT | Theme_BatchAddShapeEnd (SUHANDLE hTheme)
SURESULT | Theme_ReplaceShapeData (SUHANDLE hTheme, SUHANDLE hShape, const CShapeRecord *shapeData)
SURESULT | Theme_DeleteShape (SUHANDLE hTheme, SUHANDLE hShape)
SURESULT | Theme_IsSelected (SUHANDLE hTheme, BOOL *selected)
SURESULT | Theme_IsReadOnly (SUHANDLE hTheme, BOOL *readonly)
SURESULT | Theme_IsVisible (SUHANDLE hTheme, BOOL *visible)
SURESULT | Theme_GetName (SUHANDLE hTheme, char *buffer, size_t *bufferSize)
SURESULT | Theme_SetName (SUHANDLE hTheme, const char *buffer)
SURESULT | Theme_GetAttributeCount (SUHANDLE hTheme, size_t *count)
SURESULT | Theme_GetAttributeName (SUHANDLE hTheme, size_t column, char *buffer, size_t *bufferSize)
SURESULT | Theme_GetAttributeType (SUHANDLE hTheme, size_t column, unsigned long *type)
SURESULT | Theme_GetAttributeIndex (SUHANDLE hTheme, const char *name, size_t *index)
SURESULT | Theme_GetShapeCount (SUHANDLE hTheme, size_t *count)
SURESULT | Theme_GetShape (SUHANDLE hTheme, size_t nIndex, SUHANDLE *hShape)
SURESULT | Theme_GetShapeFromIndex (SUHANDLE hTheme, size_t nIndex, SUHANDLE *hShape)
SURESULT | Theme_GetShapeType (SUHANDLE hTheme, ShapeType *type)
SURESULT | Theme_GetBounds (SUHANDLE hTheme, double *xmin, double *ymin, double *xmax, double *ymax)
SURESULT | Theme_RecalcBounds (SUHANDLE hTheme)
SURESULT | Theme_GetIntersectingShapes (SUHANDLE hTheme, SUHANDLE hShape, SUHANDLE *hRecordset)
SURESULT | Theme_GetShapesInRect (SUHANDLE hTheme, double xmin, double ymin, double xmax, double ymax, BOOL bPartInRectOk, SUHANDLE *hRecordset)
SURESULT | Theme_GetSelectionCount (SUHANDLE hTheme, size_t *count)
SURESULT | Theme_GetSelectedShapes (SUHANDLE hTheme, SUHANDLE *hRecordset)
SURESULT | Theme_GetSelectedShapesInRect (SUHANDLE hTheme, double xmin, double ymin, double xmax, double ymax, BOOL bPartInRectOk, SUHANDLE *hRecordset)
SURESULT | Theme_GetInfoTip (SUHANDLE hTheme, SUHANDLE hShape, char *buffer, size_t *bufferSize)
SURESULT | Theme_GetFont (SUHANDLE hTheme, LOGFONT *font, COLORREF *clr)
SURESULT | Theme_GetShapesByQuery (SUHANDLE hTheme, const char *where, SUHANDLE *hRecordset)
SURESULT | Theme_LookupWorkspace (SUHANDLE hTheme, SUHANDLE *hWorkspace)
SURESULT | Theme_AddAttribute (SUHANDLE hTheme, unsigned long type, const char *name, size_t *index)
SURESULT | Theme_DeleteAttribute (SUHANDLE hTheme, size_t index)
SURESULT | Theme_SetAttributeComment (SUHANDLE hTheme, size_t index, const char *buffer)
SURESULT | Theme_GetComment (SUHANDLE hTheme, char *buffer, size_t *bufferSize)
SURESULT | Theme_SetComment (SUHANDLE hTheme, const char *buffer)
SURESULT | Theme_GetPenColor (SUHANDLE hTheme, COLORREF *clr)
SURESULT | Theme_SetPenColor (SUHANDLE hTheme, COLORREF clr)
SURESULT | Theme_GetFillColor (SUHANDLE hTheme, COLORREF *clr)
SURESULT | Theme_SetFillColor (SUHANDLE hTheme, COLORREF clr)
SURESULT | Theme_GetPenWidth (SUHANDLE hTheme, size_t *width)
SURESULT | Theme_SetPenWidth (SUHANDLE hTheme, size_t width)
SURESULT | Theme_GetPenStyle (SUHANDLE hTheme, size_t *style)
SURESULT | Theme_SetPenStyle (SUHANDLE hTheme, size_t style)
SURESULT | Theme_SetRasterImage (SUHANDLE hTheme, HBITMAP hbm, double west, double south, double east, double north, const char *sourceHint)
SURESULT | Theme_SetSerialData (SUHANDLE hTheme, size_t byteCount, const void *bytes)
SURESULT | Theme_ClearSelection (SUHANDLE hTheme)
SURESULT | Theme_Select (SUHANDLE hTheme, bool select)
SURESULT | Theme_InvertSelection (SUHANDLE hTheme)
SURESULT | Shape_IsSelected (SUHANDLE hShape, SUHANDLE hTheme, BOOL *selected)
SURESULT | Shape_Select (SUHANDLE hShape, SUHANDLE hTheme, BOOL select)
SURESULT | Shape_GetShapeType (SUHANDLE hShape, ShapeType *type)
SURESULT | Shape_GetBounds (SUHANDLE hShape, double *xmin, double *ymin, double *xmax, double *ymax)
SURESULT | Shape_GetPartCount (SUHANDLE hShape, size_t *count)
SURESULT | Shape_GetCoordinateCount (SUHANDLE hShape, size_t part, size_t *count)
SURESULT | Shape_GetCoordinate (SUHANDLE hShape, size_t part, size_t coordIndex, double *x, double *y, double *z)
SURESULT | Shape_GetClosestPoint (SUHANDLE hShape, double refx, double refy, double *closestx, double *closesty)
SURESULT | Shape_GetAttribute (SUHANDLE hShape, SUHANDLE hTheme, size_t column, char *buffer, size_t *bufferSize)
SURESULT | Shape_SetAttribute (SUHANDLE hShape, SUHANDLE hTheme, size_t column, const char *data)
SURESULT | Shape_GetShapeBytes (SUHANDLE hShape, unsigned char *buffer, size_t *bufferSize)
SURESULT | Recordset_Next (SUHANDLE hRecordset)
SURESULT | Recordset_Prev (SUHANDLE hRecordset)
SURESULT | Recordset_First (SUHANDLE hRecordset)
SURESULT | Recordset_Last (SUHANDLE hRecordset)
SURESULT | Recordset_Get (SUHANDLE hRecordset, SUHANDLE *handle)
SURESULT | Recordset_Eof (SUHANDLE hRecordset, BOOL *eof)
SURESULT | Recordset_Bof (SUHANDLE hRecordset, BOOL *bof)
SURESULT | Recordset_Close (SUHANDLE hRecordset)
SURESULT | ShapeUp_AddSimpleHook_Helper (int ht, unsigned long ud, void *args)
SURESULT | ShapeUp_RemoveHook_Helper (int hookType)
SURESULT | DataPage_Remove (SUHANDLE hDataPage)
SURESULT | DataPage_GetHWND (SUHANDLE hDataPage, HWND *hWnd)
SURESULT | Theme_AddAttribute (SUHANDLE hTheme, unsigned long type, const char *name, const char *defaultval, size_t *index)
SURESULT | Shape_SetAttributes (SUHANDLE hShape, SUHANDLE hTheme, size_t count, const char *data[])
SURESULT | Recordset_GetCount (SUHANDLE hRecordset, size_t *count)

Variables

SUExport suapi

Define Documentation

#define __FNTYPE_COUNT__ 0x0084

#define __FNTYPE_NIL__ 0x0000

#define __HOOKTYPE_COUNT__ 0x0012

Do not use. For internal use only.

#define __HOOKTYPE_NIL__ 0x0000

Invalid value.

#define __MAPSTATE_COUNT__ 0x0015

Do not use. For internal use only.

#define __MAPSTATE_NIL__ 0x0000

Invalid value.

#define __MENUITEMTYPE_COUNT__ 0x0008

Do not use. For internal use only.

#define __MENUITEMTYPE_NIL__ 0x0000

Invalid value.

#define __PENSTYLE_COUNT__ 0x0005

Do not use. For internal use only.

#define ATTRIBUTETYPE_BOOL 4

Boolean attribute.

#define ATTRIBUTETYPE_DATE 3

Date attribute.

#define ATTRIBUTETYPE_DOUBLE 2

Double precision floating point attribute.

#define ATTRIBUTETYPE_INT 1

Integer attribute.

#define ATTRIBUTETYPE_PRIMARYKEY 0x80000000

Indicates this attribute is part of a primary key.

#define ATTRIBUTETYPE_STRING 0

String attribute.

Examples:
example_loadergpi.cpp.

#define FNTYPE_DATAPAGE_GETHWND 0x0070

#define FNTYPE_DATAPAGE_REMOVE 0x006F

#define FNTYPE_JAVASCRIPT_CALLFUNCTION 0x0058

#define FNTYPE_JAVASCRIPT_CLOSE 0x0059

#define FNTYPE_JAVASCRIPT_RUN 0x0057

#define FNTYPE_MAP_CENTERMAP 0x003A

#define FNTYPE_MAP_DPTOGP 0x0014

#define FNTYPE_MAP_DRAW 0x0017

#define FNTYPE_MAP_GETBOUNDS 0x0011

#define FNTYPE_MAP_GETHWND 0x0015

#define FNTYPE_MAP_GETINTERACTIONSTATE 0x003E

#define FNTYPE_MAP_GETVIEWSIZE 0x0012

#define FNTYPE_MAP_GPTODP 0x0013

#define FNTYPE_MAP_REPAINT 0x0016

#define FNTYPE_MAP_SETINTERACTIONSTATE 0x003F

#define FNTYPE_MAP_ZOOM 0x003B

#define FNTYPE_MAP_ZOOMTOEXTENT 0x003D

#define FNTYPE_MAP_ZOOMTOSELECTION 0x003C

#define FNTYPE_MENUITEM_SETENABLED 0x004E

#define FNTYPE_RECORDSET_BOF 0x0038

#define FNTYPE_RECORDSET_CLOSE 0x0039

#define FNTYPE_RECORDSET_EOF 0x0037

#define FNTYPE_RECORDSET_FIRST 0x0034

#define FNTYPE_RECORDSET_GET 0x0036

#define FNTYPE_RECORDSET_GETCOUNT 0x0041

#define FNTYPE_RECORDSET_LAST 0x0035

#define FNTYPE_RECORDSET_NEXT 0x0032

#define FNTYPE_RECORDSET_PREV 0x0033

#define FNTYPE_SHAPE_GETATTRIBUTE 0x0030

#define FNTYPE_SHAPE_GETBOUNDS 0x002F

#define FNTYPE_SHAPE_GETCLOSESTPOINT 0x0080

#define FNTYPE_SHAPE_GETCOORDINATE 0x007C

#define FNTYPE_SHAPE_GETCOORDINATECOUNT 0x007B

#define FNTYPE_SHAPE_GETPARTCOUNT 0x007A

#define FNTYPE_SHAPE_GETSHAPEBYTES 0x0031

#define FNTYPE_SHAPE_GETSHAPETYPE 0x002E

#define FNTYPE_SHAPE_ISSELECTED 0x002C

#define FNTYPE_SHAPE_SELECT 0x002D

#define FNTYPE_SHAPE_SETATTRIBUTE 0x0047

#define FNTYPE_SHAPE_SETATTRIBUTES 0x0064

#define FNTYPE_SHAPEUP_ADDHOOK 0x0001

#define FNTYPE_SHAPEUP_ALLOCATE 0x0074

#define FNTYPE_SHAPEUP_ALLOCATESTATUSBARPANE 0x004A

#define FNTYPE_SHAPEUP_BEGINPROGRESS 0x004F

#define FNTYPE_SHAPEUP_DEALLOCATE 0x0075

#define FNTYPE_SHAPEUP_ENDPROGRESS 0x0051

#define FNTYPE_SHAPEUP_GETACTIVEWORKSPACE 0x0007

#define FNTYPE_SHAPEUP_GETERRORDESCRIPTION 0x0004

#define FNTYPE_SHAPEUP_GETVERSION 0x0076

#define FNTYPE_SHAPEUP_GETWORKSPACE 0x0006

#define FNTYPE_SHAPEUP_GETWORKSPACECOUNT 0x0005

#define FNTYPE_SHAPEUP_HASJAVASCRIPTSUPPORT 0x005A

#define FNTYPE_SHAPEUP_ISVALIDHANDLE 0x005C

#define FNTYPE_SHAPEUP_RELEASESTATUSBARPANE 0x004B

#define FNTYPE_SHAPEUP_REMOVEALLHOOKS 0x0003

#define FNTYPE_SHAPEUP_REMOVEHOOK 0x0002

#define FNTYPE_SHAPEUP_SETPROGRESS 0x0050

#define FNTYPE_SHAPEUP_SETSTATUSBARPANEINFO 0x0008

#define FNTYPE_SHAPEUP_SETSTATUSBARTEXT 0x0069

#define FNTYPE_SHAPEUP_WANTUPDATE 0x005B

#define FNTYPE_THEME_ADDATTRIBUTE 0x0053

#define FNTYPE_THEME_ADDSHAPE 0x0018

#define FNTYPE_THEME_BATCHADDSHAPE 0x0063

#define FNTYPE_THEME_CLEARSELECTION 0x0071

#define FNTYPE_THEME_DELETEATTRIBUTE 0x0054

#define FNTYPE_THEME_DELETESHAPE 0x001A

#define FNTYPE_THEME_GETATTRIBUTECOUNT 0x001F

#define FNTYPE_THEME_GETATTRIBUTEINDEX 0x007D

#define FNTYPE_THEME_GETATTRIBUTENAME 0x0046

#define FNTYPE_THEME_GETATTRIBUTETYPE 0x0077

#define FNTYPE_THEME_GETBOUNDS 0x0024

#define FNTYPE_THEME_GETCOMMENT 0x005F

#define FNTYPE_THEME_GETFILLCOLOR 0x0065

#define FNTYPE_THEME_GETFONT 0x002A

#define FNTYPE_THEME_GETINFOTIP 0x0029

#define FNTYPE_THEME_GETINTERSECTINGSHAPES 0x0026

#define FNTYPE_THEME_GETNAME 0x001D

#define FNTYPE_THEME_GETPENCOLOR 0x0061

#define FNTYPE_THEME_GETPENSTYLE 0x0081

#define FNTYPE_THEME_GETPENWIDTH 0x0067

#define FNTYPE_THEME_GETSELECTEDSHAPES 0x0028

#define FNTYPE_THEME_GETSELECTEDSHAPESINRECT 0x0052

#define FNTYPE_THEME_GETSELECTIONCOUNT 0x0027

#define FNTYPE_THEME_GETSHAPE 0x0021

#define FNTYPE_THEME_GETSHAPECOUNT 0x0020

#define FNTYPE_THEME_GETSHAPEFROMINDEX 0x0022

#define FNTYPE_THEME_GETSHAPESBYQUERY 0x002B

#define FNTYPE_THEME_GETSHAPESINRECT 0x0040

#define FNTYPE_THEME_GETSHAPETYPE 0x0023

#define FNTYPE_THEME_INVERTSELECTION 0x007F

#define FNTYPE_THEME_ISREADONLY 0x001C

#define FNTYPE_THEME_ISSELECTED 0x001B

#define FNTYPE_THEME_ISVISIBLE 0x004C

#define FNTYPE_THEME_LOOKUPWORKSPACE 0x0049

#define FNTYPE_THEME_RECALCBOUNDS 0x0025

#define FNTYPE_THEME_REPLACESHAPEDATA 0x0019

#define FNTYPE_THEME_SELECT 0x0072

#define FNTYPE_THEME_SETATTRIBUTECOMMENT 0x0083

#define FNTYPE_THEME_SETCOMMENT 0x0060

#define FNTYPE_THEME_SETFILLCOLOR 0x0066

#define FNTYPE_THEME_SETNAME 0x001E

#define FNTYPE_THEME_SETPENCOLOR 0x0062

#define FNTYPE_THEME_SETPENSTYLE 0x0082

#define FNTYPE_THEME_SETPENWIDTH 0x0068

#define FNTYPE_THEME_SETRASTERIMAGE 0x006B

#define FNTYPE_THEME_SETSERIALDATA 0x006D

#define FNTYPE_TOOLBAR_CREATE 0x0042

#define FNTYPE_TOOLBAR_GETBUTTONCOUNT 0x0043

#define FNTYPE_TOOLBAR_ISVISIBLE 0x0079

#define FNTYPE_TOOLBAR_SETBUTTONCHECKED 0x0045

#define FNTYPE_TOOLBAR_SETBUTTONENABLED 0x0044

#define FNTYPE_WORKSPACE_ADDDATAPAGE 0x006E

#define FNTYPE_WORKSPACE_BROWSETHEME 0x0010

#define FNTYPE_WORKSPACE_CLEARSELECTION 0x0073

#define FNTYPE_WORKSPACE_CREATENEWTHEME 0x000C

#define FNTYPE_WORKSPACE_CREATENEWTHEMEFROMSELECTION 0x007E

#define FNTYPE_WORKSPACE_GETBOUNDS 0x000D

#define FNTYPE_WORKSPACE_GETCOMMENT 0x005D

#define FNTYPE_WORKSPACE_GETMAPWINDOW 0x0009

#define FNTYPE_WORKSPACE_GETSELECTEDTHEME 0x0055

#define FNTYPE_WORKSPACE_GETSELECTEDTHEMES 0x004D

#define FNTYPE_WORKSPACE_GETSELECTIONCOUNT 0x0078

#define FNTYPE_WORKSPACE_GETTHEME 0x000B

#define FNTYPE_WORKSPACE_GETTHEMECOUNT 0x000A

#define FNTYPE_WORKSPACE_ISACTIVE 0x000F

#define FNTYPE_WORKSPACE_LOADJAVASCRIPT 0x0056

#define FNTYPE_WORKSPACE_LOG 0x000E

#define FNTYPE_WORKSPACE_REFRESH 0x0048

#define FNTYPE_WORKSPACE_REMOVETHEME 0x006A

#define FNTYPE_WORKSPACE_SETCOMMENT 0x005E

#define FNTYPE_WORKSPACE_SETSERIALDATA 0x006C

#define HOOKTYPE_DESERIALIZE 0x000E

args is of type SUDeserializeHookData*.

#define HOOKTYPE_FILEFORMATHANDLER 0x000D

args is of type SUFileFormatHandlerHookData*.

#define HOOKTYPE_IDLE 0x0002

args is of type SUHookData*.

Examples:
example_hooks.cpp, and example_sutoolbar.cpp.

#define HOOKTYPE_JAVASCRIPTINVOKE 0x0010

args is of type SUJavaScriptInvokeHookData*.

Examples:
example_javascriptable.cpp.

#define HOOKTYPE_LAYERSELCHANGE 0x0011

args is of type SUHookData*.

#define HOOKTYPE_LBUTTONDOWN 0x0007

args is of type SUMouseHookData*.

Examples:
example_hooks.cpp.

#define HOOKTYPE_LBUTTONUP 0x0008

args is of type SUMouseHookData*.

#define HOOKTYPE_MENUITEM 0x000A

args is of type SUMenuItemHookData*.

Examples:
example_loadergpi.cpp.

#define HOOKTYPE_MOUSEMOVE 0x0003

args is of type SUMouseHookData*.

#define HOOKTYPE_POSTDRAW 0x0001

args is of type SUHookData*.

#define HOOKTYPE_PRECLOSEWORKSPACE 0x0005

args is of type SUHookData*.

#define HOOKTYPE_PREREMOVESHAPE 0x000B

args is of type SUPreRemoveShapeHookData*.

#define HOOKTYPE_PREREMOVETHEME 0x0006

args is of type SUPreRemoveThemeHookData*.

Examples:
example_hooks.cpp.

#define HOOKTYPE_SHAPESELCHANGE 0x0004

args is of type SUShapeSelChangeHookData*.

#define HOOKTYPE_TOOLBARBUTTON 0x0009

args is of type SUToolBarButtonHookData*.

Examples:
example_hooks.cpp, and example_sutoolbar.cpp.

#define HOOKTYPE_WANTUPDATE 0x000C

args is of type SUHookData*.

#define HOOKTYPE_WORKSPACEREADY 0x000F

args is of type SUHookData*.

Examples:
example_sudatapage.cpp.

#define JSIHDF_DEFAULT 0x00000000

Default value.

#define JSIHDF_TREATRETURNASSINGLEVALUE 0x00000001

Used to indicate that there is only one returned value, and that it should not be treated as an Array in JavaScript.

#define MAPSTATE_ADDINGVERTEX 0x0010

Adding new vertex in progress. Read-only state.

#define MAPSTATE_ADDVERTEX 0x000F

Add new vertex mode enabled.

#define MAPSTATE_ADJUSTINGVERTEX 0x000E

Adjusting vertex in progress. Read-only state.

#define MAPSTATE_ADJUSTVERTEX 0x000D

Adjust vertex mode enabled.

#define MAPSTATE_CIRCLESELECT 0x0004

Circle select mode enabled.

#define MAPSTATE_CIRCLESELECTTRACKING 0x0005

Cirlce selection in progress. Read-only state.

#define MAPSTATE_CUSTOM 0x00FF

Indicates that another GPI has set a map state. This is a read-only state.

#define MAPSTATE_DRAWING 0x000C

Drawing mode enabled.

#define MAPSTATE_MEASURING 0x000B

Measuring mode enabled.

#define MAPSTATE_PAN 0x0006

Panning mode enabled.

#define MAPSTATE_PANNING 0x0007

Panning in progress. Read-only state.

#define MAPSTATE_PLUGINSTATEFIRST 0x0100

First available custom GPI state

#define MAPSTATE_PLUGINSTATELAST 0x01FF

Last available custom GPI state

#define MAPSTATE_POLYGONSELECT 0x0011

Polygon selection mode enabled.

#define MAPSTATE_POLYGONSELECTTRACKING 0x0012

Polygon selection in progress. Read-only state.

#define MAPSTATE_RECTSELECT 0x0002

Rectangle select mode enabled.

#define MAPSTATE_RECTSELECTTRACKING 0x0003

Rectangle selection in progress. Read-only state.

#define MAPSTATE_SINGLESELECT 0x0001

Single select mode enabled.

#define MAPSTATE_SPLITOBJECT 0x0013

Split object mode enabled.

#define MAPSTATE_SPLITTINGOBJECT 0x0014

Splitting object in progress. Read-only state.

#define MAPSTATE_ZOOMIN 0x0008

Zoom in mode enabled.

#define MAPSTATE_ZOOMINTRACKING 0x0009

Zomming in progress. Read-only state.

#define MAPSTATE_ZOOMOUT 0x000A

Zoom out mode enabled.

#define MENUITEMTYPE_ADDNEWLAYER 0x0001

Used when a new layer can be constructed without an external data source. E.g. Use this for layers created from a selection of objects in another theme.

#define MENUITEMTYPE_ADVANCEDEDIT 0x0004

Used to add an item in the Edit | Advanced Edit sub-menu.

#define MENUITEMTYPE_ADVANCEDSELECTION 0x0003

Used to add an item in the Edit | Advanced Selection sub-menu.

#define MENUITEMTYPE_COPYSPECIAL 0x0007

Used to add an item in the Edit | Copy Special sub-menu.

#define MENUITEMTYPE_EXPORTLAYER 0x0005

Used to add an item in the Theme | Export dialog.

#define MENUITEMTYPE_LOADLAYER 0x0002

Used when a new layer can be constructed from an external data source.

#define MENUITEMTYPE_TOOLS 0x0006

Used to add an item in the Tools menu.

#define PENSTYLE_DASH 1

A dashed line.

#define PENSTYLE_DASHDOT 3

A dash/dot line.

#define PENSTYLE_DASHDOTDOT 4

A das/dot/dot line.

#define PENSTYLE_DOT 2

A dotted line.

#define PENSTYLE_SOLID 0

A solid drawn line.

#define SHAPEUP_API_VERSION 100

This should be returned by the function fnVersion()

Examples:
example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

#define SURESULT_E_BUFFEROVERFLOW 106

#define SURESULT_E_ILLEGALPARAM 101

Examples:
example_javascriptable.cpp.

#define SURESULT_E_INDEXOUTOFBOUNDS 104

#define SURESULT_E_INVALIDHANDLE 100

#define SURESULT_E_INVALIDQUERY 107

#define SURESULT_E_NOSUCHERROR 3

#define SURESULT_E_NOTIMPLEMENTED 2

#define SURESULT_E_OUTOFRESOURCES 109

#define SURESULT_E_PERMISSIONDENIED 105

#define SURESULT_E_SCRIPTERROR 110

#define SURESULT_E_UNEXPECTEDSHAPETYPE 103

#define SURESULT_E_UNKNOWNHOOKTYPE 108

#define SURESULT_E_UNSUPPORTEDSHAPETYPE 102

#define SURESULT_FALSE 1

#define SURESULT_OK 0

Examples:
example_hooks.cpp, example_javascriptable.cpp, example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

Typedef Documentation

typedef enum tagDataType DataType

typedef void(__cdecl *) PFNSETTINGS()

typedef struct tagSUAddFileFormatHandlerHookData SUAddFileFormatHandlerHookData

typedef struct tagSUAddJavaScriptInvokeHookData SUAddJavaScriptInvokeHookData

typedef struct tagSUAddMenuItemHookData SUAddMenuItemHookData

typedef struct tagSUARGAddAttribute SUARGAddAttribute

typedef struct tagSUARGAddDataPage SUARGAddDataPage

typedef struct tagSUARGAddHook SUARGAddHook

typedef struct tagSUARGAddShape SUARGAddShape

typedef struct tagSUARGAllocate SUARGAllocate

typedef struct tagSUARGAllocateStatusBarPane SUARGAllocateStatusBarPane

typedef struct tagSUARGBatchAddShape SUARGBatchAddShape

typedef struct tagSUARGBeginProgress SUARGBeginProgress

typedef struct tagSUARGBrowseTheme SUARGBrowseTheme

typedef struct tagSUARGCreateNewTheme SUARGCreateNewTheme

typedef struct tagSUARGCreateNewThemeFromSelection SUARGCreateNewThemeFromSelection

typedef struct tagSUARGCreateToolBar SUARGCreateToolBar

typedef struct tagSUARGDeleteAttribute SUARGDeleteAttribute

typedef struct tagSUARGDeleteShape SUARGDeleteShape

typedef struct tagSUARGDPtoGP SUARGDPtoGP

typedef struct tagSUARGDraw SUARGDraw

typedef struct tagSUARGGetAttribute SUARGGetAttribute

typedef struct tagSUARGGetAttributeIndex SUARGGetAttributeIndex

typedef struct tagSUARGGetAttributeType SUARGGetAttributeType

typedef struct tagSUARGGetBOOL SUARGGetBOOL

typedef struct tagSUARGGetBounds SUARGGetBounds

typedef struct tagSUARGGetClosestPoint SUARGGetClosestPoint

typedef struct tagSUARGGetColor SUARGGetColor

typedef struct tagSUARGGetCoordinate SUARGGetCoordinate

typedef struct tagSUARGGetDWORD SUARGGetDWORD

typedef struct tagSUARGGetErrorDescription SUARGGetErrorDescription

typedef struct tagSUARGGetFont SUARGGetFont

typedef struct tagSUARGGetHandle SUARGGetHandle

typedef struct tagSUARGGetHandleByIndex SUARGGetHandleByIndex

typedef struct tagSUARGGetHWND SUARGGetHWND

typedef struct tagSUARGGetInfoTip SUARGGetInfoTip

typedef struct tagSUARGGetInteractionState SUARGGetInteractionState

typedef struct tagSUARGGetIntersectingShapes SUARGGetIntersectingShapes

typedef struct tagSUARGGetShapeBytes SUARGGetShapeBytes

typedef struct tagSUARGGetShapesByQuery SUARGGetShapesByQuery

typedef struct tagSUARGGetShapesInRect SUARGGetShapesInRect

typedef struct tagSUARGGetShapeType SUARGGetShapeType

typedef struct tagSUARGGetSize SUARGGetSize

typedef struct tagSUARGGetText SUARGGetText

typedef struct tagSUARGGetTextByIndex SUARGGetTextByIndex

typedef struct tagSUARGGetUnsigned SUARGGetUnsigned

typedef struct tagSUARGGetUnsignedByIndex SUARGGetUnsignedByIndex

typedef struct tagSUARGGetWorkspace SUARGGetWorkspace

typedef struct tagSUARGGPtoDP SUARGGPtoDP

typedef struct tagSUARGIsShapeSelected SUARGIsShapeSelected

typedef struct tagSUARGJSCallFunction SUARGJSCallFunction

typedef struct tagSUARGLoadJavaScript SUARGLoadJavaScript

typedef struct tagSUARGLog SUARGLog

typedef struct tagSUARGRemoveHook SUARGRemoveHook

typedef struct tagSUARGRemoveTheme SUARGRemoveTheme

typedef struct tagSUARGRepaint SUARGRepaint

typedef struct tagSUARGReplaceShapeData SUARGReplaceShapeData

typedef struct tagSUARGSelectShape SUARGSelectShape

typedef struct tagSUARGSetAttribute SUARGSetAttribute

typedef struct tagSUARGSetAttributes SUARGSetAttributes

typedef struct tagSUARGSetBOOL SUARGSetBOOL

typedef struct tagSUARGSetButtonBOOL SUARGSetButtonBOOL

typedef struct tagSUARGSetColor SUARGSetColor

typedef struct tagSUARGSetDouble SUARGSetDouble

typedef struct tagSUARGSetDWORD SUARGSetDWORD

typedef struct tagSUARGSetFloat SUARGSetFloat

typedef struct tagSUARGSetInteractionState SUARGSetInteractionState

typedef struct tagSUARGSetPoint SUARGSetPoint

typedef struct tagSUARGSetRasterImage SUARGSetRasterImage

typedef struct tagSUARGSetSerialData SUARGSetSerialData

typedef struct tagSUARGSetStatusBarPaneInfo SUARGSetStatusBarPaneInfo

typedef struct tagSUARGSetText SUARGSetText

typedef struct tagSUARGSetTextByIndex SUARGSetTextByIndex

typedef struct tagSUARGSetUnsigned SUARGSetUnsigned

typedef struct tagSUARGWantUpdate SUARGWantUpdate

typedef struct tagSUARGZoomToExtent SUARGZoomToExtent

typedef struct tagSUARGZoomToSelection SUARGZoomToSelection

typedef SURESULT(__cdecl *) SUCall(int function, void *arg)

typedef struct tagSUDeserializeHookData SUDeserializeHookData

typedef struct tagSUExport SUExport

typedef struct tagSUFileFormatHandlerHookData SUFileFormatHandlerHookData

typedef HANDLE SUHANDLE

Examples:
example_hooks.cpp, example_javascriptable.cpp, example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

typedef struct tagSUHookData SUHookData

typedef SURESULT(__cdecl *) SUHOOKFUNC(SUHANDLE hWorkspace, int hookType, SUHookData *args)

typedef struct tagSUImport SUImport

typedef struct tagSUJavaScriptArgument SUJavaScriptArgument

typedef struct tagSUJavaScriptInvokeHookData SUJavaScriptInvokeHookData

This is an example of how to construct the return values.

    // Let's return 2 values, a shape and a string, to the calling JavaScript
    // (Error handling omitted for simplicity)

    SUJavaScriptInvokeHookData *args; // From the hook function
    SUHANDLE hWorkspace;              // From the hook function

    args->retc = 2;
    ShapeUp_Allocate(sizeof(SUJavaScriptArgument) * args->retc, (void**)&args->rets);

    args->rets[0].type = DT_SUHANDLE;
    args->rets[0].handleVal = SUWorkspace(hWorkspace).GetTheme(0).GetShape(0);

    args->rets[1].type = DT_STRING;
    args->rets[1].stringVal = ShapeUp_DuplicateString("A string");
The return value is by default treated as an Array of values, even if there is only one element. To avoid this if the intention is just to return one value, set the flags member of SUJavaScriptInvokeHookData to include JSIHDF_TREATRETURNASSINGLEVALUE.

The following return values are supported:

  • int
  • double
  • null terminated char*
  • boolean
  • COLORREF
  • SUHANDLE to a theme
  • SUHANDLE to a shape
Note:
It's important to use ShapeUp_Allocate() or one of its relatives to allocate memory for the return values since ShapeUp will deallocate the structure.
The hook function can return any of:
  • SURESULT_OK to indicate success.
  • SURESULT_E_NOTIMPLEMENTED to indicate the the call was not handled.
  • SURESULT_E_ILLEGALPARAM to indicate that the parameters were incorrect for this method.
See also:
ShapeUp_Allocate(), ShapeUp_DuplicateString()

typedef struct tagSUMenuItemHookData SUMenuItemHookData

typedef struct tagSUMouseHookData SUMouseHookData

typedef struct tagSUPreRemoveShapeHookData SUPreRemoveShapeHookData

typedef struct tagSUPreRemoveThemeHookData SUPreRemoveThemeHookData

typedef HRESULT SURESULT

Examples:
example_hooks.cpp, example_javascriptable.cpp, example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

typedef struct tagSUShapeSelChangeHookData SUShapeSelChangeHookData

typedef struct tagSUToolBarButtonHookData SUToolBarButtonHookData

Enumeration Type Documentation

enum tagDataType

Enumerator:
DT_SUHANDLE
DT_INT
DT_STRING
DT_DOUBLE
DT_BOOL
DT_COLOR

Function Documentation

SURESULT DataPage_GetHWND | ( | SUHANDLE | hDataPage,
 |  | HWND * | hWnd |
 | ) |  |  | [inline]

Retrievs the window handle to the ShapeUp map window.

Parameters:
hDataPage | is the SUHANDLE to the custom data page.
hWnd | is a pointer to a HWND that will receive the data page window handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHWND, FNTYPE_DATAPAGE_GETHWND

SURESULT DataPage_Remove ( SUHANDLE hDataPage ) [inline]

Removes a custom data page for a workspace. A data page is an addition to the four native data pages supplied by ShapeUp: Attributes, Coordinates, Statistics and Bookmarks.
A custom data page can be used to display any windows control as a child.

Parameters:
hDataPage is an SUHANDLE to the data page to remove.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_DATAPAGE_REMOVE, Workspace_AddDataPage()

const GUID* __cdecl fnGUID ( )

Identifies this plug-in. E.g. used for plug-in invokation from JavaScript. Make sure this function returns a newly generated GUID for this plug-in.

Examples:
example_javascriptable.cpp, example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

SURESULT __cdecl fnInit ( const SUExport * export )

This is the main plug-in function. This function is called after the plug-in was loaded to allow the plug-in to hook up into the ShapeUp main executable.

Parameters:
export is a pointer to the ShapeUp API SUExport struct which in turn has an import member which must be initiallised.
See also:
SUExport, SUImport
Examples:
example_hooks.cpp, example_javascriptable.cpp, example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

void __cdecl fnTerminate ( )

This function is called by ShapeUp just before the plug-in is unloaded. Perform any necessary clean-up here. A plug-in is normally not unloaded until ShapeUp terminates, but it might be possible for the user to unload plugins manually anytime during a ShapeUp session, and thus, clean-up should be taken seriously.

size_t __cdecl fnVersion ( )

This function should return the version of the ShapeUp API used when building the plug-in. This is the defined value SHAPEUP_API_VERSION. The plug-in shuld just return this constant.

See also:
SHAPEUP_API_VERSION
Examples:
example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

SURESULT JavaScript_CallFunction | ( | SUHANDLE | hJavaScript,
 |  | const char * | name |
 | ) |  |  | [inline]

Executes a specified funcion in a ShapeUp JavaScript.

Parameters:
hJavaScript | is the SUHANDLE to the JavaScript to execute.
name | is a null-terminated string containing the name of the function to execute. Names are case sensitive.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
ShapeUp_HasJavaScriptSupport(), Workspace_LoadJavaScript(), SUARGJSCallFunction, FNTYPE_JAVASCRIPT_CALLFUNCTION, example_jscallfunction.js

SURESULT JavaScript_Close ( SUHANDLE hJavaScript ) [inline]

Closes a ShapeUp JavaScript.

Parameters:
hJavaScript is the SUHANDLE to the JavaScript to close.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
ShapeUp_HasJavaScriptSupport(), Workspace_LoadJavaScript(), FNTYPE_JAVASCRIPT_CLOSE

SURESULT JavaScript_Run ( SUHANDLE hJavaScript ) [inline]

Executes a ShapeUp JavaScript.

Parameters:
hJavaScript is the SUHANDLE to the JavaScript to execute.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
ShapeUp_HasJavaScriptSupport(), Workspace_LoadJavaScript(), FNTYPE_JAVASCRIPT_RUN

SURESULT Map_CenterMap | ( | SUHANDLE | hMap,
 |  | double | x,
 |  | double | y |
 | ) |  |  | [inline]

Centers the ShapeUp map window around a point.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map.
x | is the new center point east-west component.
y | is the new center point north-south component.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetPoint, FNTYPE_MAP_CENTERMAP

SURESULT Map_DPtoGP | ( | SUHANDLE | hMap,
 |  | int | dpx,
 |  | int | dpy,
 |  | double * | gpx,
 |  | double * | gpy |
 | ) |  |  | [inline]

Converts a device point to a geographical point.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map.
dpx | is an int that contains the east-west value to convert.
dpy | is an int that contains the north-south value to convert.
gpx | is a pointer to a double that will receive the east-west value.
gpy | is a pointer to a double that will receive the north-south value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGDPtoGP, FNTYPE_MAP_DPTOGP

SURESULT Map_Draw | ( | SUHANDLE | hMap,
 |  | HDC | hdc,
 |  | size_t | iw,
 |  | size_t | ih,
 |  | double | x,
 |  | double | y,
 |  | double | gw,
 |  | double | gh |
 | ) |  |  | [inline]

Draws a ShapeUp workspace to an external Windows device context.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map.
hdc | is a handle to the target Windows device context.
iw | is the width in device units of the image to draw.
ih | is the height in device units of the image to draw.
x | is the center point east-west component.
y | is the center point north-south component.
gw | is the east-west geographical extent.
gh | is the north-south geographical extent.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGDraw, FNTYPE_MAP_DRAW

SURESULT Map_GetBounds | ( | SUHANDLE | hMap,
 |  | double * | xmin,
 |  | double * | ymin,
 |  | double * | xmax,
 |  | double * | ymax |
 | ) |  |  | [inline]

Gets the map's bounding box.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map to query.
xmin | is a pointer to a double that will receive the west-most value.
ymin | is a pointer to a double that will receive the south-most value.
xmax | is a pointer to a double that will receive the east-most value.
ymax | is a pointer to a double that will receive the north-most value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBounds, FNTYPE_MAP_GETBOUNDS

SURESULT Map_GetHWND | ( | SUHANDLE | hMap,
 |  | HWND * | hWnd |
 | ) |  |  | [inline]

Retrievs the window handle to the ShapeUp map window.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map to query.
hWnd | is a pointer to a HWND that will receive the map window handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHWND, FNTYPE_MAP_GETHWND

SURESULT Map_GetInteractionState | ( | SUHANDLE | hMap,
 |  | unsigned long * | state |
 | ) |  |  | [inline]

Retrieves the current map interaction state. The interaction state is a value indicating what the user is about to do, or is doing, in the map. This is in short the state of the mutual exclusive toolbar buttons like select, rectangle select, circle select, etc. This can be used to add new states to the map.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map to query.
state | is a pointer to an unsigned long that will receive the current map interaction state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetInteractionState, Map_SetInteractionState(), MAPSTATE, FNTYPE_MAP_GETINTERACTIONSTATE

SURESULT Map_GetViewSize | ( | SUHANDLE | hMap,
 |  | size_t * | width,
 |  | size_t * | height |
 | ) |  |  | [inline]

Gets the map's view size in device units.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map to query.
width | is a pointer to a size_t that will receive the width in device units.
height | is a pointer to a size_t that will receive the height in device units.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetSize, FNTYPE_MAP_GETVIEWSIZE

SURESULT Map_GPtoDP | ( | SUHANDLE | hMap,
 |  | double | gpx,
 |  | double | gpy,
 |  | int * | dpx,
 |  | int * | dpy |
 | ) |  |  | [inline]

Converts a geographical point to a device point.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map.
gpx | is a double that contains the east-west value to convert.
gpy | is a double that contains the north-south value to convert.
dpx | is a pointer to an int that will receive the east-west value.
dpy | is a pointer to an int that will receive the north-south value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGPtoDP, FNTYPE_MAP_GPTODP

SURESULT Map_Repaint | ( | SUHANDLE | hMap,
 |  | BOOL | bFullRedraw |
 | ) |  |  | [inline]

Forces a repaint of the ShapeUp map window.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map to refresh.
bFullRedraw | if true, all map objects are redrawn, and if false, the background buffer is used to paint the map objects and only the top items are redrawn.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGRepaint, FNTYPE_MAP_REPAINT

SURESULT Map_SetInteractionState | ( | SUHANDLE | hMap,
 |  | unsigned long | state |
 | ) |  |  | [inline]

Sets a new map interaction state. The interaction state is a value indicating what the user is about to do, or is doing, in the map. This is in short the state of the mutual exclusive toolbar buttons like select, rectangle select, circle select, etc. This can be used to add new states to the map.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map.
state | is an unsigned long containing the new map interaction state. Note: Not all map states defined can be set. Check MAPSTATE for more info.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetInteractionState, Map_GetInteractionState(), MAPSTATE, FNTYPE_MAP_SETINTERACTIONSTATE

SURESULT Map_Zoom | ( | SUHANDLE | hMap,
 |  | double | factor |
 | ) |  |  | [inline]

Zooms the map.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map.
factor | is the factor used to zoom the map. 0.0 < factor < 1.0 zooms in, and 1.0 < factor zooms out.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetDouble, FNTYPE_MAP_ZOOM

SURESULT Map_ZoomToExtent | ( | SUHANDLE | hMap,
 |  | SUHANDLE | hTheme |
 | ) |  |  | [inline]

Zooms the map to fit the entire workspace, or to fit a specified theme.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map.
hTheme | is the SUHANDLE to the ShapeUp theme to fit. If this parameter is NULL, the map will zoom to fit the entire workspace.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGZoomToExtent, FNTYPE_MAP_ZOOMTOEXTENT

SURESULT Map_ZoomToSelection | ( | SUHANDLE | hMap,
 |  | SUHANDLE | hTheme |
 | ) |  |  | [inline]

Zooms the map to fit the selection in a specified theme.

Parameters:
hMap | is the SUHANDLE to the ShapeUp map.
hTheme | is the SUHANDLE to the ShapeUp theme that contains the selection.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGZoomToSelection, FNTYPE_MAP_ZOOMTOSELECTION

SURESULT MenuItem_SetEnabled | ( | SUHANDLE | hMenuItem,
 |  | BOOL | bEnabled |
 | ) |  |  | [inline]

Enables or disables a ShapeUp menu item.

Parameters:
hMenuItem | is the SUHANDLE to the menu item to change.
bEnabled | is the new enabled state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetBOOL, FNTYPE_MENUITEM_SETENABLED

SURESULT Recordset_Bof | ( | SUHANDLE | hRecordset,
 |  | BOOL * | bof |
 | ) |  |  | [inline]

Checks if the recordset cursor is moved before the first element.

Parameters:
hRecordset | is an SUHANDLE to the recordset.
bof | is a pointer to a BOOL that will receive the beginning-of-file state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBOOL, FNTYPE_RECORDSET_BOF

SURESULT Recordset_Close ( SUHANDLE hRecordset ) [inline]

Closes a ShapeUp recordset. It is important to close all retrieved recordsets to avoid resource leaks.

Parameters:
hRecordset is an SUHANDLE to the recordset.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_RECORDSET_CLOSE

SURESULT Recordset_Eof | ( | SUHANDLE | hRecordset,
 |  | BOOL * | eof |
 | ) |  |  | [inline]

Checks if the recordset cursor is moved past the last element.

Parameters:
hRecordset | is an SUHANDLE to the recordset.
eof | is a pointer to a BOOL that will receive the end-of-file state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBOOL, FNTYPE_RECORDSET_EOF

SURESULT Recordset_First ( SUHANDLE hRecordset ) [inline]

Moves a ShapeUp recordset cursor to the first item.

Parameters:
hRecordset is an SUHANDLE to the recordset.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_RECORDSET_FIRST

SURESULT Recordset_Get | ( | SUHANDLE | hRecordset,
 |  | SUHANDLE * | handle |
 | ) |  |  | [inline]

Get an element from a ShapeUp recordset at the current cursor position.

Parameters:
hRecordset | is an SUHANDLE to the recordset.
handle | is a pointer to an SUHANDLE that will receive a handle to an object defined in the recordset.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHandle, FNTYPE_RECORDSET_GET

SURESULT Recordset_GetCount | ( | SUHANDLE | hRecordset,
 |  | size_t * | count |
 | ) |  |  | [inline]

Retrieves the number of item in a ShapeUp recordset.

Parameters:
hRecordset | is an SUHANDLE to the recordset.
count | is a pointer to size_t that will receive the item count.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsigned, FNTYPE_RECORDSET_GETCOUNT

SURESULT Recordset_Last ( SUHANDLE hRecordset ) [inline]

Moves a ShapeUp recordset cursor to the last item.

Parameters:
hRecordset is an SUHANDLE to the recordset.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_RECORDSET_LAST

SURESULT Recordset_Next ( SUHANDLE hRecordset ) [inline]

Advances a ShapeUp recordset to the next item.

Parameters:
hRecordset is an SUHANDLE to the recordset.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_RECORDSET_NEXT

SURESULT Recordset_Prev ( SUHANDLE hRecordset ) [inline]

Steps a ShapeUp recordset to the previous item.

Parameters:
hRecordset is an SUHANDLE to the recordset.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_RECORDSET_PREV

SURESULT Shape_GetAttribute | ( | SUHANDLE | hShape,
 |  | SUHANDLE | hTheme,
 |  | size_t | column,
 |  | char * | buffer,
 |  | size_t * | bufferSize |
 | ) |  |  | [inline]

Retrieves an attribute for a shape within a theme.

This function can be used in a two step process. First it's used to query ShapeUp for the buffer size needed to fit the text, then the actual text can be fetched.

To query for the buffer size, set buffer to NULL, and let bufferSize point to a size_t that will receive the value. The size returned includes space for the null termination of the string. Allocate a proper character buffer and call the function again with this buffer and the returned bufferSize.

Parameters:
hShape | is an SUHANDLE to the shape to query.
hTheme | is an SUHANDLE to the theme containing the shape.
column | is the zero-based index of the attribute to query.
buffer | is a pointer to a character buffer that will receive the text.
bufferSize | is a pointer to a size_t indicates the size of the buffer.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetAttribute, FNTYPE_SHAPE_GETATTRIBUTE

SURESULT Shape_GetBounds | ( | SUHANDLE | hShape,
 |  | double * | xmin,
 |  | double * | ymin,
 |  | double * | xmax,
 |  | double * | ymax |
 | ) |  |  | [inline]

Gets a shape's bounding box.

Parameters:
hShape | is the SUHANDLE to the shape to query.
xmin | is a pointer to a double that will receive the west-most value. This parameter might be NULL if it's of no interest.
ymin | is a pointer to a double that will receive the south-most value. This parameter might be NULL if it's of no interest.
xmax | is a pointer to a double that will receive the east-most value. This parameter might be NULL if it's of no interest.
ymax | is a pointer to a double that will receive the north-most value. This parameter might be NULL if it's of no interest.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBounds, FNTYPE_SHAPE_GETBOUNDS

SURESULT Shape_GetClosestPoint | ( | SUHANDLE | hShape,
 |  | double | refx,
 |  | double | refy,
 |  | double * | closestx,
 |  | double * | closesty |
 | ) |  |  | [inline]

Gets the coordinate of this shape closest to a reference point.

Parameters:
hShape | is the SUHANDLE to the shape to query.
refx | [in] = reference point x value.
refy | [in] = reference point y value.
closestx | [out] = the coordinate on this shape closest to ref x value.
closesty | [out] = the coordinate on this shape closest to ref y value.
See also:
SUARGGetClosestPoint, FNTYPE_SHAPE_GETCLOSESTPOINT

SURESULT Shape_GetCoordinate | ( | SUHANDLE | hShape,
 |  | size_t | part,
 |  | size_t | coordIndex,
 |  | double * | x,
 |  | double * | y,
 |  | double * | z |
 | ) |  |  | [inline]

Gets the count of all parts in this shape.

Parameters:
hShape | is the SUHANDLE to the shape to query.
part | is the zero based index of the part in this shape to query.
coordIndex | is zero based index of the coordinate in the specified part.
x | [out] is a pointer to an double that will receive the x value. This value can be set to NULL if it's of no interest.
y | [out] is a pointer to an double that will receive the y value. This value can be set to NULL if it's of no interest.
z | [out] is a pointer to an double that will receive the z value. This value can be set to NULL if it's of no interest.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetCoordinate, FNTYPE_SHAPE_GETCOORDINATE

SURESULT Shape_GetCoordinateCount | ( | SUHANDLE | hShape,
 |  | size_t | part,
 |  | size_t * | count |
 | ) |  |  | [inline]

Gets the count of all parts in this shape.

Parameters:
hShape | is the SUHANDLE to the shape to query.
part | is the zero based index of the part in this shape to query.
count | is a pointer to an unsigned int that will receive the count value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsignedByIndex, FNTYPE_SHAPE_GETCOORDINATECOUNT

SURESULT Shape_GetPartCount | ( | SUHANDLE | hShape,
 |  | size_t * | count |
 | ) |  |  | [inline]

Gets the count of all parts in this shape.

Parameters:
hShape | is the SUHANDLE to the shape to query.
count | is a pointer to an unsigned int that will receive the count value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsigned, FNTYPE_SHAPE_GETPARTCOUNT

SURESULT Shape_GetShapeBytes | ( | SUHANDLE | hShape,
 |  | unsigned char * | buffer,
 |  | size_t * | bufferSize |
 | ) |  |  | [inline]

Retrieves underlying shape byte buffer for a shape. The resulting buffer can be casted to pointer to a CShapeRecord.

This function can be used in a two step process. First it's used to query ShapeUp for the buffer size needed to fit the data, then the actual data can be fetched.

To query for the buffer size, set buffer to NULL, and let bufferSize point to a size_t that will receive the value. The size returned includes space for the null termination of the string. Allocate a proper character buffer and call the function again with this buffer and the returned bufferSize.

Parameters:
hShape | is an SUHANDLE to the shape to query.
buffer | is a pointer to a byte buffer that will receive the data.
bufferSize | is a pointer to a size_t indicates the size of the buffer.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetShapeBytes, FNTYPE_SHAPE_GETSHAPEBYTES

SURESULT Shape_GetShapeType | ( | SUHANDLE | hShape,
 |  | ShapeType * | type |
 | ) |  |  | [inline]

Retrieves the type of this shape.

Parameters:
hShape | is an SUHANDLE to the shape to query.
type | is a pointer to a ShapeType that will receive the shapes's type.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetShapeType, FNTYPE_SHAPE_GETSHAPETYPE,

SURESULT Shape_IsSelected | ( | SUHANDLE | hShape,
 |  | SUHANDLE | hTheme,
 |  | BOOL * | selected |
 | ) |  |  | [inline]

Determines if a shape is selected within a given theme.

Parameters:
hShape | is an SUHANDLE to the shape to query.
hTheme | is an SUHANDLE to the theme containing the shape.
selected | is a pointer to a BOOL that will receive the selected state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGIsShapeSelected, FNTYPE_SHAPE_ISSELECTED

SURESULT Shape_Select | ( | SUHANDLE | hShape,
 |  | SUHANDLE | hTheme,
 |  | BOOL | select |
 | ) |  |  | [inline]

Changes the selection state of a shape in a given theme.

Parameters:
hShape | is an SUHANDLE to the shape to select.
hTheme | is an SUHANDLE to the theme containing the shape.
select | is a BOOL that contains the new selection state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSelectShape, FNTYPE_SHAPE_SELECT

SURESULT Shape_SetAttribute | ( | SUHANDLE | hShape,
 |  | SUHANDLE | hTheme,
 |  | size_t | column,
 |  | const char * | data |
 | ) |  |  | [inline]

Sets an attribute value of a shape within a theme.

Parameters:
hShape | is an SUHANDLE to the shape to query.
hTheme | is an SUHANDLE to the theme containing the shape.
column | is the zero-based index of the attribute.
data | is a null-terminated string that contains the new value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetAttribute, FNTYPE_SHAPE_SETATTRIBUTE

SURESULT Shape_SetAttributes | ( | SUHANDLE | hShape,
 |  | SUHANDLE | hTheme,
 |  | size_t | count,
 |  | const char * | data[] |
 | ) |  |  | [inline]

Sets multiple attribute values of a shape within a theme.

Parameters:
hShape | is an SUHANDLE to the shape to query.
hTheme | is an SUHANDLE to the theme containing the shape.
count | is the number of attribute values in data.
data | is an array of null-terminated strings that contains the new values. The data array may contain fewer attributes than the theme can handle. To avoid affecting an attribute value, set the appropriate field to NULL. To clear an attribute, set the field to an empty string, "".
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
Shape_SetAttribute(), SUARGSetAttributes, FNTYPE_SHAPE_SETATTRIBUTES

SURESULT ShapeUp_AddAdvancedEditHook | ( | unsigned long | userData,
 |  | const char * | menuString,
 |  | const char * | menuDescr,
 |  | void * | pReserved,
 |  | SUHANDLE * | hMenuItem |
 | ) |  |  | [inline]

Adds a menu item in the Edit | Advanced Edit sub-menu. This hook should be used if the plug-in can be used to edit object data.

Parameters:
userData | is a user specific value that will be sent to the hook function when the event occurs.
menuString | is the text that will be displayed in the menu.
menuDescr | is a one-line text describing what the menu item does.
pReserved | is not used, and must be set to NULL.
hMenuItem | is a pointer to a SUHANDLE that will receive a handle to the added menu item. This parameter might be set to NULL if the plug-in has no interest in changing its state (enable/disable/...).
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_MENUITEM, MENUITEMTYPE_ADVANCEDEDIT, SUMenuItemHookData, HOOKTYPE_IDLE

SURESULT ShapeUp_AddAdvancedSelectionHook | ( | unsigned long | userData,
 |  | const char * | menuString,
 |  | const char * | menuDescr,
 |  | void * | pReserved,
 |  | SUHANDLE * | hMenuItem |
 | ) |  |  | [inline]

Adds a menu item in the Edit | Advanced Selection sub-menu. This hook should be used if the plug-in can be used to select objects.

Parameters:
userData | is a user specific value that will be sent to the hook function when the event occurs.
menuString | is the text that will be displayed in the menu.
menuDescr | is a one-line text describing what the menu item does.
pReserved | is not used, and must be set to NULL.
hMenuItem | is a pointer to a SUHANDLE that will receive a handle to the added menu item. This parameter might be set to NULL if the plug-in has no interest in changing its state (enable/disable/...).
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_MENUITEM, MENUITEMTYPE_ADVANCEDSELECTION, SUMenuItemHookData, HOOKTYPE_IDLE

SURESULT ShapeUp_AddCopySpecialHook | ( | unsigned long | userData,
 |  | const char * | menuString,
 |  | const char * | menuDescr,
 |  | void * | pReserved,
 |  | SUHANDLE * | hMenuItem |
 | ) |  |  | [inline]

Adds a menu item in the Edit | Copy Special sub-menu. This hook should be used if the plug-in can copy objects in a special format and place the content on the Clipboard.

Parameters:
userData | is a user specific value that will be sent to the hook function when the event occurs.
menuString | is the text that will be displayed in the menu.
menuDescr | is a one-line text describing what the menu item does.
pReserved | is not used, and must be set to NULL.
hMenuItem | is a pointer to a SUHANDLE that will receive a handle to the added menu item. This parameter might be set to NULL if the plug-in has no interest in changing its state (enable/disable/...).
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_MENUITEM, MENUITEMTYPE_COPYSPECIAL, SUMenuItemHookData, HOOKTYPE_IDLE

SURESULT ShapeUp_AddDeserializeHook ( unsigned long userData ) [inline]

This hook ensures the plugin gets called when a ShapeUp workspace file is loaded, if the file contains data that were previously stored by this plug-in. If that is the case, the hook funktion will be called for the workspace or individual themes within it where applicable.
The hTheme SUHANDLE of the SUDeserializeHookData will be NULL if the workspace is deserialized, and contain a valid theme SUHANDLE if a theme is deserialized.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_DESERIALIZE, SUDeserializeHookData, Workspace_SetSerialData(), Theme_SetSerialData()

SURESULT ShapeUp_AddExportLayerHook | ( | unsigned long | userData,
 |  | const char * | menuString,
 |  | const char * | menuDescr,
 |  | void * | pReserved,
 |  | SUHANDLE * | hMenuItem |
 | ) |  |  | [inline]

Adds an item in the Theme | Export dialog. This hook should be used if the plug-in can be used to export object data.
Even though the export options are not in a menu directly, the added hook can be handled from the plug-in as if it was a menu item. If the menu item is set disabled, it will not end up in the exporter list. This should be used if the current selection is not exportable by the plug-in.

Parameters:
userData | is a user specific value that will be sent to the hook function when the event occurs.
menuString | is the text that will be displayed in the menu.
menuDescr | is a one-line text describing what the menu item does.
pReserved | is not used, and must be set to NULL.
hMenuItem | is a pointer to a SUHANDLE that will receive a handle to the added menu item. This parameter might be set to NULL if the plug-in has no interest in changing its state (enable/disable/...).
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_MENUITEM, MENUITEMTYPE_ADVANCEDEDIT, SUMenuItemHookData, HOOKTYPE_IDLE

SURESULT ShapeUp_AddFileFormatHandlerHook | ( | unsigned long | userData,
 |  | const char * | filterdescription,
 |  | const char * | pattern |
 | ) |  |  | [inline]

Extends the ShapeUp File Open dialog with new file fomats. This hook can be used if the plug-in acts as a loader for data stored on file.

Parameters:
userData | is a user specific value that will be sent to the hook function when the event occurs.
filterdescription | is the text that will be displayed in the file dialog file type combo box, e.g "Text files (*.txt)".
pattern | is the pattern for files that can be handeled, e.g "*.txt", or multiple filters separated by ';', e.g "*.txt;*.log".
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_FILEFORMATHANDLER, SUAddFileFormatHandlerHookData, ShapeUp_AddLoadLayerHook()

SURESULT ShapeUp_AddIdleHook ( unsigned long userData ) [inline]

Adds a hook for notifications when ShapeUp is idle. This can be used to let the plug-in update its menu items or toolbar buttons states.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_IDLE, SUHookData
Examples:
example_hooks.cpp, and example_sutoolbar.cpp.

SURESULT ShapeUp_AddJavaScriptInvokeHook | ( | unsigned long | userData,
 |  | const char * | properties[],
 |  | const char * | methods[] |
 | ) |  |  | [inline]

This hook is called when a JavaScript is invoking the plug-in. It supports multiple arguments as well as multiple return values to and from the plug-in.

Parameters:
userData | is a user specific value that will be sent to the hook function when the event occurs.
properties | is an array of strings containing property names exposed by this GPI. The last element in this array must be NULL. If no properties are exposed, this parameter may be set to NULL.
methods | is an array of strings containing method names exposed by this GPI. The last element in this array must be NULL. If no methods are exposed, this parameter may be set to NULL.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_JAVASCRIPTINVOKE, SUHookData
Examples:
example_javascriptable.cpp.

SURESULT ShapeUp_AddLayerSelectionChangedHook ( unsigned long userData ) [inline]

This hook is called when the layer selection changes.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_LAYERSELCHANGE, SUHookData

SURESULT ShapeUp_AddLButtonDownHook ( unsigned long userData ) [inline]

Adds a hook for notifications when the left mouse button is pressed within the ShapeUp map.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_LBUTTONDOWN, SUMouseHookData
Examples:
example_hooks.cpp.

SURESULT ShapeUp_AddLButtonUpHook ( unsigned long userData ) [inline]

Adds a hook for notifications when the left mouse button is released within the ShapeUp map.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_LBUTTONUP, SUMouseHookData

SURESULT ShapeUp_AddLoadLayerHook | ( | unsigned long | userData,
 |  | const char * | menuString,
 |  | const char * | menuDescr,
 |  | void * | pReserved,
 |  | SUHANDLE * | hMenuItem |
 | ) |  |  | [inline]

Adds a menu item in the Insert | Add Theme From sub-menu. This hook should be used if the plug-in creates a new layer using external data sources. This is equivalent to the old ShapeUp loader plug-ins.

Parameters:
userData | is a user specific value that will be sent to the hook function when the event occurs.
menuString | is the text that will be displayed in the menu.
menuDescr | is a one-line text describing what the menu item does.
pReserved | is not used, and must be set to NULL.
hMenuItem | is a pointer to a SUHANDLE that will receive a handle to the added menu item. This parameter might be set to NULL if the plug-in has no interest in changing its state (enable/disable/...).
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_MENUITEM, MENUITEMTYPE_LOADLAYER, SUMenuItemHookData, ShapeUp_AddNewLayerHook(), HOOKTYPE_IDLE
Examples:
example_loadergpi.cpp.

SURESULT ShapeUp_AddMouseMoveHook ( unsigned long userData ) [inline]

Adds a hook for notifications when the mouse is moved within the ShapeUp map.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_MOUSEMOVE, SUMouseHookData

SURESULT ShapeUp_AddNewLayerHook | ( | unsigned long | userData,
 |  | const char * | menuString,
 |  | const char * | menuDescr,
 |  | void * | pReserved,
 |  | SUHANDLE * | hMenuItem |
 | ) |  |  | [inline]

Adds a menu item in the Insert | New Theme sub-menu. This hook should be used if the plug-in creates a new layer not using external data sources.

Parameters:
userData | is a user specific value that will be sent to the hook function when the event occurs.
menuString | is the text that will be displayed in the menu.
menuDescr | is a one-line text describing what the menu item does.
pReserved | is not used, and must be set to NULL.
hMenuItem | is a pointer to a SUHANDLE that will receive a handle to the added menu item. This parameter might be set to NULL if the plug-in has no interest in changing its state (enable/disable/...).
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_MENUITEM, MENUITEMTYPE_ADDNEWLAYER, SUMenuItemHookData, ShapeUp_AddLoadLayerHook(), HOOKTYPE_IDLE

SURESULT ShapeUp_AddPostDrawHook ( unsigned long userData ) [inline]

Adds a hook for notifications when ShapeUp has drawn the map. This can be used to let the plug-in overlay its own graphics.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_POSTDRAW, SUHookData

SURESULT ShapeUp_AddRemoveLayerHook ( unsigned long userData ) [inline]

Adds a hook for notifications when a theme is about to be removed.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_PREREMOVETHEME, SUPreRemoveThemeHookData
Examples:
example_hooks.cpp.

SURESULT ShapeUp_AddRemoveShapeHook ( unsigned long userData ) [inline]

Adds a hook for notifications when a shape is about to be removed. If an entire theme is removed, there will not be individual notifications for each shape.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_PREREMOVESHAPE, SUPreRemoveShapeHookData

SURESULT ShapeUp_AddShapeSelectionChangedHook ( unsigned long userData ) [inline]

This hook is called when the shape selection changes.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_SHAPESELCHANGE, SUHookData

SURESULT ShapeUp_AddSimpleHook_Helper | ( | int | ht,
 |  | unsigned long | ud,
 |  | void * | args |
 | ) |  |  | [inline]

Helper function for internal use.

Parameters:
ht | is the HOOKTYPE value.
ud | is the user data.
args | is a pointer to the hook specific data.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGAddHook, FNTYPE_SHAPEUP_ADDHOOK

SURESULT ShapeUp_AddToolBarButtonHook ( unsigned long userData ) [inline]

Adds a hook for notifications when the user selects one of the plug-ins toolbar buttons.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_LBUTTONUP, SUToolBarButtonHookData
Examples:
example_hooks.cpp, and example_sutoolbar.cpp.

SURESULT ShapeUp_AddToolsHook | ( | unsigned long | userData,
 |  | const char * | menuString,
 |  | const char * | menuDescr,
 |  | void * | pReserved,
 |  | SUHANDLE * | hMenuItem |
 | ) |  |  | [inline]

Adds a menu item in the Tools menu.

Parameters:
userData | is a user specific value that will be sent to the hook function when the event occurs.
menuString | is the text that will be displayed in the menu.
menuDescr | is a one-line text describing what the menu item does.
pReserved | is not used, and must be set to NULL.
hMenuItem | is a pointer to a SUHANDLE that will receive a handle to the added menu item. This parameter might be set to NULL if the plug-in has no interest in changing its state (enable/disable/...).
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_MENUITEM, MENUITEMTYPE_TOOLS, SUMenuItemHookData, HOOKTYPE_IDLE

SURESULT ShapeUp_AddWorkspaceReadyHook ( unsigned long userData ) [inline]

This hook is called when a new workspace is created, after any serialization has taken place, or after a new empty workspace has been created.

Parameters:
userData is a user specific value that will be sent to the hook function when the event occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_WORKSPACEREADY, SUHookData
Examples:
example_sudatapage.cpp.

SURESULT ShapeUp_Allocate | ( | size_t | count,
 |  | void ** | bytes |
 | ) |  |  | [inline]

Allocates a memory buffer. This function should be used where a data buffer is handed over from the plug-in to ShapeUp.

Parameters:
count | is the number of bytes to allocate.
bytes | is the address of a pointer that will receive the allocated buffer.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGAllocate, FNTYPE_SHAPEUP_ALLOCATE
Examples:
example_javascriptable.cpp.

SURESULT ShapeUp_AllocateStatusBarPane | ( | size_t | width,
 |  | SUHANDLE * | hStatusPane |
 | ) |  |  | [inline]

Allocates a pane in the ShapeUp status bar. The ShapeUp status bar is a limited resource. Use sparingly. When an allocated pane is not needed anymore, it should be released with a call to ShapeUp_ReleaseStatusBarPane().

Parameters:
width | is the requested width in device units of the new pane.
hStatusPane | is a pointer to a SUHANDLE that will receive the pane handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGAllocateStatusBarPane, ShapeUp_SetStatusBarPaneInfo(), ShapeUp_ReleaseStatusBarPane(), FNTYPE_SHAPEUP_SETSTATUSBARPANEINFO

SURESULT ShapeUp_BeginProgress | ( | const char * | title,
 |  | float | progress,
 |  | SUHANDLE * | hProgress |
 | ) |  |  | [inline]

Initiates a ShapeUp progress bar session. The ShapeUp progress bar is shown in the left corner of the ShapeUp status bar, and can be used to show the progress of lengthy operations. When the progress bar is not used anymore, it must be released with a call to ShapeUp_EndProgress().

Parameters:
title | is a null terminated string of text to be displayed to the left of the progress bar. May be NULL to show no text.
progress | is the initial value of the progress. Usually 0.
hProgress | is a pointer to an SUHANDLE that will receive the progress bar handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGBeginProgress, ShapeUp_EndProgress(), ShapeUp_SetProgress(), FNTYPE_SHAPEUP_BEGINPROGRESS

SURESULT ShapeUp_Deallocate ( void * bytes ) [inline]

Dellocates a memory buffer previously allocated by ShapeUp_Allocate().

Parameters:
bytes is the buffer to release.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
ShapeUp_Allocate(), FNTYPE_SHAPEUP_DEALLOCATE

char * ShapeUp_DuplicateString ( const char * str ) [inline]

Allocates a memory buffer using ShapeUp_Allocate(), and copies a given string to it. A string created with this function needs to be deallocated by a call to ShapeUp_Deallocate(), or it should be sent into one of the ShapeUp API functions that explicitly sais it will clean-up the string.

Parameters:
str is the string to duplicate.
Returns:
This function returns the duplicated string if successful, or NULL otherwise.
See also:
ShapeUp_Allocate, ShapeUp_Deallocate
Examples:
example_javascriptable.cpp.

SURESULT ShapeUp_EndProgress ( SUHANDLE hProgress ) [inline]

Releases the ShapeUp progress bar previously allocated with a call to ShapeUp_BeginProgress(). A call to this function invalidates the hProgress handle.

Parameters:
hProgress is the SUHANDLE to the progress bar.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
ShapeUp_BeginProgress(), FNTYPE_SHAPEUP_ENDPROGRESS

SURESULT ShapeUp_GetActiveWorkspace ( SUHANDLE * hWorkspace ) [inline]

Asks ShapeUp for the workspace currently active.

Parameters:
hWorkspace is a pointer to a SUHANDLE that will receive a handle to the workspace.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_SHAPEUP_GETACTIVEWORKSPACE

SURESULT ShapeUp_GetErrorDescription | ( | SURESULT | errCode,
 |  | char * | buffer,
 |  | size_t * | bufferSize |
 | ) |  |  | [inline]

Translates a SURESULT value into a human readable string.

This function can be used in a two step process. First it's used to query ShapeUp for the buffer size needed to fit the message, then the actual message can be fetched.

To query for the buffer size, set buffer to NULL, and let bufferSize point to a size_t that will receive the value. The size returned includes space for the null termination of the string. Allocate a proper character buffer and call the function again with this buffer and the returned bufferSize.

Parameters:
errCode | is the SURESULT value to translate.
buffer | is a pointer to a character buffer that will receive the text.
bufferSize | is a pointer to a size_t indicates the size of the buffer.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetErrorDescription, FNTYPE_SHAPEUP_GETERRORDESCRIPTION

SURESULT ShapeUp_GetVersion | ( | char * | buffer,
 |  | size_t * | bufferSize |
 | ) |  |  | [inline]

Returns the current version of ShapeUp as a string. This is the same string as can be seen in the Help | About dialog.

This function can be used in a two step process. First it's used to query ShapeUp for the buffer size needed to fit the version string, then the actual text can be fetched.

To query for the buffer size, set buffer to NULL, and let bufferSize point to a size_t that will receive the value. The size returned includes space for the null termination of the string. Allocate a proper character buffer and call the function again with this buffer and the returned bufferSize.

Parameters:
buffer | is a pointer to a character buffer that will receive the text.
bufferSize | is a pointer to a size_t indicates the size of the buffer.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_SHAPEUP_GETVERSION

SURESULT ShapeUp_GetWorkspace | ( | size_t | index,
 |  | SUHANDLE * | hWorkspace |
 | ) |  |  | [inline]

Asks ShapeUp for a specific workspace by index.

Parameters:
index | is a pointer to a size_t that will receive the count value.
hWorkspace | is a pointer to a SUHANDLE that will receive a handle to the workspace.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetWorkspace, FNTYPE_SHAPEUP_GETWORKSPACE

SURESULT ShapeUp_GetWorkspaceCount ( size_t * count ) [inline]

Asks ShapeUp for the number of workspaces currently opened.

Parameters:
count is a pointer to a size_t that will receive the count value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_SHAPEUP_GETWORKSPACECOUNT

SURESULT ShapeUp_HasJavaScriptSupport ( BOOL * support ) [inline]

Asks ShapeUp if it has JavaScript support, i.e. if the Mozilla SpiderMonkey js32.dll is present.

Parameters:
support is a pointer to a BOOL that will receive the value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_SHAPEUP_HASJAVASCRIPTSUPPORT

SURESULT ShapeUp_IsValidHandle | ( | SUHANDLE | handle,
 |  | BOOL * | valid |
 | ) |  |  | [inline]

Asks ShapeUp if the supplied handle is a valid one.

Parameters:
handle | is the handle to test.
valid | is a pointer to a BOOL that will receive the value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBOOL, FNTYPE_SHAPEUP_ISVALIDHANDLE

SURESULT ShapeUp_ReleaseStatusBarPane ( SUHANDLE hStatusPane ) [inline]

Releases a pane in the ShapeUp status bar previously allocated by a call to ShapeUp_AllocateStatusBarPane(). A call to this function invalidates the hStatusPane handle.

Parameters:
hStatusPane is a SUHANDLE to the pane to release.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
ShapeUp_AllocateStatusBarPane(), FNTYPE_SHAPEUP_SETSTATUSBARPANEINFO

SURESULT ShapeUp_RemoveAllHooks ( ) [inline]

Removes all removable hooks. Not all hooks are removable. Don't use.

Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_SHAPEUP_REMOVEHOOK

SURESULT ShapeUp_RemoveHook_Helper ( int hookType ) [inline]

Helper function for internal use.

Parameters:
hookType is the HOOKTYPE value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGRemoveHook, FNTYPE_SHAPEUP_REMOVEHOOK

SURESULT ShapeUp_RemoveLayerSelectionChangedHook ( ) [inline]

Removes the notification hook set by an earlier call to ShapeUp_AddLayerSelectionChangedHook().

Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_LAYERSELCHANGE, FNTYPE_SHAPEUP_REMOVEHOOK

SURESULT ShapeUp_RemoveMouseMoveHook ( ) [inline]

Removes the mouse move notification hook set by an earlier call to ShapeUp_AddMouseMoveHook().

Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_MOUSEMOVE, FNTYPE_SHAPEUP_REMOVEHOOK

SURESULT ShapeUp_RemoveShapeSelectionChangedHook ( ) [inline]

Removes the notification hook set by an earlier call to ShapeUp_AddShapeSelectionChangedHook().

Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
HOOKTYPE_SHAPESELCHANGE, FNTYPE_SHAPEUP_REMOVEHOOK

SURESULT ShapeUp_SetProgress | ( | SUHANDLE | hProgress,
 |  | float | progress |
 | ) |  |  | [inline]

Sets the progress of the ShapeUp progress bar.

Parameters:
hProgress | is the SUHANDLE to the progress bar.
progress | is the value of the progress. 0 <= progress <= 1.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetFloat, ShapeUp_BeginProgress(), FNTYPE_SHAPEUP_SETPROGRESS

SURESULT ShapeUp_SetStatusBarPaneInfo | ( | SUHANDLE | hStatusPane,
 |  | const char * | text,
 |  | HICON | hIcon,
 |  | void * | pReserved |
 | ) |  |  | [inline]

Sets information in an allocated pane in the ShapeUp status bar.

Parameters:
hStatusPane | is a handle to the status bar pane.
text | is a pointer to a null terminated string to be displayed. May be NULL to clear the current text.
hIcon | is a handle to an icon to be displayed. May be NULL to clear the current icon.
pReserved | is fur future use, must be NULL.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetStatusBarPaneInfo, ShapeUp_AllocateStatusBarPane(), FNTYPE_SHAPEUP_SETSTATUSBARPANEINFO

SURESULT ShapeUp_SetStatusBarText ( const char * text ) [inline]

Sets informational text in the ShapeUp status bar.

Parameters:
text is a pointer to a null terminated string to be displayed. May be NULL to clear the current text.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetText, FNTYPE_SHAPEUP_SETSTATUSBARTEXT

SURESULT ShapeUp_WantUpdate ( unsigned long userData ) [inline]

Requests a synchronised call from ShapeUp.

If a plug-in is running a separate thread, that thread is not allowed to call any of the ShapeUp API functions except ShapeUp_WantUpdate(). The plug-in then has to wait for its hook function to get called in which it may access all ShapeUp API functions.

Parameters:
userData is a user specific value that will be sent to the hook function when the syncronised call occurs.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGWantUpdate, FNTYPE_SHAPEUP_WANTUPDATE, HOOKTYPE_WANTUPDATE, GPI Threading

SURESULT Theme_AddAttribute | ( | SUHANDLE | hTheme,
 |  | unsigned long | type,
 |  | const char * | name,
 |  | const char * | defaultval,
 |  | size_t * | index |
 | ) |  |  | [inline]

Adds a new attribute to a ShapeUp theme.

Parameters:
hTheme | is the SUHANDLE to the theme.
type | is the ATTRIBUTETYPE of the new attribute.
name | is null-terminated string containing the name of the new attribute. This parameter cannot be NULL nor an empty string.
defaultval | is null-terminated string containing a default value of the new attribute. This parameter might be NULL.
index | is a pointer to a size_t that will receive the zero-based index of the added attribute. This parameter might be NULL if it's of no interest.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGAddAttribute, FNTYPE_THEME_ADDATTRIBUTE, ATTRIBUTETYPE

SURESULT Theme_AddAttribute | ( | SUHANDLE | hTheme,
 |  | unsigned long | type,
 |  | const char * | name,
 |  | size_t * | index |
 | ) |  |  | [inline]

SURESULT Theme_AddShape | ( | SUHANDLE | hTheme,
 |  | const CShapeRecord * | shapeData,
 |  | SUHANDLE * | hShape |
 | ) |  |  | [inline]

Adds a copy of a new shape object to a theme.

Parameters:
hTheme | is the SUHANDLE to the ShapeUp theme.
shapeData | is a pointer to the new shape object to add.
hShape | is a pointer to a SUHANDLE that will receive a handle to the new shape object.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGAddShape, FNTYPE_THEME_ADDSHAPE

SURESULT Theme_BatchAddShapeBegin ( SUHANDLE hTheme ) [inline]

Turns off indexing and other time consuming tasks when calling Theme_AddShape(). Use this if many shapes should be added at once. After the shapes have been added, call Theme_BatchAddShapeEnd() to turn the features back on again.

Parameters:
hTheme is the SUHANDLE to the ShapeUp theme.
See also:
Theme_AddShape(), Theme_BatchAddShapeEnd()

SURESULT Theme_BatchAddShapeEnd ( SUHANDLE hTheme ) [inline]

Turns on indexing and other tasks after calling Theme_AddShape().

Parameters:
hTheme is the SUHANDLE to the ShapeUp theme.
See also:
Theme_AddShape(), Theme_BatchAddShapeBegin()

SURESULT Theme_ClearSelection ( SUHANDLE hTheme ) [inline]

Clears the current shape selection in a theme.

Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_THEME_CLEARSELECTION

SURESULT Theme_DeleteAttribute | ( | SUHANDLE | hTheme,
 |  | size_t | index |
 | ) |  |  | [inline]

Deletes an attribute from a ShapeUp theme.

Parameters:
hTheme | is the SUHANDLE to the theme.
index | is the zero-based index of the attribute to delete.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGDeleteAttribute, FNTYPE_THEME_DELETEATTRIBUTE

SURESULT Theme_DeleteShape | ( | SUHANDLE | hTheme,
 |  | SUHANDLE | hShape |
 | ) |  |  | [inline]

Deletes a shape within a ShapeUp theme. After this operation, the hShape handle will be invalid.

Parameters:
hTheme | is the SUHANDLE to the ShapeUp theme containing the shape object to delete.
hShape | is a SUHANDLE to the shape object to delete.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGDeleteShape, FNTYPE_THEME_DELETESHAPE

SURESULT Theme_GetAttributeCount | ( | SUHANDLE | hTheme,
 |  | size_t * | count |
 | ) |  |  | [inline]

Retrieves the number of attributes in a ShapeUp theme.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
count | is a pointer to size_t that will receive the attribute count.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsigned, FNTYPE_THEME_GETATTRIBUTECOUNT

SURESULT Theme_GetAttributeIndex | ( | SUHANDLE | hTheme,
 |  | const char * | name,
 |  | size_t * | index |
 | ) |  |  | [inline]

Retrieves the index of a named attribute in a ShapeUp theme.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
name | is a null-terminated string containing the name of the attribute to query.
index | is a pointer to a size_t which will receive the index value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function. A return value of SURESULT_FALSE means the lookup failed.
See also:
SUARGGetAttributeIndex, FNTYPE_THEME_GETATTRIBUTEINDEX

SURESULT Theme_GetAttributeName | ( | SUHANDLE | hTheme,
 |  | size_t | column,
 |  | char * | buffer,
 |  | size_t * | bufferSize |
 | ) |  |  | [inline]

Retrieves the name of an attribute in a ShapeUp theme.

This function can be used in a two step process. First it's used to query ShapeUp for the buffer size needed to fit the name, then the actual name can be fetched.

To query for the buffer size, set buffer to NULL, and let bufferSize point to a size_t that will receive the value. The size returned includes space for the null termination of the string. Allocate a proper character buffer and call the function again with this buffer and the returned bufferSize.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
column | is the zero-based index of the attribute to query.
buffer | is a pointer to a character buffer that will receive the text.
bufferSize | is a pointer to a size_t indicates the size of the buffer.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetText, FNTYPE_THEME_GETATTRIBUTENAME

SURESULT Theme_GetAttributeType | ( | SUHANDLE | hTheme,
 |  | size_t | column,
 |  | unsigned long * | type |
 | ) |  |  | [inline]

Retrieves the type of an attribute in a ShapeUp theme.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
column | is the zero-based index of the attribute to query.
type | is a pointer to an unsigned long which will receive the type value.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetAttributeType, FNTYPE_THEME_GETATTRIBUTETYPE, ATTRIBUTETYPE

SURESULT Theme_GetBounds | ( | SUHANDLE | hTheme,
 |  | double * | xmin,
 |  | double * | ymin,
 |  | double * | xmax,
 |  | double * | ymax |
 | ) |  |  | [inline]

Gets the themes's bounding box.

Parameters:
hTheme | is the SUHANDLE to the ShapeUp theme to query.
xmin | is a pointer to a double that will receive the west-most value. This parameter might be NULL if it's of no interest.
ymin | is a pointer to a double that will receive the south-most value. This parameter might be NULL if it's of no interest.
xmax | is a pointer to a double that will receive the east-most value. This parameter might be NULL if it's of no interest.
ymax | is a pointer to a double that will receive the north-most value. This parameter might be NULL if it's of no interest.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBounds, FNTYPE_THEME_GETBOUNDS

SURESULT Theme_GetComment | ( | SUHANDLE | hTheme,
 |  | char * | buffer,
 |  | size_t * | bufferSize |
 | ) |  |  | [inline]

Retrieves a theme's comment.

This function can be used in a two step process. First it's used to query ShapeUp for the buffer size needed to fit the comment, then the actual comment can be fetched.

To query for the buffer size, set buffer to NULL, and let bufferSize point to a size_t that will receive the value. The size returned includes space for the null termination of the string. Allocate a proper character buffer and call the function again with this buffer and the returned bufferSize.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
buffer | is a pointer to a character buffer that will receive the text.
bufferSize | is a pointer to a size_t indicates the size of the buffer.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetText, FNTYPE_THEME_GETCOMMENT

SURESULT Theme_GetFillColor | ( | SUHANDLE | hTheme,
 |  | COLORREF * | clr |
 | ) |  |  | [inline]

Gets a theme's fill color.

Parameters:
hTheme | is the SUHANDLE to the theme.
clr | is a pointer to a COLORREF value that will receive the current fill color.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetColor, FNTYPE_THEME_GETFILLCOLOR

SURESULT Theme_GetFont | ( | SUHANDLE | hTheme,
 |  | LOGFONT * | font,
 |  | COLORREF * | clr |
 | ) |  |  | [inline]

Retrieves font information used for labels from a ShapeUp theme.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
font | is a pointer to a LOGFON struct that will receive the font properties. This parameter might be NULL if it's of no interest.
clr | is a pointer to a COLORREF that will receive the text color. This parameter might be NULL if it's of no interest.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetInfoTip, FNTYPE_THEME_GETINFOTIP

SURESULT Theme_GetInfoTip | ( | SUHANDLE | hTheme,
 |  | SUHANDLE | hShape,
 |  | char * | buffer,
 |  | size_t * | bufferSize |
 | ) |  |  | [inline]

Retrieves the translated InfoTip of a shape in a ShapeUp theme.

This function can be used in a two step process. First it's used to query ShapeUp for the buffer size needed to fit the text, then the actual text can be fetched.

To query for the buffer size, set buffer to NULL, and let bufferSize point to a size_t that will receive the value. The size returned includes space for the null termination of the string. Allocate a proper character buffer and call the function again with this buffer and the returned bufferSize.

Parameters:
hTheme | is the SUHANDLE to the theme containing the shape.
hShape | is the SUHANDLE to the shape to query.
buffer | is a pointer to a character buffer that will receive the text.
bufferSize | is a pointer to a size_t indicates the size of the buffer.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetInfoTip, FNTYPE_THEME_GETINFOTIP

SURESULT Theme_GetIntersectingShapes | ( | SUHANDLE | hTheme,
 |  | SUHANDLE | hShape,
 |  | SUHANDLE * | hRecordset |
 | ) |  |  | [inline]

Gets all shapes from a theme intersecting a specific shape. If the shape indicated by hShape is in the searched theme, hTheme, that shape will not be included in the result.

IMPORTANT: Retrieved recordsets must be closed by a call to Recordset_Close().

Parameters:
hTheme | is the SUHANDLE to the theme to query.
hShape | is the SUHANDLE to the shape that will be used for intersection tests.
hRecordset | is a pointer to an SUHANDLE that will receive a handle to a recordset containing the intersecting shapes.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHandleByIndex, FNTYPE_THEME_GETSHAPEFROMINDEX, Theme_GetShape()

SURESULT Theme_GetName | ( | SUHANDLE | hTheme,
 |  | char * | buffer,
 |  | size_t * | bufferSize |
 | ) |  |  | [inline]

Retrieves the name of a ShapeUp theme.

This function can be used in a two step process. First it's used to query ShapeUp for the buffer size needed to fit the name, then the actual name can be fetched.

To query for the buffer size, set buffer to NULL, and let bufferSize point to a size_t that will receive the value. The size returned includes space for the null termination of the string. Allocate a proper character buffer and call the function again with this buffer and the returned bufferSize.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
buffer | is a pointer to a character buffer that will receive the text.
bufferSize | is a pointer to a size_t indicates the size of the buffer.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetText, FNTYPE_THEME_GETNAME

SURESULT Theme_GetPenColor | ( | SUHANDLE | hTheme,
 |  | COLORREF * | clr |
 | ) |  |  | [inline]

Gets a theme's pen color.

Parameters:
hTheme | is the SUHANDLE to the theme.
clr | is a pointer to a COLORREF value that will receive the current pen color.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetColor, FNTYPE_THEME_GETPENCOLOR

SURESULT Theme_GetPenStyle | ( | SUHANDLE | hTheme,
 |  | size_t * | style |
 | ) |  |  | [inline]

Gets a theme's pen style.

Parameters:
hTheme | is the SUHANDLE to the theme.
style | is a pointer to a size_t value that will receive the current pen style.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsigned, PENSTYLE, FNTYPE_THEME_GETPENSTYLE

SURESULT Theme_GetPenWidth | ( | SUHANDLE | hTheme,
 |  | size_t * | width |
 | ) |  |  | [inline]

Gets a theme's pen width.

Parameters:
hTheme | is the SUHANDLE to the theme.
width | is a pointer to a size_t value that will receive the current pen width.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsigned, FNTYPE_THEME_GETPENWIDTH

SURESULT Theme_GetSelectedShapes | ( | SUHANDLE | hTheme,
 |  | SUHANDLE * | hRecordset |
 | ) |  |  | [inline]

Gets all selected shapes from a ShapeUp theme.

IMPORTANT: Retrieved recordsets must be closed by a call to Recordset_Close().

Parameters:
hTheme | is the SUHANDLE to the theme to query.
hRecordset | is a pointer to an SUHANDLE that will receive a handle to a recordset containing the selected shapes.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHandle, FNTYPE_THEME_GETSELECTEDSHAPES, Theme_GetShape()

SURESULT Theme_GetSelectedShapesInRect | ( | SUHANDLE | hTheme,
 |  | double | xmin,
 |  | double | ymin,
 |  | double | xmax,
 |  | double | ymax,
 |  | BOOL | bPartInRectOk,
 |  | SUHANDLE * | hRecordset |
 | ) |  |  | [inline]

Gets all selected shapes from a theme contained in or intersecting a rectangle.

IMPORTANT: Retrieved recordsets must be closed by a call to Recordset_Close().

Parameters:
hTheme | is the SUHANDLE to the theme to query.
xmin | is the west-most bound of the rectangle.
ymin | is the south-most bound of the rectangle.
xmax | is the east-most bound of the rectangle.
ymax | is the north-most bound of the rectangle.
bPartInRectOk | if true, this function returns a recordset containing all selected shapes that intersects the specified rectangle. If false, it will return all selected shapes that are contained in the rectangle.
hRecordset | is a pointer to an SUHANDLE that will receive a handle to a recordset containing the resulting shapes.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetShapesInRect, FNTYPE_THEME_GETSELECTEDSHAPESINRECT, Theme_GetShape()

SURESULT Theme_GetSelectionCount | ( | SUHANDLE | hTheme,
 |  | size_t * | count |
 | ) |  |  | [inline]

Retrieves the number of selected shape objects in a ShapeUp theme.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
count | is a pointer to size_t that will receive the selected shape object count.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsigned, FNTYPE_THEME_GETSELECTIONCOUNT

SURESULT Theme_GetShape | ( | SUHANDLE | hTheme,
 |  | size_t | nIndex,
 |  | SUHANDLE * | hShape |
 | ) |  |  | [inline]

Gets a shape from a theme.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
nIndex | is the zero-based index of the shape whithin the theme.
hShape | is a pointer to an SUHANDLE that will receive the shape handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHandleByIndex, FNTYPE_THEME_GETSHAPE, Theme_GetShapeCount()

SURESULT Theme_GetShapeCount | ( | SUHANDLE | hTheme,
 |  | size_t * | count |
 | ) |  |  | [inline]

Retrieves the number of shape objects in a ShapeUp theme.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
count | is a pointer to size_t that will receive the shape object count.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsigned, FNTYPE_THEME_GETSHAPECOUNT

SURESULT Theme_GetShapeFromIndex | ( | SUHANDLE | hTheme,
 |  | size_t | nIndex,
 |  | SUHANDLE * | hShape |
 | ) |  |  | [inline]

Gets a shape from a theme looking it up by its internal index identifier.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
nIndex | is the shape's internal index identifier.
hShape | is a pointer to an SUHANDLE that will receive the shape handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHandleByIndex, FNTYPE_THEME_GETSHAPEFROMINDEX, Theme_GetShape()

SURESULT Theme_GetShapesByQuery | ( | SUHANDLE | hTheme,
 |  | const char * | where,
 |  | SUHANDLE * | hRecordset |
 | ) |  |  | [inline]

Gets all selected shapes from a theme matching attributes.

IMPORTANT: Retrieved recordsets must be closed by a call to Recordset_Close().

Parameters:
hTheme | is the SUHANDLE to the theme to query.
where | is a null-terminated string containing a SQL-like where statement, as can be found in the ShapeUp Query Dialog, to use for matching.
hRecordset | is a pointer to an SUHANDLE that will receive a handle to a recordset containing the matching shapes.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetShapesByQuery, FNTYPE_THEME_GETSHAPESBYQUERY, Theme_GetShape()

SURESULT Theme_GetShapesInRect | ( | SUHANDLE | hTheme,
 |  | double | xmin,
 |  | double | ymin,
 |  | double | xmax,
 |  | double | ymax,
 |  | BOOL | bPartInRectOk,
 |  | SUHANDLE * | hRecordset |
 | ) |  |  | [inline]

Gets all shapes from a theme contained in or intersecting a rectangle.

IMPORTANT: Retrieved recordsets must be closed by a call to Recordset_Close().

Parameters:
hTheme | is the SUHANDLE to the theme to query.
xmin | is the west-most bound of the rectangle.
ymin | is the south-most bound of the rectangle.
xmax | is the east-most bound of the rectangle.
ymax | is the north-most bound of the rectangle.
bPartInRectOk | if true, this function returns a recordset containing all shapes that intersects the specified rectangle. If false, it will return all shapes that are contained in the rectangle.
hRecordset | is a pointer to an SUHANDLE that will receive a handle to a recordset containing the resulting shapes.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetShapesInRect, FNTYPE_THEME_GETSHAPESINRECT, Theme_GetShape()

SURESULT Theme_GetShapeType | ( | SUHANDLE | hTheme,
 |  | ShapeType * | type |
 | ) |  |  | [inline]

Retrieves the type of shapes this theme contains.

Parameters:
hTheme | is the SUHANDLE to the theme to query.
type | is a pointer to a ShapeType that will receive the theme's shape type.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetShapeType, FNTYPE_THEME_GETSHAPETYPE,

SURESULT Theme_InvertSelection ( SUHANDLE hTheme ) [inline]

Inverts the current selection in a theme.

Parameters:
hTheme is the SUHANDLE to the theme.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_THEME_INVERTSELECTION

SURESULT Theme_IsReadOnly | ( | SUHANDLE | hTheme,
 |  | BOOL * | readonly |
 | ) |  |  | [inline]

Determines if a theme is read-only.

Parameters:
hTheme | is the SUHANDLE to the ShapeUp theme to query.
readonly | is a pointer to a BOOL that will receive the read-only state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBOOL, FNTYPE_THEME_ISREADONLY

SURESULT Theme_IsSelected | ( | SUHANDLE | hTheme,
 |  | BOOL * | selected |
 | ) |  |  | [inline]

Determines if a theme is selected.

Parameters:
hTheme | is the SUHANDLE to the ShapeUp theme to query.
selected | is a pointer to a BOOL that will receive the selected state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBOOL, FNTYPE_THEME_ISSELECTED

SURESULT Theme_IsVisible | ( | SUHANDLE | hTheme,
 |  | BOOL * | visible |
 | ) |  |  | [inline]

Determines if a theme is visible.

Parameters:
hTheme | is the SUHANDLE to the ShapeUp theme to query.
visible | is a pointer to a BOOL that will receive the visibility state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBOOL, FNTYPE_THEME_ISVISIBLE

SURESULT Theme_LookupWorkspace | ( | SUHANDLE | hTheme,
 |  | SUHANDLE * | hWorkspace |
 | ) |  |  | [inline]

Retrievs the workspace containing the ShapeUp theme.

Parameters:
hTheme | is the SUHANDLE to a theme.
hWorkspace | is a pointer to an SUHANDLE that will receive a handle to the hosting workspace.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHandle, FNTYPE_THEME_LOOKUPWORKSPACE

SURESULT Theme_RecalcBounds ( SUHANDLE hTheme ) [inline]

Recalculates a themes's bounding box. This function needs to be called after the geometry of a contained object is changed.

Parameters:
hTheme is the SUHANDLE to the ShapeUp theme to update.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_THEME_RECALCBOUNDS

SURESULT Theme_ReplaceShapeData | ( | SUHANDLE | hTheme,
 |  | SUHANDLE | hShape,
 |  | const CShapeRecord * | shapeData |
 | ) |  |  | [inline]

Replaces the geometry of a shape object in a theme with a new geometry.

Parameters:
hTheme | is the SUHANDLE to the ShapeUp theme.
hShape | is a SUHANDLE to the shape object to replace.
shapeData | is a pointer to the new shape object to insert.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGReplaceShapeData, FNTYPE_THEME_REPLACESHAPEDATA

SURESULT Theme_Select | ( | SUHANDLE | hTheme,
 |  | bool | select |
 | ) |  |  | [inline]

Selects a theme.

Parameters:
hTheme | is the SUHANDLE to the theme.
select | is true if selecting and false if deselecting.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_THEME_SELECT

SURESULT Theme_SetAttributeComment | ( | SUHANDLE | hTheme,
 |  | size_t | index,
 |  | const char * | buffer |
 | ) |  |  | [inline]

Sets an attribute's comment.

Parameters:
hTheme | is the SUHANDLE to the theme.
index | is the zero-based index of the attribute.
buffer | is a null-terminated string that contains the new comment. Use NULL to clear the comment.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetTextByIndex, FNTYPE_THEME_SETATTRIBUTECOMMENT

SURESULT Theme_SetComment | ( | SUHANDLE | hTheme,
 |  | const char * | buffer |
 | ) |  |  | [inline]

Sets a theme's comment.

Parameters:
hTheme | is the SUHANDLE to the theme.
buffer | is a null-terminated string that contains the new comment.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetText, FNTYPE_THEME_SETCOMMENT

SURESULT Theme_SetFillColor | ( | SUHANDLE | hTheme,
 |  | COLORREF | clr |
 | ) |  |  | [inline]

Sets a theme's fill color.

Parameters:
hTheme | is the SUHANDLE to the theme.
clr | is a COLORREF value for the new color.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetColor, FNTYPE_THEME_SETFILLCOLOR

SURESULT Theme_SetName | ( | SUHANDLE | hTheme,
 |  | const char * | buffer |
 | ) |  |  | [inline]

Sets the name of a ShapeUp theme.

Parameters:
hTheme | is the SUHANDLE to the theme.
buffer | is a null-terminated string that contains the new name.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetText, FNTYPE_THEME_SETNAME

SURESULT Theme_SetPenColor | ( | SUHANDLE | hTheme,
 |  | COLORREF | clr |
 | ) |  |  | [inline]

Sets a theme's pen color.

Parameters:
hTheme | is the SUHANDLE to the theme.
clr | is a COLORREF value for the new color.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetColor, FNTYPE_THEME_SETPENCOLOR

SURESULT Theme_SetPenStyle | ( | SUHANDLE | hTheme,
 |  | size_t | style |
 | ) |  |  | [inline]

Sets a theme's pen style.

Parameters:
hTheme | is the SUHANDLE to the theme.
style | is a size_t value for the new pen style.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetUnsigned, PENSTYLE, FNTYPE_THEME_SETPENSTYLE

SURESULT Theme_SetPenWidth | ( | SUHANDLE | hTheme,
 |  | size_t | width |
 | ) |  |  | [inline]

Sets a theme's pen width.

Parameters:
hTheme | is the SUHANDLE to the theme.
width | is a size_t value for the new pen width.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetUnsigned, FNTYPE_THEME_SETPENWIDTH

SURESULT Theme_SetRasterImage | ( | SUHANDLE | hTheme,
 |  | HBITMAP | hbm,
 |  | double | west,
 |  | double | south,
 |  | double | east,
 |  | double | north,
 |  | const char * | sourceHint |
 | ) |  |  | [inline]

Sets a raster themes image data.

Parameters:
hTheme | is the SUHANDLE to the theme.
hbm | is a handle to a Windows bitmap. ShapeUp will take ownership of the bitmap and destroy it when its no longer needed.
west | is the western boudary of the raster.
south | is the southern boudary of the raster.
east | is the eastern boudary of the raster.
north | is the northern boudary of the raster.
sourceHint | is a description of where the data came from. E.g. if loaded from a file, this could be the file name. This parameter is informational only, and may be NULL. If supplied, it is displayed in the ShapeUp statistical view.
See also:
SUARGSetRasterImage, FNTYPE_THEME_SETRASTERIMAGE

SURESULT Theme_SetSerialData | ( | SUHANDLE | hTheme,
 |  | size_t | byteCount,
 |  | const void * | bytes |
 | ) |  |  | [inline]

Sets data to be serialized with a theme. This function can be called at any time setting new data. However, when this function is called, any old data is discarded and fully replaced with the new.
This data can later be restored from a ShapeUp workspace file when it is loaded, if the plug-in has set up a deserialize hook using the ShapeUp_AddDeserializeHook call.

Parameters:
hTheme | is the SUHANDLE to the theme.
byteCount | is the size of the bytes array.
bytes | is a pointer to a byte sequence containing the data to be serialized.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetSerialData, FNTYPE_WORKSPACE_SETSERIALDATA, ShapeUp_AddDeserializeHook()

SURESULT ToolBar_Create | ( | HINSTANCE | hInstResource,
 |  | LPCTSTR | lpszResourceName,
 |  | const char * | name,
 |  | SUHANDLE * | hToolbar |
 | ) |  |  | [inline]

Creates a new ShapeUp toolbar.

Parameters:
hInstResource | is plug-in (DLL) resource instance from where ShapeUp loads te toolbar resource.
lpszResourceName | is resource identifier of the toolbar to load.
name | is a null terminated string containing the name of the new toolbar. E.g. this name is used in the View | Plug-in Toolbars and should be on the form "<MYNAME> Toolbar".
hToolbar | is a pointer to an SUHANDLE that will receive the toolbar handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGCreateToolBar, FNTYPE_TOOLBAR_CREATE

SURESULT ToolBar_GetButtonCount | ( | SUHANDLE | hToolbar,
 |  | size_t * | count |
 | ) |  |  | [inline]

Retrieves the number of buttons in a ShapeUp toolbar.

Parameters:
hToolbar | is the SUHANDLE to the toolbar to query.
count | is a pointer to size_t that will receive the toolbar button count.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsigned, ToolBar_Create(), FNTYPE_TOOLBAR_GETBUTTONCOUNT

SURESULT ToolBar_IsVisible | ( | SUHANDLE | hToolbar,
 |  | BOOL * | visible |
 | ) |  |  | [inline]

Checks if this toolbar is visible or not.

Parameters:
hToolbar | is the SUHANDLE to the toolbar to query.
visible | is a pointer to BOOL that will receive the toolbar state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBOOL, ToolBar_Create(), FNTYPE_TOOLBAR_ISVISIBLE

SURESULT ToolBar_SetButtonChecked | ( | SUHANDLE | hToolbar,
 |  | UINT | nID,
 |  | BOOL | bChecked |
 | ) |  |  | [inline]

Checkes or unchecks a ShapeUp toolbar button.

Parameters:
hToolbar | is the SUHANDLE to the toolbar containing the button.
nID | is the command ID of the button.
bChecked | is the new checked state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetButtonBOOL, FNTYPE_TOOLBAR_SETBUTTONCHECKED

SURESULT ToolBar_SetButtonEnabled | ( | SUHANDLE | hToolbar,
 |  | UINT | nID,
 |  | BOOL | bEnabled |
 | ) |  |  | [inline]

Enables or disables a ShapeUp toolbar button.

Parameters:
hToolbar | is the SUHANDLE to the toolbar containing the button.
nID | is the command ID of the button.
bEnabled | is the new enabled state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetButtonBOOL, FNTYPE_TOOLBAR_SETBUTTONENABLED

SURESULT Workspace_AddDataPage | ( | SUHANDLE | hWorkspace,
 |  | const char * | name,
 |  | HWND * | page,
 |  | SUHANDLE * | hDataPage |
 | ) |  |  | [inline]

Creates a new custom data page for a workspace. A data page is an addition to the four native data pages supplied by ShapeUp: Attributes, Coordinates, Statistics and Bookmarks.
A custom data page can be used to display any windows control as a child.

Parameters:
hWorkspace | is the SUHANDLE to the workspace.
name | is the name of the new data page. This name is displayed in the view menu as well as in the Quick Tabs.
page | is a pointer to a windows handle to be used as the parent of the new the new child control. This parameter might be NULL.
hDataPage | is a SUHANDLE that will identify the created data page. This parameter might be NULL.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGAddDataPage, FNTYPE_WORKSPACE_ADDDATAPAGE

SURESULT Workspace_BrowseTheme | ( | SUHANDLE | hWorkspace,
 |  | const char * | title,
 |  | SUHANDLE * | hTheme |
 | ) |  |  | [inline]

Opens ShapeUp's theme selection dialog and lets the user select a theme.

Parameters:
hWorkspace | is the SUHANDLE to the workspace containing the themes.
title | is a null-terminated string containing the title for the dialog. Might be NULL if default title "Select Theme" is ok.
hTheme | is a pointer to an SUHANDLE that will receive the theme handle. This handle will be NULL if the user presses cancel.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGBrowseTheme, FNTYPE_WORKSPACE_BROWSETHEME

SURESULT Workspace_ClearSelection ( SUHANDLE hWorkspace ) [inline]

Deselects all themes in a workspace.

Parameters:
hWorkspace is the SUHANDLE to the workspace.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_WORKSPACE_CLEARSELECTION

SURESULT Workspace_CreateNewTheme | ( | SUHANDLE | hWorkspace,
 |  | ShapeType | type,
 |  | const char * | name,
 |  | SUHANDLE * | hTheme |
 | ) |  |  | [inline]

Creates a new theme of specified sort in a ShapeUp workspace.

Parameters:
hWorkspace | is a SUHANDLE to the workspace to add the new theme in.
type | is the type of objects this theme should contain.
name | is a null-terminated string used as the themes initial name. This parameter might be NULL to get default naming.
hTheme | is a pointer to an SUHANDLE that will receive a handle to the new theme.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGCreateNewTheme, FNTYPE_WORKSPACE_CREATENEWTHEME

SURESULT Workspace_CreateNewThemeFromSelection | ( | SUHANDLE | hWorkspace,
 |  | SUHANDLE | hSourceTheme,
 |  | const char * | name,
 |  | SUHANDLE * | hTheme |
 | ) |  |  | [inline]

Creates a new theme based on the selection in a source theme in this workspace.

Parameters:
hWorkspace | is a SUHANDLE to the workspace to add the new theme in.
hSourceTheme | is the theme containing selected shapes to be copied.
name | is a null-terminated string used as the themes initial name. This parameter might be NULL to get default naming.
hTheme | is a pointer to an SUHANDLE that will receive a handle to the new theme.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGCreateNewThemeFromSelection, FNTYPE_WORKSPACE_CREATENEWTHEMEFROMSELECTION

SURESULT Workspace_GetBounds | ( | SUHANDLE | hWorkspace,
 |  | double * | xmin,
 |  | double * | ymin,
 |  | double * | xmax,
 |  | double * | ymax |
 | ) |  |  | [inline]

Gets the workspace's bounding box.

Parameters:
hWorkspace | is the SUHANDLE to the workspace to query.
xmin | is a pointer to a double that will receive the west-most value. This parameter might be NULL if it's of no interest.
ymin | is a pointer to a double that will receive the south-most value. This parameter might be NULL if it's of no interest.
xmax | is a pointer to a double that will receive the east-most value. This parameter might be NULL if it's of no interest.
ymax | is a pointer to a double that will receive the north-most value. This parameter might be NULL if it's of no interest.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBounds, FNTYPE_WORKSPACE_GETBOUNDS

SURESULT Workspace_GetComment | ( | SUHANDLE | hWorkspace,
 |  | char * | buffer,
 |  | size_t * | bufferSize |
 | ) |  |  | [inline]

Retrieves a workspace's comment.

This function can be used in a two step process. First it's used to query ShapeUp for the buffer size needed to fit the comment, then the actual comment can be fetched.

To query for the buffer size, set buffer to NULL, and let bufferSize point to a size_t that will receive the value. The size returned includes space for the null termination of the string. Allocate a proper character buffer and call the function again with this buffer and the returned bufferSize.

Parameters:
hWorkspace | is the SUHANDLE to the workspace to query.
buffer | is a pointer to a character buffer that will receive the text.
bufferSize | is a pointer to a size_t indicates the size of the buffer.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetText, FNTYPE_WORKSPACE_GETCOMMENT

SURESULT Workspace_GetMapWindow | ( | SUHANDLE | hWorkspace,
 |  | SUHANDLE * | hMap |
 | ) |  |  | [inline]

Retrieves the ShapeUp map window associated with a workspace.

Parameters:
hWorkspace | is the workspace to query.
hMap | is a pointer to an SUHANDLE that will receive the map window handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHandle, FNTYPE_WORKSPACE_GETMAPWINDOW

SURESULT Workspace_GetSelectedTheme | ( | SUHANDLE | hWorkspace,
 |  | SUHANDLE * | hTheme |
 | ) |  |  | [inline]

Retrieves a single selected theme in a ShapeUp workspace. If there is exactly one selected theme, this theme will be retrieved, otherwise the function returns a NULL hTheme handle.

This function is a shortcut to check for and get a single selected theme supplied since many operations needs just one selected theme. To get all selected themes use Workspace_GetSelectedThemes().

Parameters:
hWorkspace | is the SUHANDLE to the workspace to query.
hTheme | is a pointer to an SUHANDLE that will receive the theme handle, or it will receive a NULL handle if there is more or less than one (1) selected theme.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHandle, Workspace_GetSelectedThemes(), FNTYPE_WORKSPACE_GETSELECTEDTHEME

SURESULT Workspace_GetSelectedThemes | ( | SUHANDLE | hWorkspace,
 |  | SUHANDLE * | hRecordset |
 | ) |  |  | [inline]

Retrieves all selected themes in a ShapeUp workspace. The result is in the form of a ShapeUp recordset containing ShapeUp theme handles.

Parameters:
hWorkspace | is the SUHANDLE to the workspace to query.
hRecordset | is a pointer to an SUHANDLE that will receive the recordset handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHandle, Workspace_GetSelectedTheme(), FNTYPE_WORKSPACE_GETSELECTEDTHEMES

SURESULT Workspace_GetSelectionCount | ( | SUHANDLE | hWorkspace,
 |  | size_t * | count |
 | ) |  |  | [inline]

Retrieves the number of selected themes in a ShapeUp workspace.

Parameters:
hWorkspace | is the SUHANDLE to the workspace to query.
count | is a pointer to size_t that will receive the selected theme count.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsigned, FNTYPE_WORKSPACE_GETSELECTIONCOUNT

SURESULT Workspace_GetTheme | ( | SUHANDLE | hWorkspace,
 |  | size_t | nIndex,
 |  | SUHANDLE * | hTheme |
 | ) |  |  | [inline]

Retrieves a theme at a specified index in a ShapeUp workspace.

Parameters:
hWorkspace | is the SUHANDLE to the workspace to query.
nIndex | is zero-based index for the theme.
hTheme | is a pointer to an SUHANDLE that will receive the theme handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetHandleByIndex, FNTYPE_WORKSPACE_GETTHEMECOUNT

SURESULT Workspace_GetThemeCount | ( | SUHANDLE | hWorkspace,
 |  | size_t * | count |
 | ) |  |  | [inline]

Retrieves the number of themes in a ShapeUp workspace.

Parameters:
hWorkspace | is the SUHANDLE to the workspace to query.
count | is a pointer to size_t that will receive the theme count.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetUnsigned, FNTYPE_WORKSPACE_GETTHEMECOUNT

SURESULT Workspace_IsActive | ( | SUHANDLE | hWorkspace,
 |  | BOOL * | active |
 | ) |  |  | [inline]

Retrieves the active state of a ShapeUp workspace. A ShapeUp workspace is considered active if it has the input focus.

Parameters:
hWorkspace | is the SUHANDLE to the workspace to query.
active | is a pointer to a BOOL that will receive the active state.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGGetBOOL, FNTYPE_WORKSPACE_ISACTIVE

SURESULT Workspace_LoadJavaScript | ( | SUHANDLE | hWorkspace,
 |  | const char * | file,
 |  | SUHANDLE * | hJavaScript |
 | ) |  |  | [inline]

Loads a JavaScript.

Parameters:
hWorkspace | is the SUHANDLE to the workspace that will become the target of the JavaScript.
file | is a null-terminated string containing the file name of the JavaScript.
hJavaScript | is a pointer to an SUHANDLE that will receive the JavaScript handle.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGLoadJavaScript, FNTYPE_WORKSPACE_LOADJAVASCRIPT, JavaScript_Run(), JavaScript_CallFunction(), JavaScript_Close()

SURESULT Workspace_Log | ( | SUHANDLE | hWorkspace,
 |  | const char * | line |
 | ) |  |  | [inline]

Writes a text to a workspace's console window. It does not end the text with a new line. If a new line is required the character '\n' should be supplied in the text.

Parameters:
hWorkspace | is the SUHANDLE to the workspace that contains the console.
line | is a null-terminated string to be sent to the console window.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGLog, FNTYPE_WORKSPACE_LOG

SURESULT Workspace_Refresh ( SUHANDLE hWorkspace ) [inline]

Forces the entire workspace to update its user interface components, such as the legend view, map view and data view.

Parameters:
hWorkspace is the SUHANDLE to the workspace to refresh.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
FNTYPE_WORKSPACE_REFRESH

SURESULT Workspace_RemoveTheme | ( | SUHANDLE | hWorkspace,
 |  | SUHANDLE | hTheme,
 |  | BOOL * | ok |
 | ) |  |  | [inline]

Removes a theme from a workspace.

Parameters:
hWorkspace | is the SUHANDLE to the workspace.
hTheme | is the SUHANDLE to the theme to remove.
ok | is a pointer to a BOOL that will receive the success of the operation.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGRemoveTheme, FNTYPE_WORKSPACE_REMOVETHEME

SURESULT Workspace_SetComment | ( | SUHANDLE | hWorkspace,
 |  | const char * | buffer |
 | ) |  |  | [inline]

Sets a workspace's comment.

Parameters:
hWorkspace | is the SUHANDLE to the workspace.
buffer | is a null-terminated string that contains the new comment.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetText, FNTYPE_WORKSPACE_SETCOMMENT

SURESULT Workspace_SetSerialData | ( | SUHANDLE | hWorkspace,
 |  | size_t | byteCount,
 |  | const void * | bytes |
 | ) |  |  | [inline]

Sets data to be serialized with a workspace. This function can be called at any time setting new data. However, when this function is called, any old data is discarded and fully replaced with the new.
This data can later be restored from a ShapeUp workspace file when it is loaded, if the plug-in has set up a deserialize hook using the ShapeUp_AddDeserializeHook call.

Parameters:
hWorkspace | is the SUHANDLE to the workspace.
byteCount | is the size of the bytes array.
bytes | is a pointer to a byte sequence containing the data to be serialized.
Returns:
This function returns the SURESULT value that ShapeUp returns from the SUExport::ShapeUp_Call() function.
See also:
SUARGSetSerialData, FNTYPE_WORKSPACE_SETSERIALDATA, ShapeUp_AddDeserializeHook()

Variable Documentation

SUExport suapi

Examples:
example_loadergpi.cpp, example_sudatapage.cpp, and example_sutoolbar.cpp.

Generated on Thu Apr 15 10:55:33 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Examples

ShapeUp API Examples

Here is a list of all examples:
  • example_hooks.cpp
  • example_javascriptable.cpp
  • example_jscallfunction.js
  • example_loadergpi.cpp
  • example_sudatapage.cpp
  • example_sutoolbar.cpp
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: example_hooks.cpp

example_hooks.cpp

This is an example of how to use the hooks in a GPI to get notifications of ShapeUp events.

00001 #include <ShapeUpAPI.h>
00002
00003 SURESULT __cdecl fnInit(SUExport *pExport)
00004 {
00005     ...
00006
00007     // Set-up our hook callback
00008     pExport->import.pfnHook = HookFunc;
00009
00010     // In this example we send a zero as user data to the various
00011     // ShapeUp_AddXxxHook() functions. You can specify any value,
00012     // and this value can later be found when the hook function
00013     // is called.
00014
00015     // We want notification when the user presses our toolbar buttons
00016     ShapeUp_AddToolBarButtonHook(0);
00017
00018     // The idle hook is used to set the state of toolbar buttons (disabled/checked/...)
00019     ShapeUp_AddIdleHook(0);
00020
00021     // We want notification when the user presses the left mouse button in the map window
00022     ShapeUp_AddLButtonDownHook(0);
00023
00024     // We want notification when the user removes a layer from a workspace
00025     ShapeUp_AddRemoveLayerHook(0);
00026
00027     ...
00028 }
00029
00030 // ShapeUp will call this function when an event occurs
00031 SURESULT __cdecl HookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args)
00032 {
00033     AFX_MANAGE_STATE(AfxGetStaticModuleState());
00034
00035     // args->userData contains the value specified when adding the hook
00036     // The args pointer is interpreted differently for different hook types.
00037     // For more info check the various hook type values.
00038
00039     switch (hookType)
00040     {
00041     case HOOKTYPE_TOOLBARBUTTON:
00042         return OnToolBarButton(hWorkspace, (SUToolBarButtonHookData*) args);
00043     case HOOKTYPE_IDLE:
00044         return OnIdle(hWorkspace, args);
00045     case HOOKTYPE_LBUTTONDOWN:
00046         return OnLButtonDown(hWorkspace, (SUMouseHookData*) args);
00047     case HOOKTYPE_PREREMOVETHEME:
00048         return OnRemoveTheme(hWorkspace, (SUPreRemoveThemeHookData*) args);
00049     case ...:
00050         break;
00051     default:
00052         break;
00053     }
00054
00055     return SURESULT_OK;
00056 }
Generated on Thu Apr 15 10:55:32 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: example_javascriptable.cpp

example_javascriptable.cpp

This is an example on how to enable a GPI for scripting.

00001 #include <ShapeUpAPI.h>
00002
00003 SURESULT OnJSInvoke(SUHANDLE hWorkspace, SUJavaScriptInvokeHookData *args);
00004
00005 // Each GPI needs its own GUID
00006 const GUID* __cdecl fnGUID()
00007 {
00008     // {9A6C4339-51D3-4c13-9B63-B0016F74FCE8}
00009     static const GUID guid =
00010         { 0x9a6c4339, 0x51d3, 0x4c13, { 0x9b, 0x63, 0xb0, 0x1, 0x6f, 0x74, 0xfc, 0xe8 } };
00011     return &guid;
00012 }
00013
00014 SURESULT __cdecl fnInit(SUExport *pExport)
00015 {
00016     ...
00017
00018     // Set-up our hook callback
00019     pExport->import.pfnHook = HookFunc;
00020
00021     // In this example we send a zero as user data to the various
00022     // ShapeUp_AddXxxHook() functions. You can specify any value,
00023     // and this value can later be found when the hook function
00024     // is called.
00025
00026     // If someone invokes us using JavaScript we want to get notified
00027     const char* properties[] =
00028     {
00029         "color",
00030         NULL
00031     };
00032     const char* methods[] =
00033     {
00034         "getStringValue",
00035         NULL
00036     };
00037     ShapeUp_AddJavaScriptInvokeHook(0, properties, methods);
00038
00039     ...
00040 }
00041
00042 // ShapeUp will call this function when an event occurs
00043 SURESULT __cdecl HookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args)
00044 {
00045     ...
00046
00047     switch (hookType)
00048     {
00049     case HOOKTYPE_JAVASCRIPTINVOKE:
00050         return OnJSInvoke(hWorkspace, (SUJavaScriptInvokeHookData*)args);
00051     ...
00052     default:
00053         break;
00054     }
00055
00056     return SURESULT_OK;
00057 }
00058
00059 // If a JavaScript calls this function like this
00060 //    var guid = '{9A6C4339-51D3-4c13-9B63-B0016F74FCE8}';
00061 //    var plugin = new Plugin(guid);
00062 //    plugin.color = new Color(255, 0, 255);
00063 //    var aString = plugin.getStringValue()[0];
00064 //    // functions always returns an Array -^
00065 SURESULT OnJSInvoke(SUHANDLE hWorkspace, SUJavaScriptInvokeHookData *args)
00066 {
00067     // The property color
00068     extern COLORREF myColor;
00069
00070     if (0 == strcmp("color", args->name)) // Defined property
00071     {
00072         if (args->argc >= 1)
00073         {
00074             // Set value
00075             if (args->args[0].type != DT_COLOR)
00076                 return SURESULT_E_ILLEGALPARAM;
00077             myColor = args->args[0].colorVal;
00078         }
00079         else
00080         {
00081             // Get value
00082             args->retc = 1;
00083             ShapeUp_Allocate(sizeof(SUJavaScriptArgument) * args->retc, (void**)&args->rets);
00084
00085             args->rets[0].type = DT_COLOR;
00086             args->rets[0].colorVal = myColor;
00087         }
00088     }
00089     else if (0 == strcmp("getStringValue", args->name)) // Defined function
00090     {
00091         // Set-up return value
00092         args->retc = 1;
00093         ShapeUp_Allocate(sizeof(SUJavaScriptArgument) * args->retc, (void**)&args->rets);
00094
00095         args->rets[0].type = DT_STRING;
00096         args->rets[0].stringVal = ShapeUp_DuplicateString("A string");
00097     }
00098
00099     return SURESULT_OK;
00100 }
Generated on Thu Apr 15 10:55:32 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: example_jscallfunction.js

example_jscallfunction.js

This is an example of a JavaScript in ShapeUp that is intended to be run by a GPI plugin using the SUJavaScript::CallFunction() method with 'doSomething' as argument. Note that since a call to init() is made at file level, the init() function will be called the first time SUJavaScript::CallFunction() is called. To avoid this behaviour, remove the call to init at file level at line 16.

00001 var myState1 = 0;
00002 var myLayer = null;
00003
00004 function doSomething()
00005 {
00006     myState++;
00007 }
00008
00009 function init()
00010 {
00011     myLayer = workspace.addNewLayer('Point');
00012     workspace.refresh();
00013 }
00014
00015 // call to init() on file level, see SUJavaScript
00016 init();
Generated on Thu Apr 15 10:55:32 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: example_loadergpi.cpp

example_loadergpi.cpp

This is an example on how to create a loader plug-in using the new GPI object model.

00001 #include <ShapeUpAPI.h>
00002
00003 SURESULT __cdecl HookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args);
00004
00005 // Every plug-in needs an instance of SUExport called suapi
00006 SUExport suapi;
00007
00008 size_t __cdecl fnVersion()
00009 {
00010     return SHAPEUP_API_VERSION;
00011 }
00012
00013 const GUID* __cdecl fnGUID()
00014 {
00015     // CREATE YOUR OWN GUID !!
00016     // {97F4EA41-7D7E-42c1-B555-2D4C86C912A7}
00017     static const GUID guid =
00018         { 0x97f4ea41, 0x7d7e, 0x42c1, { 0xb5, 0x55, 0x2d, 0x4c, 0x86, 0xc9, 0x12, 0xa7 } };
00019     return &guid;
00020 }
00021
00022 SURESULT __cdecl fnInit(SUExport *pExport)
00023 {
00024     AFX_MANAGE_STATE(AfxGetStaticModuleState());
00025
00026     pExport->import.pszName = "Test of GPI and ShapeUp API";
00027     pExport->import.pszDescription = "Test of GPI and ShapeUp API\nGPI Test";
00028     pExport->import.pszInfo = "Copyright (c) 2007";
00029     pExport->import.pszPluginVersion = "1.00";
00030
00031     // Now keep the entire struct which is the actual ShapeUp API
00032     // (we need the function pointers later)
00033     ::memcpy(&suapi, pExport, sizeof(SUExport));
00034
00035     // Set-up our hook callback
00036     pExport->import.pfnHook = HookFunc;
00037
00038     // Add our load layer menu item
00039     ShapeUp_AddLoadLayerHook(0, "Example Loader", "A random point loader", NULL, NULL);
00040
00041     return SURESULT_OK;
00042 }
00043
00044 // ShapeUp will call this function when an event occurs
00045 SURESULT __cdecl HookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args)
00046 {
00047     AFX_MANAGE_STATE(AfxGetStaticModuleState());
00048
00049     switch (hookType)
00050     {
00051     case HOOKTYPE_MENUITEM:
00052         // Only add stuff if we have an active workspace
00053         if (hWorkspace != NULL)
00054         {
00055             // args is really a SUMenuItemHookData*
00056
00057             // TODO: Load data here
00058
00059             SUWorkspace workspace(hWorkspace);
00060             SUTheme theme = workspace.CreateNewTheme(Shape_Point, "New Point layer");
00061
00062             theme.AddAttribute(ATTRIBUTETYPE_STRING, "ObjectName", NULL);
00063
00064             for (int i = 0; i < numberOfPoints; ++i)
00065             {
00066                 SUShape shape = theme.AddShape(shapeData[i]);
00067                 shape.SetAttribute(theme, 0, "A name");
00068             }
00069         }
00070         return SURESULT_OK;
00071     default:
00072         break;
00073     }
00074
00075     return SURESULT_OK;
00076 }
Generated on Thu Apr 15 10:55:32 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: example_sudatapage.cpp

example_sudatapage.cpp

This is an example of how to add custom data pages in ShapeUp. In this particular example, a page containing a singe tree control is created and populated with some dummy data.

00001 #include <ShapeUpAPI.h>
00002 #include "./resource.h"
00003
00004 SURESULT __cdecl HookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args);
00005 SURESULT __cdecl OnWorkspaceReady(SUHANDLE hWorkspace);
00006
00007 // Every plug-in needs an instance of SUExport called suapi
00008 SUExport suapi;
00009
00010 size_t __cdecl fnVersion()
00011 {
00012     return SHAPEUP_API_VERSION;
00013 }
00014
00015 const GUID* __cdecl fnGUID()
00016 {
00017     // CREATE YOUR OWN GUID !!
00018     // {97F4EA41-7D7E-42c1-B555-2D4C86C912A7}
00019     static const GUID guid =
00020         { 0x97f4ea41, 0x7d7e, 0x42c1, { 0xb5, 0x55, 0x2d, 0x4c, 0x86, 0xc9, 0x12, 0xa7 } };
00021     return &guid;
00022 }
00023
00024 SURESULT __cdecl fnInit(SUExport *pExport)
00025 {
00026     AFX_MANAGE_STATE(AfxGetStaticModuleState());
00027
00028     pExport->import.pszName = "Test of GPI and ShapeUp API";
00029     pExport->import.pszDescription = "Test of GPI and ShapeUp API\nGPI Test";
00030     pExport->import.pszInfo = "Copyright (c) 2007";
00031     pExport->import.pszPluginVersion = "1.00";
00032
00033     // Now keep the entire struct which is the actual ShapeUp API
00034     // (we need the function pointers later)
00035     ::memcpy(&suapi, pExport, sizeof(SUExport));
00036
00037     // Set-up our hook callback
00038     pExport->import.pfnHook = HookFunc;
00039
00040     // We want to get notified when a workspace has been initialized
00041     // We cannot add a data page before this event has occurred!
00042     ShapeUp_AddWorkspaceReadyHook(0);
00043
00044     return SURESULT_OK;
00045 }
00046
00047 // ShapeUp will call this function when an event occurs
00048 SURESULT __cdecl HookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args)
00049 {
00050     AFX_MANAGE_STATE(AfxGetStaticModuleState());
00051
00052     switch (hookType)
00053     {
00054     case HOOKTYPE_WORKSPACEREADY:
00055         // At this point, it's ok to add a data page!
00056         return OnWorkspaceReady(hWorkspace);
00057     default:
00058         break;
00059     }
00060
00061     return SURESULT_OK;
00062 }
00063
00064 SURESULT __cdecl OnWorkspaceReady(SUHANDLE hWorkspace)
00065 {
00066     try
00067     {
00068         SUWorkspace workspace(hWorkspace);
00069         SUDataPage page = workspace.AddDataPage("Tree data");
00070
00071         // Create a tree view control
00072         VERIFY(AfxDeferRegisterClass(AFX_WNDCOMMCTL_TREEVIEW_REG));
00073
00074         // The style to be. WS_CHILD is important.
00075         DWORD dwStyle = WS_VISIBLE | WS_TABSTOP | WS_CHILD
00076                     | TVS_HASBUTTONS | TVS_LINESATROOT | TVS_HASLINES
00077                     | TVS_DISABLEDRAGDROP;
00078
00079         // Ask the data page for its windows handle to use as the new
00080         // controls parent
00081         HWND hwndParent = page.GetHWND();
00082
00083         // Ctrl id. Any id is good.
00084         UINT nID = 42001;
00085
00086         // Create the control
00087         HWND hWnd = ::CreateWindowEx(0, WC_TREEVIEW,
00088             NULL, dwStyle, 0, 0, 100, 100,
00089             hwndParent, (HMENU)(UINT_PTR)nID, AfxGetInstanceHandle(), NULL);
00090
00091         if (hWnd != NULL)
00092         {
00093             // Populate the control
00094             TV_INSERTSTRUCT is;
00095             is.hInsertAfter = NULL;
00096             is.hParent = NULL;
00097             is.item.mask = TVIF_TEXT;
00098             is.item.pszText = "First line";
00099
00100             HTREEITEM hRoot = TreeView_InsertItem(hWnd, &is);
00101             is.hParent = hRoot;
00102             is.item.pszText = "Another line";
00103             for (int i = 0; i < 400; ++i)
00104                 TreeView_InsertItem(hWnd, &is);
00105         }
00106         else
00107             page.Remove();
00108     }
00109     catch (SUException &ex)
00110     {
00111         AfxMessageBox(ex.GetErrorDesc().c_str(), 0, 0);
00112     }
00113
00114     return SURESULT_OK;
00115 }
Generated on Thu Apr 15 10:55:33 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: example_sutoolbar.cpp

example_sutoolbar.cpp

This is an example of how to use the SUToolBar class. It assumes there is a toolbar resource named IDR_TOOLBAR, with two buttons, ID_LOAD_TBBUTTON and ID_SAVE_TBBUTTON.

00001 #include <ShapeUpAPI.h>
00002 #include "./resource.h"
00003
00004 SURESULT __cdecl HookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args);
00005 SURESULT __cdecl OnToolBarButton(SUHANDLE hWorkspace, SUToolBarButtonHookData* args);
00006 SURESULT __cdecl OnIdle(SUHANDLE hWorkspace, SUHookData *args);
00007
00008 // Our toolbar
00009 SUToolBar toolbar;
00010
00011 // Every plug-in needs an instance of SUExport called suapi
00012 SUExport suapi;
00013
00014 size_t __cdecl fnVersion()
00015 {
00016     return SHAPEUP_API_VERSION;
00017 }
00018
00019 const GUID* __cdecl fnGUID()
00020 {
00021     // CREATE YOUR OWN GUID !!
00022     // {97F4EA41-7D7E-42c1-B555-2D4C86C912A7}
00023     static const GUID guid =
00024         { 0x97f4ea41, 0x7d7e, 0x42c1, { 0xb5, 0x55, 0x2d, 0x4c, 0x86, 0xc9, 0x12, 0xa7 } };
00025     return &guid;
00026 }
00027
00028 SURESULT __cdecl fnInit(SUExport *pExport)
00029 {
00030     AFX_MANAGE_STATE(AfxGetStaticModuleState());
00031
00032     pExport->import.pszName = "Test of GPI and ShapeUp API";
00033     pExport->import.pszDescription = "Test of GPI and ShapeUp API\nGPI Test";
00034     pExport->import.pszInfo = "Copyright (c) 2007";
00035     pExport->import.pszPluginVersion = "1.00";
00036
00037     // Now keep the entire struct which is the actual ShapeUp API
00038     // (we need the function pointers later)
00039     ::memcpy(&suapi, pExport, sizeof(SUExport));
00040
00041     // Set-up our hook callback
00042     pExport->import.pfnHook = HookFunc;
00043
00044     // We want to get notified when the user presses our toolbar buttons
00045     ShapeUp_AddToolBarButtonHook(0);
00046     // The idle hook is used to set the state of toolbar buttons (disabled/checked/...)
00047     ShapeUp_AddIdleHook(0);
00048
00049     // Create our toolbar
00050     toolbar.Create(AfxGetInstanceHandle(), IDR_TOOLBAR, "Test of GPI Toolbar");
00051
00052     return SURESULT_OK;
00053 }
00054
00055 // ShapeUp will call this function when an event occurs
00056 SURESULT __cdecl HookFunc(SUHANDLE hWorkspace, int hookType, SUHookData *args)
00057 {
00058     AFX_MANAGE_STATE(AfxGetStaticModuleState());
00059
00060     switch (hookType)
00061     {
00062     case HOOKTYPE_TOOLBARBUTTON:
00063         return OnToolBarButton(hWorkspace, (SUToolBarButtonHookData*) args);
00064     case HOOKTYPE_IDLE:
00065         return OnIdle(hWorkspace, args);
00066     default:
00067         break;
00068     }
00069
00070     return SURESULT_OK;
00071 }
00072
00073 SURESULT __cdecl OnToolBarButton(SUHANDLE hWorkspace, SUToolBarButtonHookData* args)
00074 {
00075     try
00076     {
00077         switch (args->nCommandID)
00078         {
00079         case ID_LOAD_TBBUTTON:
00080             {
00081                 CFileDialog dlg(TRUE);
00082                 if (dlg.DoModal() == IDOK)
00083                 {
00084                 }
00085             }
00086             break;
00087         case ID_SAVE_TBBUTTON:
00088             {
00089                 CFileDialog dlg(FALSE);
00090                 if (dlg.DoModal() == IDOK)
00091                 {
00092                 }
00093             }
00094             break;
00095         default:
00096             break;
00097         }
00098     }
00099     catch (SUException &ex)
00100     {
00101         AfxMessageBox(ex.GetErrorDesc().c_str(), 0, 0);
00102     }
00103
00104     return SURESULT_OK;
00105 }
00106
00107
00108 SURESULT __cdecl OnIdle(SUHANDLE hWorkspace, SUHookData *args)
00109 {
00110     try
00111     {
00112         if (hWorkspace != NULL)
00113         {
00114             SUWorkspace workspace(hWorkspace);
00115
00116             bool bChecked = /* some condition */;
00117             bool bEnabled = /* some condition */;
00118
00119             toolbar.SetButtonChecked(ID_SAVE_TBBUTTON, bChecked);
00120
00121             toolbar.SetButtonEnabled(ID_LOAD_TBBUTTON, bEnabled);
00122             toolbar.SetButtonEnabled(ID_SAVE_TBBUTTON, bEnabled);
00123         }
00124         else
00125         {
00126             // If there's no active workspace, we disable the buttons
00127             toolbar.SetButtonEnabled(ID_LOAD_TBBUTTON, false);
00128             toolbar.SetButtonEnabled(ID_SAVE_TBBUTTON, false);
00129         }
00130     }
00131     catch (SUException &/*ex*/)
00132     {
00133         // Do NOT open any message boxes from here
00134     }
00135
00136     return SURESULT_OK;
00137 }
Generated on Thu Apr 15 10:55:33 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- _ -

  • __FNTYPE_COUNT__ : ShapeUpAPI.h
  • __FNTYPE_NIL__ : ShapeUpAPI.h
  • __HOOKTYPE_COUNT__ : ShapeUpAPI.h
  • __HOOKTYPE_NIL__ : ShapeUpAPI.h
  • __MAPSTATE_COUNT__ : ShapeUpAPI.h
  • __MAPSTATE_NIL__ : ShapeUpAPI.h
  • __MENUITEMTYPE_COUNT__ : ShapeUpAPI.h
  • __MENUITEMTYPE_NIL__ : ShapeUpAPI.h
  • __PENSTYLE_COUNT__ : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Page Index

ShapeUp API Related Pages

Here is a list of all related documentation pages:
  • Todo List
Generated on Thu Apr 15 10:55:40 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Todo List

Todo List

Member SUJavaScript::CallFunction (const char *func_name)
There is currently no support for passing arguments to the function back and forth.

Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUDataPage Member List

This is the complete list of members for SUDataPage, including all inherited members.

_h | SUObject | [protected]
GetHWND() | SUDataPage | [inline]
IsValid() const | SUObject | [inline, virtual]
operator SUHANDLE() | SUObject | [inline]
Remove() | SUDataPage | [inline]
SUDataPage() | SUDataPage | [inline]
SUDataPage(SUHANDLE hDataPage) | SUDataPage | [inline]
SUObject() | SUObject | [inline]
SUObject(SUHANDLE h) | SUObject | [inline]
~SUObject() | SUObject | [inline, virtual]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUException Member List

This is the complete list of members for SUException, including all inherited members.

_res | SUException | [protected]
GetErrorCode() const | SUException | [inline]
GetErrorDesc() const | SUException | [inline]
SUException(SURESULT res) | SUException | [inline]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUJavaScript Member List

This is the complete list of members for SUJavaScript, including all inherited members.

_h | SUObject | [protected]
CallFunction(const char *func_name) | SUJavaScript | [inline]
Close() | SUJavaScript | [inline]
IsValid() const | SUObject | [inline, virtual]
operator SUHANDLE() | SUObject | [inline]
Run() | SUJavaScript | [inline]
SUJavaScript() | SUJavaScript | [inline]
SUJavaScript(SUHANDLE hJavaScript) | SUJavaScript | [inline]
SUObject() | SUObject | [inline]
SUObject(SUHANDLE h) | SUObject | [inline]
~SUObject() | SUObject | [inline, virtual]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUMap Member List

This is the complete list of members for SUMap, including all inherited members.

_h | SUObject | [protected]
CenterMap(const SUPointf &pt) | SUMap | [inline]
CenterMap(double x, double y) | SUMap | [inline]
DPtoGP(const SUPoint &p, SUPointf &pt) | SUMap | [inline]
Draw(HDC hdc, const SUSize &imagesize, const SUPointf &center, double geoWidth=0., double geoHeight=0.) | SUMap | [inline]
GetBounds(SURectf &r) | SUMap | [inline]
GetHWND() | SUMap | [inline]
GetInteractionState() | SUMap | [inline]
GetViewSize(SUSize &s) | SUMap | [inline]
GPtoDP(const SUPointf &p, SUPoint &pt) | SUMap | [inline]
IsValid() const | SUObject | [inline, virtual]
operator SUHANDLE() | SUObject | [inline]
Repaint(bool bFullRedraw) | SUMap | [inline]
SetInteractionState(unsigned long state) | SUMap | [inline]
SUMap(SUHANDLE hMap) | SUMap | [inline]
SUObject() | SUObject | [inline]
SUObject(SUHANDLE h) | SUObject | [inline]
Zoom(double factor) | SUMap | [inline]
ZoomToExtent(SUHANDLE hTheme) | SUMap | [inline]
ZoomToSelection(SUHANDLE hTheme) | SUMap | [inline]
~SUObject() | SUObject | [inline, virtual]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUMenuItem Member List

This is the complete list of members for SUMenuItem, including all inherited members.

_h | SUObject | [protected]
IsValid() const | SUObject | [inline, virtual]
operator SUHANDLE() | SUObject | [inline]
SetEnabled(bool bEnable) | SUMenuItem | [inline]
SUMenuItem() | SUMenuItem | [inline]
SUMenuItem(SUHANDLE hMenuItem) | SUMenuItem | [inline]
SUObject() | SUObject | [inline]
SUObject(SUHANDLE h) | SUObject | [inline]
~SUObject() | SUObject | [inline, virtual]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUObject Member List

This is the complete list of members for SUObject, including all inherited members.

_h | SUObject | [protected]
IsValid() const | SUObject | [inline, virtual]
operator SUHANDLE() | SUObject | [inline]
SUObject() | SUObject | [inline]
SUObject(SUHANDLE h) | SUObject | [inline]
~SUObject() | SUObject | [inline, virtual]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUPoint Member List

This is the complete list of members for SUPoint, including all inherited members.

operator!=(const SUPoint &rhs) const | SUPoint | [inline]
operator+=(const SUPoint &p) | SUPoint | [inline]
operator-=(const SUPoint &p) | SUPoint | [inline]
operator==(const SUPoint &rhs) const | SUPoint | [inline]
SUPoint() | SUPoint | [inline]
SUPoint(int _x, int _y) | SUPoint | [inline]
x | SUPoint |
y | SUPoint |

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUPointf Member List

This is the complete list of members for SUPointf, including all inherited members.

operator!=(const SUPointf &rhs) const | SUPointf | [inline]
operator+=(const SUPointf &p) | SUPointf | [inline]
operator-=(const SUPointf &p) | SUPointf | [inline]
operator==(const SUPointf &rhs) const | SUPointf | [inline]
SUPointf() | SUPointf | [inline]
SUPointf(double _x, double _y) | SUPointf | [inline]
x | SUPointf |
y | SUPointf |

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SURecordset Member List

This is the complete list of members for SURecordset, including all inherited members.

_h | SUObject | [protected]
Bof() | SURecordset | [inline]
Close() | SURecordset | [inline]
Eof() | SURecordset | [inline]
First() | SURecordset | [inline]
Get() | SURecordset | [inline]
GetCount() | SURecordset | [inline]
IsValid() const | SUObject | [inline, virtual]
Last() | SURecordset | [inline]
Next() | SURecordset | [inline]
operator SUHANDLE() | SUObject | [inline]
Prev() | SURecordset | [inline]
SUObject() | SUObject | [inline]
SUObject(SUHANDLE h) | SUObject | [inline]
SURecordset() | SURecordset | [inline]
SURecordset(SUHANDLE hRecordset) | SURecordset | [inline]
~SUObject() | SUObject | [inline, virtual]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SURectf Member List

This is the complete list of members for SURectf, including all inherited members.

Contains(const SUPointf &p) | SURectf | [inline]
Contains(double x, double y) const | SURectf | [inline]
Height() const | SURectf | [inline]
Inflate(const SUSizef &s) | SURectf | [inline]
Intersects(const SURectf &r) const | SURectf | [inline]
Normalize() | SURectf | [inline]
SURectf() | SURectf | [inline]
SURectf(double _x1, double _y1, double _x2, double _y2) | SURectf | [inline]
Width() const | SURectf | [inline]
x1 | SURectf |
x2 | SURectf |
y1 | SURectf |
y2 | SURectf |

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUShape Member List

This is the complete list of members for SUShape, including all inherited members.

_h | SUObject | [protected]
GetAttribute(SUHANDLE hTheme, size_t index) const | SUShape | [inline]
GetBounds(SURectf &r) const | SUShape | [inline]
GetClosestPoint(const SUPointf &ref, SUPointf &closest) const | SUShape | [inline]
GetCoordinate(size_t part, size_t coordIndex, SUPointf &coord) const | SUShape | [inline]
GetCoordinateCount(size_t part) const | SUShape | [inline]
GetPartCount() const | SUShape | [inline]
GetShapeBytes(unsigned char *buffer, size_t bufferSize) const | SUShape | [inline]
GetShapeSizeBytes() const | SUShape | [inline]
GetShapeType() const | SUShape | [inline]
IsSelected(SUHANDLE hTheme) const | SUShape | [inline]
IsValid() const | SUObject | [inline, virtual]
operator SUHANDLE() | SUObject | [inline]
Select(SUHANDLE hTheme, bool bSelect) | SUShape | [inline]
SetAttribute(SUHANDLE hTheme, size_t index, const char *data) | SUShape | [inline]
SetAttributes(SUHANDLE hTheme, size_t count, const char *data[]) | SUShape | [inline]
SUObject() | SUObject | [inline]
SUObject(SUHANDLE h) | SUObject | [inline]
SUShape() | SUShape | [inline]
SUShape(SUHANDLE hShape) | SUShape | [inline]
~SUObject() | SUObject | [inline, virtual]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUSize Member List

This is the complete list of members for SUSize, including all inherited members.

height | SUSize |
SUSize() | SUSize | [inline]
SUSize(size_t w, size_t h) | SUSize | [inline]
width | SUSize |

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUSizef Member List

This is the complete list of members for SUSizef, including all inherited members.

height | SUSizef |
SUSizef() | SUSizef | [inline]
SUSizef(double w, double h) | SUSizef | [inline]
width | SUSizef |

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUStatusBar Member List

This is the complete list of members for SUStatusBar, including all inherited members.

_hProgress | SUStatusBar | [protected]
_paneHandles | SUStatusBar | [protected]
AllocatePane(size_t width) | SUStatusBar | [inline]
BeginProgress(const char *title=NULL, float progress=0.f) | SUStatusBar | [inline]
EndProgress() | SUStatusBar | [inline]
GetPaneCount() | SUStatusBar | [inline]
ReleasePane(size_t paneIndex) | SUStatusBar | [inline]
SetPaneInfo(size_t paneIndex, const char *text, HICON hIcon) | SUStatusBar | [inline]
SetProgress(float progress) | SUStatusBar | [inline]
SetText(const char *text) | SUStatusBar | [inline]
SUStatusBar() | SUStatusBar | [inline]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUTheme Member List

This is the complete list of members for SUTheme, including all inherited members.

_h | SUObject | [protected]
AddAttribute(unsigned long type, const char *name, const char *defaultval=NULL) | SUTheme | [inline]
AddShape(const CShapeRecord *shapeData) | SUTheme | [inline]
BatchAddShapeBegin() | SUTheme | [inline]
BatchAddShapeEnd() | SUTheme | [inline]
ClearSelection() | SUTheme | [inline]
DeleteAttribute(size_t index) | SUTheme | [inline]
DeleteShape(SUHANDLE hShape) | SUTheme | [inline]
GetAttributeCount() | SUTheme | [inline]
GetAttributeIndex(const char *name) | SUTheme | [inline]
GetAttributeName(size_t column) | SUTheme | [inline]
GetAttributeType(size_t column) | SUTheme | [inline]
GetBounds(SURectf &r) | SUTheme | [inline]
GetComment() | SUTheme | [inline]
GetFillColor() | SUTheme | [inline]
GetFont(LOGFONT *font, COLORREF *clr) | SUTheme | [inline]
GetInfoTip(SUShape shape) | SUTheme | [inline]
GetIntersectingShapes(SUShape shape) | SUTheme | [inline]
GetName() | SUTheme | [inline]
GetPenColor() | SUTheme | [inline]
GetPenStyle() | SUTheme | [inline]
GetPenWidth() | SUTheme | [inline]
GetSelectedShapes() | SUTheme | [inline]
GetSelectedShapesInRect(const SURectf &r, bool bPartiallyInRectOk) | SUTheme | [inline]
GetSelectionCount() | SUTheme | [inline]
GetShape(size_t index) | SUTheme | [inline]
GetShapeCount() | SUTheme | [inline]
GetShapeFromIndex(size_t index) | SUTheme | [inline]
GetShapesByQuery(const char *where) | SUTheme | [inline]
GetShapesInRect(const SURectf &r, bool bPartiallyInRectOk) | SUTheme | [inline]
GetShapeType() | SUTheme | [inline]
InvertSelection() | SUTheme | [inline]
IsReadOnly() | SUTheme | [inline]
IsSelected() | SUTheme | [inline]
IsValid() const | SUObject | [inline, virtual]
IsVisible() | SUTheme | [inline]
LookupWorkspace() | SUTheme | [inline]
operator SUHANDLE() | SUObject | [inline]
RecalcBounds() | SUTheme | [inline]
ReplaceShapeData(SUHANDLE hShape, const CShapeRecord *shapeData) | SUTheme | [inline]
Select(bool select) | SUTheme | [inline]
SetAttributeComment(size_t index, const char *comment) | SUTheme | [inline]
SetComment(const char *comment) | SUTheme | [inline]
SetFillColor(COLORREF clr) | SUTheme | [inline]
SetName(const char *name) | SUTheme | [inline]
SetPenColor(COLORREF clr) | SUTheme | [inline]
SetPenStyle(size_t style) | SUTheme | [inline]
SetPenWidth(size_t width) | SUTheme | [inline]
SetRasterImage(HBITMAP hbm, double west, double south, double east, double north, const char *sourceHint) | SUTheme | [inline]
SetSerialData(size_t byteCount, const void *bytes) | SUTheme | [inline]
SUObject() | SUObject | [inline]
SUObject(SUHANDLE h) | SUObject | [inline]
SUTheme() | SUTheme | [inline]
SUTheme(SUHANDLE hTheme) | SUTheme | [inline]
~SUObject() | SUObject | [inline, virtual]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUToolBar Member List

This is the complete list of members for SUToolBar, including all inherited members.

_h | SUObject | [protected]
Create(HINSTANCE hInstance, LPCTSTR lpszResourceName, const char *name) | SUToolBar | [inline]
Create(HINSTANCE hInstance, UINT nID, const char *name) | SUToolBar | [inline]
GetButtonCount() | SUToolBar | [inline]
IsValid() const | SUObject | [inline, virtual]
IsVisible() | SUToolBar | [inline]
operator SUHANDLE() | SUObject | [inline]
SetButtonChecked(UINT nID, bool bChecked) | SUToolBar | [inline]
SetButtonEnabled(UINT nID, bool bEnable) | SUToolBar | [inline]
SUObject() | SUObject | [inline]
SUObject(SUHANDLE h) | SUObject | [inline]
SUToolBar() | SUToolBar | [inline]
~SUObject() | SUObject | [inline, virtual]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

SUWorkspace Member List

This is the complete list of members for SUWorkspace, including all inherited members.

_h | SUObject | [protected]
AddDataPage(const char *name) | SUWorkspace | [inline]
BrowseTheme(const char *title, SUTheme &theme) | SUWorkspace | [inline]
ClearSelection() | SUWorkspace | [inline]
CreateNewTheme(ShapeType type, const char *name) | SUWorkspace | [inline]
CreateNewThemeFromSelection(SUTheme source, const char *name) | SUWorkspace | [inline]
GetBounds(SURectf &r) | SUWorkspace | [inline]
GetComment() | SUWorkspace | [inline]
GetMapWindow() | SUWorkspace | [inline]
GetSelectedTheme() | SUWorkspace | [inline]
GetSelectedThemes() | SUWorkspace | [inline]
GetSelectionCount() | SUWorkspace | [inline]
GetTheme(size_t index) | SUWorkspace | [inline]
GetThemeCount() const | SUWorkspace | [inline]
IsActive() | SUWorkspace | [inline]
IsValid() const | SUObject | [inline, virtual]
LoadJavaScript(const char *file) | SUWorkspace | [inline]
Log(const char *line) | SUWorkspace | [inline]
operator SUHANDLE() | SUObject | [inline]
Refresh() | SUWorkspace | [inline]
RemoveTheme(SUTheme theme) | SUWorkspace | [inline]
SetComment(const char *comment) | SUWorkspace | [inline]
SetSerialData(size_t byteCount, const void *bytes) | SUWorkspace | [inline]
SUObject() | SUObject | [inline]
SUObject(SUHANDLE h) | SUObject | [inline]
SUWorkspace() | SUWorkspace | [inline]
SUWorkspace(SUHANDLE hWorkspace) | SUWorkspace | [inline]
~SUObject() | SUObject | [inline, virtual]

Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- l -

  • Last() : SURecordset
  • line : tagSUARGLog
  • LoadJavaScript() : SUWorkspace
  • Log() : SUWorkspace
  • LookupWorkspace() : SUTheme
  • lpszResourceName : tagSUARGCreateToolBar
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- m -

  • menuDescr : tagSUAddMenuItemHookData
  • menuItemType : tagSUAddMenuItemHookData
  • menuString : tagSUAddMenuItemHookData
  • methods : tagSUAddJavaScriptInvokeHookData
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- n -

  • name : tagSUJavaScriptInvokeHookData , tagSUARGGetAttributeIndex , tagSUARGCreateToolBar , tagSUARGAddAttribute , tagSUARGJSCallFunction , tagSUARGAddDataPage
  • nCol : tagSUARGGetAttribute , tagSUARGSetAttribute
  • nCommandID : tagSUToolBarButtonHookData
  • Next() : SURecordset
  • nID : tagSUARGSetButtonBOOL
  • nIndex : tagSUARGGetWorkspace , tagSUARGGetUnsignedByIndex , tagSUARGGetHandleByIndex , tagSUARGGetCoordinate
  • Normalize() : SURectf
  • north : tagSUARGSetRasterImage
  • nPart : tagSUARGGetCoordinate
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- o -

  • ok : tagSUARGRemoveTheme
  • operator SUHANDLE() : SUObject
  • operator!=() : SUPointf , SUPoint
  • operator+=() : SUPoint , SUPointf
  • operator-=() : SUPointf , SUPoint
  • operator==() : SUPointf , SUPoint
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- z -

  • z : tagSUARGGetCoordinate
  • Zoom() : SUMap
  • ZoomToExtent() : SUMap
  • ZoomToSelection() : SUMap
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~SUObject() : SUObject
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- a -

  • AddAttribute() : SUTheme
  • AddDataPage() : SUWorkspace
  • AddShape() : SUTheme
  • AllocatePane() : SUStatusBar
  • argc : tagSUJavaScriptInvokeHookData
  • args : tagSUARGAddHook , tagSUJavaScriptInvokeHookData
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- b -

  • bAllowNewGUI : tagSUShapeSelChangeHookData
  • BatchAddShapeBegin() : SUTheme
  • BatchAddShapeEnd() : SUTheme
  • BeginProgress() : SUStatusBar
  • bFullRedraw : tagSUARGRepaint
  • Bof() : SURecordset
  • boolVal : tagSUJavaScriptArgument
  • boolval : tagSUARGGetBOOL , tagSUARGSetBOOL , tagSUARGSetButtonBOOL
  • bPartInRectOk : tagSUARGGetShapesInRect
  • BrowseTheme() : SUWorkspace
  • buffer : tagSUARGGetInfoTip , tagSUARGGetAttribute , tagSUARGGetText , tagSUARGGetShapeBytes , tagSUARGGetErrorDescription , tagSUARGSetText , tagSUARGGetTextByIndex , tagSUARGSetTextByIndex
  • bufferSize : tagSUARGGetAttribute , tagSUARGGetText , tagSUARGGetShapeBytes , tagSUARGGetInfoTip , tagSUARGGetTextByIndex , tagSUARGGetErrorDescription
  • byteCount : tagSUDeserializeHookData , tagSUARGSetSerialData
  • bytes : tagSUDeserializeHookData , tagSUARGSetSerialData , tagSUARGAllocate
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- c -

  • CallFunction() : SUJavaScript
  • CenterMap() : SUMap
  • ClearSelection() : SUTheme , SUWorkspace
  • Close() : SURecordset , SUJavaScript
  • closestx : tagSUARGGetClosestPoint
  • closesty : tagSUARGGetClosestPoint
  • clr : tagSUARGGetFont , tagSUARGGetColor , tagSUARGSetColor
  • colorVal : tagSUJavaScriptArgument
  • Contains() : SURectf
  • count : tagSUARGSetAttributes , tagSUARGAllocate
  • Create() : SUToolBar
  • CreateNewTheme() : SUWorkspace
  • CreateNewThemeFromSelection() : SUWorkspace
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- d -

  • data : tagSUARGSetAttribute , tagSUARGSetAttributes
  • defaultval : tagSUARGAddAttribute
  • DeleteAttribute() : SUTheme
  • DeleteShape() : SUTheme
  • doubleval : tagSUARGSetDouble
  • doubleVal : tagSUJavaScriptArgument
  • DPtoGP() : SUMap
  • dpx : tagSUARGGPtoDP , tagSUARGDPtoGP
  • dpy : tagSUARGDPtoGP , tagSUARGGPtoDP
  • Draw() : SUMap
  • dwordval : tagSUARGGetDWORD , tagSUARGSetDWORD
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- e -

  • east : tagSUARGSetRasterImage
  • EndProgress() : SUStatusBar
  • Eof() : SURecordset
  • errCode : tagSUARGGetErrorDescription
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- f -

  • file : tagSUARGLoadJavaScript
  • filename : tagSUFileFormatHandlerHookData
  • filterdescription : tagSUAddFileFormatHandlerHookData
  • First() : SURecordset
  • flags : tagSUMouseHookData , tagSUJavaScriptInvokeHookData
  • floatval : tagSUARGSetFloat
  • font : tagSUARGGetFont
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- g -

  • geoHeight : tagSUARGDraw
  • geoWidth : tagSUARGDraw
  • Get() : SURecordset
  • GetAttribute() : SUShape
  • GetAttributeCount() : SUTheme
  • GetAttributeIndex() : SUTheme
  • GetAttributeName() : SUTheme
  • GetAttributeType() : SUTheme
  • GetBounds() : SUTheme , SUShape , SUMap , SUWorkspace
  • GetButtonCount() : SUToolBar
  • GetClosestPoint() : SUShape
  • GetComment() : SUTheme , SUWorkspace
  • GetCoordinate() : SUShape
  • GetCoordinateCount() : SUShape
  • GetCount() : SURecordset
  • GetErrorCode() : SUException
  • GetErrorDesc() : SUException
  • GetFillColor() : SUTheme
  • GetFont() : SUTheme
  • GetHWND() : SUMap , SUDataPage
  • GetInfoTip() : SUTheme
  • GetInteractionState() : SUMap
  • GetIntersectingShapes() : SUTheme
  • GetMapWindow() : SUWorkspace
  • GetName() : SUTheme
  • GetPaneCount() : SUStatusBar
  • GetPartCount() : SUShape
  • GetPenColor() : SUTheme
  • GetPenStyle() : SUTheme
  • GetPenWidth() : SUTheme
  • GetSelectedShapes() : SUTheme
  • GetSelectedShapesInRect() : SUTheme
  • GetSelectedTheme() : SUWorkspace
  • GetSelectedThemes() : SUWorkspace
  • GetSelectionCount() : SUWorkspace , SUTheme
  • GetShape() : SUTheme
  • GetShapeBytes() : SUShape
  • GetShapeCount() : SUTheme
  • GetShapeFromIndex() : SUTheme
  • GetShapesByQuery() : SUTheme
  • GetShapesInRect() : SUTheme
  • GetShapeSizeBytes() : SUShape
  • GetShapeType() : SUShape , SUTheme
  • GetTheme() : SUWorkspace
  • GetThemeCount() : SUWorkspace
  • GetViewSize() : SUMap
  • GPtoDP() : SUMap
  • gpx : tagSUARGDPtoGP , tagSUARGGPtoDP
  • gpy : tagSUARGGPtoDP , tagSUARGDPtoGP
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- h -

  • handleVal : tagSUJavaScriptArgument
  • hbm : tagSUARGSetRasterImage
  • hd : tagSUShapeSelChangeHookData , tagSUPreRemoveShapeHookData , tagSUAddJavaScriptInvokeHookData , tagSUMouseHookData , tagSUToolBarButtonHookData , tagSUJavaScriptInvokeHookData , tagSUMenuItemHookData , tagSUPreRemoveThemeHookData , tagSUFileFormatHandlerHookData , tagSUDeserializeHookData
  • hDataPage : tagSUARGAddDataPage
  • hdc : tagSUARGDraw
  • height : SUSize , SUSizef
  • Height() : SURectf
  • height : tagSUARGGetSize
  • hIcon : tagSUARGSetStatusBarPaneInfo
  • hInstResource : tagSUARGCreateToolBar
  • hJavaScript : tagSUARGJSCallFunction , tagSUARGLoadJavaScript
  • hMap : tagSUARGGetInteractionState , tagSUARGSetInteractionState , tagSUARGGPtoDP , tagSUARGDPtoGP , tagSUARGDraw , tagSUARGRepaint , tagSUARGZoomToSelection , tagSUARGZoomToExtent
  • hMenuItem : tagSUMenuItemHookData , tagSUAddMenuItemHookData
  • hObject : tagSUARGGetBOOL , tagSUARGGetText , tagSUARGSetText , tagSUARGGetTextByIndex , tagSUARGGetDWORD , tagSUARGSetTextByIndex , tagSUARGSetDWORD , tagSUARGGetUnsigned , tagSUARGGetBounds , tagSUARGGetUnsignedByIndex , tagSUARGSetUnsigned , tagSUARGGetHandleByIndex , tagSUARGGetShapeType , tagSUARGGetSize , tagSUARGGetFont , tagSUARGGetHWND , tagSUARGSetPoint , tagSUARGSetDouble , tagSUARGSetFloat , tagSUARGGetColor , tagSUARGSetColor , tagSUARGSetBOOL , tagSUARGSetSerialData , tagSUARGGetHandle
  • hookType : tagSUARGAddHook , tagSUARGRemoveHook
  • hProgress : tagSUARGBeginProgress
  • hRecordset : tagSUARGGetShapesInRect , tagSUARGGetIntersectingShapes , tagSUARGGetShapesByQuery
  • hReserved : tagSUAddMenuItemHookData
  • hResult : tagSUARGGetHandle , tagSUARGGetHandleByIndex
  • hResultTheme : tagSUARGCreateNewThemeFromSelection
  • hShape : tagSUARGDeleteShape , tagSUARGIsShapeSelected , tagSUARGGetClosestPoint , tagSUARGGetCoordinate , tagSUARGGetIntersectingShapes , tagSUARGGetInfoTip , tagSUARGAddShape , tagSUARGSelectShape , tagSUARGGetAttribute , tagSUARGSetAttribute , tagSUARGSetAttributes , tagSUARGGetShapeBytes , tagSUPreRemoveShapeHookData , tagSUARGReplaceShapeData
  • hShapeUp : tagSUARGBatchAddShape , tagSUExport , tagSUARGSetInteractionState , tagSUARGGetInteractionState , tagSUARGRemoveHook , tagSUARGCreateToolBar , tagSUARGSetButtonBOOL , tagSUARGAddHook , tagSUARGWantUpdate , tagSUARGSetSerialData
  • hSourceTheme : tagSUARGCreateNewThemeFromSelection
  • hStatusPane : tagSUARGSetStatusBarPaneInfo , tagSUARGAllocateStatusBarPane
  • hTheme : tagSUARGGetShapesInRect , tagSUDeserializeHookData , tagSUARGCreateNewTheme , tagSUARGSetRasterImage , tagSUARGGetAttribute , tagSUARGSetAttribute , tagSUARGSetAttributes , tagSUPreRemoveShapeHookData , tagSUARGBatchAddShape , tagSUARGReplaceShapeData , tagSUARGRemoveTheme , tagSUPreRemoveThemeHookData , tagSUARGZoomToExtent , tagSUARGGetIntersectingShapes , tagSUShapeSelChangeHookData , tagSUARGGetAttributeIndex , tagSUARGGetAttributeType , tagSUARGSelectShape , tagSUARGDeleteShape , tagSUARGGetInfoTip , tagSUARGIsShapeSelected , tagSUARGZoomToSelection , tagSUARGAddShape , tagSUARGGetShapesByQuery , tagSUARGDeleteAttribute , tagSUARGAddAttribute , tagSUARGBrowseTheme
  • hToolBar : tagSUARGSetButtonBOOL , tagSUARGCreateToolBar
  • hWnd : tagSUARGGetHWND
  • hWorkspace : tagSUARGLoadJavaScript , tagSUARGGetWorkspace , tagSUARGLog , tagSUARGRemoveTheme , tagSUARGCreateNewTheme , tagSUARGBrowseTheme , tagSUARGCreateNewThemeFromSelection , tagSUARGAddDataPage
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- i -

  • imageHeight : tagSUARGDraw
  • imageWidth : tagSUARGDraw
  • import : tagSUExport
  • index : tagSUARGDeleteAttribute , tagSUARGGetTextByIndex , tagSUARGGetAttributeIndex , tagSUARGSetTextByIndex , tagSUARGAddAttribute , tagSUARGGetAttributeType
  • index_on : tagSUARGBatchAddShape
  • Inflate() : SURectf
  • Intersects() : SURectf
  • intVal : tagSUJavaScriptArgument
  • InvertSelection() : SUTheme
  • IsActive() : SUWorkspace
  • IsReadOnly() : SUTheme
  • IsSelected() : SUShape , SUTheme
  • IsValid() : SUObject
  • IsVisible() : SUToolBar , SUTheme
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- p -

  • page : tagSUARGAddDataPage
  • pattern : tagSUAddFileFormatHandlerHookData
  • pfnHook : tagSUImport
  • pfnSettings : tagSUImport
  • pReserved : tagSUARGSetStatusBarPaneInfo , tagSUImport
  • Prev() : SURecordset
  • progress : tagSUARGBeginProgress
  • properties : tagSUAddJavaScriptInvokeHookData
  • pszDescription : tagSUImport
  • pszInfo : tagSUImport
  • pszName : tagSUARGCreateNewTheme , tagSUImport , tagSUARGCreateNewThemeFromSelection
  • pszPluginVersion : tagSUImport
  • pszTitle : tagSUARGBrowseTheme
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- r -

  • RecalcBounds() : SUTheme
  • Refresh() : SUWorkspace
  • refx : tagSUARGGetClosestPoint
  • refy : tagSUARGGetClosestPoint
  • ReleasePane() : SUStatusBar
  • Remove() : SUDataPage
  • RemoveTheme() : SUWorkspace
  • Repaint() : SUMap
  • ReplaceShapeData() : SUTheme
  • retc : tagSUJavaScriptInvokeHookData
  • rets : tagSUJavaScriptInvokeHookData
  • Run() : SUJavaScript
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- s -

  • select : tagSUARGSelectShape
  • Select() : SUShape , SUTheme
  • selected : tagSUARGIsShapeSelected
  • SetAttribute() : SUShape
  • SetAttributeComment() : SUTheme
  • SetAttributes() : SUShape
  • SetButtonChecked() : SUToolBar
  • SetButtonEnabled() : SUToolBar
  • SetComment() : SUTheme , SUWorkspace
  • SetEnabled() : SUMenuItem
  • SetFillColor() : SUTheme
  • SetInteractionState() : SUMap
  • SetName() : SUTheme
  • SetPaneInfo() : SUStatusBar
  • SetPenColor() : SUTheme
  • SetPenStyle() : SUTheme
  • SetPenWidth() : SUTheme
  • SetProgress() : SUStatusBar
  • SetRasterImage() : SUTheme
  • SetSerialData() : SUTheme , SUWorkspace
  • SetText() : SUStatusBar
  • shapeData : tagSUARGReplaceShapeData , tagSUARGAddShape
  • ShapeUp_Call : tagSUExport
  • sourceHint : tagSUARGSetRasterImage
  • south : tagSUARGSetRasterImage
  • state : tagSUARGGetInteractionState , tagSUARGSetInteractionState
  • stringVal : tagSUJavaScriptArgument
  • SUDataPage() : SUDataPage
  • SUException() : SUException
  • SUJavaScript() : SUJavaScript
  • SUMap() : SUMap
  • SUMenuItem() : SUMenuItem
  • SUObject() : SUObject
  • SUPoint() : SUPoint
  • SUPointf() : SUPointf
  • SURecordset() : SURecordset
  • SURectf() : SURectf
  • SUShape() : SUShape
  • SUSize() : SUSize
  • SUSizef() : SUSizef
  • SUStatusBar() : SUStatusBar
  • SUTheme() : SUTheme
  • SUToolBar() : SUToolBar
  • SUWorkspace() : SUWorkspace
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- t -

  • text : tagSUARGSetStatusBarPaneInfo
  • title : tagSUARGBeginProgress
  • type : tagSUARGAddAttribute , tagSUJavaScriptArgument , tagSUARGGetShapeType , tagSUARGCreateNewTheme , tagSUARGGetAttributeType
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- u -

  • ulReserved : tagSUMouseHookData
  • ulUserData : tagSUARGWantUpdate
  • unsignedval : tagSUARGGetUnsigned , tagSUARGGetUnsignedByIndex , tagSUARGSetUnsigned
  • userData : tagSUHookData , tagSUARGAddHook
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- w -

  • west : tagSUARGSetRasterImage
  • where : tagSUARGGetShapesByQuery
  • width : SUSizef , SUSize , tagSUARGGetSize , tagSUARGAllocateStatusBarPane
  • Width() : SURectf
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- x -

  • x : tagSUMouseHookData , tagSUARGSetPoint , SUPoint , SUPointf , tagSUARGGetCoordinate
  • x1 : SURectf
  • x2 : SURectf
  • xCenter : tagSUARGDraw
  • xmax : tagSUARGGetBounds , tagSUARGGetShapesInRect
  • xmin : tagSUARGGetShapesInRect , tagSUARGGetBounds
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z
  • ~

Here is a list of all class members with links to the classes they belong to:

- y -

  • y : tagSUMouseHookData , tagSUARGSetPoint , SUPoint , SUPointf , tagSUARGGetCoordinate
  • y1 : SURectf
  • y2 : SURectf
  • yCenter : tagSUARGDraw
  • ymax : tagSUARGGetBounds , tagSUARGGetShapesInRect
  • ymin : tagSUARGGetShapesInRect , tagSUARGGetBounds
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Functions

  • All
  • Functions
  • Variables
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • n
  • o
  • p
  • r
  • s
  • w
  • z
  • ~

- a -

  • AddAttribute() : SUTheme
  • AddDataPage() : SUWorkspace
  • AddShape() : SUTheme
  • AllocatePane() : SUStatusBar

- b -

  • BatchAddShapeBegin() : SUTheme
  • BatchAddShapeEnd() : SUTheme
  • BeginProgress() : SUStatusBar
  • Bof() : SURecordset
  • BrowseTheme() : SUWorkspace

- c -

  • CallFunction() : SUJavaScript
  • CenterMap() : SUMap
  • ClearSelection() : SUTheme , SUWorkspace
  • Close() : SURecordset , SUJavaScript
  • Contains() : SURectf
  • Create() : SUToolBar
  • CreateNewTheme() : SUWorkspace
  • CreateNewThemeFromSelection() : SUWorkspace

- d -

  • DeleteAttribute() : SUTheme
  • DeleteShape() : SUTheme
  • DPtoGP() : SUMap
  • Draw() : SUMap

- e -

  • EndProgress() : SUStatusBar
  • Eof() : SURecordset

- f -

  • First() : SURecordset

- g -

  • Get() : SURecordset
  • GetAttribute() : SUShape
  • GetAttributeCount() : SUTheme
  • GetAttributeIndex() : SUTheme
  • GetAttributeName() : SUTheme
  • GetAttributeType() : SUTheme
  • GetBounds() : SUMap , SUShape , SUWorkspace , SUTheme
  • GetButtonCount() : SUToolBar
  • GetClosestPoint() : SUShape
  • GetComment() : SUTheme , SUWorkspace
  • GetCoordinate() : SUShape
  • GetCoordinateCount() : SUShape
  • GetCount() : SURecordset
  • GetErrorCode() : SUException
  • GetErrorDesc() : SUException
  • GetFillColor() : SUTheme
  • GetFont() : SUTheme
  • GetHWND() : SUMap , SUDataPage
  • GetInfoTip() : SUTheme
  • GetInteractionState() : SUMap
  • GetIntersectingShapes() : SUTheme
  • GetMapWindow() : SUWorkspace
  • GetName() : SUTheme
  • GetPaneCount() : SUStatusBar
  • GetPartCount() : SUShape
  • GetPenColor() : SUTheme
  • GetPenStyle() : SUTheme
  • GetPenWidth() : SUTheme
  • GetSelectedShapes() : SUTheme
  • GetSelectedShapesInRect() : SUTheme
  • GetSelectedTheme() : SUWorkspace
  • GetSelectedThemes() : SUWorkspace
  • GetSelectionCount() : SUTheme , SUWorkspace
  • GetShape() : SUTheme
  • GetShapeBytes() : SUShape
  • GetShapeCount() : SUTheme
  • GetShapeFromIndex() : SUTheme
  • GetShapesByQuery() : SUTheme
  • GetShapesInRect() : SUTheme
  • GetShapeSizeBytes() : SUShape
  • GetShapeType() : SUTheme , SUShape
  • GetTheme() : SUWorkspace
  • GetThemeCount() : SUWorkspace
  • GetViewSize() : SUMap
  • GPtoDP() : SUMap

- h -

  • Height() : SURectf

- i -

  • Inflate() : SURectf
  • Intersects() : SURectf
  • InvertSelection() : SUTheme
  • IsActive() : SUWorkspace
  • IsReadOnly() : SUTheme
  • IsSelected() : SUShape , SUTheme
  • IsValid() : SUObject
  • IsVisible() : SUToolBar , SUTheme

- l -

  • Last() : SURecordset
  • LoadJavaScript() : SUWorkspace
  • Log() : SUWorkspace
  • LookupWorkspace() : SUTheme

- n -

  • Next() : SURecordset
  • Normalize() : SURectf

- o -

  • operator SUHANDLE() : SUObject
  • operator!=() : SUPoint , SUPointf
  • operator+=() : SUPoint , SUPointf
  • operator-=() : SUPoint , SUPointf
  • operator==() : SUPoint , SUPointf

- p -

  • Prev() : SURecordset

- r -

  • RecalcBounds() : SUTheme
  • Refresh() : SUWorkspace
  • ReleasePane() : SUStatusBar
  • Remove() : SUDataPage
  • RemoveTheme() : SUWorkspace
  • Repaint() : SUMap
  • ReplaceShapeData() : SUTheme
  • Run() : SUJavaScript

- s -

  • Select() : SUShape , SUTheme
  • SetAttribute() : SUShape
  • SetAttributeComment() : SUTheme
  • SetAttributes() : SUShape
  • SetButtonChecked() : SUToolBar
  • SetButtonEnabled() : SUToolBar
  • SetComment() : SUTheme , SUWorkspace
  • SetEnabled() : SUMenuItem
  • SetFillColor() : SUTheme
  • SetInteractionState() : SUMap
  • SetName() : SUTheme
  • SetPaneInfo() : SUStatusBar
  • SetPenColor() : SUTheme
  • SetPenStyle() : SUTheme
  • SetPenWidth() : SUTheme
  • SetProgress() : SUStatusBar
  • SetRasterImage() : SUTheme
  • SetSerialData() : SUTheme , SUWorkspace
  • SetText() : SUStatusBar
  • SUDataPage() : SUDataPage
  • SUException() : SUException
  • SUJavaScript() : SUJavaScript
  • SUMap() : SUMap
  • SUMenuItem() : SUMenuItem
  • SUObject() : SUObject
  • SUPoint() : SUPoint
  • SUPointf() : SUPointf
  • SURecordset() : SURecordset
  • SURectf() : SURectf
  • SUShape() : SUShape
  • SUSize() : SUSize
  • SUSizef() : SUSizef
  • SUStatusBar() : SUStatusBar
  • SUTheme() : SUTheme
  • SUToolBar() : SUToolBar
  • SUWorkspace() : SUWorkspace

- w -

  • Width() : SURectf

- z -

  • Zoom() : SUMap
  • ZoomToExtent() : SUMap
  • ZoomToSelection() : SUMap

- ~ -

  • ~SUObject() : SUObject
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- _ -

  • _h : SUObject
  • _hProgress : SUStatusBar
  • _paneHandles : SUStatusBar
  • _res : SUException
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- l -

  • line : tagSUARGLog
  • lpszResourceName : tagSUARGCreateToolBar
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- m -

  • menuDescr : tagSUAddMenuItemHookData
  • menuItemType : tagSUAddMenuItemHookData
  • menuString : tagSUAddMenuItemHookData
  • methods : tagSUAddJavaScriptInvokeHookData
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- n -

  • name : tagSUJavaScriptInvokeHookData , tagSUARGGetAttributeIndex , tagSUARGCreateToolBar , tagSUARGAddAttribute , tagSUARGJSCallFunction , tagSUARGAddDataPage
  • nCol : tagSUARGGetAttribute , tagSUARGSetAttribute
  • nCommandID : tagSUToolBarButtonHookData
  • nID : tagSUARGSetButtonBOOL
  • nIndex : tagSUARGGetCoordinate , tagSUARGGetUnsignedByIndex , tagSUARGGetWorkspace , tagSUARGGetHandleByIndex
  • north : tagSUARGSetRasterImage
  • nPart : tagSUARGGetCoordinate
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- o -

  • ok : tagSUARGRemoveTheme
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- z -

  • z : tagSUARGGetCoordinate
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- a -

  • argc : tagSUJavaScriptInvokeHookData
  • args : tagSUARGAddHook , tagSUJavaScriptInvokeHookData
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- b -

  • bAllowNewGUI : tagSUShapeSelChangeHookData
  • bFullRedraw : tagSUARGRepaint
  • boolVal : tagSUJavaScriptArgument
  • boolval : tagSUARGGetBOOL , tagSUARGSetBOOL , tagSUARGSetButtonBOOL
  • bPartInRectOk : tagSUARGGetShapesInRect
  • buffer : tagSUARGGetInfoTip , tagSUARGGetAttribute , tagSUARGGetText , tagSUARGGetShapeBytes , tagSUARGGetErrorDescription , tagSUARGSetText , tagSUARGGetTextByIndex , tagSUARGSetTextByIndex
  • bufferSize : tagSUARGGetAttribute , tagSUARGGetShapeBytes , tagSUARGGetText , tagSUARGGetInfoTip , tagSUARGGetErrorDescription , tagSUARGGetTextByIndex
  • byteCount : tagSUDeserializeHookData , tagSUARGSetSerialData
  • bytes : tagSUARGAllocate , tagSUDeserializeHookData , tagSUARGSetSerialData
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- c -

  • closestx : tagSUARGGetClosestPoint
  • closesty : tagSUARGGetClosestPoint
  • clr : tagSUARGSetColor , tagSUARGGetFont , tagSUARGGetColor
  • colorVal : tagSUJavaScriptArgument
  • count : tagSUARGSetAttributes , tagSUARGAllocate
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- d -

  • data : tagSUARGSetAttribute , tagSUARGSetAttributes
  • defaultval : tagSUARGAddAttribute
  • doubleVal : tagSUJavaScriptArgument
  • doubleval : tagSUARGSetDouble
  • dpx : tagSUARGDPtoGP , tagSUARGGPtoDP
  • dpy : tagSUARGDPtoGP , tagSUARGGPtoDP
  • dwordval : tagSUARGGetDWORD , tagSUARGSetDWORD
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- e -

  • east : tagSUARGSetRasterImage
  • errCode : tagSUARGGetErrorDescription
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- f -

  • file : tagSUARGLoadJavaScript
  • filename : tagSUFileFormatHandlerHookData
  • filterdescription : tagSUAddFileFormatHandlerHookData
  • flags : tagSUMouseHookData , tagSUJavaScriptInvokeHookData
  • floatval : tagSUARGSetFloat
  • font : tagSUARGGetFont
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- g -

  • geoHeight : tagSUARGDraw
  • geoWidth : tagSUARGDraw
  • gpx : tagSUARGGPtoDP , tagSUARGDPtoGP
  • gpy : tagSUARGDPtoGP , tagSUARGGPtoDP
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- h -

  • handleVal : tagSUJavaScriptArgument
  • hbm : tagSUARGSetRasterImage
  • hd : tagSUShapeSelChangeHookData , tagSUPreRemoveShapeHookData , tagSUAddJavaScriptInvokeHookData , tagSUMouseHookData , tagSUToolBarButtonHookData , tagSUJavaScriptInvokeHookData , tagSUMenuItemHookData , tagSUPreRemoveThemeHookData , tagSUFileFormatHandlerHookData , tagSUDeserializeHookData
  • hDataPage : tagSUARGAddDataPage
  • hdc : tagSUARGDraw
  • height : SUSize , SUSizef , tagSUARGGetSize
  • hIcon : tagSUARGSetStatusBarPaneInfo
  • hInstResource : tagSUARGCreateToolBar
  • hJavaScript : tagSUARGJSCallFunction , tagSUARGLoadJavaScript
  • hMap : tagSUARGGetInteractionState , tagSUARGSetInteractionState , tagSUARGGPtoDP , tagSUARGDPtoGP , tagSUARGDraw , tagSUARGRepaint , tagSUARGZoomToSelection , tagSUARGZoomToExtent
  • hMenuItem : tagSUMenuItemHookData , tagSUAddMenuItemHookData
  • hObject : tagSUARGGetText , tagSUARGSetBOOL , tagSUARGSetText , tagSUARGGetTextByIndex , tagSUARGGetDWORD , tagSUARGSetTextByIndex , tagSUARGSetDWORD , tagSUARGGetBOOL , tagSUARGGetUnsigned , tagSUARGGetBounds , tagSUARGGetUnsignedByIndex , tagSUARGSetUnsigned , tagSUARGGetHandleByIndex , tagSUARGGetShapeType , tagSUARGGetSize , tagSUARGGetFont , tagSUARGGetHWND , tagSUARGSetPoint , tagSUARGSetDouble , tagSUARGSetFloat , tagSUARGGetColor , tagSUARGSetColor , tagSUARGSetSerialData , tagSUARGGetHandle
  • hookType : tagSUARGAddHook , tagSUARGRemoveHook
  • hProgress : tagSUARGBeginProgress
  • hRecordset : tagSUARGGetShapesInRect , tagSUARGGetIntersectingShapes , tagSUARGGetShapesByQuery
  • hReserved : tagSUAddMenuItemHookData
  • hResult : tagSUARGGetHandleByIndex , tagSUARGGetHandle
  • hResultTheme : tagSUARGCreateNewThemeFromSelection
  • hShape : tagSUARGIsShapeSelected , tagSUARGDeleteShape , tagSUARGGetClosestPoint , tagSUARGGetCoordinate , tagSUARGGetIntersectingShapes , tagSUARGGetInfoTip , tagSUARGAddShape , tagSUARGSelectShape , tagSUARGGetAttribute , tagSUARGSetAttribute , tagSUARGSetAttributes , tagSUARGGetShapeBytes , tagSUPreRemoveShapeHookData , tagSUARGReplaceShapeData
  • hShapeUp : tagSUARGBatchAddShape , tagSUExport , tagSUARGSetSerialData , tagSUARGGetInteractionState , tagSUARGSetInteractionState , tagSUARGRemoveHook , tagSUARGAddHook , tagSUARGCreateToolBar , tagSUARGSetButtonBOOL , tagSUARGWantUpdate
  • hSourceTheme : tagSUARGCreateNewThemeFromSelection
  • hStatusPane : tagSUARGSetStatusBarPaneInfo , tagSUARGAllocateStatusBarPane
  • hTheme : tagSUARGGetShapesInRect , tagSUARGGetAttributeIndex , tagSUARGDeleteAttribute , tagSUARGSelectShape , tagSUARGSetAttributes , tagSUARGReplaceShapeData , tagSUPreRemoveShapeHookData , tagSUARGGetAttribute , tagSUARGDeleteShape , tagSUARGCreateNewTheme , tagSUShapeSelChangeHookData , tagSUPreRemoveThemeHookData , tagSUARGGetIntersectingShapes , tagSUARGGetShapesByQuery , tagSUARGGetInfoTip , tagSUARGSetRasterImage , tagSUARGGetAttributeType , tagSUARGRemoveTheme , tagSUARGSetAttribute , tagSUDeserializeHookData , tagSUARGZoomToSelection , tagSUARGZoomToExtent , tagSUARGBatchAddShape , tagSUARGBrowseTheme , tagSUARGAddShape , tagSUARGIsShapeSelected , tagSUARGAddAttribute
  • hToolBar : tagSUARGSetButtonBOOL , tagSUARGCreateToolBar
  • hWnd : tagSUARGGetHWND
  • hWorkspace : tagSUARGAddDataPage , tagSUARGLog , tagSUARGCreateNewThemeFromSelection , tagSUARGLoadJavaScript , tagSUARGRemoveTheme , tagSUARGGetWorkspace , tagSUARGBrowseTheme , tagSUARGCreateNewTheme
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- i -

  • imageHeight : tagSUARGDraw
  • imageWidth : tagSUARGDraw
  • import : tagSUExport
  • index : tagSUARGGetAttributeIndex , tagSUARGDeleteAttribute , tagSUARGGetAttributeType , tagSUARGAddAttribute , tagSUARGGetTextByIndex , tagSUARGSetTextByIndex
  • index_on : tagSUARGBatchAddShape
  • intVal : tagSUJavaScriptArgument
Generated on Thu Apr 15 10:55:34 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- p -

  • page : tagSUARGAddDataPage
  • pattern : tagSUAddFileFormatHandlerHookData
  • pfnHook : tagSUImport
  • pfnSettings : tagSUImport
  • pReserved : tagSUImport , tagSUARGSetStatusBarPaneInfo
  • progress : tagSUARGBeginProgress
  • properties : tagSUAddJavaScriptInvokeHookData
  • pszDescription : tagSUImport
  • pszInfo : tagSUImport
  • pszName : tagSUARGCreateNewTheme , tagSUImport , tagSUARGCreateNewThemeFromSelection
  • pszPluginVersion : tagSUImport
  • pszTitle : tagSUARGBrowseTheme
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- r -

  • refx : tagSUARGGetClosestPoint
  • refy : tagSUARGGetClosestPoint
  • retc : tagSUJavaScriptInvokeHookData
  • rets : tagSUJavaScriptInvokeHookData
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- s -

  • select : tagSUARGSelectShape
  • selected : tagSUARGIsShapeSelected
  • shapeData : tagSUARGReplaceShapeData , tagSUARGAddShape
  • ShapeUp_Call : tagSUExport
  • sourceHint : tagSUARGSetRasterImage
  • south : tagSUARGSetRasterImage
  • state : tagSUARGGetInteractionState , tagSUARGSetInteractionState
  • stringVal : tagSUJavaScriptArgument
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- t -

  • text : tagSUARGSetStatusBarPaneInfo
  • title : tagSUARGBeginProgress
  • type : tagSUARGAddAttribute , tagSUJavaScriptArgument , tagSUARGGetShapeType , tagSUARGCreateNewTheme , tagSUARGGetAttributeType
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- u -

  • ulReserved : tagSUMouseHookData
  • ulUserData : tagSUARGWantUpdate
  • unsignedval : tagSUARGGetUnsigned , tagSUARGGetUnsignedByIndex , tagSUARGSetUnsigned
  • userData : tagSUHookData , tagSUARGAddHook
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- w -

  • west : tagSUARGSetRasterImage
  • where : tagSUARGGetShapesByQuery
  • width : SUSize , tagSUARGGetSize , tagSUARGAllocateStatusBarPane , SUSizef
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- x -

  • x : tagSUMouseHookData , tagSUARGSetPoint , SUPoint , SUPointf , tagSUARGGetCoordinate
  • x1 : SURectf
  • x2 : SURectf
  • xCenter : tagSUARGDraw
  • xmax : tagSUARGGetBounds , tagSUARGGetShapesInRect
  • xmin : tagSUARGGetShapesInRect , tagSUARGGetBounds
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members - Variables

  • All
  • Functions
  • Variables
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • w
  • x
  • y
  • z

- y -

  • y : tagSUMouseHookData , tagSUARGSetPoint , SUPoint , SUPointf , tagSUARGGetCoordinate
  • y1 : SURectf
  • y2 : SURectf
  • yCenter : tagSUARGDraw
  • ymax : tagSUARGGetBounds , tagSUARGGetShapesInRect
  • ymin : tagSUARGGetShapesInRect , tagSUARGGetBounds
Generated on Thu Apr 15 10:55:35 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- j -

  • JavaScript_CallFunction() : ShapeUpAPI.h
  • JavaScript_Close() : ShapeUpAPI.h
  • JavaScript_Run() : ShapeUpAPI.h
  • JSIHDF_DEFAULT : ShapeUpAPI.h
  • JSIHDF_TREATRETURNASSINGLEVALUE : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- m -

  • Map_CenterMap() : ShapeUpAPI.h
  • Map_DPtoGP() : ShapeUpAPI.h
  • Map_Draw() : ShapeUpAPI.h
  • Map_GetBounds() : ShapeUpAPI.h
  • Map_GetHWND() : ShapeUpAPI.h
  • Map_GetInteractionState() : ShapeUpAPI.h
  • Map_GetViewSize() : ShapeUpAPI.h
  • Map_GPtoDP() : ShapeUpAPI.h
  • Map_Repaint() : ShapeUpAPI.h
  • Map_SetInteractionState() : ShapeUpAPI.h
  • Map_Zoom() : ShapeUpAPI.h
  • Map_ZoomToExtent() : ShapeUpAPI.h
  • Map_ZoomToSelection() : ShapeUpAPI.h
  • MAPSTATE_ADDINGVERTEX : ShapeUpAPI.h
  • MAPSTATE_ADDVERTEX : ShapeUpAPI.h
  • MAPSTATE_ADJUSTINGVERTEX : ShapeUpAPI.h
  • MAPSTATE_ADJUSTVERTEX : ShapeUpAPI.h
  • MAPSTATE_CIRCLESELECT : ShapeUpAPI.h
  • MAPSTATE_CIRCLESELECTTRACKING : ShapeUpAPI.h
  • MAPSTATE_CUSTOM : ShapeUpAPI.h
  • MAPSTATE_DRAWING : ShapeUpAPI.h
  • MAPSTATE_MEASURING : ShapeUpAPI.h
  • MAPSTATE_PAN : ShapeUpAPI.h
  • MAPSTATE_PANNING : ShapeUpAPI.h
  • MAPSTATE_PLUGINSTATEFIRST : ShapeUpAPI.h
  • MAPSTATE_PLUGINSTATELAST : ShapeUpAPI.h
  • MAPSTATE_POLYGONSELECT : ShapeUpAPI.h
  • MAPSTATE_POLYGONSELECTTRACKING : ShapeUpAPI.h
  • MAPSTATE_RECTSELECT : ShapeUpAPI.h
  • MAPSTATE_RECTSELECTTRACKING : ShapeUpAPI.h
  • MAPSTATE_SINGLESELECT : ShapeUpAPI.h
  • MAPSTATE_SPLITOBJECT : ShapeUpAPI.h
  • MAPSTATE_SPLITTINGOBJECT : ShapeUpAPI.h
  • MAPSTATE_ZOOMIN : ShapeUpAPI.h
  • MAPSTATE_ZOOMINTRACKING : ShapeUpAPI.h
  • MAPSTATE_ZOOMOUT : ShapeUpAPI.h
  • MenuItem_SetEnabled() : ShapeUpAPI.h
  • MENUITEMTYPE_ADDNEWLAYER : ShapeUpAPI.h
  • MENUITEMTYPE_ADVANCEDEDIT : ShapeUpAPI.h
  • MENUITEMTYPE_ADVANCEDSELECTION : ShapeUpAPI.h
  • MENUITEMTYPE_COPYSPECIAL : ShapeUpAPI.h
  • MENUITEMTYPE_EXPORTLAYER : ShapeUpAPI.h
  • MENUITEMTYPE_LOADLAYER : ShapeUpAPI.h
  • MENUITEMTYPE_TOOLS : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- a -

  • ATTRIBUTETYPE_BOOL : ShapeUpAPI.h
  • ATTRIBUTETYPE_DATE : ShapeUpAPI.h
  • ATTRIBUTETYPE_DOUBLE : ShapeUpAPI.h
  • ATTRIBUTETYPE_INT : ShapeUpAPI.h
  • ATTRIBUTETYPE_PRIMARYKEY : ShapeUpAPI.h
  • ATTRIBUTETYPE_STRING : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- d -

  • DataPage_GetHWND() : ShapeUpAPI.h
  • DataPage_Remove() : ShapeUpAPI.h
  • DataType : ShapeUpAPI.h
  • DT_BOOL : ShapeUpAPI.h
  • DT_COLOR : ShapeUpAPI.h
  • DT_DOUBLE : ShapeUpAPI.h
  • DT_INT : ShapeUpAPI.h
  • DT_STRING : ShapeUpAPI.h
  • DT_SUHANDLE : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- f -

  • fnGUID() : ShapeUpAPI.h
  • fnInit() : ShapeUpAPI.h
  • fnTerminate() : ShapeUpAPI.h
  • FNTYPE_DATAPAGE_GETHWND : ShapeUpAPI.h
  • FNTYPE_DATAPAGE_REMOVE : ShapeUpAPI.h
  • FNTYPE_JAVASCRIPT_CALLFUNCTION : ShapeUpAPI.h
  • FNTYPE_JAVASCRIPT_CLOSE : ShapeUpAPI.h
  • FNTYPE_JAVASCRIPT_RUN : ShapeUpAPI.h
  • FNTYPE_MAP_CENTERMAP : ShapeUpAPI.h
  • FNTYPE_MAP_DPTOGP : ShapeUpAPI.h
  • FNTYPE_MAP_DRAW : ShapeUpAPI.h
  • FNTYPE_MAP_GETBOUNDS : ShapeUpAPI.h
  • FNTYPE_MAP_GETHWND : ShapeUpAPI.h
  • FNTYPE_MAP_GETINTERACTIONSTATE : ShapeUpAPI.h
  • FNTYPE_MAP_GETVIEWSIZE : ShapeUpAPI.h
  • FNTYPE_MAP_GPTODP : ShapeUpAPI.h
  • FNTYPE_MAP_REPAINT : ShapeUpAPI.h
  • FNTYPE_MAP_SETINTERACTIONSTATE : ShapeUpAPI.h
  • FNTYPE_MAP_ZOOM : ShapeUpAPI.h
  • FNTYPE_MAP_ZOOMTOEXTENT : ShapeUpAPI.h
  • FNTYPE_MAP_ZOOMTOSELECTION : ShapeUpAPI.h
  • FNTYPE_MENUITEM_SETENABLED : ShapeUpAPI.h
  • FNTYPE_RECORDSET_BOF : ShapeUpAPI.h
  • FNTYPE_RECORDSET_CLOSE : ShapeUpAPI.h
  • FNTYPE_RECORDSET_EOF : ShapeUpAPI.h
  • FNTYPE_RECORDSET_FIRST : ShapeUpAPI.h
  • FNTYPE_RECORDSET_GET : ShapeUpAPI.h
  • FNTYPE_RECORDSET_GETCOUNT : ShapeUpAPI.h
  • FNTYPE_RECORDSET_LAST : ShapeUpAPI.h
  • FNTYPE_RECORDSET_NEXT : ShapeUpAPI.h
  • FNTYPE_RECORDSET_PREV : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETATTRIBUTE : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETBOUNDS : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETCLOSESTPOINT : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETCOORDINATE : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETCOORDINATECOUNT : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETPARTCOUNT : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETSHAPEBYTES : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETSHAPETYPE : ShapeUpAPI.h
  • FNTYPE_SHAPE_ISSELECTED : ShapeUpAPI.h
  • FNTYPE_SHAPE_SELECT : ShapeUpAPI.h
  • FNTYPE_SHAPE_SETATTRIBUTE : ShapeUpAPI.h
  • FNTYPE_SHAPE_SETATTRIBUTES : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_ADDHOOK : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_ALLOCATE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_ALLOCATESTATUSBARPANE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_BEGINPROGRESS : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_DEALLOCATE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_ENDPROGRESS : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_GETACTIVEWORKSPACE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_GETERRORDESCRIPTION : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_GETVERSION : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_GETWORKSPACE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_GETWORKSPACECOUNT : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_HASJAVASCRIPTSUPPORT : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_ISVALIDHANDLE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_RELEASESTATUSBARPANE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_REMOVEALLHOOKS : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_REMOVEHOOK : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_SETPROGRESS : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_SETSTATUSBARPANEINFO : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_SETSTATUSBARTEXT : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_WANTUPDATE : ShapeUpAPI.h
  • FNTYPE_THEME_ADDATTRIBUTE : ShapeUpAPI.h
  • FNTYPE_THEME_ADDSHAPE : ShapeUpAPI.h
  • FNTYPE_THEME_BATCHADDSHAPE : ShapeUpAPI.h
  • FNTYPE_THEME_CLEARSELECTION : ShapeUpAPI.h
  • FNTYPE_THEME_DELETEATTRIBUTE : ShapeUpAPI.h
  • FNTYPE_THEME_DELETESHAPE : ShapeUpAPI.h
  • FNTYPE_THEME_GETATTRIBUTECOUNT : ShapeUpAPI.h
  • FNTYPE_THEME_GETATTRIBUTEINDEX : ShapeUpAPI.h
  • FNTYPE_THEME_GETATTRIBUTENAME : ShapeUpAPI.h
  • FNTYPE_THEME_GETATTRIBUTETYPE : ShapeUpAPI.h
  • FNTYPE_THEME_GETBOUNDS : ShapeUpAPI.h
  • FNTYPE_THEME_GETCOMMENT : ShapeUpAPI.h
  • FNTYPE_THEME_GETFILLCOLOR : ShapeUpAPI.h
  • FNTYPE_THEME_GETFONT : ShapeUpAPI.h
  • FNTYPE_THEME_GETINFOTIP : ShapeUpAPI.h
  • FNTYPE_THEME_GETINTERSECTINGSHAPES : ShapeUpAPI.h
  • FNTYPE_THEME_GETNAME : ShapeUpAPI.h
  • FNTYPE_THEME_GETPENCOLOR : ShapeUpAPI.h
  • FNTYPE_THEME_GETPENSTYLE : ShapeUpAPI.h
  • FNTYPE_THEME_GETPENWIDTH : ShapeUpAPI.h
  • FNTYPE_THEME_GETSELECTEDSHAPES : ShapeUpAPI.h
  • FNTYPE_THEME_GETSELECTEDSHAPESINRECT : ShapeUpAPI.h
  • FNTYPE_THEME_GETSELECTIONCOUNT : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPE : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPECOUNT : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPEFROMINDEX : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPESBYQUERY : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPESINRECT : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPETYPE : ShapeUpAPI.h
  • FNTYPE_THEME_INVERTSELECTION : ShapeUpAPI.h
  • FNTYPE_THEME_ISREADONLY : ShapeUpAPI.h
  • FNTYPE_THEME_ISSELECTED : ShapeUpAPI.h
  • FNTYPE_THEME_ISVISIBLE : ShapeUpAPI.h
  • FNTYPE_THEME_LOOKUPWORKSPACE : ShapeUpAPI.h
  • FNTYPE_THEME_RECALCBOUNDS : ShapeUpAPI.h
  • FNTYPE_THEME_REPLACESHAPEDATA : ShapeUpAPI.h
  • FNTYPE_THEME_SELECT : ShapeUpAPI.h
  • FNTYPE_THEME_SETATTRIBUTECOMMENT : ShapeUpAPI.h
  • FNTYPE_THEME_SETCOMMENT : ShapeUpAPI.h
  • FNTYPE_THEME_SETFILLCOLOR : ShapeUpAPI.h
  • FNTYPE_THEME_SETNAME : ShapeUpAPI.h
  • FNTYPE_THEME_SETPENCOLOR : ShapeUpAPI.h
  • FNTYPE_THEME_SETPENSTYLE : ShapeUpAPI.h
  • FNTYPE_THEME_SETPENWIDTH : ShapeUpAPI.h
  • FNTYPE_THEME_SETRASTERIMAGE : ShapeUpAPI.h
  • FNTYPE_THEME_SETSERIALDATA : ShapeUpAPI.h
  • FNTYPE_TOOLBAR_CREATE : ShapeUpAPI.h
  • FNTYPE_TOOLBAR_GETBUTTONCOUNT : ShapeUpAPI.h
  • FNTYPE_TOOLBAR_ISVISIBLE : ShapeUpAPI.h
  • FNTYPE_TOOLBAR_SETBUTTONCHECKED : ShapeUpAPI.h
  • FNTYPE_TOOLBAR_SETBUTTONENABLED : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_ADDDATAPAGE : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_BROWSETHEME : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_CLEARSELECTION : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_CREATENEWTHEME : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_CREATENEWTHEMEFROMSELECTION : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETBOUNDS : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETCOMMENT : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETMAPWINDOW : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETSELECTEDTHEME : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETSELECTEDTHEMES : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETSELECTIONCOUNT : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETTHEME : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETTHEMECOUNT : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_ISACTIVE : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_LOADJAVASCRIPT : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_LOG : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_REFRESH : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_REMOVETHEME : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_SETCOMMENT : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_SETSERIALDATA : ShapeUpAPI.h
  • fnVersion() : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- h -

  • HOOKTYPE_DESERIALIZE : ShapeUpAPI.h
  • HOOKTYPE_FILEFORMATHANDLER : ShapeUpAPI.h
  • HOOKTYPE_IDLE : ShapeUpAPI.h
  • HOOKTYPE_JAVASCRIPTINVOKE : ShapeUpAPI.h
  • HOOKTYPE_LAYERSELCHANGE : ShapeUpAPI.h
  • HOOKTYPE_LBUTTONDOWN : ShapeUpAPI.h
  • HOOKTYPE_LBUTTONUP : ShapeUpAPI.h
  • HOOKTYPE_MENUITEM : ShapeUpAPI.h
  • HOOKTYPE_MOUSEMOVE : ShapeUpAPI.h
  • HOOKTYPE_POSTDRAW : ShapeUpAPI.h
  • HOOKTYPE_PRECLOSEWORKSPACE : ShapeUpAPI.h
  • HOOKTYPE_PREREMOVESHAPE : ShapeUpAPI.h
  • HOOKTYPE_PREREMOVETHEME : ShapeUpAPI.h
  • HOOKTYPE_SHAPESELCHANGE : ShapeUpAPI.h
  • HOOKTYPE_TOOLBARBUTTON : ShapeUpAPI.h
  • HOOKTYPE_WANTUPDATE : ShapeUpAPI.h
  • HOOKTYPE_WORKSPACEREADY : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- p -

  • PENSTYLE_DASH : ShapeUpAPI.h
  • PENSTYLE_DASHDOT : ShapeUpAPI.h
  • PENSTYLE_DASHDOTDOT : ShapeUpAPI.h
  • PENSTYLE_DOT : ShapeUpAPI.h
  • PENSTYLE_SOLID : ShapeUpAPI.h
  • PFNSETTINGS : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- r -

  • Recordset_Bof() : ShapeUpAPI.h
  • Recordset_Close() : ShapeUpAPI.h
  • Recordset_Eof() : ShapeUpAPI.h
  • Recordset_First() : ShapeUpAPI.h
  • Recordset_Get() : ShapeUpAPI.h
  • Recordset_GetCount() : ShapeUpAPI.h
  • Recordset_Last() : ShapeUpAPI.h
  • Recordset_Next() : ShapeUpAPI.h
  • Recordset_Prev() : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- s -

  • Shape_GetAttribute() : ShapeUpAPI.h
  • Shape_GetBounds() : ShapeUpAPI.h
  • Shape_GetClosestPoint() : ShapeUpAPI.h
  • Shape_GetCoordinate() : ShapeUpAPI.h
  • Shape_GetCoordinateCount() : ShapeUpAPI.h
  • Shape_GetPartCount() : ShapeUpAPI.h
  • Shape_GetShapeBytes() : ShapeUpAPI.h
  • Shape_GetShapeType() : ShapeUpAPI.h
  • Shape_IsSelected() : ShapeUpAPI.h
  • Shape_Select() : ShapeUpAPI.h
  • Shape_SetAttribute() : ShapeUpAPI.h
  • Shape_SetAttributes() : ShapeUpAPI.h
  • ShapeUp_AddAdvancedEditHook() : ShapeUpAPI.h
  • ShapeUp_AddAdvancedSelectionHook() : ShapeUpAPI.h
  • ShapeUp_AddCopySpecialHook() : ShapeUpAPI.h
  • ShapeUp_AddDeserializeHook() : ShapeUpAPI.h
  • ShapeUp_AddExportLayerHook() : ShapeUpAPI.h
  • ShapeUp_AddFileFormatHandlerHook() : ShapeUpAPI.h
  • ShapeUp_AddIdleHook() : ShapeUpAPI.h
  • ShapeUp_AddJavaScriptInvokeHook() : ShapeUpAPI.h
  • ShapeUp_AddLayerSelectionChangedHook() : ShapeUpAPI.h
  • ShapeUp_AddLButtonDownHook() : ShapeUpAPI.h
  • ShapeUp_AddLButtonUpHook() : ShapeUpAPI.h
  • ShapeUp_AddLoadLayerHook() : ShapeUpAPI.h
  • ShapeUp_AddMouseMoveHook() : ShapeUpAPI.h
  • ShapeUp_AddNewLayerHook() : ShapeUpAPI.h
  • ShapeUp_AddPostDrawHook() : ShapeUpAPI.h
  • ShapeUp_AddRemoveLayerHook() : ShapeUpAPI.h
  • ShapeUp_AddRemoveShapeHook() : ShapeUpAPI.h
  • ShapeUp_AddShapeSelectionChangedHook() : ShapeUpAPI.h
  • ShapeUp_AddSimpleHook_Helper() : ShapeUpAPI.h
  • ShapeUp_AddToolBarButtonHook() : ShapeUpAPI.h
  • ShapeUp_AddToolsHook() : ShapeUpAPI.h
  • ShapeUp_AddWorkspaceReadyHook() : ShapeUpAPI.h
  • ShapeUp_Allocate() : ShapeUpAPI.h
  • ShapeUp_AllocateStatusBarPane() : ShapeUpAPI.h
  • SHAPEUP_API_VERSION : ShapeUpAPI.h
  • ShapeUp_BeginProgress() : ShapeUpAPI.h
  • ShapeUp_Deallocate() : ShapeUpAPI.h
  • ShapeUp_DuplicateString() : ShapeUpAPI.h
  • ShapeUp_EndProgress() : ShapeUpAPI.h
  • ShapeUp_GetActiveWorkspace() : ShapeUpAPI.h
  • ShapeUp_GetErrorDescription() : ShapeUpAPI.h
  • ShapeUp_GetVersion() : ShapeUpAPI.h
  • ShapeUp_GetWorkspace() : ShapeUpAPI.h
  • ShapeUp_GetWorkspaceCount() : ShapeUpAPI.h
  • ShapeUp_HasJavaScriptSupport() : ShapeUpAPI.h
  • ShapeUp_IsValidHandle() : ShapeUpAPI.h
  • ShapeUp_ReleaseStatusBarPane() : ShapeUpAPI.h
  • ShapeUp_RemoveAllHooks() : ShapeUpAPI.h
  • ShapeUp_RemoveHook_Helper() : ShapeUpAPI.h
  • ShapeUp_RemoveLayerSelectionChangedHook() : ShapeUpAPI.h
  • ShapeUp_RemoveMouseMoveHook() : ShapeUpAPI.h
  • ShapeUp_RemoveShapeSelectionChangedHook() : ShapeUpAPI.h
  • ShapeUp_SetProgress() : ShapeUpAPI.h
  • ShapeUp_SetStatusBarPaneInfo() : ShapeUpAPI.h
  • ShapeUp_SetStatusBarText() : ShapeUpAPI.h
  • ShapeUp_WantUpdate() : ShapeUpAPI.h
  • SUAddFileFormatHandlerHookData : ShapeUpAPI.h
  • SUAddJavaScriptInvokeHookData : ShapeUpAPI.h
  • SUAddMenuItemHookData : ShapeUpAPI.h
  • suapi : ShapeUpAPI.h
  • SUARGAddAttribute : ShapeUpAPI.h
  • SUARGAddDataPage : ShapeUpAPI.h
  • SUARGAddHook : ShapeUpAPI.h
  • SUARGAddShape : ShapeUpAPI.h
  • SUARGAllocate : ShapeUpAPI.h
  • SUARGAllocateStatusBarPane : ShapeUpAPI.h
  • SUARGBatchAddShape : ShapeUpAPI.h
  • SUARGBeginProgress : ShapeUpAPI.h
  • SUARGBrowseTheme : ShapeUpAPI.h
  • SUARGCreateNewTheme : ShapeUpAPI.h
  • SUARGCreateNewThemeFromSelection : ShapeUpAPI.h
  • SUARGCreateToolBar : ShapeUpAPI.h
  • SUARGDeleteAttribute : ShapeUpAPI.h
  • SUARGDeleteShape : ShapeUpAPI.h
  • SUARGDPtoGP : ShapeUpAPI.h
  • SUARGDraw : ShapeUpAPI.h
  • SUARGGetAttribute : ShapeUpAPI.h
  • SUARGGetAttributeIndex : ShapeUpAPI.h
  • SUARGGetAttributeType : ShapeUpAPI.h
  • SUARGGetBOOL : ShapeUpAPI.h
  • SUARGGetBounds : ShapeUpAPI.h
  • SUARGGetClosestPoint : ShapeUpAPI.h
  • SUARGGetColor : ShapeUpAPI.h
  • SUARGGetCoordinate : ShapeUpAPI.h
  • SUARGGetDWORD : ShapeUpAPI.h
  • SUARGGetErrorDescription : ShapeUpAPI.h
  • SUARGGetFont : ShapeUpAPI.h
  • SUARGGetHandle : ShapeUpAPI.h
  • SUARGGetHandleByIndex : ShapeUpAPI.h
  • SUARGGetHWND : ShapeUpAPI.h
  • SUARGGetInfoTip : ShapeUpAPI.h
  • SUARGGetInteractionState : ShapeUpAPI.h
  • SUARGGetIntersectingShapes : ShapeUpAPI.h
  • SUARGGetShapeBytes : ShapeUpAPI.h
  • SUARGGetShapesByQuery : ShapeUpAPI.h
  • SUARGGetShapesInRect : ShapeUpAPI.h
  • SUARGGetShapeType : ShapeUpAPI.h
  • SUARGGetSize : ShapeUpAPI.h
  • SUARGGetText : ShapeUpAPI.h
  • SUARGGetTextByIndex : ShapeUpAPI.h
  • SUARGGetUnsigned : ShapeUpAPI.h
  • SUARGGetUnsignedByIndex : ShapeUpAPI.h
  • SUARGGetWorkspace : ShapeUpAPI.h
  • SUARGGPtoDP : ShapeUpAPI.h
  • SUARGIsShapeSelected : ShapeUpAPI.h
  • SUARGJSCallFunction : ShapeUpAPI.h
  • SUARGLoadJavaScript : ShapeUpAPI.h
  • SUARGLog : ShapeUpAPI.h
  • SUARGRemoveHook : ShapeUpAPI.h
  • SUARGRemoveTheme : ShapeUpAPI.h
  • SUARGRepaint : ShapeUpAPI.h
  • SUARGReplaceShapeData : ShapeUpAPI.h
  • SUARGSelectShape : ShapeUpAPI.h
  • SUARGSetAttribute : ShapeUpAPI.h
  • SUARGSetAttributes : ShapeUpAPI.h
  • SUARGSetBOOL : ShapeUpAPI.h
  • SUARGSetButtonBOOL : ShapeUpAPI.h
  • SUARGSetColor : ShapeUpAPI.h
  • SUARGSetDouble : ShapeUpAPI.h
  • SUARGSetDWORD : ShapeUpAPI.h
  • SUARGSetFloat : ShapeUpAPI.h
  • SUARGSetInteractionState : ShapeUpAPI.h
  • SUARGSetPoint : ShapeUpAPI.h
  • SUARGSetRasterImage : ShapeUpAPI.h
  • SUARGSetSerialData : ShapeUpAPI.h
  • SUARGSetStatusBarPaneInfo : ShapeUpAPI.h
  • SUARGSetText : ShapeUpAPI.h
  • SUARGSetTextByIndex : ShapeUpAPI.h
  • SUARGSetUnsigned : ShapeUpAPI.h
  • SUARGWantUpdate : ShapeUpAPI.h
  • SUARGZoomToExtent : ShapeUpAPI.h
  • SUARGZoomToSelection : ShapeUpAPI.h
  • SUCall : ShapeUpAPI.h
  • SUDeserializeHookData : ShapeUpAPI.h
  • SUExport : ShapeUpAPI.h
  • SUFileFormatHandlerHookData : ShapeUpAPI.h
  • SUHANDLE : ShapeUpAPI.h
  • SUHookData : ShapeUpAPI.h
  • SUHOOKFUNC : ShapeUpAPI.h
  • SUImport : ShapeUpAPI.h
  • SUJavaScriptArgument : ShapeUpAPI.h
  • SUJavaScriptInvokeHookData : ShapeUpAPI.h
  • SUMenuItemHookData : ShapeUpAPI.h
  • SUMouseHookData : ShapeUpAPI.h
  • SUPreRemoveShapeHookData : ShapeUpAPI.h
  • SUPreRemoveThemeHookData : ShapeUpAPI.h
  • SURESULT : ShapeUpAPI.h
  • SURESULT_E_BUFFEROVERFLOW : ShapeUpAPI.h
  • SURESULT_E_ILLEGALPARAM : ShapeUpAPI.h
  • SURESULT_E_INDEXOUTOFBOUNDS : ShapeUpAPI.h
  • SURESULT_E_INVALIDHANDLE : ShapeUpAPI.h
  • SURESULT_E_INVALIDQUERY : ShapeUpAPI.h
  • SURESULT_E_NOSUCHERROR : ShapeUpAPI.h
  • SURESULT_E_NOTIMPLEMENTED : ShapeUpAPI.h
  • SURESULT_E_OUTOFRESOURCES : ShapeUpAPI.h
  • SURESULT_E_PERMISSIONDENIED : ShapeUpAPI.h
  • SURESULT_E_SCRIPTERROR : ShapeUpAPI.h
  • SURESULT_E_UNEXPECTEDSHAPETYPE : ShapeUpAPI.h
  • SURESULT_E_UNKNOWNHOOKTYPE : ShapeUpAPI.h
  • SURESULT_E_UNSUPPORTEDSHAPETYPE : ShapeUpAPI.h
  • SURESULT_FALSE : ShapeUpAPI.h
  • SURESULT_OK : ShapeUpAPI.h
  • SUShapeSelChangeHookData : ShapeUpAPI.h
  • SUToolBarButtonHookData : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- t -

  • tagDataType : ShapeUpAPI.h
  • Theme_AddAttribute() : ShapeUpAPI.h
  • Theme_AddShape() : ShapeUpAPI.h
  • Theme_BatchAddShapeBegin() : ShapeUpAPI.h
  • Theme_BatchAddShapeEnd() : ShapeUpAPI.h
  • Theme_ClearSelection() : ShapeUpAPI.h
  • Theme_DeleteAttribute() : ShapeUpAPI.h
  • Theme_DeleteShape() : ShapeUpAPI.h
  • Theme_GetAttributeCount() : ShapeUpAPI.h
  • Theme_GetAttributeIndex() : ShapeUpAPI.h
  • Theme_GetAttributeName() : ShapeUpAPI.h
  • Theme_GetAttributeType() : ShapeUpAPI.h
  • Theme_GetBounds() : ShapeUpAPI.h
  • Theme_GetComment() : ShapeUpAPI.h
  • Theme_GetFillColor() : ShapeUpAPI.h
  • Theme_GetFont() : ShapeUpAPI.h
  • Theme_GetInfoTip() : ShapeUpAPI.h
  • Theme_GetIntersectingShapes() : ShapeUpAPI.h
  • Theme_GetName() : ShapeUpAPI.h
  • Theme_GetPenColor() : ShapeUpAPI.h
  • Theme_GetPenStyle() : ShapeUpAPI.h
  • Theme_GetPenWidth() : ShapeUpAPI.h
  • Theme_GetSelectedShapes() : ShapeUpAPI.h
  • Theme_GetSelectedShapesInRect() : ShapeUpAPI.h
  • Theme_GetSelectionCount() : ShapeUpAPI.h
  • Theme_GetShape() : ShapeUpAPI.h
  • Theme_GetShapeCount() : ShapeUpAPI.h
  • Theme_GetShapeFromIndex() : ShapeUpAPI.h
  • Theme_GetShapesByQuery() : ShapeUpAPI.h
  • Theme_GetShapesInRect() : ShapeUpAPI.h
  • Theme_GetShapeType() : ShapeUpAPI.h
  • Theme_InvertSelection() : ShapeUpAPI.h
  • Theme_IsReadOnly() : ShapeUpAPI.h
  • Theme_IsSelected() : ShapeUpAPI.h
  • Theme_IsVisible() : ShapeUpAPI.h
  • Theme_LookupWorkspace() : ShapeUpAPI.h
  • Theme_RecalcBounds() : ShapeUpAPI.h
  • Theme_ReplaceShapeData() : ShapeUpAPI.h
  • Theme_Select() : ShapeUpAPI.h
  • Theme_SetAttributeComment() : ShapeUpAPI.h
  • Theme_SetComment() : ShapeUpAPI.h
  • Theme_SetFillColor() : ShapeUpAPI.h
  • Theme_SetName() : ShapeUpAPI.h
  • Theme_SetPenColor() : ShapeUpAPI.h
  • Theme_SetPenStyle() : ShapeUpAPI.h
  • Theme_SetPenWidth() : ShapeUpAPI.h
  • Theme_SetRasterImage() : ShapeUpAPI.h
  • Theme_SetSerialData() : ShapeUpAPI.h
  • ToolBar_Create() : ShapeUpAPI.h
  • ToolBar_GetButtonCount() : ShapeUpAPI.h
  • ToolBar_IsVisible() : ShapeUpAPI.h
  • ToolBar_SetButtonChecked() : ShapeUpAPI.h
  • ToolBar_SetButtonEnabled() : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • d
  • f
  • h
  • j
  • m
  • p
  • r
  • s
  • t
  • w

Here is a list of all file members with links to the files they belong to:

- w -

  • Workspace_AddDataPage() : ShapeUpAPI.h
  • Workspace_BrowseTheme() : ShapeUpAPI.h
  • Workspace_ClearSelection() : ShapeUpAPI.h
  • Workspace_CreateNewTheme() : ShapeUpAPI.h
  • Workspace_CreateNewThemeFromSelection() : ShapeUpAPI.h
  • Workspace_GetBounds() : ShapeUpAPI.h
  • Workspace_GetComment() : ShapeUpAPI.h
  • Workspace_GetMapWindow() : ShapeUpAPI.h
  • Workspace_GetSelectedTheme() : ShapeUpAPI.h
  • Workspace_GetSelectedThemes() : ShapeUpAPI.h
  • Workspace_GetSelectionCount() : ShapeUpAPI.h
  • Workspace_GetTheme() : ShapeUpAPI.h
  • Workspace_GetThemeCount() : ShapeUpAPI.h
  • Workspace_IsActive() : ShapeUpAPI.h
  • Workspace_LoadJavaScript() : ShapeUpAPI.h
  • Workspace_Log() : ShapeUpAPI.h
  • Workspace_Refresh() : ShapeUpAPI.h
  • Workspace_RemoveTheme() : ShapeUpAPI.h
  • Workspace_SetComment() : ShapeUpAPI.h
  • Workspace_SetSerialData() : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • f
  • h
  • j
  • m
  • p
  • s

- _ -

  • __FNTYPE_COUNT__ : ShapeUpAPI.h
  • __FNTYPE_NIL__ : ShapeUpAPI.h
  • __HOOKTYPE_COUNT__ : ShapeUpAPI.h
  • __HOOKTYPE_NIL__ : ShapeUpAPI.h
  • __MAPSTATE_COUNT__ : ShapeUpAPI.h
  • __MAPSTATE_NIL__ : ShapeUpAPI.h
  • __MENUITEMTYPE_COUNT__ : ShapeUpAPI.h
  • __MENUITEMTYPE_NIL__ : ShapeUpAPI.h
  • __PENSTYLE_COUNT__ : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • f
  • h
  • j
  • m
  • p
  • s

- j -

  • JSIHDF_DEFAULT : ShapeUpAPI.h
  • JSIHDF_TREATRETURNASSINGLEVALUE : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:40 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • f
  • h
  • j
  • m
  • p
  • s

- m -

  • MAPSTATE_ADDINGVERTEX : ShapeUpAPI.h
  • MAPSTATE_ADDVERTEX : ShapeUpAPI.h
  • MAPSTATE_ADJUSTINGVERTEX : ShapeUpAPI.h
  • MAPSTATE_ADJUSTVERTEX : ShapeUpAPI.h
  • MAPSTATE_CIRCLESELECT : ShapeUpAPI.h
  • MAPSTATE_CIRCLESELECTTRACKING : ShapeUpAPI.h
  • MAPSTATE_CUSTOM : ShapeUpAPI.h
  • MAPSTATE_DRAWING : ShapeUpAPI.h
  • MAPSTATE_MEASURING : ShapeUpAPI.h
  • MAPSTATE_PAN : ShapeUpAPI.h
  • MAPSTATE_PANNING : ShapeUpAPI.h
  • MAPSTATE_PLUGINSTATEFIRST : ShapeUpAPI.h
  • MAPSTATE_PLUGINSTATELAST : ShapeUpAPI.h
  • MAPSTATE_POLYGONSELECT : ShapeUpAPI.h
  • MAPSTATE_POLYGONSELECTTRACKING : ShapeUpAPI.h
  • MAPSTATE_RECTSELECT : ShapeUpAPI.h
  • MAPSTATE_RECTSELECTTRACKING : ShapeUpAPI.h
  • MAPSTATE_SINGLESELECT : ShapeUpAPI.h
  • MAPSTATE_SPLITOBJECT : ShapeUpAPI.h
  • MAPSTATE_SPLITTINGOBJECT : ShapeUpAPI.h
  • MAPSTATE_ZOOMIN : ShapeUpAPI.h
  • MAPSTATE_ZOOMINTRACKING : ShapeUpAPI.h
  • MAPSTATE_ZOOMOUT : ShapeUpAPI.h
  • MENUITEMTYPE_ADDNEWLAYER : ShapeUpAPI.h
  • MENUITEMTYPE_ADVANCEDEDIT : ShapeUpAPI.h
  • MENUITEMTYPE_ADVANCEDSELECTION : ShapeUpAPI.h
  • MENUITEMTYPE_COPYSPECIAL : ShapeUpAPI.h
  • MENUITEMTYPE_EXPORTLAYER : ShapeUpAPI.h
  • MENUITEMTYPE_LOADLAYER : ShapeUpAPI.h
  • MENUITEMTYPE_TOOLS : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:40 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • f
  • h
  • j
  • m
  • p
  • s

- a -

  • ATTRIBUTETYPE_BOOL : ShapeUpAPI.h
  • ATTRIBUTETYPE_DATE : ShapeUpAPI.h
  • ATTRIBUTETYPE_DOUBLE : ShapeUpAPI.h
  • ATTRIBUTETYPE_INT : ShapeUpAPI.h
  • ATTRIBUTETYPE_PRIMARYKEY : ShapeUpAPI.h
  • ATTRIBUTETYPE_STRING : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:40 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • f
  • h
  • j
  • m
  • p
  • s

- f -

  • FNTYPE_DATAPAGE_GETHWND : ShapeUpAPI.h
  • FNTYPE_DATAPAGE_REMOVE : ShapeUpAPI.h
  • FNTYPE_JAVASCRIPT_CALLFUNCTION : ShapeUpAPI.h
  • FNTYPE_JAVASCRIPT_CLOSE : ShapeUpAPI.h
  • FNTYPE_JAVASCRIPT_RUN : ShapeUpAPI.h
  • FNTYPE_MAP_CENTERMAP : ShapeUpAPI.h
  • FNTYPE_MAP_DPTOGP : ShapeUpAPI.h
  • FNTYPE_MAP_DRAW : ShapeUpAPI.h
  • FNTYPE_MAP_GETBOUNDS : ShapeUpAPI.h
  • FNTYPE_MAP_GETHWND : ShapeUpAPI.h
  • FNTYPE_MAP_GETINTERACTIONSTATE : ShapeUpAPI.h
  • FNTYPE_MAP_GETVIEWSIZE : ShapeUpAPI.h
  • FNTYPE_MAP_GPTODP : ShapeUpAPI.h
  • FNTYPE_MAP_REPAINT : ShapeUpAPI.h
  • FNTYPE_MAP_SETINTERACTIONSTATE : ShapeUpAPI.h
  • FNTYPE_MAP_ZOOM : ShapeUpAPI.h
  • FNTYPE_MAP_ZOOMTOEXTENT : ShapeUpAPI.h
  • FNTYPE_MAP_ZOOMTOSELECTION : ShapeUpAPI.h
  • FNTYPE_MENUITEM_SETENABLED : ShapeUpAPI.h
  • FNTYPE_RECORDSET_BOF : ShapeUpAPI.h
  • FNTYPE_RECORDSET_CLOSE : ShapeUpAPI.h
  • FNTYPE_RECORDSET_EOF : ShapeUpAPI.h
  • FNTYPE_RECORDSET_FIRST : ShapeUpAPI.h
  • FNTYPE_RECORDSET_GET : ShapeUpAPI.h
  • FNTYPE_RECORDSET_GETCOUNT : ShapeUpAPI.h
  • FNTYPE_RECORDSET_LAST : ShapeUpAPI.h
  • FNTYPE_RECORDSET_NEXT : ShapeUpAPI.h
  • FNTYPE_RECORDSET_PREV : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETATTRIBUTE : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETBOUNDS : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETCLOSESTPOINT : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETCOORDINATE : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETCOORDINATECOUNT : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETPARTCOUNT : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETSHAPEBYTES : ShapeUpAPI.h
  • FNTYPE_SHAPE_GETSHAPETYPE : ShapeUpAPI.h
  • FNTYPE_SHAPE_ISSELECTED : ShapeUpAPI.h
  • FNTYPE_SHAPE_SELECT : ShapeUpAPI.h
  • FNTYPE_SHAPE_SETATTRIBUTE : ShapeUpAPI.h
  • FNTYPE_SHAPE_SETATTRIBUTES : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_ADDHOOK : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_ALLOCATE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_ALLOCATESTATUSBARPANE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_BEGINPROGRESS : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_DEALLOCATE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_ENDPROGRESS : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_GETACTIVEWORKSPACE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_GETERRORDESCRIPTION : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_GETVERSION : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_GETWORKSPACE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_GETWORKSPACECOUNT : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_HASJAVASCRIPTSUPPORT : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_ISVALIDHANDLE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_RELEASESTATUSBARPANE : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_REMOVEALLHOOKS : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_REMOVEHOOK : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_SETPROGRESS : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_SETSTATUSBARPANEINFO : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_SETSTATUSBARTEXT : ShapeUpAPI.h
  • FNTYPE_SHAPEUP_WANTUPDATE : ShapeUpAPI.h
  • FNTYPE_THEME_ADDATTRIBUTE : ShapeUpAPI.h
  • FNTYPE_THEME_ADDSHAPE : ShapeUpAPI.h
  • FNTYPE_THEME_BATCHADDSHAPE : ShapeUpAPI.h
  • FNTYPE_THEME_CLEARSELECTION : ShapeUpAPI.h
  • FNTYPE_THEME_DELETEATTRIBUTE : ShapeUpAPI.h
  • FNTYPE_THEME_DELETESHAPE : ShapeUpAPI.h
  • FNTYPE_THEME_GETATTRIBUTECOUNT : ShapeUpAPI.h
  • FNTYPE_THEME_GETATTRIBUTEINDEX : ShapeUpAPI.h
  • FNTYPE_THEME_GETATTRIBUTENAME : ShapeUpAPI.h
  • FNTYPE_THEME_GETATTRIBUTETYPE : ShapeUpAPI.h
  • FNTYPE_THEME_GETBOUNDS : ShapeUpAPI.h
  • FNTYPE_THEME_GETCOMMENT : ShapeUpAPI.h
  • FNTYPE_THEME_GETFILLCOLOR : ShapeUpAPI.h
  • FNTYPE_THEME_GETFONT : ShapeUpAPI.h
  • FNTYPE_THEME_GETINFOTIP : ShapeUpAPI.h
  • FNTYPE_THEME_GETINTERSECTINGSHAPES : ShapeUpAPI.h
  • FNTYPE_THEME_GETNAME : ShapeUpAPI.h
  • FNTYPE_THEME_GETPENCOLOR : ShapeUpAPI.h
  • FNTYPE_THEME_GETPENSTYLE : ShapeUpAPI.h
  • FNTYPE_THEME_GETPENWIDTH : ShapeUpAPI.h
  • FNTYPE_THEME_GETSELECTEDSHAPES : ShapeUpAPI.h
  • FNTYPE_THEME_GETSELECTEDSHAPESINRECT : ShapeUpAPI.h
  • FNTYPE_THEME_GETSELECTIONCOUNT : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPE : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPECOUNT : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPEFROMINDEX : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPESBYQUERY : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPESINRECT : ShapeUpAPI.h
  • FNTYPE_THEME_GETSHAPETYPE : ShapeUpAPI.h
  • FNTYPE_THEME_INVERTSELECTION : ShapeUpAPI.h
  • FNTYPE_THEME_ISREADONLY : ShapeUpAPI.h
  • FNTYPE_THEME_ISSELECTED : ShapeUpAPI.h
  • FNTYPE_THEME_ISVISIBLE : ShapeUpAPI.h
  • FNTYPE_THEME_LOOKUPWORKSPACE : ShapeUpAPI.h
  • FNTYPE_THEME_RECALCBOUNDS : ShapeUpAPI.h
  • FNTYPE_THEME_REPLACESHAPEDATA : ShapeUpAPI.h
  • FNTYPE_THEME_SELECT : ShapeUpAPI.h
  • FNTYPE_THEME_SETATTRIBUTECOMMENT : ShapeUpAPI.h
  • FNTYPE_THEME_SETCOMMENT : ShapeUpAPI.h
  • FNTYPE_THEME_SETFILLCOLOR : ShapeUpAPI.h
  • FNTYPE_THEME_SETNAME : ShapeUpAPI.h
  • FNTYPE_THEME_SETPENCOLOR : ShapeUpAPI.h
  • FNTYPE_THEME_SETPENSTYLE : ShapeUpAPI.h
  • FNTYPE_THEME_SETPENWIDTH : ShapeUpAPI.h
  • FNTYPE_THEME_SETRASTERIMAGE : ShapeUpAPI.h
  • FNTYPE_THEME_SETSERIALDATA : ShapeUpAPI.h
  • FNTYPE_TOOLBAR_CREATE : ShapeUpAPI.h
  • FNTYPE_TOOLBAR_GETBUTTONCOUNT : ShapeUpAPI.h
  • FNTYPE_TOOLBAR_ISVISIBLE : ShapeUpAPI.h
  • FNTYPE_TOOLBAR_SETBUTTONCHECKED : ShapeUpAPI.h
  • FNTYPE_TOOLBAR_SETBUTTONENABLED : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_ADDDATAPAGE : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_BROWSETHEME : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_CLEARSELECTION : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_CREATENEWTHEME : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_CREATENEWTHEMEFROMSELECTION : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETBOUNDS : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETCOMMENT : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETMAPWINDOW : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETSELECTEDTHEME : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETSELECTEDTHEMES : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETSELECTIONCOUNT : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETTHEME : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_GETTHEMECOUNT : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_ISACTIVE : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_LOADJAVASCRIPT : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_LOG : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_REFRESH : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_REMOVETHEME : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_SETCOMMENT : ShapeUpAPI.h
  • FNTYPE_WORKSPACE_SETSERIALDATA : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:40 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • f
  • h
  • j
  • m
  • p
  • s

- h -

  • HOOKTYPE_DESERIALIZE : ShapeUpAPI.h
  • HOOKTYPE_FILEFORMATHANDLER : ShapeUpAPI.h
  • HOOKTYPE_IDLE : ShapeUpAPI.h
  • HOOKTYPE_JAVASCRIPTINVOKE : ShapeUpAPI.h
  • HOOKTYPE_LAYERSELCHANGE : ShapeUpAPI.h
  • HOOKTYPE_LBUTTONDOWN : ShapeUpAPI.h
  • HOOKTYPE_LBUTTONUP : ShapeUpAPI.h
  • HOOKTYPE_MENUITEM : ShapeUpAPI.h
  • HOOKTYPE_MOUSEMOVE : ShapeUpAPI.h
  • HOOKTYPE_POSTDRAW : ShapeUpAPI.h
  • HOOKTYPE_PRECLOSEWORKSPACE : ShapeUpAPI.h
  • HOOKTYPE_PREREMOVESHAPE : ShapeUpAPI.h
  • HOOKTYPE_PREREMOVETHEME : ShapeUpAPI.h
  • HOOKTYPE_SHAPESELCHANGE : ShapeUpAPI.h
  • HOOKTYPE_TOOLBARBUTTON : ShapeUpAPI.h
  • HOOKTYPE_WANTUPDATE : ShapeUpAPI.h
  • HOOKTYPE_WORKSPACEREADY : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:40 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • f
  • h
  • j
  • m
  • p
  • s

- p -

  • PENSTYLE_DASH : ShapeUpAPI.h
  • PENSTYLE_DASHDOT : ShapeUpAPI.h
  • PENSTYLE_DASHDOTDOT : ShapeUpAPI.h
  • PENSTYLE_DOT : ShapeUpAPI.h
  • PENSTYLE_SOLID : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:40 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • f
  • h
  • j
  • m
  • p
  • s

- s -

  • SHAPEUP_API_VERSION : ShapeUpAPI.h
  • SURESULT_E_BUFFEROVERFLOW : ShapeUpAPI.h
  • SURESULT_E_ILLEGALPARAM : ShapeUpAPI.h
  • SURESULT_E_INDEXOUTOFBOUNDS : ShapeUpAPI.h
  • SURESULT_E_INVALIDHANDLE : ShapeUpAPI.h
  • SURESULT_E_INVALIDQUERY : ShapeUpAPI.h
  • SURESULT_E_NOSUCHERROR : ShapeUpAPI.h
  • SURESULT_E_NOTIMPLEMENTED : ShapeUpAPI.h
  • SURESULT_E_OUTOFRESOURCES : ShapeUpAPI.h
  • SURESULT_E_PERMISSIONDENIED : ShapeUpAPI.h
  • SURESULT_E_SCRIPTERROR : ShapeUpAPI.h
  • SURESULT_E_UNEXPECTEDSHAPETYPE : ShapeUpAPI.h
  • SURESULT_E_UNKNOWNHOOKTYPE : ShapeUpAPI.h
  • SURESULT_E_UNSUPPORTEDSHAPETYPE : ShapeUpAPI.h
  • SURESULT_FALSE : ShapeUpAPI.h
  • SURESULT_OK : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:40 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • tagDataType : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • DT_BOOL : ShapeUpAPI.h
  • DT_COLOR : ShapeUpAPI.h
  • DT_DOUBLE : ShapeUpAPI.h
  • DT_INT : ShapeUpAPI.h
  • DT_STRING : ShapeUpAPI.h
  • DT_SUHANDLE : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • d
  • f
  • j
  • m
  • r
  • s
  • t
  • w

- d -

  • DataPage_GetHWND() : ShapeUpAPI.h
  • DataPage_Remove() : ShapeUpAPI.h

- f -

  • fnGUID() : ShapeUpAPI.h
  • fnInit() : ShapeUpAPI.h
  • fnTerminate() : ShapeUpAPI.h
  • fnVersion() : ShapeUpAPI.h

- j -

  • JavaScript_CallFunction() : ShapeUpAPI.h
  • JavaScript_Close() : ShapeUpAPI.h
  • JavaScript_Run() : ShapeUpAPI.h

- m -

  • Map_CenterMap() : ShapeUpAPI.h
  • Map_DPtoGP() : ShapeUpAPI.h
  • Map_Draw() : ShapeUpAPI.h
  • Map_GetBounds() : ShapeUpAPI.h
  • Map_GetHWND() : ShapeUpAPI.h
  • Map_GetInteractionState() : ShapeUpAPI.h
  • Map_GetViewSize() : ShapeUpAPI.h
  • Map_GPtoDP() : ShapeUpAPI.h
  • Map_Repaint() : ShapeUpAPI.h
  • Map_SetInteractionState() : ShapeUpAPI.h
  • Map_Zoom() : ShapeUpAPI.h
  • Map_ZoomToExtent() : ShapeUpAPI.h
  • Map_ZoomToSelection() : ShapeUpAPI.h
  • MenuItem_SetEnabled() : ShapeUpAPI.h

- r -

  • Recordset_Bof() : ShapeUpAPI.h
  • Recordset_Close() : ShapeUpAPI.h
  • Recordset_Eof() : ShapeUpAPI.h
  • Recordset_First() : ShapeUpAPI.h
  • Recordset_Get() : ShapeUpAPI.h
  • Recordset_GetCount() : ShapeUpAPI.h
  • Recordset_Last() : ShapeUpAPI.h
  • Recordset_Next() : ShapeUpAPI.h
  • Recordset_Prev() : ShapeUpAPI.h

- s -

  • Shape_GetAttribute() : ShapeUpAPI.h
  • Shape_GetBounds() : ShapeUpAPI.h
  • Shape_GetClosestPoint() : ShapeUpAPI.h
  • Shape_GetCoordinate() : ShapeUpAPI.h
  • Shape_GetCoordinateCount() : ShapeUpAPI.h
  • Shape_GetPartCount() : ShapeUpAPI.h
  • Shape_GetShapeBytes() : ShapeUpAPI.h
  • Shape_GetShapeType() : ShapeUpAPI.h
  • Shape_IsSelected() : ShapeUpAPI.h
  • Shape_Select() : ShapeUpAPI.h
  • Shape_SetAttribute() : ShapeUpAPI.h
  • Shape_SetAttributes() : ShapeUpAPI.h
  • ShapeUp_AddAdvancedEditHook() : ShapeUpAPI.h
  • ShapeUp_AddAdvancedSelectionHook() : ShapeUpAPI.h
  • ShapeUp_AddCopySpecialHook() : ShapeUpAPI.h
  • ShapeUp_AddDeserializeHook() : ShapeUpAPI.h
  • ShapeUp_AddExportLayerHook() : ShapeUpAPI.h
  • ShapeUp_AddFileFormatHandlerHook() : ShapeUpAPI.h
  • ShapeUp_AddIdleHook() : ShapeUpAPI.h
  • ShapeUp_AddJavaScriptInvokeHook() : ShapeUpAPI.h
  • ShapeUp_AddLayerSelectionChangedHook() : ShapeUpAPI.h
  • ShapeUp_AddLButtonDownHook() : ShapeUpAPI.h
  • ShapeUp_AddLButtonUpHook() : ShapeUpAPI.h
  • ShapeUp_AddLoadLayerHook() : ShapeUpAPI.h
  • ShapeUp_AddMouseMoveHook() : ShapeUpAPI.h
  • ShapeUp_AddNewLayerHook() : ShapeUpAPI.h
  • ShapeUp_AddPostDrawHook() : ShapeUpAPI.h
  • ShapeUp_AddRemoveLayerHook() : ShapeUpAPI.h
  • ShapeUp_AddRemoveShapeHook() : ShapeUpAPI.h
  • ShapeUp_AddShapeSelectionChangedHook() : ShapeUpAPI.h
  • ShapeUp_AddSimpleHook_Helper() : ShapeUpAPI.h
  • ShapeUp_AddToolBarButtonHook() : ShapeUpAPI.h
  • ShapeUp_AddToolsHook() : ShapeUpAPI.h
  • ShapeUp_AddWorkspaceReadyHook() : ShapeUpAPI.h
  • ShapeUp_Allocate() : ShapeUpAPI.h
  • ShapeUp_AllocateStatusBarPane() : ShapeUpAPI.h
  • ShapeUp_BeginProgress() : ShapeUpAPI.h
  • ShapeUp_Deallocate() : ShapeUpAPI.h
  • ShapeUp_DuplicateString() : ShapeUpAPI.h
  • ShapeUp_EndProgress() : ShapeUpAPI.h
  • ShapeUp_GetActiveWorkspace() : ShapeUpAPI.h
  • ShapeUp_GetErrorDescription() : ShapeUpAPI.h
  • ShapeUp_GetVersion() : ShapeUpAPI.h
  • ShapeUp_GetWorkspace() : ShapeUpAPI.h
  • ShapeUp_GetWorkspaceCount() : ShapeUpAPI.h
  • ShapeUp_HasJavaScriptSupport() : ShapeUpAPI.h
  • ShapeUp_IsValidHandle() : ShapeUpAPI.h
  • ShapeUp_ReleaseStatusBarPane() : ShapeUpAPI.h
  • ShapeUp_RemoveAllHooks() : ShapeUpAPI.h
  • ShapeUp_RemoveHook_Helper() : ShapeUpAPI.h
  • ShapeUp_RemoveLayerSelectionChangedHook() : ShapeUpAPI.h
  • ShapeUp_RemoveMouseMoveHook() : ShapeUpAPI.h
  • ShapeUp_RemoveShapeSelectionChangedHook() : ShapeUpAPI.h
  • ShapeUp_SetProgress() : ShapeUpAPI.h
  • ShapeUp_SetStatusBarPaneInfo() : ShapeUpAPI.h
  • ShapeUp_SetStatusBarText() : ShapeUpAPI.h
  • ShapeUp_WantUpdate() : ShapeUpAPI.h

- t -

  • Theme_AddAttribute() : ShapeUpAPI.h
  • Theme_AddShape() : ShapeUpAPI.h
  • Theme_BatchAddShapeBegin() : ShapeUpAPI.h
  • Theme_BatchAddShapeEnd() : ShapeUpAPI.h
  • Theme_ClearSelection() : ShapeUpAPI.h
  • Theme_DeleteAttribute() : ShapeUpAPI.h
  • Theme_DeleteShape() : ShapeUpAPI.h
  • Theme_GetAttributeCount() : ShapeUpAPI.h
  • Theme_GetAttributeIndex() : ShapeUpAPI.h
  • Theme_GetAttributeName() : ShapeUpAPI.h
  • Theme_GetAttributeType() : ShapeUpAPI.h
  • Theme_GetBounds() : ShapeUpAPI.h
  • Theme_GetComment() : ShapeUpAPI.h
  • Theme_GetFillColor() : ShapeUpAPI.h
  • Theme_GetFont() : ShapeUpAPI.h
  • Theme_GetInfoTip() : ShapeUpAPI.h
  • Theme_GetIntersectingShapes() : ShapeUpAPI.h
  • Theme_GetName() : ShapeUpAPI.h
  • Theme_GetPenColor() : ShapeUpAPI.h
  • Theme_GetPenStyle() : ShapeUpAPI.h
  • Theme_GetPenWidth() : ShapeUpAPI.h
  • Theme_GetSelectedShapes() : ShapeUpAPI.h
  • Theme_GetSelectedShapesInRect() : ShapeUpAPI.h
  • Theme_GetSelectionCount() : ShapeUpAPI.h
  • Theme_GetShape() : ShapeUpAPI.h
  • Theme_GetShapeCount() : ShapeUpAPI.h
  • Theme_GetShapeFromIndex() : ShapeUpAPI.h
  • Theme_GetShapesByQuery() : ShapeUpAPI.h
  • Theme_GetShapesInRect() : ShapeUpAPI.h
  • Theme_GetShapeType() : ShapeUpAPI.h
  • Theme_InvertSelection() : ShapeUpAPI.h
  • Theme_IsReadOnly() : ShapeUpAPI.h
  • Theme_IsSelected() : ShapeUpAPI.h
  • Theme_IsVisible() : ShapeUpAPI.h
  • Theme_LookupWorkspace() : ShapeUpAPI.h
  • Theme_RecalcBounds() : ShapeUpAPI.h
  • Theme_ReplaceShapeData() : ShapeUpAPI.h
  • Theme_Select() : ShapeUpAPI.h
  • Theme_SetAttributeComment() : ShapeUpAPI.h
  • Theme_SetComment() : ShapeUpAPI.h
  • Theme_SetFillColor() : ShapeUpAPI.h
  • Theme_SetName() : ShapeUpAPI.h
  • Theme_SetPenColor() : ShapeUpAPI.h
  • Theme_SetPenStyle() : ShapeUpAPI.h
  • Theme_SetPenWidth() : ShapeUpAPI.h
  • Theme_SetRasterImage() : ShapeUpAPI.h
  • Theme_SetSerialData() : ShapeUpAPI.h
  • ToolBar_Create() : ShapeUpAPI.h
  • ToolBar_GetButtonCount() : ShapeUpAPI.h
  • ToolBar_IsVisible() : ShapeUpAPI.h
  • ToolBar_SetButtonChecked() : ShapeUpAPI.h
  • ToolBar_SetButtonEnabled() : ShapeUpAPI.h

- w -

  • Workspace_AddDataPage() : ShapeUpAPI.h
  • Workspace_BrowseTheme() : ShapeUpAPI.h
  • Workspace_ClearSelection() : ShapeUpAPI.h
  • Workspace_CreateNewTheme() : ShapeUpAPI.h
  • Workspace_CreateNewThemeFromSelection() : ShapeUpAPI.h
  • Workspace_GetBounds() : ShapeUpAPI.h
  • Workspace_GetComment() : ShapeUpAPI.h
  • Workspace_GetMapWindow() : ShapeUpAPI.h
  • Workspace_GetSelectedTheme() : ShapeUpAPI.h
  • Workspace_GetSelectedThemes() : ShapeUpAPI.h
  • Workspace_GetSelectionCount() : ShapeUpAPI.h
  • Workspace_GetTheme() : ShapeUpAPI.h
  • Workspace_GetThemeCount() : ShapeUpAPI.h
  • Workspace_IsActive() : ShapeUpAPI.h
  • Workspace_LoadJavaScript() : ShapeUpAPI.h
  • Workspace_Log() : ShapeUpAPI.h
  • Workspace_Refresh() : ShapeUpAPI.h
  • Workspace_RemoveTheme() : ShapeUpAPI.h
  • Workspace_SetComment() : ShapeUpAPI.h
  • Workspace_SetSerialData() : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • d
  • p
  • s

- d -

  • DataType : ShapeUpAPI.h

- p -

  • PFNSETTINGS : ShapeUpAPI.h

- s -

  • SUAddFileFormatHandlerHookData : ShapeUpAPI.h
  • SUAddJavaScriptInvokeHookData : ShapeUpAPI.h
  • SUAddMenuItemHookData : ShapeUpAPI.h
  • SUARGAddAttribute : ShapeUpAPI.h
  • SUARGAddDataPage : ShapeUpAPI.h
  • SUARGAddHook : ShapeUpAPI.h
  • SUARGAddShape : ShapeUpAPI.h
  • SUARGAllocate : ShapeUpAPI.h
  • SUARGAllocateStatusBarPane : ShapeUpAPI.h
  • SUARGBatchAddShape : ShapeUpAPI.h
  • SUARGBeginProgress : ShapeUpAPI.h
  • SUARGBrowseTheme : ShapeUpAPI.h
  • SUARGCreateNewTheme : ShapeUpAPI.h
  • SUARGCreateNewThemeFromSelection : ShapeUpAPI.h
  • SUARGCreateToolBar : ShapeUpAPI.h
  • SUARGDeleteAttribute : ShapeUpAPI.h
  • SUARGDeleteShape : ShapeUpAPI.h
  • SUARGDPtoGP : ShapeUpAPI.h
  • SUARGDraw : ShapeUpAPI.h
  • SUARGGetAttribute : ShapeUpAPI.h
  • SUARGGetAttributeIndex : ShapeUpAPI.h
  • SUARGGetAttributeType : ShapeUpAPI.h
  • SUARGGetBOOL : ShapeUpAPI.h
  • SUARGGetBounds : ShapeUpAPI.h
  • SUARGGetClosestPoint : ShapeUpAPI.h
  • SUARGGetColor : ShapeUpAPI.h
  • SUARGGetCoordinate : ShapeUpAPI.h
  • SUARGGetDWORD : ShapeUpAPI.h
  • SUARGGetErrorDescription : ShapeUpAPI.h
  • SUARGGetFont : ShapeUpAPI.h
  • SUARGGetHandle : ShapeUpAPI.h
  • SUARGGetHandleByIndex : ShapeUpAPI.h
  • SUARGGetHWND : ShapeUpAPI.h
  • SUARGGetInfoTip : ShapeUpAPI.h
  • SUARGGetInteractionState : ShapeUpAPI.h
  • SUARGGetIntersectingShapes : ShapeUpAPI.h
  • SUARGGetShapeBytes : ShapeUpAPI.h
  • SUARGGetShapesByQuery : ShapeUpAPI.h
  • SUARGGetShapesInRect : ShapeUpAPI.h
  • SUARGGetShapeType : ShapeUpAPI.h
  • SUARGGetSize : ShapeUpAPI.h
  • SUARGGetText : ShapeUpAPI.h
  • SUARGGetTextByIndex : ShapeUpAPI.h
  • SUARGGetUnsigned : ShapeUpAPI.h
  • SUARGGetUnsignedByIndex : ShapeUpAPI.h
  • SUARGGetWorkspace : ShapeUpAPI.h
  • SUARGGPtoDP : ShapeUpAPI.h
  • SUARGIsShapeSelected : ShapeUpAPI.h
  • SUARGJSCallFunction : ShapeUpAPI.h
  • SUARGLoadJavaScript : ShapeUpAPI.h
  • SUARGLog : ShapeUpAPI.h
  • SUARGRemoveHook : ShapeUpAPI.h
  • SUARGRemoveTheme : ShapeUpAPI.h
  • SUARGRepaint : ShapeUpAPI.h
  • SUARGReplaceShapeData : ShapeUpAPI.h
  • SUARGSelectShape : ShapeUpAPI.h
  • SUARGSetAttribute : ShapeUpAPI.h
  • SUARGSetAttributes : ShapeUpAPI.h
  • SUARGSetBOOL : ShapeUpAPI.h
  • SUARGSetButtonBOOL : ShapeUpAPI.h
  • SUARGSetColor : ShapeUpAPI.h
  • SUARGSetDouble : ShapeUpAPI.h
  • SUARGSetDWORD : ShapeUpAPI.h
  • SUARGSetFloat : ShapeUpAPI.h
  • SUARGSetInteractionState : ShapeUpAPI.h
  • SUARGSetPoint : ShapeUpAPI.h
  • SUARGSetRasterImage : ShapeUpAPI.h
  • SUARGSetSerialData : ShapeUpAPI.h
  • SUARGSetStatusBarPaneInfo : ShapeUpAPI.h
  • SUARGSetText : ShapeUpAPI.h
  • SUARGSetTextByIndex : ShapeUpAPI.h
  • SUARGSetUnsigned : ShapeUpAPI.h
  • SUARGWantUpdate : ShapeUpAPI.h
  • SUARGZoomToExtent : ShapeUpAPI.h
  • SUARGZoomToSelection : ShapeUpAPI.h
  • SUCall : ShapeUpAPI.h
  • SUDeserializeHookData : ShapeUpAPI.h
  • SUExport : ShapeUpAPI.h
  • SUFileFormatHandlerHookData : ShapeUpAPI.h
  • SUHANDLE : ShapeUpAPI.h
  • SUHookData : ShapeUpAPI.h
  • SUHOOKFUNC : ShapeUpAPI.h
  • SUImport : ShapeUpAPI.h
  • SUJavaScriptArgument : ShapeUpAPI.h
  • SUJavaScriptInvokeHookData : ShapeUpAPI.h
  • SUMenuItemHookData : ShapeUpAPI.h
  • SUMouseHookData : ShapeUpAPI.h
  • SUPreRemoveShapeHookData : ShapeUpAPI.h
  • SUPreRemoveThemeHookData : ShapeUpAPI.h
  • SURESULT : ShapeUpAPI.h
  • SUShapeSelChangeHookData : ShapeUpAPI.h
  • SUToolBarButtonHookData : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Class Members

  • File List
  • File Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines

  • suapi : ShapeUpAPI.h
Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGAddAttribute Member List

This is the complete list of members for tagSUARGAddAttribute, including all inherited members.

defaultval | tagSUARGAddAttribute
hTheme | tagSUARGAddAttribute
index | tagSUARGAddAttribute
name | tagSUARGAddAttribute
type | tagSUARGAddAttribute

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGAddDataPage Member List

This is the complete list of members for tagSUARGAddDataPage, including all inherited members.

hDataPage | tagSUARGAddDataPage
hWorkspace | tagSUARGAddDataPage
name | tagSUARGAddDataPage
page | tagSUARGAddDataPage

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGAddHook Member List

This is the complete list of members for tagSUARGAddHook, including all inherited members.

args | tagSUARGAddHook
hookType | tagSUARGAddHook
hShapeUp | tagSUARGAddHook
userData | tagSUARGAddHook

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGAddShape Member List

This is the complete list of members for tagSUARGAddShape, including all inherited members.

hShape | tagSUARGAddShape
hTheme | tagSUARGAddShape
shapeData | tagSUARGAddShape

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGAllocate Member List

This is the complete list of members for tagSUARGAllocate, including all inherited members.

bytes | tagSUARGAllocate
count | tagSUARGAllocate

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGAllocateStatusBarPane Member List

This is the complete list of members for tagSUARGAllocateStatusBarPane, including all inherited members.

hStatusPane | tagSUARGAllocateStatusBarPane
width | tagSUARGAllocateStatusBarPane

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGBatchAddShape Member List

This is the complete list of members for tagSUARGBatchAddShape, including all inherited members.

hShapeUp | tagSUARGBatchAddShape
hTheme | tagSUARGBatchAddShape
index_on | tagSUARGBatchAddShape

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGBeginProgress Member List

This is the complete list of members for tagSUARGBeginProgress, including all inherited members.

hProgress | tagSUARGBeginProgress
progress | tagSUARGBeginProgress
title | tagSUARGBeginProgress

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGBrowseTheme Member List

This is the complete list of members for tagSUARGBrowseTheme, including all inherited members.

hTheme | tagSUARGBrowseTheme
hWorkspace | tagSUARGBrowseTheme
pszTitle | tagSUARGBrowseTheme

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGCreateNewTheme Member List

This is the complete list of members for tagSUARGCreateNewTheme, including all inherited members.

hTheme | tagSUARGCreateNewTheme
hWorkspace | tagSUARGCreateNewTheme
pszName | tagSUARGCreateNewTheme
type | tagSUARGCreateNewTheme

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGCreateNewThemeFromSelection Member List

This is the complete list of members for tagSUARGCreateNewThemeFromSelection, including all inherited members.

hResultTheme | tagSUARGCreateNewThemeFromSelection
hSourceTheme | tagSUARGCreateNewThemeFromSelection
hWorkspace | tagSUARGCreateNewThemeFromSelection
pszName | tagSUARGCreateNewThemeFromSelection

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGCreateToolBar Member List

This is the complete list of members for tagSUARGCreateToolBar, including all inherited members.

hInstResource | tagSUARGCreateToolBar
hShapeUp | tagSUARGCreateToolBar
hToolBar | tagSUARGCreateToolBar
lpszResourceName | tagSUARGCreateToolBar
name | tagSUARGCreateToolBar

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGDPtoGP Member List

This is the complete list of members for tagSUARGDPtoGP, including all inherited members.

dpx | tagSUARGDPtoGP
dpy | tagSUARGDPtoGP
gpx | tagSUARGDPtoGP
gpy | tagSUARGDPtoGP
hMap | tagSUARGDPtoGP

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGDeleteAttribute Member List

This is the complete list of members for tagSUARGDeleteAttribute, including all inherited members.

hTheme | tagSUARGDeleteAttribute
index | tagSUARGDeleteAttribute

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGDeleteShape Member List

This is the complete list of members for tagSUARGDeleteShape, including all inherited members.

hShape | tagSUARGDeleteShape
hTheme | tagSUARGDeleteShape

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGDraw Member List

This is the complete list of members for tagSUARGDraw, including all inherited members.

geoHeight | tagSUARGDraw
geoWidth | tagSUARGDraw
hdc | tagSUARGDraw
hMap | tagSUARGDraw
imageHeight | tagSUARGDraw
imageWidth | tagSUARGDraw
xCenter | tagSUARGDraw
yCenter | tagSUARGDraw

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGPtoDP Member List

This is the complete list of members for tagSUARGGPtoDP, including all inherited members.

dpx | tagSUARGGPtoDP
dpy | tagSUARGGPtoDP
gpx | tagSUARGGPtoDP
gpy | tagSUARGGPtoDP
hMap | tagSUARGGPtoDP

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetAttribute Member List

This is the complete list of members for tagSUARGGetAttribute, including all inherited members.

buffer | tagSUARGGetAttribute
bufferSize | tagSUARGGetAttribute
hShape | tagSUARGGetAttribute
hTheme | tagSUARGGetAttribute
nCol | tagSUARGGetAttribute

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetAttributeIndex Member List

This is the complete list of members for tagSUARGGetAttributeIndex, including all inherited members.

hTheme | tagSUARGGetAttributeIndex
index | tagSUARGGetAttributeIndex
name | tagSUARGGetAttributeIndex

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetAttributeType Member List

This is the complete list of members for tagSUARGGetAttributeType, including all inherited members.

hTheme | tagSUARGGetAttributeType
index | tagSUARGGetAttributeType
type | tagSUARGGetAttributeType

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetBOOL Member List

This is the complete list of members for tagSUARGGetBOOL, including all inherited members.

boolval | tagSUARGGetBOOL
hObject | tagSUARGGetBOOL

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetBounds Member List

This is the complete list of members for tagSUARGGetBounds, including all inherited members.

hObject | tagSUARGGetBounds
xmax | tagSUARGGetBounds
xmin | tagSUARGGetBounds
ymax | tagSUARGGetBounds
ymin | tagSUARGGetBounds

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetClosestPoint Member List

This is the complete list of members for tagSUARGGetClosestPoint, including all inherited members.

closestx | tagSUARGGetClosestPoint
closesty | tagSUARGGetClosestPoint
hShape | tagSUARGGetClosestPoint
refx | tagSUARGGetClosestPoint
refy | tagSUARGGetClosestPoint

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetColor Member List

This is the complete list of members for tagSUARGGetColor, including all inherited members.

clr | tagSUARGGetColor
hObject | tagSUARGGetColor

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetCoordinate Member List

This is the complete list of members for tagSUARGGetCoordinate, including all inherited members.

hShape | tagSUARGGetCoordinate
nIndex | tagSUARGGetCoordinate
nPart | tagSUARGGetCoordinate
x | tagSUARGGetCoordinate
y | tagSUARGGetCoordinate
z | tagSUARGGetCoordinate

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetDWORD Member List

This is the complete list of members for tagSUARGGetDWORD, including all inherited members.

dwordval | tagSUARGGetDWORD
hObject | tagSUARGGetDWORD

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetErrorDescription Member List

This is the complete list of members for tagSUARGGetErrorDescription, including all inherited members.

buffer | tagSUARGGetErrorDescription
bufferSize | tagSUARGGetErrorDescription
errCode | tagSUARGGetErrorDescription

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetFont Member List

This is the complete list of members for tagSUARGGetFont, including all inherited members.

clr | tagSUARGGetFont
font | tagSUARGGetFont
hObject | tagSUARGGetFont

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetHWND Member List

This is the complete list of members for tagSUARGGetHWND, including all inherited members.

hObject | tagSUARGGetHWND
hWnd | tagSUARGGetHWND

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetHandle Member List

This is the complete list of members for tagSUARGGetHandle, including all inherited members.

hObject | tagSUARGGetHandle
hResult | tagSUARGGetHandle

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetHandleByIndex Member List

This is the complete list of members for tagSUARGGetHandleByIndex, including all inherited members.

hObject | tagSUARGGetHandleByIndex
hResult | tagSUARGGetHandleByIndex
nIndex | tagSUARGGetHandleByIndex

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetInfoTip Member List

This is the complete list of members for tagSUARGGetInfoTip, including all inherited members.

buffer | tagSUARGGetInfoTip
bufferSize | tagSUARGGetInfoTip
hShape | tagSUARGGetInfoTip
hTheme | tagSUARGGetInfoTip

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetInteractionState Member List

This is the complete list of members for tagSUARGGetInteractionState, including all inherited members.

hMap | tagSUARGGetInteractionState
hShapeUp | tagSUARGGetInteractionState
state | tagSUARGGetInteractionState

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetIntersectingShapes Member List

This is the complete list of members for tagSUARGGetIntersectingShapes, including all inherited members.

hRecordset | tagSUARGGetIntersectingShapes
hShape | tagSUARGGetIntersectingShapes
hTheme | tagSUARGGetIntersectingShapes

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetShapeBytes Member List

This is the complete list of members for tagSUARGGetShapeBytes, including all inherited members.

buffer | tagSUARGGetShapeBytes
bufferSize | tagSUARGGetShapeBytes
hShape | tagSUARGGetShapeBytes

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetShapeType Member List

This is the complete list of members for tagSUARGGetShapeType, including all inherited members.

hObject | tagSUARGGetShapeType
type | tagSUARGGetShapeType

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetShapesByQuery Member List

This is the complete list of members for tagSUARGGetShapesByQuery, including all inherited members.

hRecordset | tagSUARGGetShapesByQuery
hTheme | tagSUARGGetShapesByQuery
where | tagSUARGGetShapesByQuery

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetShapesInRect Member List

This is the complete list of members for tagSUARGGetShapesInRect, including all inherited members.

bPartInRectOk | tagSUARGGetShapesInRect
hRecordset | tagSUARGGetShapesInRect
hTheme | tagSUARGGetShapesInRect
xmax | tagSUARGGetShapesInRect
xmin | tagSUARGGetShapesInRect
ymax | tagSUARGGetShapesInRect
ymin | tagSUARGGetShapesInRect

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetSize Member List

This is the complete list of members for tagSUARGGetSize, including all inherited members.

height | tagSUARGGetSize
hObject | tagSUARGGetSize
width | tagSUARGGetSize

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetText Member List

This is the complete list of members for tagSUARGGetText, including all inherited members.

buffer | tagSUARGGetText
bufferSize | tagSUARGGetText
hObject | tagSUARGGetText

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetTextByIndex Member List

This is the complete list of members for tagSUARGGetTextByIndex, including all inherited members.

buffer | tagSUARGGetTextByIndex
bufferSize | tagSUARGGetTextByIndex
hObject | tagSUARGGetTextByIndex
index | tagSUARGGetTextByIndex

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetUnsigned Member List

This is the complete list of members for tagSUARGGetUnsigned, including all inherited members.

hObject | tagSUARGGetUnsigned
unsignedval | tagSUARGGetUnsigned

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetUnsignedByIndex Member List

This is the complete list of members for tagSUARGGetUnsignedByIndex, including all inherited members.

hObject | tagSUARGGetUnsignedByIndex
nIndex | tagSUARGGetUnsignedByIndex
unsignedval | tagSUARGGetUnsignedByIndex

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGGetWorkspace Member List

This is the complete list of members for tagSUARGGetWorkspace, including all inherited members.

hWorkspace | tagSUARGGetWorkspace
nIndex | tagSUARGGetWorkspace

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGIsShapeSelected Member List

This is the complete list of members for tagSUARGIsShapeSelected, including all inherited members.

hShape | tagSUARGIsShapeSelected
hTheme | tagSUARGIsShapeSelected
selected | tagSUARGIsShapeSelected

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGJSCallFunction Member List

This is the complete list of members for tagSUARGJSCallFunction, including all inherited members.

hJavaScript | tagSUARGJSCallFunction
name | tagSUARGJSCallFunction

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGLoadJavaScript Member List

This is the complete list of members for tagSUARGLoadJavaScript, including all inherited members.

file | tagSUARGLoadJavaScript
hJavaScript | tagSUARGLoadJavaScript
hWorkspace | tagSUARGLoadJavaScript

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGLog Member List

This is the complete list of members for tagSUARGLog, including all inherited members.

hWorkspace | tagSUARGLog
line | tagSUARGLog

Generated on Thu Apr 15 10:55:37 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGRemoveHook Member List

This is the complete list of members for tagSUARGRemoveHook, including all inherited members.

hookType | tagSUARGRemoveHook
hShapeUp | tagSUARGRemoveHook

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGRemoveTheme Member List

This is the complete list of members for tagSUARGRemoveTheme, including all inherited members.

hTheme | tagSUARGRemoveTheme
hWorkspace | tagSUARGRemoveTheme
ok | tagSUARGRemoveTheme

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGRepaint Member List

This is the complete list of members for tagSUARGRepaint, including all inherited members.

bFullRedraw | tagSUARGRepaint
hMap | tagSUARGRepaint

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGReplaceShapeData Member List

This is the complete list of members for tagSUARGReplaceShapeData, including all inherited members.

hShape | tagSUARGReplaceShapeData
hTheme | tagSUARGReplaceShapeData
shapeData | tagSUARGReplaceShapeData

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSelectShape Member List

This is the complete list of members for tagSUARGSelectShape, including all inherited members.

hShape | tagSUARGSelectShape
hTheme | tagSUARGSelectShape
select | tagSUARGSelectShape

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetAttribute Member List

This is the complete list of members for tagSUARGSetAttribute, including all inherited members.

data | tagSUARGSetAttribute
hShape | tagSUARGSetAttribute
hTheme | tagSUARGSetAttribute
nCol | tagSUARGSetAttribute

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetAttributes Member List

This is the complete list of members for tagSUARGSetAttributes, including all inherited members.

count | tagSUARGSetAttributes
data | tagSUARGSetAttributes
hShape | tagSUARGSetAttributes
hTheme | tagSUARGSetAttributes

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetBOOL Member List

This is the complete list of members for tagSUARGSetBOOL, including all inherited members.

boolval | tagSUARGSetBOOL
hObject | tagSUARGSetBOOL

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetButtonBOOL Member List

This is the complete list of members for tagSUARGSetButtonBOOL, including all inherited members.

boolval | tagSUARGSetButtonBOOL
hShapeUp | tagSUARGSetButtonBOOL
hToolBar | tagSUARGSetButtonBOOL
nID | tagSUARGSetButtonBOOL

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetColor Member List

This is the complete list of members for tagSUARGSetColor, including all inherited members.

clr | tagSUARGSetColor
hObject | tagSUARGSetColor

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetDWORD Member List

This is the complete list of members for tagSUARGSetDWORD, including all inherited members.

dwordval | tagSUARGSetDWORD
hObject | tagSUARGSetDWORD

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetDouble Member List

This is the complete list of members for tagSUARGSetDouble, including all inherited members.

doubleval | tagSUARGSetDouble
hObject | tagSUARGSetDouble

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetFloat Member List

This is the complete list of members for tagSUARGSetFloat, including all inherited members.

floatval | tagSUARGSetFloat
hObject | tagSUARGSetFloat

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetInteractionState Member List

This is the complete list of members for tagSUARGSetInteractionState, including all inherited members.

hMap | tagSUARGSetInteractionState
hShapeUp | tagSUARGSetInteractionState
state | tagSUARGSetInteractionState

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetPoint Member List

This is the complete list of members for tagSUARGSetPoint, including all inherited members.

hObject | tagSUARGSetPoint
x | tagSUARGSetPoint
y | tagSUARGSetPoint

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetRasterImage Member List

This is the complete list of members for tagSUARGSetRasterImage, including all inherited members.

east | tagSUARGSetRasterImage
hbm | tagSUARGSetRasterImage
hTheme | tagSUARGSetRasterImage
north | tagSUARGSetRasterImage
sourceHint | tagSUARGSetRasterImage
south | tagSUARGSetRasterImage
west | tagSUARGSetRasterImage

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetSerialData Member List

This is the complete list of members for tagSUARGSetSerialData, including all inherited members.

byteCount | tagSUARGSetSerialData
bytes | tagSUARGSetSerialData
hObject | tagSUARGSetSerialData
hShapeUp | tagSUARGSetSerialData

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetStatusBarPaneInfo Member List

This is the complete list of members for tagSUARGSetStatusBarPaneInfo, including all inherited members.

hIcon | tagSUARGSetStatusBarPaneInfo
hStatusPane | tagSUARGSetStatusBarPaneInfo
pReserved | tagSUARGSetStatusBarPaneInfo
text | tagSUARGSetStatusBarPaneInfo

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetText Member List

This is the complete list of members for tagSUARGSetText, including all inherited members.

buffer | tagSUARGSetText
hObject | tagSUARGSetText

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetTextByIndex Member List

This is the complete list of members for tagSUARGSetTextByIndex, including all inherited members.

buffer | tagSUARGSetTextByIndex
hObject | tagSUARGSetTextByIndex
index | tagSUARGSetTextByIndex

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGSetUnsigned Member List

This is the complete list of members for tagSUARGSetUnsigned, including all inherited members.

hObject | tagSUARGSetUnsigned
unsignedval | tagSUARGSetUnsigned

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGWantUpdate Member List

This is the complete list of members for tagSUARGWantUpdate, including all inherited members.

hShapeUp | tagSUARGWantUpdate
ulUserData | tagSUARGWantUpdate

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGZoomToExtent Member List

This is the complete list of members for tagSUARGZoomToExtent, including all inherited members.

hMap | tagSUARGZoomToExtent
hTheme | tagSUARGZoomToExtent

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUARGZoomToSelection Member List

This is the complete list of members for tagSUARGZoomToSelection, including all inherited members.

hMap | tagSUARGZoomToSelection
hTheme | tagSUARGZoomToSelection

Generated on Thu Apr 15 10:55:38 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUAddFileFormatHandlerHookData Member List

This is the complete list of members for tagSUAddFileFormatHandlerHookData, including all inherited members.

filterdescription | tagSUAddFileFormatHandlerHookData
pattern | tagSUAddFileFormatHandlerHookData

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUAddJavaScriptInvokeHookData Member List

This is the complete list of members for tagSUAddJavaScriptInvokeHookData, including all inherited members.

hd | tagSUAddJavaScriptInvokeHookData
methods | tagSUAddJavaScriptInvokeHookData
properties | tagSUAddJavaScriptInvokeHookData

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUAddMenuItemHookData Member List

This is the complete list of members for tagSUAddMenuItemHookData, including all inherited members.

hMenuItem | tagSUAddMenuItemHookData
hReserved | tagSUAddMenuItemHookData
menuDescr | tagSUAddMenuItemHookData
menuItemType | tagSUAddMenuItemHookData
menuString | tagSUAddMenuItemHookData

Generated on Thu Apr 15 10:55:36 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUDeserializeHookData Member List

This is the complete list of members for tagSUDeserializeHookData, including all inherited members.

byteCount | tagSUDeserializeHookData
bytes | tagSUDeserializeHookData
hd | tagSUDeserializeHookData
hTheme | tagSUDeserializeHookData

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUExport Member List

This is the complete list of members for tagSUExport, including all inherited members.

hShapeUp | tagSUExport
import | tagSUExport
ShapeUp_Call | tagSUExport

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUFileFormatHandlerHookData Member List

This is the complete list of members for tagSUFileFormatHandlerHookData, including all inherited members.

filename | tagSUFileFormatHandlerHookData
hd | tagSUFileFormatHandlerHookData

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUHookData Member List

This is the complete list of members for tagSUHookData, including all inherited members.

userData tagSUHookData

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUImport Member List

This is the complete list of members for tagSUImport, including all inherited members.

pfnHook | tagSUImport
pfnSettings | tagSUImport
pReserved | tagSUImport
pszDescription | tagSUImport
pszInfo | tagSUImport
pszName | tagSUImport
pszPluginVersion | tagSUImport

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUJavaScriptArgument Member List

This is the complete list of members for tagSUJavaScriptArgument, including all inherited members.

boolVal | tagSUJavaScriptArgument
colorVal | tagSUJavaScriptArgument
doubleVal | tagSUJavaScriptArgument
handleVal | tagSUJavaScriptArgument
intVal | tagSUJavaScriptArgument
stringVal | tagSUJavaScriptArgument
type | tagSUJavaScriptArgument

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUJavaScriptInvokeHookData Member List

This is the complete list of members for tagSUJavaScriptInvokeHookData, including all inherited members.

argc | tagSUJavaScriptInvokeHookData
args | tagSUJavaScriptInvokeHookData
flags | tagSUJavaScriptInvokeHookData
hd | tagSUJavaScriptInvokeHookData
name | tagSUJavaScriptInvokeHookData
retc | tagSUJavaScriptInvokeHookData
rets | tagSUJavaScriptInvokeHookData

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUMenuItemHookData Member List

This is the complete list of members for tagSUMenuItemHookData, including all inherited members.

hd | tagSUMenuItemHookData
hMenuItem | tagSUMenuItemHookData

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUMouseHookData Member List

This is the complete list of members for tagSUMouseHookData, including all inherited members.

flags | tagSUMouseHookData
hd | tagSUMouseHookData
ulReserved | tagSUMouseHookData
x | tagSUMouseHookData
y | tagSUMouseHookData

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUPreRemoveShapeHookData Member List

This is the complete list of members for tagSUPreRemoveShapeHookData, including all inherited members.

hd | tagSUPreRemoveShapeHookData
hShape | tagSUPreRemoveShapeHookData
hTheme | tagSUPreRemoveShapeHookData

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUPreRemoveThemeHookData Member List

This is the complete list of members for tagSUPreRemoveThemeHookData, including all inherited members.

hd | tagSUPreRemoveThemeHookData
hTheme | tagSUPreRemoveThemeHookData

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUShapeSelChangeHookData Member List

This is the complete list of members for tagSUShapeSelChangeHookData, including all inherited members.

bAllowNewGUI | tagSUShapeSelChangeHookData
hd | tagSUShapeSelChangeHookData
hTheme | tagSUShapeSelChangeHookData

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2


ShapeUp API: Member List

tagSUToolBarButtonHookData Member List

This is the complete list of members for tagSUToolBarButtonHookData, including all inherited members.

hd | tagSUToolBarButtonHookData
nCommandID | tagSUToolBarButtonHookData

Generated on Thu Apr 15 10:55:39 2010 for ShapeUp API by doxygen 1.5.2